Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Voikko - Vapaa soikko
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 21

PostPosted: Thu May 24, 2007 6:20 pm    Post subject: Reply with quote

Quote:

Ei näytä tutulta ongelmalta, mutta vaikuttaa että jokin tiedosto ei vain ole oikeassa paikassa tai asennusskripti yrittää käsitellä tiedostoa jota ei enää ole. Jos vika ei ole kovalevyssä tai vastaavassa niin tämä voisi olla ilmoittamisen arvoinen bugi.


Käännös meni läpi kun kopsasin systeemin isommalle levylle. Poistin /var/portage/tmp/office.... ja laitoin lievemmät optimoinnit. Tänään ei jaksa enää koettaa voikkoa asentaa. ehkä se openoffice-voikkokin alkaa vihdoin kääntymään.
_________________
---
Sakarias
Back to top
View user's profile Send private message
MtP
n00b
n00b


Joined: 24 Feb 2008
Posts: 2

PostPosted: Sun Feb 24, 2008 5:55 pm    Post subject: AMD64 onnistui Reply with quote

Tämä Voikko näyttää edelleen olevan vähän heikoissa kantimissa Gentoossa (ainakin amd64) ja keskustelukin näyttää tyrehtyneen. Niinpä päätin ottaa selvää, mistä ongelmat johtuvat. En ole aikaisemmin jaksanut asentaa Voikkoa 64-bittiseen, koska openoffice-voikko- paketissa on ollut riippuvuus openoffice-sdk- pakettiin, joka on sisältänyt 32 bittisiä binäärejä. En ole halunnut asentaa koko Gentoota tai pelkää OpenOfficeakaan 32-bittisenä. Myöskään aiemmin kerrottu Fedoran RPM-pakettejen kanssa säätäminen ei innostanut. Viimein onnistuin (vähän kikkailemalla) asentamaan Voikon adm64:ssa pelkästään käyttäen Gentoon portagea tai Finnish overlayta (http://overlays.gentoo.org/proj/finnish). Tarina menee seuraavasti.

Huomasin että uusimpaan OpenOffice-julkaisuun oli sisällytetty mielenkiintoinen Ooo_2.3.1_src_sdk.tar.bz2- paketti. Huomasin myös, että OpenOfficen (version 2.3.1-r1) asennuksen aikana portage myös latasi tuon paketin (ainakin jos odk-lippu oli päällä). Niinpä kokeilin openoffice-voiko:n asennusta ilman riippuvuutta ongelmalliseen openoffice-sdk- pakettiin.

Seuraavat toimenpiteet olivat tarpeen:

- Lisäsin voikko-1.6.ebuild:iin amd64 keywordin.
- Kopion openoffice-voikko-2.1.ebuild:in openoffice-voikko-2.2.ebuild nimelle (uusi versio julkaistu, jota ei ole vielä päivitetty overlayiin). Tein ebuildiin joitakin muokkauksia (joista tärkein openoffice-sdk:n poisto).
- OpenOfficen asennus jätti kaikesta huolimatta asentamatta sdk:n. Asennus kyllä asentaa kaikki sdk:n tiedostot temp:iin, mutta ei kopoi niitä OpenOfficen hakemistoon. Katso kopiontiohjeet bugirapsasta bug 194053. Saattaa olla, että noiden lisäksi tarvitsee vielä kopioida jotain muutakin, mutta sen kyllä huomaa jos openoffice-voiko:n käännös ei mene läpi.
- setsdkenv_unix-skriptin sdk-hakemiston tunnistus ei näyttänyt toimivan hyvin ebuildin kanssa, joten muokkasin skriptin rivin 5 seuraavaksi: SDKDIRECTORY="/usr/lib/openoffice/sdk"
- Skriptin suorittamisen jälkeen suoritus pysähtyi, heitin ruutuun komennon exit ja asennus jatkui. Lopputuloksena oli toimiva Voikko OpenOfficessa.

Jotta asennus saataisiin täysin kivuttomaksi tulisi OpenOfficen ebuildia muokata niin, että kopioisi myös sdk:n tiedostot OpenOfficen hakemistoon. Lisäksi tuon setsdkenv_unix-konfugurointi skriptin tekemät asiat voisi laittaa openoffice-voikko ebuildiin tai sitten muuten parantaa integraatiota skriptin ja ebuildin välillä. Skriptin kysymykset ovat mielestäni vähän turha hidaste asennuksen aikana, koska oletukset ovat kuitenkin oikein.
Back to top
View user's profile Send private message
MtP
n00b
n00b


Joined: 24 Feb 2008
Posts: 2

PostPosted: Sun Feb 24, 2008 6:25 pm    Post subject: Reply with quote

Tietenkinhän myös tää muokattu / päivitetty openoffice-voikko-2.2.ebuild vois olla hyvä liittää tähän.

Code:

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils versionator multilib

MY_P="${P/office-voikko/office.org-voikko}"
MY_PN="${PN/office-voikko/office.org-voikko}"

DESCRIPTION="Voikko—Free Finnish spell checking and hyphenation for OpenOffice"
HOMEPAGE="http://voikko.sf.net/"
SRC_URI="mirror://sourceforge/voikko/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-x86 amd64" # This’s broken till SDK is fixed and whatnot

#DEPEND="|| ( >=app-office/openoffice-2 (
#      >=app-office/openoffice-bin-2 app-office/openoffice-sdk
#      )
#   )
DEPEND="|| ( >=app-office/openoffice-2 >=app-office/openoffice-bin-2 )
   app-text/voikko
   sys-apps/grep
   sys-apps/sed
   sys-apps/sysvinit
   !app-office/oo2-voikko"
RDEPEND="|| ( >=app-office/openoffice-2 >=app-office/openoffice-bin-2 )
   app-text/voikko"

S="${WORKDIR}/${MY_P}"

pkg_setup() {
   # This check originates from soikko times I think...
   # Also, pidof belongs to sysvinit, dep?
   if pidof soffice.bin >/dev/null; then
      die "${PN} can’t be installed while OpenOffice.org is running."
   fi
   # We need OpenOffice SDK initialisation sh script executable
   # If we could trust openoffice use +odk work, this was unnecessary:
   if [[ ! -x "${ROOT}/usr/lib/openoffice/sdk/setsdkenv_unix" ]] ; then
      die "Couldn’t find open office SDK settings from \
         ${ROOT}/usr/lib/openoffice/sdk/setsdkenv_unix"
   else
      export SDKENV="${ROOT}/usr/lib/openoffice/sdk/setsdkenv_unix"
   fi
   if [[ ! -x "${ROOT}/usr/$(get_libdir)/openoffice/program/unopkg"  ]] ; then
      die "Couldn’t find unopkg binary"
   else
      export UNOPKG="${ROOT}/usr/$(get_libdir)/openoffice/program/unopkg"
   fi

   # Open Office must be installed with SDK
   if has_version app-office/openoffice ; then
      if ! built_with_use app-office/openoffice odk ; then
         ewarn "OpenOffice should be built with USE flag “odk”"
         ewarn "for building uno package from source to work"
      fi
   fi
   einfo "Searching OpenOffice.org SDK environment..."
   source "${SDKENV}"
   einfo "SDK set to: OO_SDK_HOME=${OO_SDK_HOME}"
}

src_compile() {
   emake || die "emake failed"
   emake all || die "emake failed"
}

src_install() {
   dodoc README ChangeLog || die "docs missing"
   dodir /usr/lib/${P}
   insinto /usr/lib/${P}
   doins build/voikko.oxt
}

# FIXME: installation of an unopkg is troublesome, move to src_install when
# OO.o supports it somehow sanely
pkg_postinst() {
   
   # N.B.: uno packages meddle with $HOME, let’s fool it
   HOME="${S}"
   cd "${S}"
   # Yay, OO.o package installation requires .ooo-2.0 directory from once
   # started instance of the program. How fun!
   tar jxf "${FILESDIR}/ooo-2.0-home.tar.bz2"

   # select component
   COMPONENT="${ROOT}usr/lib/${P}/voikko.oxt"
   PKG=$(basename "${COMPONENT}")

   # Global scope in install-oo2-voikko
   if [[ -e "${HOME}/.openoffice.org2/.lock" ]] ;
   then
      die "lockfile from previous failed installation attempt found in \
         ${HOME}/.openoffice.org2/.lock, please clean and retry"
   fi
   # register()
   if [[ "${COMPONENT}" == "" ]] ;
   then
      die "UNO component not found"
   fi
   einfo "Trying to register uno package ${COMPONENT}..."
   HOME=${HOME} "${UNOPKG}" add --shared "${COMPONENT}"
   if [[ $? == 0 ]] ;
   then
      einfo "Voikko package (${PKG}) registered succesfully"
   else
      die "Couldn’t register ${PN} package (${PKG})"
   fi
   elog "Please note that ${PN} is very dependent on ABI compatible "
   elog "version of OpenOffice.org to exist on system when removing voikko!"
   elog "Before incompatible update or removal of OpenOffice you must"
   elog "unmerge ${PN}!"
   
}

pkg_prerm() {
   #unregister()
   UNOPKG_LIST="$(${UNOPKG} list --shared 2> /dev/null)"
   if [[ $? != 0 ]] ; then
      ewarn "Couldn’t list existing packages..."
   fi
   PKG=$(echo ${UNOPKG_LIST} | egrep -m1 "^Identifier: (org.puimula.ooovoikko|org.openoffice.legacy.openoffice.org-voikko.*.uno.pkg)" | sed -ne "s/^Identifier: \\(.*\\)/\\1/p")
   if [ "${PKG}" != "" ]; then
      einfo "Removing uno package ${PKG}..."
      if "${UNOPKG}" remove --shared ${PKG} &>/dev/null
      then
         einfo "${PN} package (${PKG}) unregistered succesfully"
      else
         die "Couldn’t uninstall existing ${PN} packages"
      fi
   else
      ewarn "Couldn’t find existing ${PN} packages."
      ewarn "You may need to \`unopkg remove\` them manually."
   fi
}
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Mar 04, 2008 2:16 am    Post subject: Re: AMD64 onnistui Reply with quote

MtP wrote:
Jotta asennus saataisiin täysin kivuttomaksi tulisi OpenOfficen ebuildia muokata niin, että kopioisi myös sdk:n tiedostot OpenOfficen hakemistoon.


Niin, se on se joka vaaditaan jotta openoffice-voikon saisi edes teoriassa Portage-puuhun (tai edes toimimaan järkevästi muutenkaan). En usko että asiaan tulee kuitenkaan parannusta vieläkään.

Quote:
Lisäksi tuon setsdkenv_unix-konfugurointi skriptin tekemät asiat voisi laittaa openoffice-voikko ebuildiin tai sitten muuten parantaa integraatiota skriptin ja ebuildin välillä.


Jossain ikivanhassa ebuildissa oli SDK-muuttujat mukana. Muistaakseni sanottiin, ettei toimi jos ${ROOT} != /, tai jos muuttujat mitenkään oo.o:n versioiden välillä muuttuvat, joten mahdoton ylläpidettävä sellaisenaan.

Quote:
Skriptin kysymykset ovat mielestäni vähän turha hidaste asennuksen aikana, koska oletukset ovat kuitenkin oikein.


Openoffice-sdk-paketissa oli joskus pätsätty skripti josta kysymykset oli kai poistettu niin että sourcettaminen riitti.

Voin päivittää tuon overlayn paketin version tuolla ebuildilla, mutten hirveästi jouda näkemään vaivaa sen eteen kun en kuitenkaan jouda korjata openofficen SDK -juttua.
Back to top
View user's profile Send private message
ville.aakko
n00b
n00b


Joined: 06 Aug 2006
Posts: 65
Location: Oulu, Finland

PostPosted: Sat Jul 19, 2008 10:21 am    Post subject: Reply with quote

Hei!

Mikähän on "oikea" tapa asentaa Voikko Gentoohon tällä hetkellä? Käsittääkseni OOo:n odk-useflag ei toimi vieläkään niin kuin pitäisi? Hunspell-fi -overlaytä ei enää ole, ja finnish-overlay ei tykkää OOo:n 2.4 -versiosta joka on portagessa. Finnish- overlay:ssä on openoffice-sdk 2.3.0 joka vaatii OOo:n 2.3.x -version jota ei ole missään. Hmm...

Onko se rikki vai löytyykö jostakin oikein asentuva voikko :)

Tällä hetkellä taitaa olla voikko asennettuna omasta paikallisesta overlaystä, enkä enää muista mistä hain ebuildit. Viimeksi kun oikolukua tarvitsin, toimi voikko ihan ongelmitta. Ja toimii näemmä tälläkin hetkellä tässä Firefoxissa :)

- Ville
_________________
- Ville
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Fri Aug 08, 2008 7:58 pm    Post subject: Reply with quote

ville.aakko wrote:
Mikähän on "oikea" tapa asentaa Voikko Gentoohon tällä hetkellä?


Itse käsin varmaan :-)

Quote:
Hunspell-fi -overlaytä ei enää ole, ja finnish-overlay ei tykkää OOo:n 2.4 -versiosta joka on portagessa. Finnish- overlay:ssä on openoffice-sdk 2.3.0 joka vaatii OOo:n 2.3.x -version jota ei ole missään. Hmm...


Näin-o. Katselen tänä viikonloppuna, mutta jos se ei mene suht helposti kuten pahoin pelkään en välttämättä tappele paljoa sen kanssa. Itse kun en oikeastaan käytä OpenOffice.orgia kuin satunnaisen postissa tulevan M$ Office -roskan lukemiseen. Ja OpenOfficen kanssa tappelu on melko työlästä ja pitkällistä.

Quote:
Onko se rikki vai löytyykö jostakin oikein asentuva voikko :)


Juh, voikko itsessään varmaan on kunnossa overlayssa jo viikonlopun jälkeen, se on melko kiltti ja toimiva paketti riippuvuuksineenkin, ja luulen jo tietäväni mitä pikkujuttuja on lahonnut.


Voikot ja tmispellit pitäis kyllä toimia ainakin nyt. Mozvoikko ei ihan lähtenyt, vissiin paras asentaa käsin .xpi:stä. OpenOffice kääntyy seuraavat n tuntia vielä.
Back to top
View user's profile Send private message
corec
n00b
n00b


Joined: 25 Oct 2007
Posts: 8

PostPosted: Mon Oct 20, 2008 2:21 pm    Post subject: Voikko ja Oo3 Reply with quote

Onkos kukaan laittanut voikkoa toimimaan Openoffice 3:n kanssa vielä? Ainakaan finnish-overlayssa ei ollut openoffice-sdk:ta kuin versiolle 2.2 ja 2.3.
Back to top
View user's profile Send private message
Nuteater
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 193
Location: Jyväskylä, Finland

PostPosted: Thu Oct 23, 2008 9:04 am    Post subject: Reply with quote

tmispellin (0.7) DEPENDeistä taitaa puuttua glibmm. Ainakin täällä tulee tällaista herjaa configurelta.

Sain muuten voikolla siivottua muutaman krijoitusvirheen gradusta. Kiitokset siis tekijöille ja finnish-overlayn ylläpitäjälle :).
_________________
I am Nuteater, hear me roar.
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Thu Oct 23, 2008 7:53 pm    Post subject: Reply with quote

Nuteater wrote:
tmispellin (0.7) DEPENDeistä taitaa puuttua glibmm. Ainakin täällä tulee tällaista herjaa configurelta.


Totta, lisäsin sen.

Quote:
Sain muuten voikolla siivottua muutaman krijoitusvirheen gradusta.


Itselläni se vain lisäili kielioppivirheitä ja ehdotteli törkeyksiä joka puolella ;-)
Back to top
View user's profile Send private message
corec
n00b
n00b


Joined: 25 Oct 2007
Posts: 8

PostPosted: Sat Oct 25, 2008 8:54 am    Post subject: Reply with quote

Flammie wrote:
Nuteater wrote:
tmispellin (0.7) DEPENDeistä taitaa puuttua glibmm. Ainakin täällä tulee tällaista herjaa configurelta.


Totta, lisäsin sen.



Voisitko korjata dependin
Code:
>=dev-libs/glibmm-2.4

Oikea paketti näyttäisi olevan
Code:
>=dev-cpp/glibmm-2.4
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Sun Oct 26, 2008 8:30 pm    Post subject: Reply with quote

corec wrote:
Voisitko korjata dependin
Code:
>=dev-libs/glibmm-2.4

Oikea paketti näyttäisi olevan
Code:
>=dev-cpp/glibmm-2.4


Hehjoo, nyt pitäisi olla oikein.
Back to top
View user's profile Send private message
anatemus
n00b
n00b


Joined: 29 Nov 2004
Posts: 9
Location: Finland

PostPosted: Fri Dec 19, 2008 1:15 pm    Post subject: KDE4.1 ja Voikko Reply with quote

FYI, jos ei ole vielä mainittu: KDE4.1 (ja siten myös Koffice?) löytää suomenkielisen oikoluvun kun asentaa ensin app-text/voikko:n (itsellä 2.0 versio) overlaysta ja sen jälkeen kääntää uudestaan/päivittää app-text/enchant-1.4.2:n suoraan portagesta. Enchantissa on k.o. versiosta eteenpäin tuki Voikolle ja se löysi Voikon asennuksen aikana.

corec wrote:
Onkos kukaan laittanut voikkoa toimimaan Openoffice 3:n kanssa vielä? Ainakaan finnish-overlayssa ei ollut openoffice-sdk:ta kuin versiolle 2.2 ja 2.3.

Yritin bumpata versioita openoffice-sdk:sta ja openoffice-voikko:sta, mutta näyttää ikävä kyllä vaativan enemmän asiantuntemusta :( Sain SDK-kludgen jotakuinkin asentumaan, mutta Voikon kääntäminen ei onnistu sen kanssa (kirjastoja puuttuu tms). Tod.näk. SDK:n asennus ei mennyt nappiin, eikä minullakaan ole NIIN suurta tarvetta oikoluvulle OOo:ssa että innoistuisin debuggaamaan pidemmälle...
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Mon Dec 22, 2008 8:45 am    Post subject: Re: KDE4.1 ja Voikko Reply with quote

anatemus wrote:
FYI, jos ei ole vielä mainittu: KDE4.1 (ja siten myös Koffice?) löytää suomenkielisen oikoluvun kun asentaa ensin app-text/voikko:n (itsellä 2.0 versio) overlaysta ja sen jälkeen kääntää uudestaan/päivittää app-text/enchant-1.4.2:n suoraan portagesta. Enchantissa on k.o. versiosta eteenpäin tuki Voikolle ja se löysi Voikon asennuksen aikana.


Joo, vanhastaan tuo enchantin voikko-laajennos oli voikko-paketin asennuksessa, eli jos joku esim. portagen collision-protectissa törmää virheisiin niin se johtuu siitä.

Quote:
corec wrote:
Onkos kukaan laittanut voikkoa toimimaan Openoffice 3:n kanssa vielä? Ainakaan finnish-overlayssa ei ollut openoffice-sdk:ta kuin versiolle 2.2 ja 2.3.

Yritin bumpata versioita openoffice-sdk:sta ja openoffice-voikko:sta, mutta näyttää ikävä kyllä vaativan enemmän asiantuntemusta :( Sain SDK-kludgen jotakuinkin asentumaan, mutta Voikon kääntäminen ei onnistu sen kanssa (kirjastoja puuttuu tms). Tod.näk. SDK:n asennus ei mennyt nappiin, eikä minullakaan ole NIIN suurta tarvetta oikoluvulle OOo:ssa että innoistuisin debuggaamaan pidemmälle...


Openofficen binääri-SDK:ssa versus sorsa-paketin udk-installaatiossa on vielä ainakin pari elementtiä, jotka pitää hoitaa että asennus edes satunnaisesti toimii. Yksi on SDK:n setenv-skripti, joka interaktiivisesti asettelee muuttujia. Toinen ongelma on että joka versiossa headerit ja muut data-tiedostot ja jotkin sovellusbinääritkin näyttävät jakautuvan eri tavalla vähän eri paikkoihin jotta muutoinkin fragiili bumppaus olisi hankalaa.
Back to top
View user's profile Send private message
Nuteater
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 193
Location: Jyväskylä, Finland

PostPosted: Fri Jul 24, 2009 5:10 am    Post subject: Reply with quote

Tuolla finnish-overlayssä on varmaan jäänyt suomi-malagan päivitys hieman kesken
tai sitten on tapahtunut jotain muuta hämäryyttä. Huomasin vaan, että versiosta 1.2
puuttuu nyt x86-keywordi kokonaan, ja ChangeLog sanoo että:
Code:
*suomi-malaga-1.2 (23 Jun 2009)

  23 Jun 2009; Flammie Pirinen <flammie@gentoo.org>
  +suomi-malaga-1.3.ebuild:
  version bump.

*suomi-malaga-1.2 (02 Oct 2008)

  02 Oct 2008; Flammie Pirinen <flammie@gentoo.org>
  +suomi-malaga-1.2.ebuild:
  version bump.


Kuitenkaan tuota 1.3-version ebuildia ei overlaystä löydy. Alkoi vain häiritsemään
kun tuon puuttuvan keywordin takia portage haluaisi nyt poistaa tyystin koko
suomi-malagan :).
_________________
I am Nuteater, hear me roar.
Back to top
View user's profile Send private message
playmiac
n00b
n00b


Joined: 08 Nov 2005
Posts: 18

PostPosted: Wed Aug 19, 2009 7:24 pm    Post subject: Reply with quote

Onko kukaan virittänyt Voikkoa toimimaan OpenOffice 3.1:een amd64:ssa GCC 4.4.1:llä käännettynä?

Tuumin tässä UDKn asennusvirittelyä ja pohdin onko kenelläkään vinkkejä päänsäryn hillitsemiseksi :)
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Fri Sep 11, 2009 4:46 pm    Post subject: Reply with quote

Nuteater wrote:
Tuolla finnish-overlayssä on varmaan jäänyt suomi-malagan päivitys hieman kesken
tai sitten on tapahtunut jotain muuta hämäryyttä. Huomasin vaan, että versiosta 1.2
puuttuu nyt x86-keywordi kokonaan, ja ChangeLog sanoo että:
Code:
*suomi-malaga-1.2 (23 Jun 2009)

  23 Jun 2009; Flammie Pirinen <flammie@gentoo.org>
  +suomi-malaga-1.3.ebuild:
  version bump.

*suomi-malaga-1.2 (02 Oct 2008)

  02 Oct 2008; Flammie Pirinen <flammie@gentoo.org>
  +suomi-malaga-1.2.ebuild:
  version bump.


Kuitenkaan tuota 1.3-version ebuildia ei overlaystä löydy. Alkoi vain häiritsemään
kun tuon puuttuvan keywordin takia portage haluaisi nyt poistaa tyystin koko
suomi-malagan :).


Korjasin nyt tämän. Keywordit ovataina sitä millä on testattu, joten jos siellä on ~amd64 niin se pitää lisätä keywords.confiin vaikka muutoin olisikin x86-järjestelmä. Ainoa oikea x86 mikä minulla on jäljelä on AspireOne D150 eikä se ole mikään paras testialusta niin ~x86-keywordeja on enintään satunnaisesti.
Back to top
View user's profile Send private message
Kranu
n00b
n00b


Joined: 27 Jan 2008
Posts: 5

PostPosted: Thu Nov 26, 2009 3:56 pm    Post subject: ODK asennus korjattu Portagessa! Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=151798

Eli Portagesta löytyy nyt OpenOfficen korjattu ebuild. Nyt asentuu ODK oikein (ainakin korjauksen tekijän mukaan, en ole vielä itse testannut).

Toivottavasti tämä tulee jatkossa helpottamaan Voikon asennusta :)
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Dec 15, 2009 7:38 pm    Post subject: Re: ODK asennus korjattu Portagessa! Reply with quote

Kranu wrote:
https://bugs.gentoo.org/show_bug.cgi?id=151798

Eli Portagesta löytyy nyt OpenOfficen korjattu ebuild. Nyt asentuu ODK oikein (ainakin korjauksen tekijän mukaan, en ole vielä itse testannut).

Toivottavasti tämä tulee jatkossa helpottamaan Voikon asennusta :)


Näyttää toimivan. Nyt openoffice-voikko riippuu openoffice[odk]:sta.
Back to top
View user's profile Send private message
playmiac
n00b
n00b


Joined: 08 Nov 2005
Posts: 18

PostPosted: Sun Mar 28, 2010 12:06 pm    Post subject: Reply with quote

Päivitin itselleni finnish overlay:ssä olevia ebuildeja versionumeroita kasvattamalla ja keyword:ejä lisäämällä seuraavasti: voikko-> 2.3.1, suomi-malaga->1.5, malaga->7.12 sekä openoffice-voikko 3.3.1 (OpenOffice versio on 3.2). Pikakokeiden perusteella toimii hyvin amd64:ssä. Kiitokset kehittäjille! :D
Back to top
View user's profile Send private message
Nuteater
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 193
Location: Jyväskylä, Finland

PostPosted: Mon Dec 13, 2010 7:33 pm    Post subject: Reply with quote

Tuolla finnish-overlayssä on joku digest pielessä:
Code:
Calculating dependencies \ * Digest verification failed:
 * /var/lib/layman/finnish/sci-misc/suomi-malaga/suomi-malaga-9999.ebuild
 * Reason: Failed on RMD160 verification
 * Got: 2d4d68fb3120a689beb9dfcf56e3dd4d9c7e81c1
 * Expected: 555ba2d25f779e27b08c8f36993ebb70a1fc950a


Lisäys: ja nyt itse asiassa huomasin tällaisenkin: :)
Code:
!!! The following installed packages are masked:
- app-text/ispell-3.3.02-r99::finnish (masked by: invalid: RDEPEND: missing whitespace around ')' at 'app-text/tmispell)', token 3 in '/var/db/pkg/app-text/ispell-3.3.02-r99/RDEPEND')

_________________
I am Nuteater, hear me roar.
Back to top
View user's profile Send private message
meklu
n00b
n00b


Joined: 05 Dec 2010
Posts: 8
Location: Helsinki, Finland

PostPosted: Thu Apr 07, 2011 8:18 pm    Post subject: Reply with quote

Olen tuossa väsännyt app-office/openoffice-voikko -ebuildin pohjalta app-office/libreoffice-voikko -paketin ja lisäsin app-text/voikko:on keywordin ~amd64 sekä bumppasin sen version 3.2:een. Molemmat ebuildit on testattu toimiviksi. Vielä kun saisi nämä overlayhin.

app-office/libreoffice-voikko-3.2: http://pastebin.com/AfXfELHT
app-text/voikko-3.2: http://pastebin.com/VziCAmkn
_________________
Never, ever, ever run this:
Code:
root@home:/# dd if=/dev/zero of=/dev/sda
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Wed May 04, 2011 8:49 am    Post subject: Reply with quote

meklu wrote:
Olen tuossa väsännyt app-office/openoffice-voikko -ebuildin pohjalta app-office/libreoffice-voikko -paketin ja lisäsin app-text/voikko:on keywordin ~amd64 sekä bumppasin sen version 3.2:een. Molemmat ebuildit on testattu toimiviksi. Vielä kun saisi nämä overlayhin.

app-office/libreoffice-voikko-3.2: http://pastebin.com/AfXfELHT
app-text/voikko-3.2: http://pastebin.com/VziCAmkn


Lisäsin voikon vihdoin, ja officen kunhan se kääntyy. Sori kun kesti tällä kertaa, yritin kiireessä jo aiempana mutta silloin en tajunnut että mystiset virheilmoitukset johtuivat siitä että pastebin oli aikaansaanut dos-rivinvaihtoja.
Back to top
View user's profile Send private message
nikoboc
n00b
n00b


Joined: 14 May 2011
Posts: 1
Location: Finland

PostPosted: Mon Sep 19, 2011 2:53 pm    Post subject: Reply with quote

Olen päivitellyt noita finnish overlaysta löytyviä ebuildeja sitä mukaa, kun uusia versioita on julkaistu, ja sain vihdoin laitettua ne julkisesti nähtäville. Eli löytyvät täältä: https://github.com/nikobockerman/nikos_gentoo_overlay
Tuolta löytyy myös libreoffice-voikko -ebuild lähes samassa muodossa kuin meklun yllä tekemä ebuild. Myös uusimmat suomi-malagan sekä voikon versiot löytyvät tuolta.
Back to top
View user's profile Send private message
ptrck
n00b
n00b


Joined: 28 Feb 2012
Posts: 1

PostPosted: Tue Feb 28, 2012 11:35 am    Post subject: Reply with quote

Toimiiko kellään finnish-overlayn libreoffice-voikko-3.2 libreoffice-3.5.03 kanssa? Mulla tulee seuraava virheilmoitus:


Code:

>>> Compiling source in /var/tmp/portage/app-office/libreoffice-voikko-3.2/work/libreoffice-voikko-3.2 ...
make -j2 oxt
mkdir -p build/oxt/META-INF
mkdir -p build/oxt
sed -e "s/VOIKKO_EXTENSION_SHAREDLIB/voikko.so/g;s/UNOPKG_PLATFORM/Linux_x86/g;/GRAMMAR_CHECKER_DISABLED/d" < oxt/META-INF/manifest.xml.template > build/oxt/META-INF/manifest.xml
sed -e "s/VOIKKO_VERSION/3.2/g" < oxt/description.xml.template > build/oxt/description.xml
mkdir -p build/hpp
"/usr/lib/libreoffice/sdk/bin/cppumaker" -Gc -BUCR -O./build/hpp "/usr/lib/libreoffice/ure-link/share/misc/types.rdb" "/usr/lib/libreoffice/program/offapi.rdb"
mkdir -p build/oxt
cp "oxt/config.xcu" "build/oxt/config.xcu"
cppumaker : init registries failed, check your registry files.
make: *** [build/hpp.flag] Virhe 99
make: *** Odotetaan keskeneräisiä töitä....
emake failed
 * ERROR: app-office/libreoffice-voikko-3.2 failed (compile phase):
 *   make failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 2281:  Called die
 * The specific snippet of code:
 *       emake oxt || die "make failed"
 *


terv. ptrck
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum