Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pacotes bloqueados.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Wed Sep 24, 2008 12:46 am    Post subject: Pacotes bloqueados. Reply with quote

Oi, pessoal:

Sabendo que tenho que aprender muito sobre o Gentoo, peço o auxílio de vcs
para a seguinte dúvida:

Ao rodar emerge --deep --update world apareceu:

[blocks B ] <media-libs/gst-plugins-ugly-0.10.6-r1 (is blocking media-libs/gstreamer-0.10.20)

No site http://gentoo-wiki.com/FAQ_Blocked_Package, achei o shellscript para desbloqueio:

#!/bin/bash

BLOCKER=$1
BLOCKED=$2

if [[ "$BLOCKED" == "" ]]; then
echo "unblock <blocker> <blocked>"
exit;
fi

emerge --buildpkgonly --nodeps $BLOCKED && emerge -C $BLOCKER && emerge --usepkgonly $BLOCKED

Ao rodar o programa, veio o seguinte:

./desbl.sh <media-video/totem-2.21 dev-libs/totem-pl-parser-2.22.3
bash: media-video/totem-2.21: No such file or directory

Como posso desbloquear? E o que significa o < em <media-video?

Desde já agradeço. [ ]'s.

****************************************************************************************

Depois de procurar mais achei a solução em http://forums.gentoo.org/viewtopic-t-195629.html

Obrigado pela atenção de todos.

[ ]'s.
Back to top
View user's profile Send private message
edbch
n00b
n00b


Joined: 09 Feb 2008
Posts: 17

PostPosted: Fri Sep 26, 2008 7:15 pm    Post subject: Reply with quote

Olha aleixoreis,

a melhor maneira de desbloquear um pacote com segurança, sabendo o que está fazendo, é faze-lo manualmente. Minha sugestão é esta.
Para desbloquear manualmente você precisa de alguns passos. Primeiro do portage mais recente, então :

emerge --sync; emerge portage

Depois você precisa entender porque o pacote está sendo bloqueado. Então novamente:

emerge -Nvp world

ai você vê com detalhes o que está acontecendo. O seu problema parece que é que você está atualizando de uma versão meio antiga. Se for este o caso você vai encontrar mais de um pacote com problema. Ai o primeiro passo é atualizar o pacote que está bloqueando o pacote mais novo para a primeira versão estável suportada. Para isso voce deve usar o eix. O eix é um programa que fornece informações sobre os pacotes instalados e disponíveis, como o emerge, mas muito mais rápido. O problema é que ele é estático, e toda vez que você faz alguma coisa precisa atualizar o seu banco de dados.

emerge eix
update-eix

ai você procura pelo pacote que está bloqueando o pacote mais novo

eix pacote velho

você vai ver a versão que está instalada, as versões disponíveis, flags etc. deu uma olhada com calma nisso.
Então vem o processo. Voce vai atualizar o pacote que está com problema para a primeira versão que aparece como estável.

emerge =pacoteCOMproblema-versao

se continuar dando problema você vai de versão em versão até o portage conseguir resolver as dependências.
Isso pode ser um pouco chato, mas funciona se voce estiver usando pacote estáveis, e também funciona com a maior parte dos instáveis.
Se isso não render frutos, posta aqui suas dúvidas, com mais detalhes do seu /etc/make.conf e a saída de emege -Nvp world.

Boa sorte.
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Wed Oct 01, 2008 9:18 pm    Post subject: Reply with quote

Boas,

Eu utilizo uma forma mais simples de resolver os pacotes bloqueados (não é de certo a mais correcta) simplesmente removo os dois pacotes que estão a dar problemas, o que esta bloqueado se estiver instalado (todas as revisões instaladas) e o que esta a causar o bloqueio (também todas as revisões), depois faço novamente emerge world -uD --newuse e geralmente resolve a questão das dependências sem mais problemas, em alguns casos só tenho de fazer separadamente um emerge a um dos pacotes se dele precisar seguido de um revdep-rebuild ....

O único problema da-se quando precisas mesmo do pacote que esta a causar o bloqueio ou bloqueado ai ou utilizas a sugestão do edbch ou colocas um dos pacotes no /etc/portage/package.mask ate sair uma revisão do pacote que não de problemas no emerge ... eu sempre fiz assim e nunca tive problemas .....
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum