Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tampakrap
Developer
Developer


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Mon Sep 29, 2008 1:06 pm    Post subject: [kde-testing] and [kde-crazy] KDE4 overlays thread (part 2) Reply with quote

This is the second part of the support thread for kde-testing and kdesvn-portage overlays (part 1)

kde-testing overlay is the official and support Gentoo KDE Team's overlay*. When mature enough and tested, packages from this overlay are being transferred to Portage repository. If you want to use this overlay visit this guide. You can get support for this overlay in #gentoo-kde and help Gentoo KDE team testing it before it is moved into the official Portage tree.

kde-crazy overlay iis playground for Gentoo KDE team. that being said it's known to eat puppies and kill kittens. It contains unstable KDE4 releases as well as live (Subversion) ebuilds. Please DON'T report any bugs regarding this overlay. If you have some suggestions or you would like to contribute, contact Gentoo KDE team on #gentoo-kde.

Please, when posting, be specific about the overlay/branch/slot you are using.


*Although ebuilds on the kde-testing overlay are supported by the KDE team, according to forums policy, questions regarding ebuilds from overlays belong to the US forum


Last edited by tampakrap on Tue Oct 28, 2008 8:09 pm; edited 2 times in total
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Mon Sep 29, 2008 6:54 pm    Post subject: Reply with quote

so
i'm using kdesvn-portage overlay with kde4.2
Portage 2.1.4.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r6 x86_64)

i've tried to update world and it try to compile a stable 3.x kde... what happens? :-)

p.s. thanks for your work
Back to top
View user's profile Send private message
tampakrap
Developer
Developer


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Mon Sep 29, 2008 8:23 pm    Post subject: Reply with quote

try to emerge the meta (or set) with the slot specified and see if anything is still keyworded or unmasked
Back to top
View user's profile Send private message
LD
Guru
Guru


Joined: 23 Dec 2003
Posts: 336
Location: Middle of No-Where Granbury, Tx

PostPosted: Mon Sep 29, 2008 9:12 pm    Post subject: Reply with quote

Several packages for the 4.2 set in the kdesvn-portage overlay have missing keywords. I was hoping someone could either explain the logic behind the missing keywords or if this is just a mistake.
_________________
[Owner/Operator: Dhampir Dreams]
Last.fm profile
Netflix Profile
Back to top
View user's profile Send private message
tampakrap
Developer
Developer


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Tue Sep 30, 2008 1:29 pm    Post subject: Reply with quote

Yesterday i cleaned up package.keywords, package.unmask and sets provided by kdesvn-portage (under directory Documentation). Those files were a mess and i tried to clean up things a bit. I renamed some files and edited almost everything so probably i have made some mistakes. Please everyone check again your symlinks and report here (or in the irc channel) about what is missing. I don't want to include in package.keywords or package.unmask any portage packages for obvious reasons. Thank you!
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2755
Location: Gainesville, Florida

PostPosted: Tue Sep 30, 2008 2:16 pm    Post subject: Reply with quote

Anyone notice in the last week or two in konsole the tabs no longer give any info other than "kdesvn : emerge :" ?

With setting the tab title format to %d : %n : %w it use to give the specific package being emerged, and where it was in the emerge list, (like 23 of 87, or whatever). Not having this is really missed, especially in Gentoo with all the compiling we do.

I looked at http://websvn.kde.org/trunk/KDE/kdebase/apps/konsole/src at the files, like TabTitleFormatAction, but didn't see how the last revision related to this new bad behavior. Is this even the right file that could have caused this, or is it something else entirely? In the ShellCommand.cpp file, the last revision refers to:
Quote:
Convert tabs to 4 spaces to match kdelibs conventions. Previously
there was a mix of tabs and spaces for indentation.
Could that be it? :?
_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.9.0, kernel 3.15.5-gentoo (USE=experimental "native")
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Sep 30, 2008 3:00 pm    Post subject: Reply with quote

Is it possible to use either/both of these overlays with Paludis.?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Tue Sep 30, 2008 3:11 pm    Post subject: Reply with quote

tampakrap wrote:
Please everyone check again your symlinks



oops :-) thanks, everything ok

now I have only one problem: plasmoids won't save their position at every reboot!

also digikam, kipi-plugins, amarok doesn't compile:

for amarok:

Code:
-----------------------------------------------------------------------------                                                                 
-- The following REQUIRED packages could NOT be located on your system.                                                                       
-- Please install them before continuing this software installation.                                                                           
-----------------------------------------------------------------------------                                                                 
+ mysqld: Embedded MySQL <http://www.mysql.com>                                                                                               
----------------------------------------------------------------------------- 


what i have to emerge? I HAVE mysql....







for digikam:
Code:
[  7%] Building CXX object digikam/CMakeFiles/digikam.dir/__/libs/dimg/dimg.o                                                                 
[  7%] Building CXX object digikam/CMakeFiles/digikam.dir/__/libs/dimg/dimgscale.o                                                             
/var/tmp/portage/media-gfx/digikam-0.10.0_beta3/work/digikam-0.10.0-beta3/libs/dimg/dimg.cpp:48:35: error: libkdcraw/dcrawbinary.h: No such file or directory                                                                                                                                 
/var/tmp/portage/media-gfx/digikam-0.10.0_beta3/work/digikam-0.10.0-beta3/libs/dimg/dimg.cpp: In static member function ‘static Digikam::DImg::FORMAT Digikam::DImg::fileFormat(const QString&)’:                                                                                             
/var/tmp/portage/media-gfx/digikam-0.10.0_beta3/work/digikam-0.10.0-beta3/libs/dimg/dimg.cpp:510: error: ‘KDcrawIface::DcrawBinary’ has not been declared                                                                                                                                     
make[2]: *** [digikam/CMakeFiles/digikam.dir/__/libs/dimg/dimg.o] Error 1                                                                     
make[2]: *** Waiting for unfinished jobs....                                                                                                   
make[1]: *** [digikam/CMakeFiles/digikam.dir/all] Error 2                                                                                     
make: *** [all] Error 2                                                                                                                       
 *                                                                                                                                             
 * ERROR: media-gfx/digikam-0.10.0_beta3 failed.                                                                                               
 * Call stack:                                                                                                                                 
 *               ebuild.sh, line   49:  Called src_compile                                                                                     
 *             environment, line 2687:  Called kde4overlay-base_src_compile                                                                   
 *             environment, line 2019:  Called kde4overlay-base_src_make                                                                       
 *             environment, line 2052:  Called cmake-utils_src_make                                                                           
 *             environment, line  703:  Called die                                                                                             
 * The specific snippet of code:                                                                                                               
 *           emake "$@" || die "Make failed!";                                                                                                 
 *  The die message:                                                                                                                           
 *   Make failed!                                                           


I have libkdcraw:
[ebuild R ] kde-base/libkdcraw-4.1.67


Last edited by Krog on Tue Sep 30, 2008 4:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
code_raptor
n00b
n00b


Joined: 24 Jun 2005
Posts: 47

PostPosted: Tue Sep 30, 2008 3:32 pm    Post subject: Reply with quote

wrc1944 wrote:
Anyone notice in the last week or two in konsole the tabs no longer give any info other than "kdesvn : emerge :" ?

With setting the tab title format to %d : %n : %w it use to give the specific package being emerged, and where it was in the emerge list, (like 23 of 87, or whatever). Not having this is really missed, especially in Gentoo with all the compiling we do.

I looked at http://websvn.kde.org/trunk/KDE/kdebase/apps/konsole/src at the files, like TabTitleFormatAction, but didn't see how the last revision related to this new bad behavior. Is this even the right file that could have caused this, or is it something else entirely? In the ShellCommand.cpp file, the last revision refers to:
Quote:
Convert tabs to 4 spaces to match kdelibs conventions. Previously
there was a mix of tabs and spaces for indentation.
Could that be it? :?


Iunno, but i think that is older than a week or two, btw http://websvn.kde.org/trunk/KDE/kdebase/apps/konsole/src/Profile.cpp?view=markup

Code:
....
    setProperty(LocalTabTitleFormat,"%d : %n");
    setProperty(RemoteTabTitleFormat,"%H (%u)");
....


looks like the fallback config when is the first run of konsole. A patch that changes those default options for "%w" looks good for gentoo users. (I was like crazy looking into portage source code the reason why those messages had gone before noticing the tab title format settings in konsole/yakuake :oops: )
_________________
just feel the code...
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Sep 30, 2008 3:36 pm    Post subject: Reply with quote

Krog wrote:
for amarok:

Code:
-----------------------------------------------------------------------------                                                                 
-- The following REQUIRED packages could NOT be located on your system.                                                                       
-- Please install them before continuing this software installation.                                                                           
-----------------------------------------------------------------------------                                                                 
+ mysqld: Embedded MySQL <http://www.mysql.com>                                                                                               
----------------------------------------------------------------------------- 


what i have to emerge? I HAVE mysql....

You need mysql with USE="embedded" enabled.

Further more you'll need to temporary add "-fPIC" to your CFLAGS before compiling mysql. Remove it again after mysql is rebuild!
That is nessecary until mysql.eclass is fixed for up to 5.0.60 or upstream fixes it in newer releases.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Master of the Darkside
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 94
Location: Iasi, Romania

PostPosted: Tue Sep 30, 2008 6:20 pm    Post subject: Reply with quote

loftwyr wrote:
Is it possible to use either/both of these overlays with Paludis.?


Sure! Use playman.
_________________
No weight nor mass nor beauty of execution can outweigh a grain or fragment of thought
Back to top
View user's profile Send private message
frankOnPPC
Apprentice
Apprentice


Joined: 26 May 2003
Posts: 169
Location: Fulda, Hessen, Germany, Europe, Earth

PostPosted: Tue Sep 30, 2008 10:31 pm    Post subject: undefined reference to `jpeg_resync_to_restart' kdelibs-4... Reply with quote

I got a

jpegloader.cpp:(.text+0xb48): undefined reference to `jpeg_finish_output'
jpegloader.cpp:(.text+0xb50): undefined reference to `jpeg_input_complete'
CMakeFiles/khtml.dir/imload/decoders/jpegloader.o:(.got2+0xc): undefined reference to `jpeg_resync_to_restart'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkhtml.so.5.1.0] Error 1
make[1]: *** [khtml/CMakeFiles/khtml.dir/all] Error 2

Which ends in

* ERROR: kde-base/kdelibs-4.1.1-r4 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 2666: Called kde4-base_src_compile
* environment, line 2003: Called kde4-base_src_make
* environment, line 2038: Called cmake-utils_src_make
* environment, line 659: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
and* The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.1.1-r4/temp/environment'.
* This ebuild used the following eclasses from overlays:
* /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass
* /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass
* This ebuild is from an overlay: '/usr/local/portage/layman/kde-testing/'

emerge --info
...
Portage 2.2_rc11 (default-linux/ppc/ppc32/2006.1, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.24-gentoo-r3 ppc)
=================================================================
System uname: Linux-2.6.24-gentoo-r3-ppc-7455,_altivec_supported-with-glibc2.0
Timestamp of tree: Mon, 29 Sep 2008 19:34:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python: 2.3.6-r6, 2.4.4-r15, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache: 2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc: 0.2.5
sys-apps/sandbox: 1.2.18.1-r3
sys-devel/autoconf: 2.13, 2.63
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.26
ACCEPT_KEYWORDS="ppc ~ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=7400 -maltivec -mabi=altivec -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php4/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php4/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=7400 -maltivec -mabi=altivec -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://212.219.56.152/sites/www.ibiblio.org/gentoo/ ftp://212.219.56.131/sites/www.ibiblio.org/gentoo/ ftp://212.219.56.162/sites/www.ibiblio.org/gentoo/ ftp://212.219.56.146/sites/www.ibiblio.org/gentoo/ ftp://ftp.ankara.edu.tr/gentoo/ http://adelie.polymtl.ca/ ftp://mirror.pacific.net.au/linux/Gentoo"
LC_ALL="C"
LDFLAGS=""
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apache2 arts berkdb bidi bitmap-fonts bonobo cdr cgi chipcard cli cracklib crypt cups dbus dri dvd dvdread dvdwrite eds emboss encode esd faad firefox foomaticdb fortran gd gdbm gif gimp gnome gpm gstreamer gtk gtk2 gtkhtml gvlc hbci iconv imlib ipv6 isdnlog jpeg kde kdeprefix kvlc ldap libwww mad matroska midi mikmod mozilla mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl php png ppc ppds pppd python qt qt3 qt4 quicktime quotes readline reflection ruby sdl session soup spell spl ssl svg tcpd tk truetype truetype-fonts type1-fonts unicode usb vorbis wxgtk1 wxwindows xml xorg xprint xulrunner xv zlib" ALSA_CARDS="usb-audio usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="ati128 fbdev vesa radeon ati"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


I'm little bit confused, at first, kde-testing is still the official overlay for kde-testing ? I'm little bit confused about those several kde-4.x.x things going on.

But back to the "link" problem, where should I look to get rid of it ?

well, re-emerge jpeg ?

Kind regards,
cheers,
Frank
_________________
always look at yellow site of Linux on the PPC.
Its PPCNUX.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Wed Oct 01, 2008 1:36 am    Post subject: Reply with quote

Master of the Darkside wrote:
loftwyr wrote:
Is it possible to use either/both of these overlays with Paludis.?


Sure! Use playman.


It's if paludis supports the @setname that portage uses. I haven't seen it mentioned in the paludis pages so I want to make sure before I convert away from the experimental overlay
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Shamus397
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 147
Location: Ur-th

PostPosted: Wed Oct 01, 2008 3:04 am    Post subject: Reply with quote

Unfortunately paludis doesn't support portage style sets, so that's a no go. That's a big part of the reason why I switched back to portage: it now supports sets and the EAPI that the devs needed, so there's no need to use paludis anymore. :)

I feel so much cleaner now that paludis is out of my system. :lol:
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Wed Oct 01, 2008 7:57 am    Post subject: Reply with quote

I have exactly same problem as Krog in kipi-plugin and digikam. The dcrawbinary.h is provided by libkdcraw-0.1.* branch, but now in 4.2 slot. what's wrong?
Also behaviro of plasmoid panel are very unpredictable.
Back to top
View user's profile Send private message
bartek
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2004
Posts: 80
Location: Poland, Pysznica

PostPosted: Wed Oct 01, 2008 6:23 pm    Post subject: Reply with quote

After I updated kdesvn-portage overlay today this happend:
Code:

X2 bartek # emerge -pv --emptytree world

These are the packages that would be merged, in order:

Calculating world dependencies                                   t
!!! All ebuilds that could satisfy "kde-base/plasma-workspace:kde-svn" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/plasma-workspace-9999 (masked by: )

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "kde-base/ksysguard-9999" [ebuild])



!!! Problem resolving dependencies for kde-base/ksysguard:kde-svn
!!! Depgraph creation failed.

but I have plasma-workspace unmasked
Code:

X2 bartek # cat /etc/portage/package.keywords |grep kde-base/plasma-workspace
=kde-base/plasma-workspace-9999:kde-svn **

so why emerge complains about plasma-workspace masked?
Back to top
View user's profile Send private message
Shamus397
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 147
Location: Ur-th

PostPosted: Thu Oct 02, 2008 3:07 am    Post subject: Reply with quote

It's been a while since I've had to do this, but I believe that you have to put
Code:
kde-base/plasma-workspace-9999:kde-svn

into /usr/portage/package.unmask.
Back to top
View user's profile Send private message
LD
Guru
Guru


Joined: 23 Dec 2003
Posts: 336
Location: Middle of No-Where Granbury, Tx

PostPosted: Thu Oct 02, 2008 5:36 am    Post subject: Reply with quote

Tried to do emerge -vp @kde-4.2

It's giving this error.

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-misc/yakuake:4.2".

_________________
[Owner/Operator: Dhampir Dreams]
Last.fm profile
Netflix Profile
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Thu Oct 02, 2008 5:41 am    Post subject: Reply with quote

with 4.2 I have some huge problems:


1)plasmoids don't save their position


2)kopete crashes: it starts minimized in systray, I click on the icon and this is the output:

Code:
krog@krogpc ~ $ kopete
Calling appendChild() on a null node does nothing.
krog@krogpc ~ $ Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
kopete(7602)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '!
kopete(7602)/kopete (statistics): error " " on query: "SELECT name FROM sqlite_master WHERE type='table'"
kopete(7602)/kopete (statistics): error " " on query: "CREATE TABLE contactstatus (id INTEGER PRIMARY KEY,metacontactid TEXT,status TEXT,datetimebegin INTEGER,datetimeend INTEGER);"
kopete(7602)/kopete (statistics): error " " on query: "CREATE TABLE commonstats (id INTEGER PRIMARY KEY,metacontactid TEXT,statname TEXT,statvalue1 TEXT,statvalue2 TEXT);"
kopete(7602)/kopete (statistics): error " " on query: "CREATE TABLE statsgroup(id INTEGER PRIMARY KEY,datetimebegin INTEGER,datetimeend INTEGER,caption TEXT);"
Calling appendChild() on a null node does nothing.
kopete(7602)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "kopete_icq" '!
Object::connect: Parentheses expected, signal QSslSocket::QAbstractSocket::SocketError
Object::connect: No such signal QSslSocket::closed()

krog@krogpc ~ $
krog@krogpc ~ $ KCrash: Application 'kopete' crashing...
sock_file=/home/krog/.kde/socket-krogpc/kdeinit4__0


i am the only one with this bugs???
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Thu Oct 02, 2008 5:52 am    Post subject: Reply with quote

/usr/portage/profiles/package.mask wrote:
# Tobias Heinlein <keytoaster@gentoo.org> (02 Oct 2008)
# KDE 4.1.2 ebuilds from the kde overlay are going to enter the tree.
# Masked to avoid problems on sync.
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Thu Oct 02, 2008 7:26 am    Post subject: update to 4.1.68 failed at plasma-workspace Reply with quote

This morning I did a
Code:
emerge -avuND world

and found kde-4.1.68 is in portage. However, emerge plasma-workspace-4.1.68 failed:
Quote:

Generating trash.moc
Scanning dependencies of target plasma_applet_trash
[ 7%] Building CXX object plasma/applets/trash/CMakeFiles/plasma_applet_trash.dir/plasma_applet_trash_automoc.o
[ 8%] Building CXX object plasma/applets/trash/CMakeFiles/plasma_applet_trash.dir/trash.o
Linking CXX shared module ../../../lib/plasma_applet_trash.so
[ 8%] Built target plasma_applet_trash
make[2]: *** No rule to make target `/var/tmp/portage/kde-base/plasma-workspace-4.1.68/work/plasma-workspace-4.1.68/krunner/org.kde.krunner.App.xml', needed by `plasma/applets/kickoff/krunner_interface.cpp'. Stop.
make[1]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/all] Error 2
make: *** [all] Error 2
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Thu Oct 02, 2008 8:03 am    Post subject: Reply with quote

kdeplasma-workspace-4.1.68 fails to build!

Code:

>>> Unpacking source...
Unpacking parts of kdebase-workspace-4.1.68.tar.bz2 to /var/tmp/portage/kde-base/plasma-workspace-4.1.68/work
Injecting library dependendencies from 'libplasma'
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/kde-base/plasma-workspace-4.1.68/work/plasma-workspace-4.1.68 ...
Enabling building of HTML handbook
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Failed
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /usr/lib/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/4.2/include
-- Found KDE 4.2 library dir: /usr/kde/4.2/lib
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/4.2/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Strigi 0.6.0
-- Found Strigi: /usr/lib/libstreams.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found QImageBlitz: /usr/include/qimageblitz
-- Found ZLIB: /lib/libz.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found LIBUSB: /lib/libusb.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Fontconfig: /usr/lib/libfontconfig.so
-- Found Freetype: -lfreetype -lz
-- checking for modules 'libggadget-1.0>=0.10.3;libggadget-qt-1.0>=0.10.3'
--   package 'libggadget-1.0>=0.10.3' not found
--   package 'libggadget-qt-1.0>=0.10.3' not found
-- Could NOT find Googlegadgets  (missing:  GOOGLEGADGETS_LIBRARIES GOOGLEGADGETS_INCLUDE_DIRS)
-- checking for modules 'qzion>=0.3.0;qedje>=0.3.0'
--   package 'qzion>=0.3.0' not found
--   package 'qedje>=0.3.0' not found
-- Could not find QZion and/or QEdje. Please download them here (http://dev.openbossa.org/trac/qedje).
-- Could NOT find QEdje  (missing:  QEdje_LIBRARY)
-- Performing Test PAM_MESSAGE_CONST
-- Performing Test PAM_MESSAGE_CONST - Success
-- Found PAM: /lib/libpam.so;/usr/lib/libdl.so
-- Looking for getspnam
-- Looking for getspnam - found
-- Looking for crypt in crypt
-- Looking for crypt in crypt - found
-- Looking for include files HAVE_CRYPT_H
-- Looking for include files HAVE_CRYPT_H - found
-- Looking for XkbLockModifiers in X11
-- Looking for XkbLockModifiers in X11 - found
-- Looking for getpassphrase
-- Looking for getpassphrase - not found
-- Looking for vsyslog
-- Looking for vsyslog - found
-- Looking for statvfs
-- Looking for statvfs - found
-- Looking for include files HAVE_LIMITS_H
-- Looking for include files HAVE_LIMITS_H - found
-- Looking for include files HAVE_SYS_TIME_H
-- Looking for include files HAVE_SYS_TIME_H - found
-- Looking for include files HAVE_STDINT_H
-- Looking for include files HAVE_STDINT_H - found
-- Looking for include files HAVE_SYS_VFS_H
-- Looking for include files HAVE_SYS_VFS_H - found
-- Looking for include files HAVE_SYS_STATVFS_H
-- Looking for include files HAVE_SYS_STATVFS_H - found
-- Looking for include files HAVE_SYS_PARAM_H
-- Looking for include files HAVE_SYS_PARAM_H - found
-- Looking for include files HAVE_SYS_MOUNT_H
-- Looking for include files HAVE_SYS_MOUNT_H - found
-- Looking for include files HAVE_SYS_STATFS_H
-- Looking for include files HAVE_SYS_STATFS_H - found
-- Looking for statfs
-- Looking for statfs - found
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of struct ucred
-- Check size of struct ucred - failed
-- Looking for getpeereid
-- Looking for getpeereid - not found
-- checking for module 'xrandr>=1.2'
--   found xrandr, version 1.2.3
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found GLIB2: /usr/lib/libglib-2.0.so
-- checking for module 'xmms'
--   package 'xmms' not found
-- Could NOT find Xmms  (missing:  XMMS_LDFLAGS XMMS_INCLUDE_DIRS)
-- Could NOT find XMMS: the nowplaying dataengine will NOT support XMMS 1.x
-- Found KDE PIM libraries
-- Found Soprano: /usr/lib/libsoprano.so
-- Found Soprano includes: /usr/include
-- Found Soprano Index: /usr/lib/libsopranoindex.so
-- Found Soprano Client: /usr/lib/libsopranoclient.so
-- Found Soprano Plugins: nquadparser nquadserializer sesame2backend
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ libxss
+ libxext
+ Soprano
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ GoogleGadgets: Google Gadgets library <http://code.google.com/p/google-gadgets-for-linux/>
Needed to build plasma scriptengine for google gadgets
+ QEdje: QEdje library <http://dev.openbossa.org/trac/qedje/>
Needed to build plasma scriptengine for edje files
+ XMMS: X MultiMedia System developement libraries <http://www.xmms.org>
Support for XMMS in the Now Playing data engine
-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/plasma-workspace-4.1.68/work/plasma-workspace_build
[  1%] [  2%] Generating ui_timezonesConfig.h
Generating ui_batteryConfig.h
Generating defaultAnimator.moc
Generating clockapplet.moc
Generating battery.moc
Scanning dependencies of target plasma_animator_default
[  2%] Generating ui_calendar.h
Scanning dependencies of target plasmaclock
Scanning dependencies of target plasma_applet_battery
[  2%] Building CXX object plasma/animators/default/CMakeFiles/plasma_animator_default.dir/defaultAnimator.o
[  2%] Building CXX object plasma/applets/battery/CMakeFiles/plasma_applet_battery.dir/battery.o
[  3%] Building CXX object plasma/applets/libplasmaclock/CMakeFiles/plasmaclock.dir/clocknumber.o
[  3%] Building CXX object plasma/applets/libplasmaclock/CMakeFiles/plasmaclock.dir/clockapplet.o
[  3%] Building CXX object plasma/animators/default/CMakeFiles/plasma_animator_default.dir/plasma_animator_default_automoc.o
Linking CXX shared module ../../../lib/plasma_animator_default.so
[  3%] Built target plasma_animator_default
Generating icon.moc
Scanning dependencies of target plasma_applet_icon
[  3%] Building CXX object plasma/applets/libplasmaclock/CMakeFiles/plasmaclock.dir/plasmaclock_automoc.o
Linking CXX shared library ../../../lib/libplasmaclock.so
[  3%] Building CXX object plasma/applets/icon/CMakeFiles/plasma_applet_icon.dir/icon.o
[  3%] Built target plasmaclock
[  3%] Generating ui_deviceNotifierConfig.h
Generating notifierview.moc
Generating devicenotifier.moc
[  3%] Building CXX object plasma/applets/battery/CMakeFiles/plasma_applet_battery.dir/plasma_applet_battery_automoc.o
Linking CXX shared module ../../../lib/plasma_applet_battery.so
Generating notifierdialog.moc
[  3%] Built target plasma_applet_battery
Generating trash.moc
Scanning dependencies of target plasma_applet_devicenotifier
[  3%] Building CXX object plasma/applets/icon/CMakeFiles/plasma_applet_icon.dir/plasma_applet_icon_automoc.o
Linking CXX shared module ../../../lib/plasma_applet_icon.so
Scanning dependencies of target plasma_applet_trash
[  3%] Built target plasma_applet_icon
make[2]: *** No rule to make target `/var/tmp/portage/kde-base/plasma-workspace-4.1.68/work/plasma-workspace-4.1.68/krunner/org.kde.krunner.App.xml', needed by `plasma/applets/kickoff/krunner_interface.cpp'.  Stop.
make[1]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[  3%] Building CXX object plasma/applets/devicenotifier/CMakeFiles/plasma_applet_devicenotifier.dir/devicenotifier.o
[  3%] Building CXX object plasma/applets/devicenotifier/CMakeFiles/plasma_applet_devicenotifier.dir/notifierdialog.o
[  3%] Building CXX object plasma/applets/trash/CMakeFiles/plasma_applet_trash.dir/trash.o
[  4%] Building CXX object plasma/applets/devicenotifier/CMakeFiles/plasma_applet_devicenotifier.dir/notifierview.o
[  5%] Building CXX object plasma/applets/devicenotifier/CMakeFiles/plasma_applet_devicenotifier.dir/plasma_applet_devicenotifier_automoc.o
Linking CXX shared module ../../../lib/plasma_applet_devicenotifier.so
[  5%] Building CXX object plasma/applets/trash/CMakeFiles/plasma_applet_trash.dir/plasma_applet_trash_automoc.o
Linking CXX shared module ../../../lib/plasma_applet_trash.so
[  5%] Built target plasma_applet_devicenotifier
[  5%] Built target plasma_applet_trash
make: *** [all] Error 2
 *
 * ERROR: kde-base/plasma-workspace-4.1.68 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 2906:  Called kde4overlay-meta_src_compile
 * environment, line 2272:  Called kde4overlay-meta_src_make
 * environment, line 2321:  Called kde4overlay-base_src_make
 * environment, line 2030:  Called cmake-utils_src_make
 * environment, line  711:  Called die
 * The specific snippet of code:
 * emake "$@" || die "Make failed!";
 * The die message:
 * Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/plasma-workspace-4.1.68/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/plasma-workspace-4.1.68/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Thu Oct 02, 2008 9:45 am    Post subject: libkdcraw and digikam/kipi-plugins Reply with quote

Emerge digikam and kipi-plugins in 4.2 slot failed due to missing dcrawbinary.h:
Quote:

[ 0%] Building CXX object digikam/CMakeFiles/digikam.dir/__/libs/dimg/dimg.o
/var/tmp/portage/media-gfx/digikam-0.10.0_beta3/work/digikam-0.10.0-beta3/libs/dimg/dimg.cpp:48:35: error: libkdcraw/dcrawbinary.h: No such file or directory
/var/tmp/portage/media-gfx/digikam-0.10.0_beta3/work/digikam-0.10.0-beta3/libs/dimg/dimg.cpp: In static member function ‘static Digikam::DImg::FORMAT Digikam::DImg::fileFormat(const QString&)’:
/var/tmp/portage/media-gfx/digikam-0.10.0_beta3/work/digikam-0.10.0-beta3/libs/dimg/dimg.cpp:510: error: ‘KDcrawIface::DcrawBinary’ has not been declared
make[2]: *** [digikam/CMakeFiles/digikam.dir/__/libs/dimg/dimg.o] Error 1
make[1]: *** [digikam/CMakeFiles/digikam.dir/all] Error 2
make: *** [all] Error 2

According to the news in libkdcraw:
Quote:

0.4.0 - Released with KDE 4.2.0
Updated LibRaw to 0.6.1.
Ported to LibRaw Api 0.6.0. Removed dcraw.c and DcrawBinary class.
Use kDebug(51002) instead qDebug().
New cameras: Canon 50D, Sony A900, Nikon D90 & P6000, Panasonic LX3 FZ28.

dcrawbinary has been removed in this release. Seems digikam and kipi-plugins in 4.2 slot are not consitent with libkdcraw release.
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Thu Oct 02, 2008 12:24 pm    Post subject: Reply with quote

For me, too , plasma-workspace 4.1.68 fails to build :(

EDIT: works with the new ebuild!!
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Thu Oct 02, 2008 12:47 pm    Post subject: Reply with quote

Yup, great work kdesvn-portage team. The new ebuild solves the issue.

And now for the big news:

KDE-4.1.2 is in portage.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 28, 29, 30  Next
Page 1 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum