Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2008.0 on T5120
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
gnork
n00b
n00b


Joined: 08 Sep 2004
Posts: 23
Location: Germany

PostPosted: Thu Sep 18, 2008 2:46 pm    Post subject: 2008.0 on T5120 Reply with quote

Hi all!

I am having a problem getting the 2008.0 Universal Install CD to boot my brand new 5120 Boxen.
The kernel can't find the CDROM device. /dev contains sda,sdb and sr0. sr0 should be the DVD/CDROM device.

dmesg snippets
Code:

.
.
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 5 ports detected
usb 1-2: new high speed USB device using ehci_hcd and address 2
usb 1-2: configuration #1 chosen from 1 choice
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: configuration #1 chosen from 1 choice
hub 1-4:1.0: USB hub found
hub 1-4:1.0: 4 ports detected
usbcore: registered new interface driver libusual
Initializing USB Mass Storage driver...
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
.
.

sr0: scsi3-mmc drive: 6x/24x writer dvd-ram cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0
.
.
.


Output of boot screen:
Code:


>> Loading modules tocol family 17
   :: Scanning for scsi_wait_scan...scsi_wait_scan loaded.
   :: Scanning for sata_promise...sata_promise loaded.
   :: Scanning for sata_sil...sata_sil loaded.
   :: Scanning for sata_sil24...sata_sil24 loaded.
   :: Scanning for sata_via...sata_via loaded.
   :: Scanning for sata_sx4...sata_sx4 loaded.
   :: Scanning for ahci...ahci loaded.
   :: Scanning for aic7xxx...aic7xxx loaded.
   :: Scanning for qla2xxx...qla2xxx loaded.
   :: Scanning for ehci-hcd...usbcore, ehci-hcd loaded.
   :: Scanning for usb-storage...libusual, usb-storage loaded.
   :: Scanning for uhci-hcd...uhci-hcd loaded.
   :: Scanning for ohci-hcd...ohci-hcd loaded.
   :: Scanning for usbhid...usbhid loaded.
   :: Scanning for dm-mod...dm-mod loaded.
   :: Scanning for dm-mirror...dm-mirror loaded.
   :: Scanning for dm-snapshot...dm-snapshot loaded.
   :: Scanning for dm-bbr...dm-bbr loaded.
   :: Scanning for raid0...md-mod, raid0 loaded.
   :: Scanning for raid1...raid1 loaded.
   :: Scanning for raid456...xor, async_xor, async_memcpy, async_tx, raid456 loaded.
   :: Scanning for raid10...raid10 loaded.
   :: Scanning for nfs...sunrpc, lockd, nfs_acl, nfs loaded.
   :: Scanning for e1000...e1000 loaded.
   :: Scanning for tg3...tg3 loaded.
>> Activating mdev
>> Making tmpfs for /newroot
>> Looking for the cdrom
>> Attempting to mount media:- /dev/sda1
>> Attempting to mount media:- /dev/sda2
>> Attempting to mount media:- /dev/sda3
>> Attempting to mount media:- /dev/sda4
>> Attempting to mount media:- /dev/sdb1
>> Attempting to mount media:- /dev/sdb2
>> Attempting to mount media:- /dev/sdb3
>> Attempting to mount media:- /dev/sdb7
!! Media not found
>> No bootable medium found. Waiting for new devices...
>> Looking for the cdrom
>> Attempting to mount media:- /dev/sr0
>> Attempting to mount media:- /dev/sda1
>> Attempting to mount media:- /dev/sda2
>> Attempting to mount media:- /dev/sda3
>> Attempting to mount media:- /dev/sda4
>> Attempting to mount media:- /dev/sdb1
>> Attempting to mount media:- /dev/sdb2
>> Attempting to mount media:- /dev/sdb3
>> Attempting to mount media:- /dev/sdb7
!! Media not found
!! Could not find CD to boot, something else needed!

usbstorage is loaded, drive is registered but still the kernel won't see it. Tried /dev/sr0 and /dev/usb* to no avail.
Any hints on how to solve this (2007.0 won't boot at all)?

2 related questions:

What -mcpu do I set for the Niagara processors, is "ultrasparc" sufficient?
How do I create a HW RAID volume, is there anything similar to Solaris' raidctl for Linux?

TIA
gnork
_________________
--
Life is like an analogy
-
Back to top
View user's profile Send private message
armin76
Developer
Developer


Joined: 24 Apr 2006
Posts: 173

PostPosted: Fri Sep 19, 2008 11:28 am    Post subject: Reply with quote

CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O2 -pipe"
Those are the CFLAGS we use on a T1.

I'm not sure about the RAID thing you mention, maybe mdraid or mdadm works?

As for not being able to boot, thats strange, because it detects the cd rom, doesn't it? Tried the netboot image? http://xrl.us/bjm3q
Back to top
View user's profile Send private message
gnork
n00b
n00b


Joined: 08 Sep 2004
Posts: 23
Location: Germany

PostPosted: Fri Sep 19, 2008 5:15 pm    Post subject: Reply with quote

Ty for the cflags.

The cdrom is detected and I can read device info from proc.

Netboot link is dead, I will try to find another netboot image. As for raidctl, found a linux
utility called "limcu" which should do the same. Could not test yet if it works with sparc.

PS:
Ubuntu boots fine, but they dropped sparc support with 7.10 and I really
want to run Gentoo on these machines (-j41?).
_________________
--
Life is like an analogy
-
Back to top
View user's profile Send private message
blu3bird
Retired Dev
Retired Dev


Joined: 04 Oct 2003
Posts: 608
Location: Munich, Germany

PostPosted: Fri Sep 19, 2008 7:03 pm    Post subject: Reply with quote

gnork wrote:
Ty for the cflags.

With gcc 4.3 you can also use -mcpu=niagara (UltraSparc T1) and -mcpu=niagara2 (UltraSparc T2) but beware, ist's still ~sparc (testing) ;)
(current is 4.1)

gnork wrote:
Ubuntu boots fine, but they dropped sparc support with 7.10 and I really
want to run Gentoo on these machines (-j41?).

You don't need a Gentoo CD to install Gentoo, almost any Linux CD will do ;)

Check if the Ubuntu CD offers some kind of rescue/emergency console (eg on ctrl + alt + f2). If it does and if it includes the proper tools (fdisk, mkfs.ext3, wget, tar, chroot) you're good to go :)
_________________
Black Holes are created when God divides by zero!
Back to top
View user's profile Send private message
gnork
n00b
n00b


Joined: 08 Sep 2004
Posts: 23
Location: Germany

PostPosted: Fri Sep 19, 2008 7:23 pm    Post subject: Reply with quote

^ ^ ^ ^

*Brett vor dem Kopf*

This could work.
_________________
--
Life is like an analogy
-
Back to top
View user's profile Send private message
gnork
n00b
n00b


Joined: 08 Sep 2004
Posts: 23
Location: Germany

PostPosted: Mon Oct 06, 2008 8:25 am    Post subject: Reply with quote

Sitrep:

No CDROM/DVD image with all the tools needed to install boots. If the image boots, it either does not find the cdrom drive or only has a busybox - which is not enough fwiw. Tried Aurora, RH, Ubuntu, Gentoo and Splack. Netboot gives me "Illegal trap" for all images I tried so far.

Updated the OBP to the newest version and will try again this week.

Any hints where to find working netboot images?
_________________
--
Life is like an analogy
-
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum