Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RaLink RT2561/RT61.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jakob-andreas
n00b
n00b


Joined: 19 Aug 2005
Posts: 53
Location: East-Germany

PostPosted: Sat Jul 21, 2007 5:41 pm    Post subject: Reply with quote

ok, ndiswrapper is even worse than the original ralink driver. must the driver from windows be configured with all parameters when i tell ndiswrapper to use it? iwconfig shows me no ap, no ssid, simply nothin! ill try the original ralink-linux-driver again...
Back to top
View user's profile Send private message
jakob-andreas
n00b
n00b


Joined: 19 Aug 2005
Posts: 53
Location: East-Germany

PostPosted: Tue Jul 24, 2007 6:47 am    Post subject: Reply with quote

YEAH, now it works fine! i ever installed the beta1 version of rt61. dont know why. with the beta2 everything works. only installed the driver and modified the configurationfile /etc/Wireless/RT61STA/rt61sta.dat. and in /etc/conf.d/net i deactivated iwconfig and wpa_supplicant.
Back to top
View user's profile Send private message
foudebassan
n00b
n00b


Joined: 09 Feb 2006
Posts: 13
Location: France

PostPosted: Mon Jul 30, 2007 12:44 pm    Post subject: Reply with quote

I recently reinstalled my gentoo back on my hard drive.
I have built a 2.6.23-rc1 kernel.

as it was said before in this post : CONFIG_NET_RADIO is no longer in .config
the two different packages for rt61 in portage are still looking for this variable.

I managed to build my rt61 module, using the daily cvs build of the rt61 source module.

Code:

cd /tmp/
wget http://rt2x00.serialmonkey.com/rt61-cvs-daily.tar.gz
tar -zxvf rt61-cvs-daily.tar.gz
cd rt61-cvs-2007*/Module
make
make install
depmod -a
modprobe rt61


You should have your firmwares in this directory
Code:


localhost  # ls -al /lib/firmware/
total 36
drwxr-xr-x 2 root root 4096 Jul 29 16:13 .
drwxr-xr-x 7 root root 4096 Jul 30 14:37 ..
-rw-r--r-- 1 root root 8192 Jul 29 16:13 rt2561.bin
-rw-r--r-- 1 root root 8192 Jul 29 16:13 rt2561s.bin
-rw-r--r-- 1 root root 8192 Jul 29 16:13 rt2661.bin



Test your card:
Code:

ifconfig wlan0 up
iwlist wlan0 scan


You should see your access point :)

In the README , you find this :

Quote:

MANUAL CONFIG:

1. Set the interface mode and bring it up
# iwconfig wlan0 mode managed
# ifconfig wlan0 up

2. Set your target network / Access Point
If you just want to join a wireless network, set its ESSID:
# iwconfig wlan0 essid <ESSID>
If you want to associate with a specific AP, set its MAC
address:
# iwconfig wlan0 ap <BSSID>

3. Set encryption if needed

a) WEP (802.11b)
Choose the authentication mode (open/restricted):
# iwconfig wlan0 key open
Or:
# iwconfig wlan0 key restricted
Set the encryption key:
# iwconfig wlan0 key <KEY>

b) WPA (802.11g)
Set the authentication mode:
# iwpriv wlan0 set AuthMode=WPAPSK
Set the encryption key:
# iwpriv wlan0 set WPAPSK=<KEY>
Set the encryption type:
# iwpriv wlan0 set EncrypType=TKIP

c) WPA2 (802.11i)
Set the authentication mode:
# iwpriv wlan0 set AuthMode=WPA2PSK
Set the encryption key:
# iwpriv wlan0 set WPAPSK=<KEY>
Set the encryption type:
# iwpriv wlan0 set EncrypType=AES



I called this script from my /etc/conf.d/local.start :
I use WPA with PSK

#cat wifi.sh

Quote:


#!/bin/bash
/sbin/ifconfig wlan0 down
/sbin/iwconfig wlan0 mode managed
/sbin/ifconfig wlan0 up
/sbin/iwconfig wlan0 essid MySSID
/sbin/iwpriv wlan0 set AuthMode=WPAPSK
/sbin/iwpriv wlan0 set WPAPSK=MyPassPhrase
/sbin/iwpriv wlan0 set EncrypType=TKIP
/sbin/dhclient wlan0



:D
_________________
E6600 - P5WDH - Gskill 2x1Go HZ 4-4-4-12-4 - Raptor 75Go 10k tr/min 16 Mo - Seasonic s12 500 - P180 - XFX 7600GT XXX + Zalman - Liteon DVD et DVD-RW - Wifi : RT61
Back to top
View user's profile Send private message
VinnieNZ
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2004
Posts: 126
Location: New Zealand

PostPosted: Fri Aug 17, 2007 7:21 am    Post subject: Reply with quote

Anyone know why I keep getting this?

Code:
transition Module # make install
*** Install module in /lib/modules/2.6.22-gentoo-r2/extra ...
make[1]: Entering directory `/usr/src/linux-2.6.22-gentoo-r2'
  INSTALL /tmp/rt61-cvs-2007081701/Module/rt61.ko
  DEPMOD  2.6.22-gentoo-r2
WARNING: /lib/modules/2.6.22-gentoo-r2/net/rt61.ko needs unknown symbol pci_module_init
make[1]: Leaving directory `/usr/src/linux-2.6.22-gentoo-r2'
/sbin/depmod -a
*** Update /etc/modprobe.conf alias for wlan*
*** Install firmware in /lib/firmware ...
*** Check old config ...
transition Module # depmod -a
transition Module # modprobe rt61
FATAL: Error inserting rt61 (/lib/modules/2.6.22-gentoo-r2/net/rt61.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Back to top
View user's profile Send private message
gerardo
Apprentice
Apprentice


Joined: 05 Feb 2004
Posts: 228
Location: Belgium

PostPosted: Sat Aug 18, 2007 11:47 am    Post subject: Reply with quote

Try this
_________________
Windoze : Plug and Pay...
Back to top
View user's profile Send private message
gerardo
Apprentice
Apprentice


Joined: 05 Feb 2004
Posts: 228
Location: Belgium

PostPosted: Sun Aug 19, 2007 9:06 pm    Post subject: Reply with quote

Wireless is working (RT61PCI) with my modified ebuild (rt2x00-9999).
I can have WEP encryption, but WPA isn't working.

My wireless network is recognized correctly.
It's set up with WPA with
Cypher suite: TKIP
Authentication: Pre-shared Key
Pre-shared key type: Passphrase (32 characters)
Group Key Re_Keying: Per 86400 Seconds

Method of foudebassan:

I get iwpriv set is not supported:
Code:
# /sbin/iwpriv wlan0 set AuthMode=WPAPSK
Invalid command : set
# /sbin/iwpriv wlan0 set WPAPSK=MyPassPhrase
Invalid command : set
# /sbin/iwpriv wlan0 set EncrypType=TKIP
Invalid command : set


In latest versions of rt2x00, /etc/Wireless/RT61STA/rt61sta.dat is not supported anymore.

Are there any ebuild available for rt61 cvs version and for patched wpa_supplicant ?
I hate installing manually as this is a pain in the neck for uninstalling and upgrading...
_________________
Windoze : Plug and Pay...
Back to top
View user's profile Send private message
evone
n00b
n00b


Joined: 10 Mar 2006
Posts: 8

PostPosted: Fri Aug 31, 2007 7:55 am    Post subject: Reply with quote

foudebassan wrote:
I recently reinstalled my gentoo back on my hard drive.
I have built a 2.6.23-rc1 kernel.
....


thx thx :)
Back to top
View user's profile Send private message
lieut_data
n00b
n00b


Joined: 26 Jun 2005
Posts: 52
Location: [Waterloo|London] Ontario, Canada

PostPosted: Thu Sep 06, 2007 1:21 pm    Post subject: Reply with quote

There's a patched wpa_supplicant and rt61 drivers over at : http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=4104&highlight=wpa that has just been recently posted, claiming to work with amd64 and, of course, WPA. Perhaps this might be useful?
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Thu Sep 06, 2007 2:54 pm    Post subject: Reply with quote

I just got my Belkin F5D7000 vers.6000 working with the RaLink reference drivers in 2.6.22-gentoo-r5... I'll have to admit, those drivers suck... royally. Well, the configuration seems pretty screwed up, I was forced to use the config file that gets loaded upon insmod, since

iwconfig ra0 essid wapname

does not appear to take. If I subsequently check what the ssid was set to, it would always return blank.

I guess I should take a look at the serialmonkey version...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
thekillinghand
n00b
n00b


Joined: 31 Jan 2008
Posts: 1

PostPosted: Sat Feb 02, 2008 11:37 am    Post subject: Reply with quote

cold_water wrote:
Here is my 2 cents...

I was waiting for the driver for a while. Last month neither of the drivers worked on my SMP: ALL drivers were hanging my machine literally. ALL OF THEM: Serialmonkey (both legacy and non-legacy from CVS), RaLink driver 1.0.4, Gentoo driver 1.0.4...

I took my version 1.1.0.0 from RaLink and it works! If you a DIY guy then just run "make" in the "Module" directory...
Following are the steps how you can manually check if it works. Note: I shut down my eth0 since it is connected to the same router (temporary while I was waiting for a working driver), hence same network.

justincataldo wrote:
Code:
Dec  8 15:26:04 aria syslog-ng[5663]: syslog-ng version 1.6.9 starting
Dec  8 15:26:04 aria syslog-ng[5663]: Changing permissions on special file /dev/tty12
Dec  8 15:26:04 aria Linux version 2.6.17-gentoo-r8 (root@aria) (gcc version 4.1.1 (Gentoo 4.1.1-r1)) #7 Fri Dec 8 01:33:29 EST 2006

[skipped...]

Dec  8 15:30:02 aria eth1: link up, 100Mbps, full-duplex, lpa 0x41E1
Dec  8 15:30:02 aria RT61: RfIcType= 3
Dec  8 15:30:03 aria skge eth0: enabling interface
Dec  8 15:30:07 aria skge eth0: disabling interface
Dec  8 15:30:07 aria skge eth0: enabling interface
Dec  8 15:30:08 aria squid[6286]: Squid Parent: child process 6288 started
Dec  8 15:30:09 aria sshd[6364]: Server listening on 0.0.0.0 port 443.
Dec  8 15:30:10 aria cron[6440]: (CRON) STARTUP (V5.0)
Dec  8 15:33:28 aria sshd[6553]: Accepted keyboard-interactive/pam for justin from 203.94.138.104 port 21480 ssh2
Dec  8 15:33:28 aria sshd(pam_unix)[6559]: session opened for user justin by (uid=0)
Dec  8 15:33:33 aria su[6565]: Successful su for root by justin
Dec  8 15:33:33 aria su[6565]: + pts/0 justin:root
Dec  8 15:33:33 aria su(pam_unix)[6565]: session opened for user root by (uid=1000)


This is how I can start my rt61.ko:
Code:

dude xander # /etc/init.d/net.eth0 stop
 * Unmounting network filesystems ...                                     [ ok ]
 * Stopping ntpd ...                                                      [ ok ]
 * Stopping eth0
 *   Bringing down eth0
 *     Shutting down eth0 ...                                             [ ok ]
dude xander # ifconfig ra0 172.16.1.44 up
dude xander # route add default gw 172.16.1.101 <- this is my Linksys WRT54GL(inux) router
dude xander # ping www.yahoo.com
PING www.yahoo-ht2.akadns.net (209.73.186.238) 56(84) bytes of data.
64 bytes from f1.www.vip.re3.yahoo.com (209.73.186.238): icmp_seq=1 ttl=52 time=60.0 ms
64 bytes from f1.www.vip.re3.yahoo.com (209.73.186.238): icmp_seq=2 ttl=52 time=61.2 ms

--- www.yahoo-ht2.akadns.net ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 60.054/60.640/61.226/0.586 ms
dude xander # route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.16.0.0      0.0.0.0         255.255.0.0     U     0      0        0 ra0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         172.16.1.101    0.0.0.0         UG    0      0        0 ra0


My /etc/Wireless/RT61STA/rt61sta.dat:
Code:

[Default]
CountryRegion=0
CountryRegionABand=7
WirelessMode=4
SSID=MY_ROUTER_SSID
NetworkType=Infra
Channel=0
AuthMode=WPA2PSK
EncrypType=TKIP
DefaultKeyID=1
Key1Type=0
Key1Str=0123456789
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
WPAPSK=MY security phrase here
TxBurst=0
PktAggregate=0
TurboRate=0
WmmCapable=0
AckPolicy1=0
AckPolicy2=0
AckPolicy3=0
AckPolicy4=0
BGProtection=0
IEEE80211H=0
TxRate=0
RTSThreshold=2347
FragThreshold=2346
RoamThreshold=75
PSMode=CAM
TxPreamble=0
FastRoaming=0


My resolv.conf:
Code:

dude xander # cat /etc/resolv.conf
# Generated by net-scripts for interface eth0
nameserver 205.152.144.23
nameserver 205.152.132.23


My messages:
Code:

Dec  8 22:21:35 dude eth0: network connection down
Dec  8 22:22:35 dude ACPI: PCI Interrupt 0000:02:09.0[A] -> GSI 21 (level, low) -> IRQ 18
Dec  8 22:22:35 dude RT61: Vendor = 0x1814, Product = 0x0301
Dec  8 22:22:35 dude net.agent[9589]: add event not handled
Dec  8 22:24:35 dude su[9000]: pam_unix(su:session): session closed for user root
Dec  8 22:24:49 dude su[9639]: Successful su for root by xander
Dec  8 22:24:49 dude su[9639]: + pts/0 xander:root
Dec  8 22:24:49 dude su[9639]: pam_unix(su:session): session opened for user root by xander(uid=1000)
Dec  8 22:27:44 dude RT61: RfIcType= 3
Dec  8 22:27:47 dude 19:76:91:82:b9:72:95:fa:86:02:86:19:2e:a4:a5:9b:
Dec  8 22:27:47 dude ec:fb:f9:dd:f7:2e:75:2d:
Dec  8 22:27:47 dude c5:ec:80:21:23:56:22:41:


iwlist scan gives:
Code:

dude xander # iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

ra0       Scan completed :
          Cell 01 - Address: 00:18:39:7A:D2:8D
                    ESSID:"MY_ROUTER_SSID"
                    Mode:Managed
                    Channel:6
                    Encryption key:on
                    Bit Rates:132 Mb/s
          Cell 02 - Address: 00:0D:72:7C:19:E9
                    ESSID:"NEIGHBOR1_SSID"
                    Mode:Managed
                    Channel:6
                    Encryption key:off
                    Bit Rates:6 Mb/s
          Cell 03 - Address: 00:13:10:A9:1E:A2
                    ESSID:"NEIGHBOR2_SSID"
                    Mode:Managed
                    Channel:6
                    Encryption key:off
                    Bit Rates:250 Mb/s


Next step is check how well wireless scripts/configs work...

To moderator: sorry if it is too lengthy.



This worked for me too after 2 weeks of scratching my head. Could not get this card working, i even considered giving up and buying a different card until it occurred to me to try a different kernel - this card is not (as far as i can see) supported by the 2.6.23-r3 kernel.. I had no luck until i downgraded to 2.6.21. I believe 2.6.22 works too.

2.6.24 is said to have a better set of wireless drivers... ill give it a try when its available thru portage.

I used the rt61 1.1.0 Beta 2 CVS drivers (emerge rt61, not ralink-rt61), worked for me...

Thanks!
Back to top
View user's profile Send private message
Tin
Guru
Guru


Joined: 22 Dec 2005
Posts: 303
Location: Namur, Belgium

PostPosted: Wed Feb 06, 2008 5:57 pm    Post subject: Reply with quote

Hi,

Thank you all of you for your help.
Thanks to you, it works for me.

I have a D-Link DWL-G510
lspci gives me :
Code:

02:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g


I emerged ralink-rt61

ln -s /etc/init.d/net.lo /etc/init.d/net.ra0
edit /etc/conf.d/net:
Code:
config_ra0=( "dhcp" )
postup() {
        if [ ra0 == ${IFACE} ]; then
                ifconfig ra0 mtu 1300
        fi
}
modules=( "!iwconfig" "!wpa_supplicant" )



I modify /etc/Wireless/RT61STA/rt61sta.dat
and change the SSID and the channel (I don't use encryption)

rmmod rt61
/etc/init.d/net.ra0 start

And the dhcp works magically :-)

Thank you all of you.
_________________
Tin, the gentoobie
Back to top
View user's profile Send private message
Tin
Guru
Guru


Joined: 22 Dec 2005
Posts: 303
Location: Namur, Belgium

PostPosted: Thu Feb 07, 2008 8:49 am    Post subject: Reply with quote

I talked too fast.
It works, but not really correctly :

When I boot the machine, all is up but the ra0 cannot get an address from the dhcp.
What I have to do is to stop the interface, unload the rt61 module (that is loaded by udev I guess), restart the interface and all is fine.
Code:

/etc/init.d/net.ra0 stop
rmmod rt61
/etc/init.d/net.ra0 start


How can I solve this problem by avoiding the module to be loaded before the interface starts ?

Thank you for your ideas.
_________________
Tin, the gentoobie
Back to top
View user's profile Send private message
Tin
Guru
Guru


Joined: 22 Dec 2005
Posts: 303
Location: Namur, Belgium

PostPosted: Thu Feb 07, 2008 11:13 am    Post subject: Reply with quote

Ok, it does not seem to be the module problem, but ifplugd.
Actually, I un-install ifplugd (an utility that detect if the cable is up or down on wired interfaces and run the /etc/init.d/net.xxx start if the cable is detected) because it believed that the cable (...) was down on the ra0 interface, and stop the interface.
Now, all is correct.
_________________
Tin, the gentoobie
Back to top
View user's profile Send private message
juc0
n00b
n00b


Joined: 27 Aug 2007
Posts: 3

PostPosted: Sun Jul 13, 2008 2:56 am    Post subject: Reply with quote

On the 2.6.24 kernel I'm having issues compiling the ralink-rt61 driver, I get:

Code:

 * Applying rtmp_main.diff ...                                                         [ ok ]
 * Preparing rt61 module
make -C /lib/modules/2.6.24-gentoo-r8/build SUBDIRS=/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0/Module modules
make[1]: Entering directory `/usr/src/linux-2.6.24-gentoo-r8'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
scripts/Makefile.build:46: *** CFLAGS was changed in "/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0/Module/Makefile". Fix it to use EXTRA_CFLAGS.  Stop.
make[1]: *** [_module_/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0/Module] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.24-gentoo-r8'
make: *** [all] Error 2
 *
 * ERROR: net-wireless/ralink-rt61-1.1.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3143:  Called linux-mod_src_compile
 *             environment, line 2407:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                                   CC=\"$(get-KERNEL_CC)\"                                          LDFLAGS=\"$(get_abi_LDFLAGS)\"                                               ${BUILD_FIXES}                              ${BUILD_PARAMS}                                          ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS=
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/temp/environment'.
 *


I've seen the bug listed here: http://bugs.gentoo.org/show_bug.cgi?id=222375 but have no idea how to apply the Makefile.6 patch.

Any help appreciated
Back to top
View user's profile Send private message
rufnut
Apprentice
Apprentice


Joined: 16 May 2005
Posts: 184

PostPosted: Thu Jul 24, 2008 10:29 am    Post subject: Reply with quote

juc0 wrote:

I've seen the bug listed here: http://bugs.gentoo.org/show_bug.cgi?id=222375 but have no idea how to apply the Makefile.6 patch.

Any help appreciated


I just modified the ebuild and changed the patch to a diff as it didnt work for me either.

Good luck
Back to top
View user's profile Send private message
Leon_UK
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2006
Posts: 128
Location: London

PostPosted: Fri Aug 08, 2008 6:30 pm    Post subject: Reply with quote

I can get my card running with the in-kernel modules and copying the firmware from the ralink tar to /lib/firmware all the lights pop up my only problem is my whole network is running on wpa2, so when i try and connect i just get the messages "WEP key is not set for "ESSID 1,2,3"" etc.. i'm gonna have a play with it see if i can get it running or i will have to reconfig my whole network just for one card,
it's a shame since i brought it from linux emporium after checking if it could work with wpa2
Back to top
View user's profile Send private message
xeonman9000
n00b
n00b


Joined: 06 Aug 2008
Posts: 51
Location: UK

PostPosted: Sat Aug 09, 2008 1:20 am    Post subject: Reply with quote

Hi, I'm brand new to Gentoo so go easy on me (I've used Fedora for the last three years or so) :).

I have a wireless card which has the ra61 chipset and it worked out of the box in Fedora 9 with WPA-SPK encryption using kernel 2.6.25 which I am also using with Gentoo, thyerefore I am thinking that I may not need to compile drivers at all. The card is recognised by iwconfig as shown below.

Code:

lambert Module # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Channel:0  Access Point: Not-Associated 
          Tx-Power=0 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B 
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


I tried installing them using portage anyway and got the following error, I couldn't find any other post with this problem, anyone have any ideas?

Code:

lambert Module # emerge ralink-rt61
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) net-wireless/ralink-rt61-1.1.1.0 to /
 * IS_Linux_STA_6x_D_1.1.1.0.tar.gz RMD160 SHA1 SHA256 size ;-) ...          [ ok ]
 * checking ebuild checksums ;-) ...                       [ ok ]
 * checking auxfile checksums ;-) ...                      [ ok ]
 * checking miscfile checksums ;-) ...                     [ ok ]
 * checking IS_Linux_STA_6x_D_1.1.1.0.tar.gz ;-) ...       [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.25-gentoo-r7/build
 * Found sources for kernel version:
 *     2.6.25-gentoo-r7
 * Checking for suitable kernel configuration options...   [ ok ]
>>> Unpacking source...
>>> Unpacking IS_Linux_STA_6x_D_1.1.1.0.tar.gz to /var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0 ...
 * Applying rtmp_main.diff ...                             [ ok ]
 * Preparing rt61 module
make -C /lib/modules/2.6.25-gentoo-r7/build SUBDIRS=/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0/Module modules
make[1]: Entering directory `/usr/src/linux-2.6.25-gentoo-r7'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
scripts/Makefile.build:46: *** CFLAGS was changed in "/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0/Module/Makefile". Fix it to use EXTRA_CFLAGS.  Stop.
make[1]: *** [_module_/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/work/IS_Linux_STA_6x_D_1.1.1.0/Module] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.25-gentoo-r7'
make: *** [all] Error 2
 *
 * ERROR: net-wireless/ralink-rt61-1.1.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3195:  Called linux-mod_src_compile
 *             environment, line 2450:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"       CC=\"$(get-KERNEL_CC)\"                                          LDFLAGS=\"$(get_abi_LDFLAGS)\"                                   ${BUILD_FIXES}                                           ${BUILD_PARAMS}                                          ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CC=x86_64-pc-linux-gnu-gcc LDFLAGS=
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/temp/environment'.
 *

 * Messages for package net-wireless/ralink-rt61-1.1.1.0:

 *
 * ERROR: net-wireless/ralink-rt61-1.1.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3195:  Called linux-mod_src_compile
 *             environment, line 2450:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"       CC=\"$(get-KERNEL_CC)\"                                          LDFLAGS=\"$(get_abi_LDFLAGS)\"                                   ${BUILD_FIXES}                                           ${BUILD_PARAMS}                                          ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CC=x86_64-pc-linux-gnu-gcc LDFLAGS=
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.1.0/temp/environment'.
 *
Back to top
View user's profile Send private message
rufnut
Apprentice
Apprentice


Joined: 16 May 2005
Posts: 184

PostPosted: Sat Aug 09, 2008 6:51 am    Post subject: Reply with quote

Leon_UK wrote:
I can get my card running with the in-kernel modules


and Xeonman9000 be aware there are 2 different sets of rt61 drivers , one from Ralink and the other from the rt2x00 group

http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page

rt2x00 are the current in kernel drivers which work well for AP access.

However, if you need Adhoc or Turbo and or Mimo functions the ralink drivers are the way to go, as far as i know rt2x00 dont support these functions yet.

Xeonman, also, as you have a late kernel the ralink package you chose wont also compile thats why I modified the ebuild in a previous post, it maybe better just to setup the in kernel ones that appear almost setup from your "iwconfig" you posted but its up to you. :)


anyway good luck whichever way you choose.
:)
Back to top
View user's profile Send private message
xeonman9000
n00b
n00b


Joined: 06 Aug 2008
Posts: 51
Location: UK

PostPosted: Sat Aug 09, 2008 4:59 pm    Post subject: Reply with quote

OK, thanks a lot rufnut, I didn't realise that rt2x00 was a driver for my card. I am still unsure how to configure it for use with a WPA-SPK router. It seems that wpa_supplicant is best for this, though I don't think it supports the driver for my card.
Does anyone have any ideas? I would have thought that the encryption would be a standard thing not reliant on the card's drivers.
Back to top
View user's profile Send private message
rufnut
Apprentice
Apprentice


Joined: 16 May 2005
Posts: 184

PostPosted: Sun Aug 10, 2008 5:26 am    Post subject: Reply with quote

No worries xeonman9000.

The encryption you want should work on all the drivers I dont think thats the problem, the setting up can be a bit tricky.

You could try adding the ebuild a few post above as it has WPA settings in a configuration file /etc/Wireless/RT61STA/rt61sta.dat when installed :

http://gentoo-wiki.com/HOWTO_Installing_3rd_Party_Ebuilds

Just remember if you do add an ebuild that its wise not to have both drivers on your system. (you may have to delete one set of modules)

Also the naming must be right as rt2x00 now refer to the device as wlan0 and ralink refer to it as ra0.

All is well documented in both sets of drivers.
Back to top
View user's profile Send private message
deathcon1
Apprentice
Apprentice


Joined: 30 Aug 2007
Posts: 182
Location: Canada

PostPosted: Mon Sep 01, 2008 4:10 pm    Post subject: Reply with quote

I'm trying to get my Linksys PCI adapter (ralink-rt2561) working on my desktop and I just cannot compile any of the drivers. This is getting incredibly frusterating. I've tried the ebuilds on the bugzilla for the ralink-rt61 drivers, which don't work. I've tried the above rt2500 drivers, they also fail to compile. Any help would be greatly appreciated.

With the ralink-rt61:
Makefile.diff.out
Code:
***** Makefile.diff *****

=========================

PATCH COMMAND:    patch -p0 -g0 -E --no-backup-if-mismatch < /usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff

=========================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nur 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6
|--- 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2007-12-10 17:47:14.000000000 +1100
|+++ 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2008-07-24 18:22:00.000000000 +1000
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
=========================

PATCH COMMAND:    patch -p1 -g0 -E --no-backup-if-mismatch < /usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff

=========================
patching file Module/Makefile.6
Hunk #1 FAILED at 25.
1 out of 1 hunk FAILED -- saving rejects to file Module/Makefile.6.rej
=========================

PATCH COMMAND:    patch -p2 -g0 -E --no-backup-if-mismatch < /usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff

=========================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nur 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6
|--- 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2007-12-10 17:47:14.000000000 +1100
|+++ 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2008-07-24 18:22:00.000000000 +1000
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
=========================

PATCH COMMAND:    patch -p3 -g0 -E --no-backup-if-mismatch < /usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff

=========================
missing header for unified diff at line 4 of patch
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nur 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6
|--- 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2007-12-10 17:47:14.000000000 +1100
|+++ 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2008-07-24 18:22:00.000000000 +1000
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
=========================

PATCH COMMAND:    patch -p4 -g0 -E --no-backup-if-mismatch < /usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff

=========================
missing header for unified diff at line 4 of patch
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nur 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6
|--- 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2007-12-10 17:47:14.000000000 +1100
|+++ 2008_0506_RT61_Linux_STA_v1.1.2.1/Module/Makefile.6   2008-07-24 18:22:00.000000000 +1000
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored


build.log
Code:
>>> cfg-update-1.8.2-r1: Checksum index is up-to-date ...
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.26-gentoo-r1/build
 * Found sources for kernel version:
 *     2.6.26-gentoo-r1
 * Checking for suitable kernel configuration options...
  [ ok ]
>>> Unpacking source...
>>> Unpacking 2008_0723_RT61_Linux_STA_v1.1.2.2.tar.bz2 to /var/tmp/portage/net-wireless/ralink-rt61-1.1.2.2/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/net-wireless/ralink-rt61-1.1.2.2/work/2008_0723_RT61_Linux_STA_v1.1.2.2 ...
 * Applying Makefile.diff ...

 * Failed Patch: Makefile.diff !
 *  ( /usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-wireless/ralink-rt61-1.1.2.2/temp/Makefile.diff-8542.out

 *
 * ERROR: net-wireless/ralink-rt61-1.1.2.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3192:  Called epatch '/usr/local/portage/mordeth/net-wireless/ralink-rt61/files/Makefile.diff'
 *             environment, line 1517:  Called die
 * The specific snippet of code:
 *                   die "Failed Patch: ${patchname}!";
 *  The die message:
 *   Failed Patch: Makefile.diff!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/ralink-rt61-1.1.2.2/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/mordeth/'
 *


with the rt2500 drivers:
build.log:
Code:
>>> cfg-update-1.8.2-r1: Checksum index is up-to-date ...
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.26-gentoo-r1/build
 * Found sources for kernel version:
 *     2.6.26-gentoo-r1
 * Checking for suitable kernel configuration options...
  [ ok ]
>>> Unpacking source...
>>> Unpacking rt2500-1.1.0_pre2007071515.tar.gz to /var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515 ...
 * Preparing rt2500 module
make: Entering directory `/usr/src/linux-2.6.26-gentoo-r1'
  CC [M]  /var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.o
  CC [M]  /var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/mlme.o
  CC [M]  /var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/connect.o
/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.c: In function 'RT2500_probe':
/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.c:254: error: implicit declaration of function 'SET_MODULE_OWNER'
/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.c: In function 'RT2500_open':
/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.c:395: error: 'SA_SHIRQ' undeclared (first use in this function)
/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.c:395: error: (Each undeclared identifier is reported only once
/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.c:395: error: for each function it appears in.)
make[1]: *** [/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module/rtmp_main.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [_module_/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module] Error 2
make: Leaving directory `/usr/src/linux-2.6.26-gentoo-r1'
 *
 * ERROR: net-wireless/rt2500-1.1.0_pre2007071515 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3203:  Called linux-mod_src_compile
 *             environment, line 2463:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CC=\"$(get-KERNEL_CC)\"                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CC=x86_64-pc-linux-gnu-gcc LDFLAGS=  -C /usr/src/linux M=/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/work/rt2500-cvs-2007071515/Module modules
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/rt2500-1.1.0_pre2007071515/temp/environment'.
 *
Back to top
View user's profile Send private message
Tin
Guru
Guru


Joined: 22 Dec 2005
Posts: 303
Location: Namur, Belgium

PostPosted: Mon Sep 01, 2008 5:00 pm    Post subject: Reply with quote

Personally, for a pci card in a desktop, the rt61 driver included in the kernel runs fine.
Perhaps should you try this option ?
_________________
Tin, the gentoobie
Back to top
View user's profile Send private message
deathcon1
Apprentice
Apprentice


Joined: 30 Aug 2007
Posts: 182
Location: Canada

PostPosted: Mon Sep 01, 2008 5:17 pm    Post subject: Reply with quote

I have that built in but it's complaining about needing the firmware? Where would I get it from?
Back to top
View user's profile Send private message
Tin
Guru
Guru


Joined: 22 Dec 2005
Posts: 303
Location: Namur, Belgium

PostPosted: Wed Sep 03, 2008 11:35 am    Post subject: Reply with quote

You can download it from ralink web site, in the support part :
http://www.ralinktech.com/ralink/Home/Support/Linux.html
Choose the firware that match your board :-)

Normally, in the error message you received, it tells you were to unzip the firmware
(I don't remember by heart)
_________________
Tin, the gentoobie
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Thu Sep 04, 2008 8:34 pm    Post subject: Reply with quote

I finally managed to get my EW-7128g (rt61 chipset) card (+WPA2) working.

Here is how I did it. I'm using the built-in driver inside the kernel (2.6.25-gentoo-r7).

Activate these following items inside the kernel config.
Code:
CONFIG_MAC80211=y
CONFIG_RT2X00=m
CONFIG_RT2X00_LIB=m
CONFIG_RT2X00_LIB_PCI=m
CONFIG_RT2X00_LIB_FIRMWARE=y
CONFIG_RT61PCI=m

RT2X00 & RT61PCI would stay hidden unless you enable CONFIG_MAC80211.

Compile the kernel, and add rt61pci into /etc/modules.autoload.d/kernel-2.6, or you can activate the module manually by using modprobe rt61pci.

Download the latest firmware from ralink website. Put all three .bin files inside /lib/firmware.
Restart your PC, and don't forget to boot into the new kernel.

Next, emerge wpa_supplicant (it is required if you are trying to access WPA2 network).

Insert these following lines into /etc/conf.d/net. (I assume that you are attempting to connect to WPA2 Personal network with TKIP encryption.)
Code:
modules="wpa_supplicant"

wpa_supplicant_wlan0="Dwext"

config_YourSSID=( "dhcp" )

wpa_timeout_wlan0=15

Add these row of codes into /etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant

ctrl_interface_group=0

network={
        ssid="YourSSID"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="YourPassword"
        priority=5
}

Create a soft link between net.lo and net.wlan0.
Code:
ln -s /etc/init.d/net.lo /etc/init.d/net.wlan0

Next, input the following command to activate your card.
Code:
ifconfig wlan0 up

If you are connected to wired network, do this, otherwise skip to the next one.
Code:
/etc/init.d/net.eth0 stop

Finally, finish the hard work.
Code:
/etc/init.d/net.wlan0 start

In order to scan the area for wireless access point, you can use iwlist from wireless-tools package or wpa_supplicant scanner.
If you happen to have wireless-tools installed, run this command.
Code:
iwlist wlan0 scan

For those who are more comfortable with GUI, compile wpa_supplicant with qt3 or qt4 flag enabled, then run wpa_gui.

================

Credit: Gentoo Forums
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum