Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ready made stage3 Gentoo Package?
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
brfsa
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2005
Posts: 121
Location: Brazil

PostPosted: Sat May 17, 2008 5:52 pm    Post subject: Ready made stage3 Gentoo Package? Reply with quote

I have been trying to run the bootstrap instructions on http://www.gentoo.org/proj/en/gentoo-alt/prefix/bootstrap-macos.xml
but I had few errors.

Could someone share a bootstrapped ready gentoo tarball?
a tar file with the $EPREFIX/gentoo folder and share it with us ?? ;)

I love gentoo so much. would be great to have it on my mac too.
:)

Thanks everyone.
_________________

Macbook Pro 15.4 C2D 2.2GHz, 4GB DDR2
- Gentoo AMD64 GCC 4.3.2, OpenRC
- OSX 10.5.6
Back to top
View user's profile Send private message
brfsa
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2005
Posts: 121
Location: Brazil

PostPosted: Sat May 17, 2008 5:57 pm    Post subject: Reply with quote

Because I am so sick of macports...
_________________

Macbook Pro 15.4 C2D 2.2GHz, 4GB DDR2
- Gentoo AMD64 GCC 4.3.2, OpenRC
- OSX 10.5.6
Back to top
View user's profile Send private message
Jokey_
Retired Dev
Retired Dev


Joined: 24 Jan 2006
Posts: 34
Location: Germany

PostPosted: Tue May 20, 2008 10:27 am    Post subject: Reply with quote

What kind of error do you have?
(Presuming I just set a fresh prefix up with that guide; copy&paste)
_________________
Your ebuild bug is assigned maintainer-wanted? Maintain it yourself in the gentoo user overlay
http://overlays.gentoo.org/proj/sunrise | irc.freenode.net #gentoo-sunrise
Back to top
View user's profile Send private message
brfsa
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2005
Posts: 121
Location: Brazil

PostPosted: Tue May 20, 2008 1:20 pm    Post subject: Reply with quote

The errors that i was getting were:

1. the findutils wont compile. I believe it has to be some of my macport binaries that are incompatible with the build process.

2. the first emerge command.: "emerge --oneshot sed" it will not run.


I will try again now from scratch but without macports in the PATH.

Originally PATH was set to:

/opt/gentoo/usr/bin:/opt/gentoo/bin:/opt/gentoo/tmp/usr/bin:/opt/gentoo/tmp/bin:/opt/local/lib/ruby/gems/1.8/bin:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/X11R6/bin:/usr/X11/bin


now I set it to:
/opt/gentoo/usr/bin:/opt/gentoo/bin:/opt/gentoo/tmp/usr/bin:/opt/gentoo/tmp/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin



Lets see how it goes
_________________

Macbook Pro 15.4 C2D 2.2GHz, 4GB DDR2
- Gentoo AMD64 GCC 4.3.2, OpenRC
- OSX 10.5.6
Back to top
View user's profile Send private message
brfsa
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2005
Posts: 121
Location: Brazil

PostPosted: Tue May 20, 2008 2:27 pm    Post subject: findutils wont install Reply with quote

here is the error I get with findutils:


Making install in testsuite
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in doc
restore=: && backupdir=".am$$" && \
am__cwd=`pwd` && cd . && \
rm -rf $backupdir && mkdir $backupdir && \
if (/bin/sh /opt/gentoo/tmp/var/tmp/findutils-4.4.0/findutils-4.4.0/build-aux/missing --run makeinfo --version) >/dev/null 2>&1; then \
for f in find.info find.info-[0-9] find.info-[0-9][0-9] find.i[0-9] find.i[0-9][0-9]; do \
if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
done; \
else :; fi && \
cd "$am__cwd"; \
if /bin/sh /opt/gentoo/tmp/var/tmp/findutils-4.4.0/findutils-4.4.0/build-aux/missing --run makeinfo -I . \
-o find.info find.texi; \
then \
rc=0; \
cd .; \
else \
rc=$?; \
cd . && \
$restore $backupdir/* `echo "./find.info" | sed 's|[^/]*$||'`; \
fi; \
rm -rf $backupdir; exit $rc
find.texi:10: @include `../locate/dblocation.texi': No such file or directory.
find.texi:554: warning: undefined flag: LOCATE_DB.
find.texi:2681: warning: undefined flag: LOCATE_DB.
find.texi:2683: warning: undefined flag: LOCATE_DB.
find.texi:3160: warning: undefined flag: LOCATE_DB.
find.texi:3346: warning: undefined flag: LOCATE_DB.
find.texi:5230: warning: undefined flag: LOCATE_DB.
find.texi:5238: warning: undefined flag: LOCATE_DB.
makeinfo: Removing output file `find.info' due to errors; use --force to preserve.
make[1]: *** [find.info] Error 1
make: *** [install-recursive] Error 1
fred@mbp /opt/gentoo $
_________________

Macbook Pro 15.4 C2D 2.2GHz, 4GB DDR2
- Gentoo AMD64 GCC 4.3.2, OpenRC
- OSX 10.5.6
Back to top
View user's profile Send private message
brfsa
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2005
Posts: 121
Location: Brazil

PostPosted: Tue May 20, 2008 3:26 pm    Post subject: anyone still would like to share their gentoo install on OSX Reply with quote

I managed to get bootstrap findutils3 instead of findutils

but still same error when I run emerge:

fred@mbp /opt/gentoo $ emerge --info
Traceback (most recent call last):
File "/opt/gentoo/tmp/usr/bin/emerge", line 20, in <module>
retval = _emerge.emerge_main()
File "/opt/gentoo/tmp/usr/lib/portage/pym/_emerge/__init__.py", line 8739, in emerge_main
settings, trees, mtimedb = load_emerge_config()
File "/opt/gentoo/tmp/usr/lib/portage/pym/_emerge/__init__.py", line 8622, in load_emerge_config
root_trees["root_config"] = RootConfig(settings, root_trees, setconfig)
File "/opt/gentoo/tmp/usr/lib/portage/pym/_emerge/__init__.py", line 749, in __init__
self.sets = self.setconfig.getSets()
File "/opt/gentoo/tmp/usr/lib/portage/pym/portage/sets/__init__.py", line 98, in getSets
self._parse()
File "/opt/gentoo/tmp/usr/lib/portage/pym/portage/sets/__init__.py", line 85, in _parse
self.psets[setname] = setclass.singleBuilder(optdict, self.settings, self.trees)
File "/opt/gentoo/tmp/usr/lib/portage/pym/portage/sets/profiles.py", line 25, in singleBuilder
return PackagesSystemSet(settings.profiles)
File "/opt/gentoo/tmp/usr/lib/portage/pym/portage/sets/profiles.py", line 17, in __init__
self.description = "System packages for profile %s" % self._profile_paths[-1]
IndexError: list index out of range


Anyone have any idea?

Thanks!

anyone still would like to share their gentoo install on OSX?
I use leopard 10.5
_________________

Macbook Pro 15.4 C2D 2.2GHz, 4GB DDR2
- Gentoo AMD64 GCC 4.3.2, OpenRC
- OSX 10.5.6
Back to top
View user's profile Send private message
grobian
Developer
Developer


Joined: 31 May 2006
Posts: 63

PostPosted: Mon Jun 09, 2008 7:40 pm    Post subject: Reply with quote

You hit some annoying bugs. Latest Portage and bootstrap script should solve them all.
_________________
Gentoo on a different level
Back to top
View user's profile Send private message
BobbyJ
n00b
n00b


Joined: 25 Feb 2003
Posts: 14
Location: Los Angeles

PostPosted: Thu Jun 12, 2008 7:03 pm    Post subject: Reply with quote

I've run into the same bug, even with the latest bootstrap script and portage.
_________________
I had amnesia once. No.....twice.
Back to top
View user's profile Send private message
grobian
Developer
Developer


Joined: 31 May 2006
Posts: 63

PostPosted: Thu Jun 26, 2008 4:11 pm    Post subject: Reply with quote

please report your problem in bugzilla under Gentoo/Alt, Prefix product.
_________________
Gentoo on a different level
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum