Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
any2dvd ghostscript imagemagick
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Rukie
l33t
l33t


Joined: 26 Jan 2004
Posts: 692
Location: SE Wi, Home of cheese and cowtippers.......

PostPosted: Mon May 26, 2008 4:18 pm    Post subject: any2dvd ghostscript imagemagick Reply with quote

I'm tryign to use any2dvd but I keep getting an error about not having ghostscript support installed with imagemagick

this is the part of the script that looks for the ghostscript
Quote:

GS_XML=`convert -list font | grep Path: | grep ghostscript | awk '{print $2}'`
if [ ! -f "$GS_XML" ] || [ ! -f "`cat $GS_XML | grep glyphs | tail -n1 | cut -d= -f2 | sed 's/\"//g'`" ]; then
errmsg Error: "GNU-Ghostscript fonts were not found"
echo " Please install GNU-Ghostscript fonts package found here ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/fonts/"
echo -e " Then re-install Imagemagick with Ghostscript support\n"
exit


i have both imagemagick installed and ghostscript-gnu installed, but I don't think it has an imagemagick use flag...

any ideas on what I should do?
_________________
Gentoomania! Support the Open Source!
http://www.rukie.ath.cx
Back to top
View user's profile Send private message
Rukie
l33t
l33t


Joined: 26 Jan 2004
Posts: 692
Location: SE Wi, Home of cheese and cowtippers.......

PostPosted: Mon May 26, 2008 8:31 pm    Post subject: Reply with quote

here's the error from the program

Quote:

Error: GNU-Ghostscript fonts were not found

Please install GNU-Ghostscript fonts package found here ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/fonts/
Then re-install Imagemagick with Ghostscript support

_________________
Gentoomania! Support the Open Source!
http://www.rukie.ath.cx
Back to top
View user's profile Send private message
Rukie
l33t
l33t


Joined: 26 Jan 2004
Posts: 692
Location: SE Wi, Home of cheese and cowtippers.......

PostPosted: Wed May 28, 2008 5:19 am    Post subject: Reply with quote

any ideas? I don't know what to do..
_________________
Gentoomania! Support the Open Source!
http://www.rukie.ath.cx
Back to top
View user's profile Send private message
anthonyw
n00b
n00b


Joined: 17 Jun 2008
Posts: 9
Location: Dundalk, Ireland

PostPosted: Tue Jun 17, 2008 12:03 pm    Post subject: Reply with quote

I had the same problem the other day, I'm using the any2dvd-0.36_beta-r2.ebuild from http://bugs.gentoo.org/show_bug.cgi?id=126994

And on my system, Imagemagick was compiled with the gs flag and both media-fonts/gnu-gs-fonts-std media-fonts/gnu-gs-fonts-other are installed

The problem is with the right hand side of the OR in the IF statement
Code:
GS_XML=`convert -list font | grep Path: | grep ghostscript | awk '{print $2}'`
if [ ! -f "$GS_XML" ] || [ ! -f "`cat $GS_XML | grep glyphs | tail -n1 | cut -d= -f2 | sed 's/\"//g'`" ]; then


The format of the file being processed must have changed and it does not return a 'path to a file' string at all.

You get this string from the command: cat /usr/lib/ImageMagick-6.3.8/config/type-ghostscript.xml | grep glyphs | tail -n1
Code:
   <type name="Symbol" fullname="Symbol" family="Symbol" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="/usr/share/fonts/default/ghostscript/s050000l.afm" glyphs="/usr/share/fonts/default/ghostscript/s050000l.pfb" version="0.1" encoding="AdobeCustom"/>


And i modified the right hand side of the IF statement to grab the file and path string from the glyphs field (this was a guess on the file to check for but i chose glyphs since there was an earlier grep on glyphs)

Here's the modified IF statement
Code:
   if [ ! -f "$GS_XML" ] || [ ! -f "`cat $GS_XML | grep glyphs | tail -n1 | sed -n 's/^.*glyphs="\([0-9a-zA-Z./]*\)".*$/\1/p'`" ]; then


This worked for my system - i have no idea if it will work for others!
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Sun Jun 22, 2008 4:22 pm    Post subject: Reply with quote

I'll have a look at it, thanks fot the note.

kind regards
blubbi
_________________
-->Please add [solved] to the initial post's subject line if you feel your problem is resolved.
-->Help answer the unanswered

http://olausson.de
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Sat Jul 05, 2008 11:17 am    Post subject: Reply with quote

Sry for my long absence.
I'll update the ebuild on monday! Promised!

regards
blubbi
_________________
-->Please add [solved] to the initial post's subject line if you feel your problem is resolved.
-->Help answer the unanswered

http://olausson.de
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Mon Jul 07, 2008 8:10 pm    Post subject: Reply with quote

anthonyw wrote:


Here's the modified IF statement
Code:
   if [ ! -f "$GS_XML" ] || [ ! -f "`cat $GS_XML | grep glyphs | tail -n1 | sed -n 's/^.*glyphs="\([0-9a-zA-Z./]*\)".*$/\1/p'`" ]; then




- I added a patch and updated the ebuild
- Fixed the new URL to my server.

will update it on bugs.gentoo.org soon.

http://dev.olausson.de/index.php?dir=any2dvd%2F

Thanks and kind regards
blubbi
_________________
-->Please add [solved] to the initial post's subject line if you feel your problem is resolved.
-->Help answer the unanswered

http://olausson.de
Back to top
View user's profile Send private message
anthonyw
n00b
n00b


Joined: 17 Jun 2008
Posts: 9
Location: Dundalk, Ireland

PostPosted: Sun Jul 20, 2008 8:08 pm    Post subject: Reply with quote

Thanks for maintaining the ebuild, it would have been a right pain to install any2dvd by myself.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Sun Jul 20, 2008 9:32 pm    Post subject: Reply with quote

anthonyw wrote:
Thanks for maintaining the ebuild, it would have been a right pain to install any2dvd by myself.


np, you are welcome

I am happy that someone is using the ebuild :P

mmh, if someone could add [SOLVED] to the subject

Kind regards
Blubbi
_________________
-->Please add [solved] to the initial post's subject line if you feel your problem is resolved.
-->Help answer the unanswered

http://olausson.de
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum