Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Official thread: "zen-sources" - Part III
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 17, 18, 19  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
stable.entropy
n00b
n00b


Joined: 27 Mar 2008
Posts: 11

PostPosted: Fri Apr 18, 2008 4:08 am    Post subject: Reply with quote

progresso wrote:
I still can not get an ati-driver to build against a 2.6.25 kernel. When I try and compile it I get this:
Code:

 * Preparing fglrx module
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/zen-sources'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_SetPageNoCache':
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1161: error: implicit declaration of function 'change_page_attr'
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_put_user_ptr':
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1594: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1594: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1594: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1594: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_PosixSecurityCapGetEffectiveVector':
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1888: error: implicit declaration of function 'cap_t'
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_PosixSecurityCapSetEffectiveVector':
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1896: error: lvalue required as left operand of assignment
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_unregister_ioctl32_conversion':
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2972: warning: 'return' with a value, in function returning void
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KAS_SlabCache_Initialize':
/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5219: warning: cast from pointer to integer of different size
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/zen-sources'
make: *** [kmod_build] Error 2
 *
 * ERROR: x11-drivers/ati-drivers-8.471.3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3257:  Called linux-mod_src_compile
 *             environment, line 2466:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CC=\"$(get-KERNEL_CC)\"                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CC=x86_64-pc-linux-gnu-gcc LDFLAGS=  GCC_VER_MAJ=4 KVER=2.6.25-rc9-zen0-09526-gb8d280d KDIR=/usr/src/linux kmod_build
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/x11-drivers:ati-drivers-8.471.3:20080417-172609.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.471.3/temp/environment'.
 *


I have no idea what to do to fix this, any help is appreciated.

Thanks,
P

I have the same problem, master-devel 2.6.25-zen0 (I modified the ebuild to have EGIT_BRANCH and EGIT_TREE set to "master-devel" instead.)
Back to top
View user's profile Send private message
stable.entropy
n00b
n00b


Joined: 27 Mar 2008
Posts: 11

PostPosted: Fri Apr 18, 2008 4:37 am    Post subject: ATI fixed maybe? Reply with quote

Code:
--- common/lib/modules/fglrx/build_mod/firegl_public.c.orig     2008-04-06 01:20:21.000000000 -0300
+++ common/lib/modules/fglrx/build_mod/firegl_public.c  2008-04-06 01:17:58.000000000 -0300
@@ -1885,7 +1885,7 @@
  */
 KCL_TYPE_Cap ATI_API_CALL KCL_PosixSecurityCapGetEffectiveVector()
 {
-    return cap_t(current->cap_effective);
+    return (current->cap_effective).cap[0];
 }
 
 /** \brief Set vector of effective security caps for the current process
@@ -1893,7 +1893,7 @@
  */
 void ATI_API_CALL KCL_PosixSecurityCapSetEffectiveVector(KCL_TYPE_Cap cap)
 {
-    cap_t(current->cap_effective) = cap;
+    (current->cap_effective).cap[0] = cap;
 }
 
 /** \brief Get number of available RAM pages
--- common/lib/modules/fglrx/build_mod/firegl_public.c.orig     2008-04-06 02:10:13.000000000 -0300
+++ common/lib/modules/fglrx/build_mod/firegl_public.c  2008-04-06 02:23:05.000000000 -0300
@@ -120,6 +120,7 @@
 #include <asm/cpufeature.h>
 #ifdef CONFIG_MTRR
 #include <asm/mtrr.h>
+#include <asm/cacheflush.h>
 #endif
 #include <asm/delay.h>
 #include <linux/agp_backend.h>
@@ -1158,7 +1159,7 @@
 
 int ATI_API_CALL KCL_SetPageNoCache(void* virt, int pages)
 {
-    return change_page_attr(virt_to_page(virt), pages, PAGE_KERNEL_NOCACHE);
+    return set_pages_uc(virt_to_page(virt), pages);
 }
 
 /** /brief Call global kernel task/thread scheduler */

^^ (Credits to sarah.a.happy for the patch.)

The above code is a patch for ati-drivers. I have modified the 8.471.3 (Catalyst 8.3) and version bumped it to 8.476.4 (Catalyst 8.4). With the above patch, and the kernel configured to export unused and obsolete symbols, it builds (with warnings). I am running 2.6.25-zen0 "master-devel".

I will compile are reboot when all is kosher.

:D

edit: looks like master-devel may be broken, i'm getting bad relocations on build. I'm rollin back some enhancements on the build to double check.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Fri Apr 18, 2008 9:53 am    Post subject: Reply with quote

i really need the reise4 patch for 2.6.25 or at least the one in zen-sources.
please can anybody help?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5698
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Apr 18, 2008 10:44 am    Post subject: Reply with quote

tranquilcool wrote:
i really need the reise4 patch for 2.6.25 or at least the one in zen-sources.
please can anybody help?


just use Edward's latest 2.6.24-patch & the 2 pending patches mentioned in this post

Cheers :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Fri Apr 18, 2008 11:21 am    Post subject: Reply with quote

kernelOfTruth wrote:
tranquilcool wrote:
i really need the reise4 patch for 2.6.25 or at least the one in zen-sources.
please can anybody help?


just use Edward's latest 2.6.24-patch & the 2 pending patches mentioned in this post

Cheers :)


thanks kernelOfTruth. needed the patch for dark-sources.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Fri Apr 18, 2008 11:33 am    Post subject: Reply with quote

ok this is not the right place.

post to inform that the reiser4 patches do not work with dark-sources.

errors;

CC fs/reiser4/plugin/file/file.o
fs/reiser4/plugin/file/file.c: In function ‘shorten_file’:
fs/reiser4/plugin/file/file.c:547: error: implicit declaration of function ‘zero_user_page’
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
dusanc
Apprentice
Apprentice


Joined: 19 Sep 2005
Posts: 219
Location: Serbia

PostPosted: Fri Apr 18, 2008 1:49 pm    Post subject: Reply with quote

Or maybe just wait for reiser4-for-2.6.25.patch as there is surely some intree differences between .24 and .25 :)
I sure wouldn't value my data a lot if it were on a untested fs under untested kernel made with some patch for different version? :)
(Untested as in not tested to work together and not meant globaly)
Maybe just ask on #reiser4 or reiser4-devel@vger.kernel.org
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5698
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Apr 18, 2008 4:25 pm    Post subject: Reply with quote

MostAwesomeDude wrote:
My temperatures haven't increased at all, except recently when DynamicClocks was enabled for R500 Radeons. I'm running a Core 2 Duo laptop in 32-bit mode with latest git and my aufs and xpad patches.


*bump* :wink:

Linus & the lkml now know of this issue: see

could anyone who can reproduce it - and has the time - bisect it ?

I'd really like to do it myself but we're writing exams on an almost weekly basis (in several cases on an daily basis !) til' july & that way you might be able to find the patch causing this much faster than I would

I - of course - will start bisecting but at earliest starting next weekend (I need this production box & my laptop is out and in use)

thanks :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
hoacker
Guru
Guru


Joined: 04 Aug 2007
Posts: 477
Location: Bürstadt, Germany

PostPosted: Fri Apr 18, 2008 4:46 pm    Post subject: Reply with quote

hoacker wrote:
v2.6.25-zen0:
Quote:
arch/x86/oprofile/nmi_int.c: In function 'nmi_setup':
arch/x86/oprofile/nmi_int.c:195: error: implicit declaration of function 'pfm_session_allcpus_acquire'
arch/x86/oprofile/nmi_int.c:199: error: implicit declaration of function 'pfm_session_allcpus_release'
make[1]: *** [arch/x86/oprofile/nmi_int.o] Error 1
make: *** [arch/x86/oprofile] Error 2



This is fixed in latest version here: http://repo.or.cz/w/linux-2.6.git?a=history;f=arch/x86/oprofile/nmi_int.c;h=1f11cf0a307f448e777f5a132e0de15ebc4ca7a3;hb=HEAD
Back to top
View user's profile Send private message
dusanc
Apprentice
Apprentice


Joined: 19 Sep 2005
Posts: 219
Location: Serbia

PostPosted: Sat Apr 19, 2008 2:35 pm    Post subject: Reply with quote

And there is now reiser4-for-2.6.25, and you can now get it from new place at kernel.org
http://www.kernel.org/pub/linux/kernel/people/edward/reiser4/reiser4-for-2.6/ where it would be more available than untill now :)

Live long and prosper :)
Dushan
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5698
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Apr 19, 2008 4:22 pm    Post subject: Reply with quote

Quote:
Live long and prosper :)


++

kudos & thanks to the kernel.org guys :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Sun Apr 20, 2008 8:27 am    Post subject: Reply with quote

dusanc wrote:
And there is now reiser4-for-2.6.25, and you can now get it from new place at kernel.org
http://www.kernel.org/pub/linux/kernel/people/edward/reiser4/reiser4-for-2.6/ where it would be more available than untill now :)

Live long and prosper :)
Dushan


thank you so much buddy!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
kriko
Tux's lil' helper
Tux's lil' helper


Joined: 18 Mar 2006
Posts: 92
Location: Slovenia

PostPosted: Sun Apr 20, 2008 4:04 pm    Post subject: Reply with quote

I saw BFQ, but kernel didn't compile with it previously. Will it be reincluded and fixed?
I'm curious about performance with it.
_________________
Zen sources - fastest kernel in world
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Sun Apr 20, 2008 4:17 pm    Post subject: Reply with quote

kriko wrote:
I saw BFQ, but kernel didn't compile with it previously. Will it be reincluded and fixed?
I'm curious about performance with it.


BFQ compiles with vanilla and dark-sources.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Sun Apr 20, 2008 9:49 pm    Post subject: Reply with quote

bfq will be in 2.6.25-zen1, which will (hopefully) be ready tomorrow.

dodo
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon Apr 21, 2008 6:34 am    Post subject: Reply with quote

Yay... I started wondering when it would come. ;)

OTOH I might wait with the upgrade until nvidia releases some decent drivers (173.08 are slow on 2.6.24, needs checking)

cheers
V.
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 180

PostPosted: Mon Apr 21, 2008 6:35 am    Post subject: can't mount with dmcrypt anymore? Reply with quote

Hi all,

here 2.6.24-zen4 works great so far, but with 2.6.24-zen5 i can't mount my crypted device anymore:
Code:

device-mapper: table: 253:0: crypt: Error initializing ESSIV hash
device-mapper: ioctl: error adding target to table
device-mapper: ioctl: device doesn't appear to be in the dev hash table.


Any hint, how I can hunt down this beast?
I thank you in advance! best regards
are
Back to top
View user's profile Send private message
kriko
Tux's lil' helper
Tux's lil' helper


Joined: 18 Mar 2006
Posts: 92
Location: Slovenia

PostPosted: Mon Apr 21, 2008 7:03 am    Post subject: Reply with quote

Oh, yes - almost forgot. Are nvidia drivers working on 2.6.15? I mean older that those latest beta because they are slow like hell.
_________________
Zen sources - fastest kernel in world
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Tue Apr 22, 2008 1:20 pm    Post subject: Reply with quote

We are still working on -zen1... it's taking a lot of time to rebase and update everything :/

Fortunately, I can announce that zen-sources will have proper patch distribution, just like kamikaze. This means that you won't have to clone the git repo in order to get the patchset, i will be uploading diffs between vanilla kernel and zen in bzip2 to (i already registered zen-sources, now waiting for approval or refusal :P) sourceforge.

dodo
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Tue Apr 22, 2008 2:02 pm    Post subject: Reply with quote

kriko wrote:
Oh, yes - almost forgot. Are nvidia drivers working on 2.6.15? I mean older that those latest beta because they are slow like hell.

If you mean .25, yeah, they compile and work on 25-zen0
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Tue Apr 22, 2008 4:46 pm    Post subject: Reply with quote

ok, here it is.

http://sourceforge.net/projects/zen-sources/

i uploaded 2.6.25-zen0 there already :).


dodo
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
Gregoire
Apprentice
Apprentice


Joined: 15 Apr 2006
Posts: 292

PostPosted: Tue Apr 22, 2008 6:15 pm    Post subject: Reply with quote

2.6.25 being finally out :-) Which according to this forum, should be the kernel which gets multiproto getting in :-)

Just for the reccord, there is now a multiproto_plus : http://jusst.de/hg/multiproto_plus which still lack support for some cards, like HVR-4000, but that's available though patch (see for example my last asking for inclusion of multiproto in this forum).

Thanks.
Back to top
View user's profile Send private message
Uzytkownik
Guru
Guru


Joined: 31 Oct 2004
Posts: 391
Location: Munich, DE

PostPosted: Thu Apr 24, 2008 7:17 am    Post subject: Reply with quote

I've getting an error with zen-sources-2.6.25-zen0 (+ versions from master-devel)[1]. I in certain conditions (after few houres of running?) cannot hibernate. It hangs on the 'seeking to xxxx free MB of ram'. If I press escape it start 'escaping'(ie. says so) but it do not seem to do anything more. What can be wrong?

[1] It worked on 2.6.24-zen*
_________________
I've probably left my head... somwhere. Please wait untill I find it.
Back to top
View user's profile Send private message
mmike
n00b
n00b


Joined: 02 May 2003
Posts: 19

PostPosted: Thu Apr 24, 2008 7:23 am    Post subject: Reply with quote

i have the same problem, but i workaround in freeing the memory myself before hibernating.
_________________
--
there is no save distance
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Thu Apr 24, 2008 8:01 am    Post subject: Reply with quote

mmike wrote:
i have the same problem, but i workaround in freeing the memory myself before hibernating.
How do you do that?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 17, 18, 19  Next
Page 8 of 19

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum