Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2007.0 fails from boot cdrom with V880
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
pr0ject42
n00b
n00b


Joined: 25 Jan 2008
Posts: 3

PostPosted: Fri Jan 25, 2008 6:47 pm    Post subject: 2007.0 fails from boot cdrom with V880 Reply with quote

I searched around and didn't find anything that helps me.

This is my first stab at Gentoo, however I'm no stranger to linux.

I had OpenBSD 4.2 running on this V880, but decided I actually want to take advantage of all of the CPUs it has.

So from the boot prompt, I enter 2617 and all seems ok, and gets past the looming "Booting linux..."

It then spits out a line that reads something like
... Calling: free_all_bootmem()

Then the screen blanks and the cursor scrolls down it a few times then it seems to reset the fb and displays more text, having to do with the video card:

Console: switching to mono PROM 80x34
Ream Time Clock Driver v1.12ac
atyfb: 3D RAGE XL (Mach64 GR, PCI-33) [0x4752 rev 0x27]
atyfb: 8M SGRAM (1:1) 29.498928 MHz XTAL, 230 MHz PLL, 83 MHz MCLK 63 MHz XCC4

Now that last line may have some typos in it, my handwriting was a little poor, but then the whole thing just hangs there and doesn't even respond to "stop a"

I tried passing in a KERNEL parameter for the resolution, thinking maybe the auto-probing was causing the server to hang, but it seems not.

I pulled every card out of the thing except the video card in effort to eliminate any variables.

Any help would be super awesome, as I saw someone got a V880 running with Gentoo, and I would really really like Linux on this thing. Thanks!!
Back to top
View user's profile Send private message
blu3bird
Retired Dev
Retired Dev


Joined: 04 Oct 2003
Posts: 611
Location: Munich, Germany

PostPosted: Sat Jan 26, 2008 3:12 pm    Post subject: Reply with quote

The 2007.0 install cd has two kernels on it, 2.6.17 and 2.6.20. When I installed Gentoo on my Blade 1000(it also has a 3D Rage XL, sun calls it PGX64) I got the same result when booting 2617, but 2620(bootet with param scsi_mod.scan=sync) worked perfectly.

It's probably a bug in the 2.6.17 kernel. I didn't investigate it further since it runs fine right now using 2.6.23.

Another solution would be to install over serial console.
_________________
Black Holes are created when God divides by zero!
Back to top
View user's profile Send private message
pr0ject42
n00b
n00b


Joined: 25 Jan 2008
Posts: 3

PostPosted: Sat Jan 26, 2008 5:18 pm    Post subject: Reply with quote

I tried the 2.6.20 kernel and the whole thing froze. It has that Qlogic SCSI controller that is mentioned in the sticky at the top of the forum that is said to be incompatable with the 2620 kernel image.

I guess trying serial console it is, and pulling the video card. This V880 is getting to be more of a pain than it is worth. Would it be worth it to try a different PCI video card instead?

You have to pardon my total ignorance with SUN hardware, but can I slap any old PCI video card in there?
Back to top
View user's profile Send private message
blu3bird
Retired Dev
Retired Dev


Joined: 04 Oct 2003
Posts: 611
Location: Munich, Germany

PostPosted: Sat Jan 26, 2008 8:05 pm    Post subject: Reply with quote

pr0ject42 wrote:
I tried the 2.6.20 kernel and the whole thing froze. It has that Qlogic SCSI controller that is mentioned in the sticky at the top of the forum that is said to be incompatable with the 2620 kernel image.
The kernel is not incompatible, genkernel is(genkernel = tool to auto-configure your kernel).

Booting 2620 should work if you do:
- enter "boot cdrom" in obp
- enter "2620 scsi_mod.scan=sync" when the bootloader is started
- wait for the kernel to boot
- enter "rmmod qla2xxx"
- enter "modprobe qla2xxx" (will take about 15secs to complete)

After that you sould be able to access your harddisk and install Gentoo. You can still decide to install kernel 2.6.17 or use a recent kernel and create an initrd to load the firmware for the controller. I created a script to create this initrd(http://porno-bullen.de/~bluebird/initrd-qla2xxx/) but you will probably have to adjust it a little for your system.

pr0ject42 wrote:
Would it be worth it to try a different PCI video card instead?
Yes

pr0ject42 wrote:
You have to pardon my total ignorance with SUN hardware, but can I slap any old PCI video card in there?
No, some non-sun video cards are known to work in xorg/console but they won't work in obp(see http://www.gentoo.org/proj/en/base/sparc/sunhw.xml)
_________________
Black Holes are created when God divides by zero!
Back to top
View user's profile Send private message
pr0ject42
n00b
n00b


Joined: 25 Jan 2008
Posts: 3

PostPosted: Sat Jan 26, 2008 8:22 pm    Post subject: Reply with quote

Bad ass dood, thank you. I'll check the 2.6.20 workaround first and see how that goes. If it fails, I'll try a different video card.

Thank you very much! I'll write back with my results!
Back to top
View user's profile Send private message
leonardosam
n00b
n00b


Joined: 28 Nov 2007
Posts: 10
Location: Campinas, Brazil

PostPosted: Thu Aug 14, 2008 8:09 pm    Post subject: Bad luck Reply with quote

I'm trying to do the same but I never get past the "Booting Linux..." line. It is a SunFire V880 and the Gentoo distribution is the 2007.0.

Has anyone successfully installed Gentoo on this "thing?"

Thanks,
Back to top
View user's profile Send private message
leonardosam
n00b
n00b


Joined: 28 Nov 2007
Posts: 10
Location: Campinas, Brazil

PostPosted: Fri Jan 09, 2009 6:04 pm    Post subject: Go OpenBSD Reply with quote

Nevermind. I decided to go OpenBSD. The baby is running smooth.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum