Joined: 12 May 2004
|Posted: Sun Jan 20, 2008 1:26 am Post subject: [ GLSA 200801-07 ] Adobe Flash Player: Multiple vulnerabilit
|Gentoo Linux Security Advisory
Title: Adobe Flash Player: Multiple vulnerabilities (GLSA 200801-07)
Date: January 20, 2008
Updated: May 28, 2009
Multiple vulnerabilities have been identified, the worst of which allow
arbitrary code execution on a user's system via a malicious Flash file.
The Adobe Flash Player is a renderer for the popular SWF file format,
which is commonly used to provide interactive websites, digital
experiences and mobile content.
Vulnerable: < 126.96.36.199
Unaffected: >= 188.8.131.52
Architectures: All supported architectures
- Flash contains a copy of PCRE which is vulnerable to a heap-based
buffer overflow (GLSA 200711-30, CVE-2007-4768).
- Aaron Portnoy reported an unspecified vulnerability related to
input validation (CVE-2007-6242).
- Jesse Michael and Thomas Biege reported that Flash does not
correctly set memory permissions (CVE-2007-6246).
- Dan Boneh, Adam Barth, Andrew Bortz, Collin Jackson, and Weidong
Shao reported that Flash does not pin DNS hostnames to a single IP
addresses, allowing for DNS rebinding attacks (CVE-2007-5275).
- David Neu reported an error withing the implementation of the
Socket and XMLSocket ActionScript 3 classes (CVE-2007-4324).
- Toshiharu Sugiyama reported that Flash does not sufficiently
restrict the interpretation and usage of cross-domain policy files,
allowing for easier cross-site scripting attacks (CVE-2007-6243).
- Rich Cannings reported a cross-site scripting vulnerability in the
way the "asfunction:" protocol was handled (CVE-2007-6244).
- Toshiharu Sugiyama discovered that Flash allows remote attackers to
modify HTTP headers for client requests and conduct HTTP Request
Splitting attacks (CVE-2007-6245).
A remote attacker could entice a user to open a specially crafted file
(usually in a web browser), possibly leading to the execution of
arbitrary code with the privileges of the user running the Adobe Flash
Player. The attacker could also cause a user's machine to establish TCP
sessions with arbitrary hosts, bypass the Security Sandbox Model,
obtain sensitive information, port scan arbitrary hosts, or conduct
There is no known workaround at this time.
All Adobe Flash Player users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-plugins/adobe-flash-184.108.40.206"
Please be advised that unaffected packages of the Adobe Flash Player
have known problems when used from within the Konqueror and Opera
Last edited by GLSA on Mon Jun 10, 2013 4:27 am; edited 2 times in total