Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
An emerge wrapper for breaking emerges into chunks
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 28, 29, 30  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Mon Nov 05, 2007 4:10 pm    Post subject: Reply with quote

One of my stupid cats, "Coco da Rat", decided that the top of my sons computer was his new lounge, That was the location of my router. Its now standing on its face leaning against the computer. It worked fine till yesterday when the cat5 connection to my switch became mechcanically unhappy. After plugging it in and wiggling it some more it made a good connection again.

FREE cats good <if thats not contradiction> selection. Ive got 2 more abandoned fuzz tailed rats trying to move in now. SIGH
_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Fri Nov 09, 2007 7:06 pm    Post subject: Reply with quote

My internet is down, just keep checking back. Hopefully it wont be all weekend.
_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
seren
Guru
Guru


Joined: 27 Aug 2005
Posts: 448
Location: Wisconsin

PostPosted: Fri Nov 09, 2007 7:14 pm    Post subject: Reply with quote

I have mirrored both emwrap.sh (old) and the emwrap.sh-r4

http://glibcsnap.googlecode.com/files/emwrap.sh
http://glibcsnap.googlecode.com/files/emwrap.sh-r4

google code should remain up for a while ;)

hielvc i hope you stay safe during those fires
Back to top
View user's profile Send private message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Sun Nov 11, 2007 6:06 pm    Post subject: Reply with quote

seren Thanks. Im checking out google.code. I bet they dont have cats or cox cable :P

The fires are out, so now we are into California's third season. Green , Brown , BLACK .
_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
hurricane
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 100

PostPosted: Mon Dec 17, 2007 11:17 pm    Post subject: emwrap stopped working Reply with quote

maybe i'm missing something, but emwrap seems to not work anymore.

after calling "sh ~/emwrap.sh -S" i get the following output:
Code:
(Perl compile output here. Perl compiles fine.)
<<<          dir /usr/share/doc/perl-5.8.8-r2
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
 * GNU info directory index is up-to-date.
2 of 56 build

!!! '='media-gfx/graphviz-2.12',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
3 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
4 of 56 build

!!! '='virtual/jdk-1.6.0',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
5 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
6 of 56 build

!!! '='app-doc/doxygen-1.5.4',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
7 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
8 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
9 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
10 of 56 build

!!! '='sys-apps/dbus-1.0.2-r2',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
11 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
12 of 56 build

!!! '='virtual/ghostscript-0',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
13 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
14 of 56 build

!!! '='app-text/ghostscript-gpl-8.61-r1',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
15 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
16 of 56 build

!!! '='dev-lang/swig-1.3.33',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
17 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
18 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
19 of 56 build

!!! '='net-print/cups-1.3.4-r3',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
20 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
21 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
22 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
23 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
24 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
25 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
26 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
27 of 56 build

!!! '='virtual/jre-1.6.0',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
28 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
29 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
30 of 56 build

!!! '='net-fs/samba-3.0.28',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
31 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
32 of 56 build

!!! '='media-libs/alsa-lib-1.0.15',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
33 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
34 of 56 build

!!! '='dev-java/sun-jdk-1.6.0.03',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
35 of 56 build

!!! '=',' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)

 these failed to build
'media-gfx/graphviz-2.12',
',
'virtual/jdk-1.6.0',
',
'app-doc/doxygen-1.5.4',
',
',
',
'sys-apps/dbus-1.0.2-r2',
',
'virtual/ghostscript-0',
',
'app-text/ghostscript-gpl-8.61-r1',
',
'dev-lang/swig-1.3.33',
',
',
'net-print/cups-1.3.4-r3',
',
',
',
',
',
',
',
'virtual/jre-1.6.0',
',
',
'net-fs/samba-3.0.28',
',
'media-libs/alsa-lib-1.0.15',
',
'dev-java/sun-jdk-1.6.0.03',
',

 these remain to build



I guess emwrap can't parse the output of emerge anymore.
Is there an update to emwrap?

UPDATE:
It seems that emwrap does not work in the case of circular dependencies. (In this case with java.)
That is, because emwrap parses the list of circular depentencies and uses them as the list of packages to install, wich of course does not work.
As a temporary workaround remove the circuar dependencies before calling emwrap.
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Tue Dec 18, 2007 10:58 am    Post subject: Reply with quote

emwrap borks out on my toolchain rebuilds as well, failing on switching gcc compilers... Dunno if I'm using an old version, but it would really help if we had an inofficial ebuild for overlaying. 8)
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
MysticPixel
n00b
n00b


Joined: 30 Nov 2004
Posts: 16

PostPosted: Thu Dec 27, 2007 9:11 am    Post subject: Reply with quote

Stumbled upon this, seems like it could solve several problems I'm having with emerge. Much appreciation to hielvc and everyone else who's helped out :)

Unfortunately, I'm having some issues: I copied/pasted, but i'm getting "emwrap.sh: line 799: syntax error: unexpected end of file."

looked through the thread for previous posts about similar problems, but none of the solutions worked for me... and the direct download links are down. I couldn't find an alternate download for the current version (4.0.8 with gcc-config-r4)... anyone have any ideas? If you have a working copy and could e-mail it to me, I'd very much appreciate it ( mystic * pixel {a} gmail * com, s/*/. )

BTW: I saw the discussion of sourceforge earlier in the thread, and I agree it's overkill, but in the interest of having a more accessable link, could I suggest creating a project on Google Code? http://code.google.com/hosting/ I don't know much about it; just throwing it out there.
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1354

PostPosted: Thu Dec 27, 2007 2:20 pm    Post subject: Reply with quote

The handling of the "failed" file looks completely broken. I tried everything I could think of (hitting the "f" key several times, typing - as the documentation inside the script indicates "emwrap failed", and several other things), but none of them worked. I ended up just doing it manually.
Back to top
View user's profile Send private message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Thu Dec 27, 2007 4:59 pm    Post subject: Reply with quote

Ill be home this weekend I'll try to sort this out. If you all could post " emwrap.sh -V " and your portage version. curmudgeon when you ran emerge did you have circular dependencies?
_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1496
Location: Oxfordshire, UK

PostPosted: Mon Jan 07, 2008 10:12 am    Post subject: Reply with quote

Hi,

I've noticed a feature when upgrading GCC on my system.

It could be because I've not updated it for months, but the following code doesn't work for me:

Code:
function gcc_config(){
        # The eselect added 7-7-06 A varition of mcquires gcc-config
        if [ "$tc" != "no" ] ; then
                if echo "$1" | grep "gcc-[0-9].*" ; then
                # Adding maguire's gcc_config  setup here
                        gcc_current=""
                        gcc_new_version_number=""
                        gcc_for_gcc_config=""
                        gcc_current_no_dot=""
                        gcc_version_number_no_dot=""
                ###############################################################
                # Let games begin
                ###############################################################
                        #10-14-07 switched to CHOST usage so that i686, x86_64 and whaterver else are picked up.
                        #10-15-07 added test for "config" or "config-"${CHOST}"
                        if [[ -e "/etc/env.d/gcc/config" ]] ;then
                                gcc_current=$(sed 's/^.*\([0-9]\.[0-9]\.[0-9]\)/\1/' /etc/env.d/gcc/config)
                        elif [ -e "/etc/env.d/gcc/config-"${CHOST}"" ] ; then
                                gcc_current=$(sed 's/^.*\([0-9]\.[0-9]\.[0-9]\)/\1/' /etc/env.d/gcc/config-"${CHOST}")
                        fi
                        # $1 is the "gcc-version" that the function build-count, passes to function gcc_config
                        gcc_new_version_number=$( echo "$1" |sed 's/^.*\([0-9]\.[0-9]\.[0-9]\).*/\1/')
                        ## echo "${gcc_new_version_number} TEST TEST TesT CHOST"
                        # For selecting the highest version gcc
                        if echo "$1" | grep -Eq "gcc-[0-9].*" ; then
                                # stripping out the dots 4.1.1 ==> 411
                                gcc_current_no_dot=$(echo ${gcc_current} | sed 's/\.//g')
                                gcc_version_number_no_dot=$(echo ${gcc_new_version_number} | sed 's/\.//g')
                                # Now finding which no_dot is larger
                                if [ "${gcc_current_no_dot}" -eq "${gcc_version_number_no_dot}" ] ; then
                                        high_gcc="${gcc_new_version_number}"
                                elif [ "${gcc_current_no_dot}" -lt "${gcc_version_number_no_dot}" ] ; then
                                        high_gcc="${gcc_new_version_number}"
                                else
                                        high_gcc="${gcc_current}"
                                fi

                                gcc_for_gcc_config="${CHOST}-${high_gcc}"



It seems that the variable ${high_gcc} is not set for me as the following code is not valid for my setup:

Code:
if [[ -e "/etc/env.d/gcc/config" ]] ;then
                                gcc_current=$(sed 's/^.*\([0-9]\.[0-9]\.[0-9]\)/\1/' /etc/env.d/gcc/config)
                        elif [ -e "/etc/env.d/gcc/config-"${CHOST}"" ] ; then
                                gcc_current=$(sed 's/^.*\([0-9]\.[0-9]\.[0-9]\)/\1/' /etc/env.d/gcc/config-"${CHOST}")
                        fi


On my system I have the following in my /etc/env.d/gcc directory:

Code:
# ls /etc/env.d/gcc/ -al
total 25
drwxr-xr-x 2 root root 368 Jan  1 17:18 .
drwxr-xr-x 4 root root 672 Jan  1 17:30 ..
lrwxrwxrwx 1 root root  23 Jan  1 17:18 .NATIVE -> i686-pc-linux-gnu-3.4.6
-rw-r--r-- 1 root root  32 Jan  1 17:18 config-i686-pc-linux-gnu
-rw-r--r-- 1 root root 235 Nov 16 14:21 i686-pc-linux-gnu-3.4.6
-rw-r--r-- 1 root root 396 Nov 16 14:21 i686-pc-linux-gnu-3.4.6-hardenednopie
-rw-r--r-- 1 root root 399 Nov 16 14:21 i686-pc-linux-gnu-3.4.6-hardenednopiessp
-rw-r--r-- 1 root root 396 Nov 16 14:21 i686-pc-linux-gnu-3.4.6-hardenednossp
-rw-r--r-- 1 root root 390 Nov 16 14:21 i686-pc-linux-gnu-3.4.6-vanilla


The best way to figure out what gcc version I'm on is to cat the config file as follows:

Code:
# cat /etc/env.d/gcc/config-i686-pc-linux-gnu
CURRENT=i686-pc-linux-gnu-3.4.6


I'm using emwrap.sh Version-4.0.8 with gcc-config-r3 so I don't know if this has been noticed already and fixed in the next version?? I was unable to download it to check.

I hope this helps with future versions of your excellent script!

Richard.
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1354

PostPosted: Sat Jan 12, 2008 11:45 pm    Post subject: Reply with quote

hielvc wrote:
If you all could post " emwrap.sh -V " and your portage version. curmudgeon when you ran emerge did you have circular dependencies?


Code:
$ ./emwrap.sh-r4 -V
        emwrap.sh  Version-4.0.8 with gcc-config-r4
 A wrapper for emerge so you can break emerges into chunks, TC, system, world
 or world - system
 Mon Oct 15 21:41:56 PDT 2007

$ equery list sys-apps/portage
[ Searching for package 'portage' in 'sys-apps' among: ]
 * installed packages
[I--] [  ] sys-apps/portage-2.1.3.19 (0)


I don't believe I had any circular dependencies overall, and certainly none in the failed package list (about a half-dozen random things, most coming from the expat upgrade).
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Sun Jan 13, 2008 12:24 pm    Post subject: Reply with quote

hielvc wrote:
(...) If you all could post " emwrap.sh -V " and your portage version. (...)

I'll show you mine if you'll show me yours ;)
./emwrap.sh -V:
        emwrap.sh  Version-4.0.8 with gcc-config
A wrapper for emerge so you can break emerges into chunks, TC, system, world
     or world - system Wed Nov 22 19:37:40 PST 2006

equery list sys-apps/portage:
[ Searching for package 'portage' in 'sys-apps' among: ]
 * installed packages
[I--] [ ~] sys-apps/portage-2.1.4 (0)

BTW, gcc-config is at 1.4.0-r4
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
Dinini
Apprentice
Apprentice


Joined: 11 Jun 2003
Posts: 236

PostPosted: Mon Feb 18, 2008 8:45 am    Post subject: Reply with quote

[edit] sigh, I really need more sleep, sorry for the repeated edits.

I belated saw the link to emwrap-r4 above (thank you for the link seren) and it includes a nicer fix than mine for the gcc-config change.

red-wolf76 that is a more recent version than the one you are using.
Quote:
./emwrap.sh-r4 -V
emwrap.sh Version-4.0.8 with gcc-config-r4
A wrapper for emerge so you can break emerges into chunks, TC, system, world
or world - system
Mon Oct 15 21:41:56 PDT 2007


I see the circular dependency problem myself with both 4.0.8 from Dec 2006 and this version (in this case it was easy enough to break the circle).
sys-apps/portage-2.1.4.4
_________________
"There are nine and sixty ways of constructing tribal lays,
And every single one of them is right!" - Rudyard Kipling "In the Neolithic Age"
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Mon Feb 18, 2008 4:16 pm    Post subject: Reply with quote

I saw it too. Happily using it now. :)
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
nitm
n00b
n00b


Joined: 27 Dec 2004
Posts: 35

PostPosted: Mon Feb 18, 2008 7:13 pm    Post subject: Reply with quote

I think, I have found a bug in the emwrap.sh:

I'm executing: ./emwrap_2.sh -wetp but it fails with the

Code:

 Running emwrap.sh 4.0.8 with gcc-config-r4 Mon Oct 15 21:41:56 PDT 2007
 If emwrap.sh is run and it detects a "failed' or "build" file
 then it will offer to build them. You can ignor this by not doing
 anything and what you wanted todo will start after automaticlly.

work_dir is
[ebuild   R   ] dev-util/codeblocks-9999-r18

You have packages blocking each other. To fix run emerge
and take care of the blockage



I've written a little patch (it seems to work):

Code:

mraz scripts # diff emwrap_2.sh emwrap_3.sh
681c681
<                       if grep "blocks" wrld.lst ; then
---
>                       if grep -v '\[ebuild' wrld.lst &&  grep "blocks" wrld.lst ; then
689c689
<                       elif grep "masked" wrld.lst ; then
---
>                       elif grep -v '\[ebuild' wrld.lst &&  grep "masked" wrld.lst ; then



And thank you for the great script :)

Best regards,
Teodor
Back to top
View user's profile Send private message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Fri Feb 22, 2008 3:24 pm    Post subject: Reply with quote

hello, i am getting an error when updating tool chain:

Code:

/root/scripts/emwrap.sh -set


Code:

BEFORE selecting new GCC:
 [1] i686-pc-linux-gnu-3.4.4
 [2] i686-pc-linux-gnu-3.4.4-hardened
 [3] i686-pc-linux-gnu-3.4.4-hardenednopie
 [4] i686-pc-linux-gnu-3.4.4-hardenednopiessp
 [5] i686-pc-linux-gnu-3.4.4-hardenednossp
 [6] i686-pc-linux-gnu-4.1.2 *

**********************************************************************
 I'm going to execute:  # gcc-config i686-pc-linux-gnu-
**********************************************************************
 Kill me NOW, or forever hold your peace!
 (sleeping for 15 seconds...)
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1
(continuing...)
 * gcc-config: Could not locate 'i686-pc-linux-gnu-' in '/etc/env.d/gcc/' !
ERROR: : gcc-config i686-pc-linux-gnu- failed!



Code:
caxton sysadmin # gcc-config -l
 [1] i686-pc-linux-gnu-3.4.4
 [2] i686-pc-linux-gnu-3.4.4-hardened
 [3] i686-pc-linux-gnu-3.4.4-hardenednopie
 [4] i686-pc-linux-gnu-3.4.4-hardenednopiessp
 [5] i686-pc-linux-gnu-3.4.4-hardenednossp
 [6] i686-pc-linux-gnu-4.1.2 *



Code:
caxton sysadmin # ls -l /etc/env.d/gcc/
total 28
-rw-r--r-- 1 root root  32 2008-02-21 20:18 config-i686-pc-linux-gnu
-rw-r--r-- 1 root root 292 2005-12-03 02:11 i686-pc-linux-gnu-3.4.4
-rw-r--r-- 1 root root 356 2005-12-03 02:11 i686-pc-linux-gnu-3.4.4-hardened
-rw-r--r-- 1 root root 361 2005-12-03 02:11 i686-pc-linux-gnu-3.4.4-hardenednopie
-rw-r--r-- 1 root root 364 2005-12-03 02:11 i686-pc-linux-gnu-3.4.4-hardenednopiessp
-rw-r--r-- 1 root root 361 2005-12-03 02:11 i686-pc-linux-gnu-3.4.4-hardenednossp
-rw-r--r-- 1 root root 235 2008-02-21 20:17 i686-pc-linux-gnu-4.1.2


Code:

caxton sysadmin # cat /etc/env.d/gcc/config-i686-pc-linux-gnu
CURRENT=i686-pc-linux-gnu-4.1.2

_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Fri Feb 22, 2008 3:58 pm    Post subject: Reply with quote

carpman wrote:
hello, i am getting an error when updating tool chain:

(...)

Use this latest version: emwrap.sh-r4 for great justice.

I used to have the same problem and now it's fixed.
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
ledskof
Apprentice
Apprentice


Joined: 22 Oct 2002
Posts: 209
Location: Atlanta, GA

PostPosted: Fri May 02, 2008 6:33 pm    Post subject: Reply with quote

This is what I've been running:
Code:
emwrap.sh -Sb
gcc-config -L
emwrap.sh -W


In the past I've had to emerge gmp and mpfr to get gcc to begin emerging. I'm doing a newer one now to see what happens.
_________________
Thie is my sig. The post is over. Now gtfo.


Last edited by ledskof on Sat Nov 15, 2008 7:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1131
Location: Motown

PostPosted: Fri Aug 01, 2008 10:58 pm    Post subject: Reply with quote

Can emwrap work with any available set, not just system and world, such as @set_name_here ?
_________________
What I need is an exact list of specific unknown problems we might encounter.
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2540
Location: Richmond, BC, Canada

PostPosted: Tue Aug 05, 2008 2:56 pm    Post subject: Reply with quote

Unless heilvc has released a new version that I missed. It was created before sets support, so no it won't handle sets yet. At least not specifically. It will pass on parameters to emerge, so try it with the -p flag and see what happens.


If you don't need the toolchain broken out from system, I have porthole working with sets support and it breaks out system and sets packages from world so they only show up in the first one in the list (upgrades view).
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
ledskof
Apprentice
Apprentice


Joined: 22 Oct 2002
Posts: 209
Location: Atlanta, GA

PostPosted: Sat Nov 15, 2008 7:51 pm    Post subject: Reply with quote

I'm building a new amd64 server for my house.

I'm getting the ss and com_err problem so I did:

Code:
emerge -f e2fsprogs e2fsprogs-libs
emerge -C ss com_err e2fsprogs
emerge e2fsprogs e2fsprogs-libs


Make sure you get all of the dependencies to emerge e2fsprogs before you unmerge ss and com_err, or you might lose the ability to download them.

I'm sure there will be a few more problems so I'll update this post.
_________________
Thie is my sig. The post is over. Now gtfo.
Back to top
View user's profile Send private message
skutnar
n00b
n00b


Joined: 13 Jun 2006
Posts: 65

PostPosted: Sun Mar 01, 2009 1:44 am    Post subject: Reply with quote

It looks like emwrap won't work when doing "emwrap -W" when the KDE game "kblocks" is installed. Here's the snippet from /tmp/emwrap/wrld.lst:

Code:
[ebuild   R   ] kde-base/kblocks-4.2.0

You have packages blocking each other. To fix run emerge
and take care of the blockage


I suppose I can uninstall the KDE game meta package...
Back to top
View user's profile Send private message
upengan78
l33t
l33t


Joined: 27 Jun 2007
Posts: 676
Location: IL

PostPosted: Wed Sep 09, 2009 6:45 pm    Post subject: Reply with quote

I ran this script today, like this : ./emwrap.sh -wuDb

I got following message,


Quote:
INSTALL /nfs1/var/tmp/portage/portage/dev-java/java-gnome-4.0.13/image//usr/share/java-gnome-4.0/lib/gtk-4.0.jar
JAR /nfs1/var/tmp/portage/portage/dev-java/java-gnome-4.0.13/image//usr/share/java-gnome-4.0/lib/gtk-4.0.jar
SYMLINK /nfs1/var/tmp/portage/portage/dev-java/java-gnome-4.0.13/image//usr/share/java-gnome-4.0/lib/gtk.jar -> gtk-4.0.jar
INSTALL /nfs1/var/tmp/portage/portage/dev-java/java-gnome-4.0.13/image//usr/lib64/java-gnome-4.0/libgtkjni-4.0.13.so
>>> Completed installing java-gnome-4.0.13 into /nfs1/var/tmp/portage/portage/dev-java/java-gnome-4.0.13/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
usr/lib64/java-gnome-4.0/libgtkjni-4.0.13.so

>>> Installing (1 of 1) dev-java/java-gnome-4.0.13
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory

ToolChain updates found

no

======================================================

grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
grep: wrld.lst: No such file or directory
awk: cmd. line:1: fatal: cannot open file `wrld.lst' for reading (No such file or directory)

0 build to emerge
these failed to build
media-libs/schroedinger-1.0.7-r1


Is this normal or something will need to be changed in the script? If so, where exactly?

emerge --info
Code:
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.4, glibc-2.10.1-r0, 2.6.28-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r3-x86_64-Intel-R-_Core-TM-2_CPU_6400_@_2.13GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 09 Sep 2009 14:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.5.4-r3, 2.6.2-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo ftp://gentoo.mirrors.tds.net/gentoo http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.llarian.net/ ftp://gentoo.llarian.net/pub/gentoo http://gentoo.binarycompass.org http://prometheus.cs.wmich.edu/gentoo http://mirror.usu.edu/mirrors/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/  http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/nfs1/var/tmp/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 aspell berkdb bzip2 cli cracklib crypt cups dbus dri gdbm gnome gpm gstreamer gtk hal iconv isdnlog jpeg ldap mmx mudflap multilib ncurses nls nptl nptlonly nsplugin openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl svg sysfs tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Code:

This is my emwrap script : http://pastebin.ca/1560108
Back to top
View user's profile Send private message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Thu Sep 10, 2009 8:23 pm    Post subject: Reply with quote

I'll take a look. It will probably be Saturday before I will have anything.
_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
upengan78
l33t
l33t


Joined: 27 Jun 2007
Posts: 676
Location: IL

PostPosted: Thu Sep 10, 2009 8:27 pm    Post subject: Reply with quote

hielvc wrote:
I'll take a look. It will probably be Saturday before I will have anything.

Many thanks, hielvc!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 28, 29, 30  Next
Page 29 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum