Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with permissions of /dev/sound/dsp
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
roman
n00b
n00b


Joined: 20 May 2002
Posts: 17

PostPosted: Thu May 23, 2002 8:01 am    Post subject: Problem with permissions of /dev/sound/dsp Reply with quote

Hallo,

I have a "problem" with permissons of /dev/sound/dsp.

When I boot, the file has "right" permissions:
Code:
crw-rw---- 1 root audio 14, 3 1970-01-01 /dev/sound/dsp


After I log in as normal user with group audio enabled and start KDE,
the permissions of file are changed to:
Code:
crw------- 1 roman audio 14, 3 1970-01-01 /dev/sound/dsp


When I logout from KDE the permissions are left to roman.

So as I log in KDE as another user, let's say guest also with audio
group enabled, this user can't use the sound anymore....

What is the solution? Or is this way of changing permissions to first
user, who use the audio, allright?

Roman.
Back to top
View user's profile Send private message
Guest






PostPosted: Fri May 24, 2002 2:22 pm    Post subject: Reply with quote

Edit /etc/security/consoleperms
I had the same problem (it is also needed for "floppy" access via mtools)
Back to top
roman
n00b
n00b


Joined: 20 May 2002
Posts: 17

PostPosted: Mon May 27, 2002 7:42 am    Post subject: Reply with quote

thanx...
Back to top
View user's profile Send private message
Faffy
n00b
n00b


Joined: 17 May 2002
Posts: 46

PostPosted: Tue May 28, 2002 11:32 pm    Post subject: Reply with quote

I have the exact same problem. Sound is working for root but, it does not work for other users.
What did you edit in console.perms.

I changed it to this:
Code:
<sound>=/dev/sound/dsp* /dev/audio* /dev/sound/midi* \
   /dev/sound/mixer* /dev/sequencer* \
   /dev/sound/* /dev/snd/* /dev/beep \
        /dev/admm* \
   /dev/adsp* /dev/aload* /dev/amidi* /dev/dmfm* \
   /dev/dmmidi* /dev/sndstat


(I replaced the /dev/dsp to /dev/sound/dsp and so on)

But it did not help.

I do not have alsa installed. I compiled my sound card module into the kernel.

Can someone tell me where to look?
Back to top
View user's profile Send private message
Faffy
n00b
n00b


Joined: 17 May 2002
Posts: 46

PostPosted: Tue May 28, 2002 11:36 pm    Post subject: Reply with quote

Ok.
I found the answer here. Disregard my previous post

http://forums.gentoo.org/viewtopic.php?t=2901&highlight=sound
Back to top
View user's profile Send private message
bobo
n00b
n00b


Joined: 18 Jul 2002
Posts: 10

PostPosted: Thu Jul 18, 2002 11:50 pm    Post subject: The solution (I think) Reply with quote

I found two minor glitches that were stopping pam_console from setting device ownerships correctly:

1. The console.perms file refers to groups cdwriter and usb, which are not in /etc/group. This causes pam to crash out in getgrnam.

2. The file /etc/pam.d was *missing* the pam_console entry. It needs the following line at the end:

session optional /lib/security/pam_console.so

Hope this helps!
Back to top
View user's profile Send private message
MPea3
n00b
n00b


Joined: 06 Jul 2002
Posts: 12
Location: atlanta, ga

PostPosted: Fri Jul 19, 2002 1:02 am    Post subject: Reply with quote

add your user name to the group audio
Back to top
View user's profile Send private message
SlCKB0Y
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2002
Posts: 105
Location: Sydney, Australia

PostPosted: Fri Jul 19, 2002 3:43 am    Post subject: Reply with quote

MPea3 wrote:
add your user name to the group audio


Yea this is what i did and it works fine
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum