Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 Overlay (Part 3)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 22, 23, 24  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Thu Oct 11, 2007 7:45 pm    Post subject: KDE4 Overlay (Part 3) Reply with quote

This is the third part of the support thread for the KDE4 overlay(s). You'll find part 1 here.
and part 2 here

The overlay is maintained by:

Wulf C. Krueger - Philantrop (philantrop at gentoo.org)
Ingmar Vanhassel - Ingmar (ingmar.vanhassel at gmail.com)
Bo Ørsted Andresen - zlin (bo.andresen at zlin.dk)
Timo Gurr - Psy (tgurr at gentoo.org)
Tobias Heinlein - keytoaster ( keytoaster at gentoo.org )
Jorge Manuel B. S. Vicetto - jmbsvicetto (jmbsvicetto at gentoo.org)

Former maintainers:

Emanuele A. Bagnaschi - Zephyrus. Thanks, Zephyrus, for your amazing work on the overlays. I hope you'll be back later on. :-)
Christian Heim - phreak

IMPORTANT NOTES

  1. Read the docs (details below). We reserve the right to kick you where it hurts if you don't. ;->
  2. We're not responsible for any damages these ebuilds can do to your computer.
  3. Do _NOT_ report bugs on Gentoo's bugzilla.


We have moved the overlay away from sf.net and are now using git. So please re-add the overlay: "layman -f && layman -d kde && layman -a kde". To manually clone it: git clone git://www2.mailstation.de/git/genkde4svn-pub.git/ [target directory]


You'll find us on Freenode in #genkdesvn and, of course, here if you need help.

To check the overlay Documentation look at the README and ReleaseNotes files and the /Documentation directory in the overlay tree. The KDE 4.0 beta and live packages have been slotted and shouldn't cause any problems with the 3.5 slot.


[Mod Edit - stuck by NeddySeagoon
Part 3 created 26 Dec 07 and above edited to include link to part 2]

[mod]Updated some content - Jorge (jmbsvicetto)[/mod]


Last edited by Philantrop on Fri Jan 04, 2008 5:20 pm; edited 2 times in total
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Wed Dec 26, 2007 1:02 pm    Post subject: Reply with quote

hm, that part with removing the env file isn't up-to-date anymore I think.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32099
Location: 56N 3W

PostPosted: Wed Dec 26, 2007 1:07 pm    Post subject: Reply with quote

Berniyh,

Possibly not. Philantrops' post started life at the top of part 2.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Wed Dec 26, 2007 1:37 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Berniyh,

Possibly not. Philantrops' post started life at the top of part 2.

At that time it was still correct.
Now things have changed.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Wed Dec 26, 2007 8:38 pm    Post subject: Reply with quote

Just because there have been some questions about this:
I just remerged kde svn and there is now a possibility to place icons on the desktop, with text and some configure dialog, just like in kde3. Additionally there is now a virtual desktop switcher.
Back to top
View user's profile Send private message
bianco
n00b
n00b


Joined: 21 Jun 2005
Posts: 54

PostPosted: Wed Dec 26, 2007 11:18 pm    Post subject: Re: KDE4 Overlay - monolithic ebuilds (Part 3) Reply with quote

Philantrop wrote:

To restore the status of KDE3, execute the following commands:

rm /etc/env.d/44kdepaths-kde-svn (or rm /etc/env.d/44kdepaths-kde-4 if are using a non-live ebuild)


8O

for me it's called:
Code:
/etc/env.d/46kdepaths-kde-svn


:wink:
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Dec 27, 2007 4:43 pm    Post subject: Reply with quote

For those asking for icons with text and a configuration dialog for the taskbar, watch this:
http://www.berniyh.net/properities.png

Currently there is only one option (enable/disable tooltips), but it's very recent (has been added
just a few hours ago), so it's only a matter of time. ;)

There is now a configuration dialog for the icons, you can set permissions etc, just like in KDE3.
Back to top
View user's profile Send private message
Maguscrowley
n00b
n00b


Joined: 23 Dec 2007
Posts: 12
Location: Owings Mills, MD

PostPosted: Thu Dec 27, 2007 4:58 pm    Post subject: Reply with quote

Can someone direct me to a list of packages to put into package.keywords?
_________________
"Does wisdom perhaps appear on earth as a raven is inspired by the smell of carrion." -Friedrich Nietzsche, Twilight of the Idols (1889)
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Dec 27, 2007 5:10 pm    Post subject: Reply with quote

Maguscrowley wrote:
Can someone direct me to a list of packages to put into package.keywords?

There is a sample package.keywords list in the Documentation folder of the overlay.
Back to top
View user's profile Send private message
Maguscrowley
n00b
n00b


Joined: 23 Dec 2007
Posts: 12
Location: Owings Mills, MD

PostPosted: Thu Dec 27, 2007 5:16 pm    Post subject: Reply with quote

Berniyh wrote:
Maguscrowley wrote:
Can someone direct me to a list of packages to put into package.keywords?

There is a sample package.keywords list in the Documentation folder of the overlay.


Yeah, but it doesn't seem to cover whats needed for kdebase-meta. I went and manually did it for each masked package that it needed. This is what I have:


# KDE 4 SVN ebuilds keywords
>=kde-base/kdelibs-3.97.0 **
>=kde-base/kdepimlibs-3.97.0 **
>=kde-base/kdebase-3.97.0 **
>=kde-base/kdeadmin-3.97.0 **
>=kde-base/kdeartwork-3.97.0 **
>=kde-base/kdeedu-3.97.0 **
>=kde-base/kdegames-3.97.0 **
>=kde-base/kdegraphics-3.97.0 **
>=kde-base/kdemultimedia-3.97.0 **
>=kde-base/kdenetwork-3.97.0 **
>=kde-base/kdepim-3.97.0 **
>=kde-base/kdesdk-3.97.0 **
>=kde-base/kdetoys-3.97.0 **
>=kde-base/kdeutils-3.97.0 **
>=kde-base/kdeaddons-3.97.0 **
# KDE 4 support libs
>=app-crypt/qca-9999 **
>=dev-libs/soprano-9999 **
>=media-libs/taglib-9999 **
>=net-libs/telepathy-qt-9999 **
>=net-voip/tapioca-qt-9999 **
>=lib-ml/facile-1.1 **
>=app-misc/strigi-9999 **


>=kde-base/dolphin-3.97.0 **
>=kde-base/kdepasswd-3.97.0:kde-4 **
>=kde-base/kdebase-meta-3.97.0 **
>=kde-base/libkonq-3.97.0:kde-4 **
>=kde-base/qimageblitz-0.0.4 **
>=kde-base/kfind-3.97.0:kde-4 **
>=kde-base/nepomuk-3.97.0:kde-4 **
>=kde-base/konsole-3.97.0:kde-4 **
>=kde-base/keditbookmarks-3.97.0:kde-4 **
>=kde-base/kdialog-3.97.0:kde-4 **
>=kde-base/konqueror-3.97.0:kde-4 **
>=kde-base/kdebase-kioslaves-3.97.0:kde-4 **
>=kde-base/kdesu-3.97.0:kde-4 **
>=kde-base/kwrite-3.97.0:kde-4 **
>=kde-base/nsplugins-3.97.0:kde-4 **
>=kde-base/kappfinder-3.97.0:kde-4 **
_________________
"Does wisdom perhaps appear on earth as a raven is inspired by the smell of carrion." -Friedrich Nietzsche, Twilight of the Idols (1889)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5398
Location: Langen (Hessen), Germany

PostPosted: Thu Dec 27, 2007 8:09 pm    Post subject: Reply with quote

Hey,

I have tried do install qt-4.4.0 but:

Code:
>>> Emerging (1 of 1) app-misc/strigi-9999 to /
 * checking ebuild checksums ;-) ...                                                                                                      [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                     [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                    [ ok ]
 *
 * ERROR: app-misc/strigi-9999 failed.
 * Call stack:
 *               ebuild.sh, line   46:  Called pkg_setup
 *      strigi-9999.ebuild, line   59:  Called built_with_use 'pkg_setup' 'pkg_setup'
 *           eutils.eclass, line 1695:  Called die
 * The specific snippet of code:
 *                                      die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   x11-libs/qt-4.4.0_rc1 does not actually support the dbus USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-misc/strigi-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/strigi-9999/temp/die.env'.



Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Dec 27, 2007 8:19 pm    Post subject: Reply with quote

Finswimmer wrote:
Hey,

I have tried do install qt-4.4.0 but:

Use qt-4.3.
KDE4 doesn't work yet with qt-4.4.

(Although the error you had is easy to fix you will run into other errors after that.)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5398
Location: Langen (Hessen), Germany

PostPosted: Thu Dec 27, 2007 9:30 pm    Post subject: Reply with quote

Berniyh wrote:
Finswimmer wrote:
Hey,

I have tried do install qt-4.4.0 but:

Use qt-4.3.
KDE4 doesn't work yet with qt-4.4.

(Although the error you had is easy to fix you will run into other errors after that.)


Hmm Ok. Thought someone has suggestend to use the new qt...

Thanks
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
timmy334
n00b
n00b


Joined: 24 Sep 2003
Posts: 69
Location: Montgomery, AL

PostPosted: Thu Dec 27, 2007 10:47 pm    Post subject: Reply with quote

I am trying to build KDE svn for the first time and I've gotten this far. It stops in kdepim but doesn't tell me much. Here's the error:

Code:
[ 13%] Built target converter
make: *** [all] Error 2
 *
 * ERROR: kde-base/kdepim-9999.4 failed.
 * Call stack:
 *              ebuild.sh, line 1701:  Called dyn_compile
 *              ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *              ebuild.sh, line   44:  Called src_compile
 *   kdepim-9999.4.ebuild, line   53:  Called kde4-base_src_compile
 *       kde4-base.eclass, line  308:  Called kde4-base_src_make
 *       kde4-base.eclass, line  360:  Called cmake-utils_src_make
 *     cmake-utils.eclass, line  127:  Called die
 * The specific snippet of code:
 *              emake || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdepim-9999.4/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/layman/kde/'
 *


[EDIT]:
Ok, I got past the above error by using USE="debug" while recompiling qt4 and using USE="debug" while attempting to compile kdepim-9999.4. Unfortunately, it got a little farther and then quit again:
Code:
Linking CXX shared library ../lib/libknodecommon.so
[ 19%] Built target knodecommon
make: *** [all] Error 2
 *
 * ERROR: kde-base/kdepim-9999.4 failed.
 * Call stack:
 *              ebuild.sh, line 1701:  Called dyn_compile
 *              ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *              ebuild.sh, line   44:  Called src_compile
 *   kdepim-9999.4.ebuild, line   53:  Called kde4-base_src_compile
 *       kde4-base.eclass, line  308:  Called kde4-base_src_make
 *       kde4-base.eclass, line  360:  Called cmake-utils_src_make
 *     cmake-utils.eclass, line  127:  Called die
 * The specific snippet of code:
 *              emake || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdepim-9999.4/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/layman/kde/'
 *

 * Messages for package kde-base/kdepim-9999.4:

 * WARNING! This is an experimental ebuild of the kdepim KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!
 *
 * ERROR: kde-base/kdepim-9999.4 failed.
 * Call stack:
 *              ebuild.sh, line 1701:  Called dyn_compile
 *              ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *              ebuild.sh, line   44:  Called src_compile
 *   kdepim-9999.4.ebuild, line   53:  Called kde4-base_src_compile
 *       kde4-base.eclass, line  308:  Called kde4-base_src_make
 *       kde4-base.eclass, line  360:  Called cmake-utils_src_make
 *     cmake-utils.eclass, line  127:  Called die
 * The specific snippet of code:
 *              emake || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdepim-9999.4/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/layman/kde/'
 *

Any ideas?
_________________
It is by caffeine alone I set my mind in motion,
It is by the beans of Java my thoughts acquire speed,
My hands acquire shaking, the shaking becomes a warning,
It is by caffeine alone I set my mind in motion
Back to top
View user's profile Send private message
Maguscrowley
n00b
n00b


Joined: 23 Dec 2007
Posts: 12
Location: Owings Mills, MD

PostPosted: Fri Dec 28, 2007 11:24 am    Post subject: Reply with quote

I finished installing all the packages listed in my above post but kwin 3.5.8, and all the rest of kde 3.5.8, is still loading. I noticed you guys reffering to a env.d/?5kde-svn path file but I think I need an example of it to manually make. Can someone post theirs?
_________________
"Does wisdom perhaps appear on earth as a raven is inspired by the smell of carrion." -Friedrich Nietzsche, Twilight of the Idols (1889)
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri Dec 28, 2007 11:30 am    Post subject: Reply with quote

Maguscrowley wrote:
I finished installing all the packages listed in my above post but kwin 3.5.8, and all the rest of kde 3.5.8, is still loading. I noticed you guys reffering to a env.d/?5kde-svn path file but I think I need an example of it to manually make. Can someone post theirs?

It gets created automatically.

I think I didn't understand the rest of your post. What actually is your current problem?
Back to top
View user's profile Send private message
Maguscrowley
n00b
n00b


Joined: 23 Dec 2007
Posts: 12
Location: Owings Mills, MD

PostPosted: Fri Dec 28, 2007 11:43 am    Post subject: Reply with quote

Berniyh wrote:
Maguscrowley wrote:
I finished installing all the packages listed in my above post but kwin 3.5.8, and all the rest of kde 3.5.8, is still loading. I noticed you guys reffering to a env.d/?5kde-svn path file but I think I need an example of it to manually make. Can someone post theirs?

It gets created automatically.

I think I didn't understand the rest of your post. What actually is your current problem?


Well I emerged kdebase-meta from the overlay and for some reason I'm still loading kde 3.5.8. I just checked though and I have three seemingly related files in /etc/env.d/, 46kdepaths-kde-4, 46kdepaths-kde-4, 45kdepaths-3.5. Are all three of those supposed to be there?
_________________
"Does wisdom perhaps appear on earth as a raven is inspired by the smell of carrion." -Friedrich Nietzsche, Twilight of the Idols (1889)
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri Dec 28, 2007 12:46 pm    Post subject: Reply with quote

Maguscrowley wrote:
Berniyh wrote:
Maguscrowley wrote:
I finished installing all the packages listed in my above post but kwin 3.5.8, and all the rest of kde 3.5.8, is still loading. I noticed you guys reffering to a env.d/?5kde-svn path file but I think I need an example of it to manually make. Can someone post theirs?

It gets created automatically.

I think I didn't understand the rest of your post. What actually is your current problem?


Well I emerged kdebase-meta from the overlay and for some reason I'm still loading kde 3.5.8. I just checked though and I have three seemingly related files in /etc/env.d/, 46kdepaths-kde-4, 46kdepaths-kde-4, 45kdepaths-3.5. Are all three of those supposed to be there?

Make sure you have at least kdebase-startkde-3.5.8-r1 for KDE3 installed.
Then I suggest you remove the env files, that are related to KDE4 and remerge kdebase-9999.4 (if you're using svn or the appropriate split packages if you are using the RCs).
Back to top
View user's profile Send private message
Ingmarv
Retired Dev
Retired Dev


Joined: 27 Feb 2007
Posts: 188
Location: Belgium

PostPosted: Fri Dec 28, 2007 5:46 pm    Post subject: Reply with quote

Berniyh wrote:
Make sure you have at least kdebase-startkde-3.5.8-r1 for KDE3 installed.
Then I suggest you remove the env files, that are related to KDE4 and remerge kdebase-9999.4 (if you're using svn or the appropriate split packages if you are using the RCs).


kdelibs installs the env.d files, not kdebase.

You do _NOT_ have to touch the env.d files if you install KDE 4.0 now.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri Dec 28, 2007 5:53 pm    Post subject: Reply with quote

Ingmarv wrote:
Berniyh wrote:
Make sure you have at least kdebase-startkde-3.5.8-r1 for KDE3 installed.
Then I suggest you remove the env files, that are related to KDE4 and remerge kdebase-9999.4 (if you're using svn or the appropriate split packages if you are using the RCs).


kdelibs installs the env.d files, not kdebase.

Ooops, of course, it's kdelibs.

Quote:
You do _NOT_ have to touch the env.d files if you install KDE 4.0 now.

That is what I was writing above, so could please someone change the first post to match the current situation?
Back to top
View user's profile Send private message
tytanick
Apprentice
Apprentice


Joined: 01 Feb 2006
Posts: 162
Location: Poland, Gdansk

PostPosted: Sat Dec 29, 2007 12:03 am    Post subject: Reply with quote

Hello, I made good package.keywords for kde-base/kde-meta-3.97.0


Code:

# /etc/portage/package.keywords
# emerge -av =kde-base/kde-meta-3.97.0
# KDE 4 meta
>=kde-base/kde-meta-3.97.0 **
>=kde-base/kdeaccessibility-meta-3.97.0 **
>=kde-base/kmag-3.97.0 **
>=kde-base/kdelibs-3.97.0 **
<=dev-libs/soprano-1.99.0 **
>=kde-base/kdepimlibs-3.97.0 **
>=kde-base/kttsd-3.97.0 **
>=kde-base/knotify-3.97.0 **
>=kde-base/phonon-3.97.0 **
>=kde-base/qimageblitz-0.0.4 **
>=kde-base/kcmshell-3.97.0 **
>=kde-base/kmouth-3.97.0 **
>=kde-base/kdeaccessibility-iconthemes-3.97.0 **
>=kde-base/kmousetool-3.97.0 **
>=kde-base/kdebase-meta-3.97.0 **
>=kde-base/kdepasswd-3.97.0 **
>=kde-base/libkonq-3.97.0 **
>=kde-base/kfind-3.97.0 **
>=kde-base/dolphin-3.97.0 **
>=kde-base/nepomuk-3.97.0 **
>=kde-base/konsole-3.97.0 **
>=kde-base/keditbookmarks-3.97.0 **
>=kde-base/kdialog-3.97.0 **
>=kde-base/konqueror-3.97.0 **
>=kde-base/kdebase-kioslaves-3.97.0 **
>=kde-base/kdesu-3.97.0 **
>=kde-base/kwrite-3.97.0 **
>=kde-base/nsplugins-3.97.0 **
>=kde-base/kappfinder-3.97.0 **
>=kde-base/kdebase-runtime-meta-3.97.0 **
>=kde-base/kcontrol-3.97.0 **
>=kde-base/khotkeys-3.97.0 **
>=kde-base/khelpcenter-3.97.0 **
>=kde-base/systemsettings-3.97.0 **
>=kde-base/kcminit-3.97.0 **
>=kde-base/ksplash-3.97.0 **
>=kde-base/kdebase-data-3.97.0 **
>=kde-base/kreadconfig-3.97.0 **
>=kde-base/kuiserver-3.97.0 **
>=kde-base/kquitapp-3.97.0 **
>=kde-base/kdebugdialog-3.97.0 **
>=kde-base/ktraderclient-3.97.0 **
>=kde-base/kpasswdserver-3.97.0 **
>=kde-base/kde-menu-3.97.0 **
>=kde-base/kfile-3.97.0 **
>=kde-base/soliduiserver-3.97.0 **
>=kde-base/solid-3.97.0 **
>=kde-base/knetattach-3.97.0 **
>=kde-base/kurifilter-plugins-3.97.0 **
>=kde-base/drkonqi-3.97.0 **
>=kde-base/kioclient-3.97.0 **
>=kde-base/ktimezoned-3.97.0 **
>=kde-base/kmimetypefinder-3.97.0 **
>=kde-base/kstyles-3.97.0 **
>=kde-base/kstart-3.97.0 **
>=kde-base/knewstuff-3.97.0 **
>=kde-base/kdebase-workspace-meta-3.97.0 **
>=kde-base/kwin-3.97.0 **
>=kde-base/kde-wallpapers-3.97.0 **
>=kde-base/kde-menu-icons-3.97.0 **
>=kde-base/ksmserver-3.97.0 **
>=kde-base/libkworkspace-3.97.0 **
>=kde-base/libplasma-3.97.0 **
>=kde-base/libtaskmanager-3.97.0 **
>=kde-base/kmenuedit-3.97.0 **
>=kde-base/kstartupconfig-3.97.0 **
>=kde-base/kdm-3.97.0 **
>=kde-base/kcheckpass-3.97.0 **
>=kde-base/ktip-3.97.0 **
>=kde-base/kdebase-startkde-3.97.0 **
>=kde-base/kscreensaver-3.97.0 **
>=kde-base/krunner-3.97.0 **
>=kde-base/plasma-3.97.0 **
>=kde-base/ksysguard-3.97.0 **
>=kde-base/ksystraycmd-3.97.0 **
>=kde-base/klipper-3.97.0 **
>=kde-base/kdeartwork-meta-3.97.0 **
>=kde-base/kdeartwork-kscreensaver-3.97.0 **
>=kde-base/kdeartwork-iconthemes-3.97.0 **
>=kde-base/kdeartwork-emoticons-3.97.0 **
>=kde-base/kdeartwork-sounds-3.97.0 **
>=kde-base/kdeartwork-wallpapers-3.97.0 **
>=kde-base/kdeartwork-styles-3.97.0 **
>=kde-base/kdemultimedia-meta-3.97.0 **
>=kde-base/kmix-3.97.0 **
>=kde-base/kscd-3.97.0 **
>=kde-base/libkcddb-3.97.0 **
>=kde-base/libkcompactdisc-3.97.0 **
>=kde-base/juk-3.97.0 **
>=kde-base/kdetoys-meta-3.97.0 **
>=kde-base/kweather-3.97.0 **
>=kde-base/amor-3.97.0 **
>=kde-base/kworldclock-3.97.0 **
>=kde-base/kteatime-3.97.0 **
>=kde-base/eyesapplet-3.97.0 **
>=kde-base/kmoon-3.97.0 **
>=kde-base/fifteenapplet-3.97.0 **
>=kde-base/ktux-3.97.0 **
>=kde-base/kdenetwork-meta-3.97.0 **
>=kde-base/knewsticker-3.97.0 **
>=kde-base/kdnssd-3.97.0 **
>=kde-base/kdenetwork-filesharing-3.97.0 **
>=kde-base/kopete-3.97.0 **
>=app-crypt/qca-2.0.0-r2 **
>=kde-base/kppp-3.97.0 **
>=kde-base/lisa-3.97.0 **
>=kde-base/krdc-3.97.0 **
>=kde-base/krfb-3.97.0 **
>=kde-base/kget-3.97.0 **
>=kde-base/kdeedu-meta-3.97.0 **
>=kde-base/kmplot-3.97.0 **
>=kde-base/marble-3.97.0 **
>=kde-base/kbruch-3.97.0 **
>=kde-base/kalzium-3.97.0 **
>=kde-base/libkdeedu-3.97.0 **
>=kde-base/kgeography-3.97.0 **
>=kde-base/kwordquiz-3.97.0 **
>=kde-base/ktouch-3.97.0 **
>=kde-base/parley-3.97.0 **
>=kde-base/kalgebra-3.97.0 **
>=kde-base/kanagram-3.97.0 **
>=kde-base/blinken-3.97.0 **
>=kde-base/kstars-3.97.0 **
>=kde-base/kiten-3.97.0 **
>=kde-base/klettres-3.97.0 **
>=kde-base/khangman-3.97.0 **
>=kde-base/kpercentage-3.97.0 **
>=kde-base/kturtle-3.97.0 **
>=kde-base/kig-3.97.0 **
>=kde-base/kdeutils-meta-3.97.0 **
>=kde-base/kcalc-3.97.0 **
>=kde-base/superkaramba-3.97.0 **
>=kde-base/kmilo-3.97.0 **
>=kde-base/kgpg-3.97.0 **
>=kde-base/ktimer-3.97.0 **
>=kde-base/kdessh-3.97.0 **
>=kde-base/kwallet-3.97.0 **
>=kde-base/kfloppy-3.97.0 **
>=kde-base/sweeper-3.97.0 **
>=kde-base/kcharselect-3.97.0 **
>=kde-base/khexedit-3.97.0 **
>=kde-base/kjots-3.97.0 **
>=kde-base/kdf-3.97.0 **
>=kde-base/ark-3.97.0 **
>=kde-base/kregexpeditor-3.97.0 **
>=kde-base/kdegraphics-meta-3.97.0 **
>=kde-base/gwenview-3.97.0 **
>=kde-base/kolourpaint-3.97.0 **
>=kde-base/kcolorchooser-3.97.0 **
>=kde-base/libkscan-3.97.0 **
>=kde-base/ksnapshot-3.97.0 **
>=kde-base/svgpart-3.97.0 **
>=kde-base/kruler-3.97.0 **
>=kde-base/okular-3.97.0 **
>=kde-base/kamera-3.97.0 **
>=kde-base/kdepim-meta-3.97.0 **
>=kde-base/kmail-3.97.0 **
>=kde-base/libkpgp-3.97.0 **
>=kde-base/kode-3.97.0 **
>=kde-base/kontact-3.97.0 **
>=kde-base/libkdepim-3.97.0 **
>=kde-base/libksieve-3.97.0 **
>=kde-base/libkleo-3.97.0 **
>=kde-base/mimelib-3.97.0 **
>=kde-base/kmailcvt-3.97.0 **
>=kde-base/korn-3.97.0 **
>=kde-base/kontact-specialdates-3.97.0 **
>=kde-base/libkholidays-3.97.0 **
>=kde-base/kaddressbook-3.97.0 **
>=kde-base/korganizer-3.97.0 **
>=kde-base/kdepim-kresources-3.97.0 **
>=kde-base/kalarm-3.97.0 **
>=kde-base/kmobiletools-3.97.0 **
>=kde-base/akonadi-3.97.0 **
>=kde-base/kdemaildir-3.97.0 **
>=kde-base/knode-3.97.0 **
>=kde-base/konsolekalendar-3.97.0 **
>=kde-base/ktnef-3.97.0 **
>=kde-base/akregator-3.97.0 **
>=kde-base/ktimetracker-3.97.0 **
>=kde-base/kabcclient-3.97.0 **
>=kde-base/kfeed-3.97.0 **
>=kde-base/knotes-3.97.0 **
>=kde-base/kdeadmin-meta-3.97.0 **
>=kde-base/knetworkconf-3.97.0 **
>=kde-base/secpolicy-3.97.0 **
>=kde-base/kcron-3.97.0 **
>=kde-base/kuser-3.97.0 **
>=kde-base/lilo-config-3.97.0 **
>=kde-base/kdegames-meta-3.97.0 **
>=kde-base/ktuberling-3.97.0 **
>=kde-base/libkdegames-3.97.0 **
>=kde-base/bovo-3.97.0 **
>=kde-base/kolf-3.97.0 **
>=kde-base/ksquares-3.97.0 **
>=kde-base/kpat-3.97.0 **
>=kde-base/ksame-3.97.0 **
>=kde-base/kbattleship-3.97.0 **
>=kde-base/ksudoku-3.97.0 **
>=kde-base/kiriki-3.97.0 **
>=kde-base/katomic-3.97.0 **
>=kde-base/konquest-3.97.0 **
>=kde-base/kwin4-3.97.0 **
>=kde-base/kgoldrunner-3.97.0 **
>=kde-base/libkmahjongg-3.97.0 **
>=kde-base/kshisen-3.97.0 **
>=kde-base/kspaceduel-3.97.0 **
>=kde-base/kmahjongg-3.97.0 **
>=kde-base/knetwalk-3.97.0 **
>=kde-base/kbounce-3.97.0 **
>=kde-base/kjumpingcube-3.97.0 **
>=kde-base/kmines-3.97.0 **
>=kde-base/kreversi-3.97.0 **
>=kde-base/klines-3.97.0 **
>=kde-base/kblackbox-3.97.0 **

_________________
Contact with me: http://www.tytanick.eu
Back to top
View user's profile Send private message
Ingmarv
Retired Dev
Retired Dev


Joined: 27 Feb 2007
Posts: 188
Location: Belgium

PostPosted: Sat Dec 29, 2007 12:17 am    Post subject: Reply with quote

There're two in the Documentation subfolder. ;)-
Back to top
View user's profile Send private message
kmare
l33t
l33t


Joined: 20 Nov 2004
Posts: 619
Location: Thessaloniki, Greece

PostPosted: Sat Dec 29, 2007 1:08 am    Post subject: Reply with quote

hello,
i was wondering.. is kopete with google talk working for you guys? it just won't connect. I would guess it has something to do with ssl, but i have qca-ossl compiled just fine. I really can't see what the problem could be, i don't even get an error message. It just says connecting without doing anything. icq is working fine.
Also: is there a way to totally remove the bar down?

thanx
_________________
Never argue with an idiot. They will only pull you down to their level, then beat you with experience.
Back to top
View user's profile Send private message
timmy334
n00b
n00b


Joined: 24 Sep 2003
Posts: 69
Location: Montgomery, AL

PostPosted: Sat Dec 29, 2007 5:31 am    Post subject: Reply with quote

Here is my build.log ----> http://pastebin.ca/836087 and emerge --info if that would help to get kdepim compiling in my above post:
Code:
Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.2.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
=================================================================
System uname: 2.6.23-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Timestamp of tree: Wed, 26 Dec 2007 23:30:08 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=native -pipe -fomit-frame-pointer -finline-functions"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.9/env /usr/kde/3.9/share/config /usr/kde/3.9/shutdown /usr/kde/svn/env /usr/kde/svn/share/config /usr/kde/svn/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -march=native -pipe -fomit-frame-pointer -finline-functions"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://mirror.mcs.anl.gov/pub/gentoo/ "
LANG="C"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/layman/xeffects /usr/local/layman/custom-kernels /usr/local/layman/gentoo-de /usr/local/layman/xen /usr/local/layman/rox /usr/local/layman/gnash-cvs /usr/local/layman/kolab /usr/local/layman/postgresql-testing /usr/local/layman/pd-overlay /usr/local/layman/openoffice-geki /usr/local/layman/wrobel /usr/local/layman/enlightenment /usr/local/layman/drizzt-overlay /usr/local/layman/mpd /usr/local/layman/live-ebuilds /usr/local/layman/zugaina /usr/local/layman/wschlich-testing /usr/local/layman/voip /usr/local/layman/d /usr/local/layman/finnish /usr/local/layman/secondlife /usr/local/layman/chtekk-syscp /usr/local/layman/xwing /usr/local/layman/jokey /usr/local/layman/java-overlay /usr/local/layman/dirtyepic /usr/local/layman/kde /usr/local/layman/vdr-testing /usr/local/layman/vmware /usr/local/layman/halcy0n /usr/local/layman/je_fro /usr/local/layman/cell /usr/local/layman/trauma /usr/local/layman/verlihub /usr/local/layman/wolf31o2 /usr/local/layman/powerpc /usr/local/layman/java-gcj-overlay /usr/local/layman/gentoo-taiwan /usr/local/layman/musicbrainz /usr/local/layman/toolchain /usr/local/layman/einit /usr/local/layman/lapis /usr/local/layman/gentoo-china /usr/local/layman/iwlwifi /usr/local/layman/gnome-experimental /usr/local/layman/sipx /usr/local/layman/gentopia /usr/local/layman/xfce /usr/local/layman/pda /usr/local/layman/masterdriverz /usr/local/layman/berkano /usr/local/layman/marineam-xen /usr/local/layman/hollow /usr/local/layman/armagetron /usr/local/layman/flameeyes-overlay /usr/local/layman/n4g-experimental /usr/local/layman/n4g /usr/local/layman/initng /usr/local/layman/dertobi123 /usr/local/layman/emacs /usr/local/layman/vdr-1.5 /usr/local/layman/voyageur /usr/local/layman/php-experimental /usr/local/layman/dev-zero /usr/local/layman/deathwing00 /usr/local/layman/vps /usr/local/layman/mozilla /usr/local/layman/efika /usr/local/layman/trapni /usr/local/layman/webapps-experimental /usr/local/layman/dma147 /usr/local/layman/science /usr/local/layman/rbu /usr/local/layman/eclipse /usr/local/layman/pro-audio /usr/local/layman/seemant /usr/local/layman/vdr-experimental /usr/local/layman/pythonhead /usr/local/layman/genstef /usr/local/layman/wschlich /usr/local/layman/ffmpeg-svn /usr/local/layman/plan9 /usr/local/layman/freevo /usr/local/layman/mysql-experimental /usr/local/layman/php-testing /usr/local/layman/ecatmur /usr/local/layman/chtekk-apps /usr/local/layman/postgresql-experimental /usr/local/layman/bangert /usr/local/layman/suka /usr/local/layman/luke-jr /usr/local/layman/nx /usr/local/layman/sunrise /usr/local/layman/xemacs /usr/local/layman/philantrop /usr/local/layman/pioto-overlay /usr/local/layman/sabayon /usr/local/layman/aross /usr/local/layman/lu_zero /usr/local/layman/mysql-testing /usr/local/layman/liquidx /usr/local/layman/lila-theme /usr/local/layman/gnustep /usr/local/layman/swegener /usr/local/layman/hanno-xgl /usr/local/portage /usr/local/layman/xeffects /usr/local/layman/custom-kernels"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi aim akamaru alsa artworkextra avi berkdb bitmap-fonts bluetooth bonobo branding bzip2 cairo cdda cddb cdparanoia cdr cli cracklib crypt cups dbus dga directfb dri dvd dvdr dvdread exif ffmpeg firefox flac fortran freetype ftp gdbm gif glib glitz gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal iconv ieee1394 imagemagick imlib ipv6 isdnlog jabber java javascript jpeg kde lame libcaca libwww mdnsresponder midi mmx mng mono mp3 mpeg mpi mplayer mudflap mysql ncurses nls nptl nptlonly nsplugin offensive ogg opengl openmp oscar pam pcre pda pdf perl png posix pppd python qt3 qt3support qt4 quicktime readline real reflection ruby samba session skins slang spell spl sse sse2 ssl svg svga symlink synaptics syslog szip tcl tcpd tetex theora tiff tk truetype truetype-fonts type1-fonts unicode usb vcd videos vim-syntax vorbis wifi win32codecs wmf wxwindows x86 xcomposite xine xml xorg xpm xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon fglrx vesa ati"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
It is by caffeine alone I set my mind in motion,
It is by the beans of Java my thoughts acquire speed,
My hands acquire shaking, the shaking becomes a warning,
It is by caffeine alone I set my mind in motion
Back to top
View user's profile Send private message
Maleita
Apprentice
Apprentice


Joined: 16 Sep 2004
Posts: 243
Location: Brasil -> São Paulo->Campinas

PostPosted: Sat Dec 29, 2007 2:54 pm    Post subject: Reply with quote

Well,i remove kde-svn and i installing kde-meta ,let me see what is.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 22, 23, 24  Next
Page 1 of 24

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum