Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thread ufficiale su Paludis
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Fri Apr 06, 2007 5:23 pm    Post subject: Reply with quote

Kernel78 wrote:
Quindi per te se un sito si vede con IE ma non con FF, per mancato rispetto degli standard, si tratta di un bug di FF ?
No ma è un discorso più complesso... si gioca sul fatto che gli standard web sono internazionali.
Quelli di portage sono standard interni quindi in qualche modo "più elastici"... diciamo che la capacità di riconoscere ebuild di vario genere va più nell'ottica della retrocompatibilità. Ovviamente partendo dal presupposto che anche ebuild scritti sui vecchi standard siano funzionanti (e pare di si).
Se vuoi fare un paragone trovo sia più calzante quello di msoffice che è scarsamente compatibili con i vecchi formati di versioni precedenti.
Comunque è un discorso del cazzo... sostanzialmente chi se ne frega. Visto che paludis non è il package manager ufficiale ma solo un progetto esterno può comportarsi un po' come gli pare (pure supportare un solo ebuild). Se mai volesse diventare ufficiale garantire la retrocompatibilità potrebbe essere una cosa simpatica.
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
yardbird
l33t
l33t


Joined: 20 Apr 2002
Posts: 688
Location: nl.leiden

PostPosted: Fri Apr 06, 2007 7:09 pm    Post subject: Reply with quote

Domanda veloce, visto che sono un attimo bloccato: come faccio a smascherare un pacchetto hard-masked su package.mask e keywordato "-*"? Io ho provato ad aggiungerlo a /etc/paludis/package_unmask.conf e a mettere la linea
Code:
pacchetto_bastardo -* x86 ~x86
in /etc/paludis/keywords.conf ma paludis mi vede solo le versioni stabili (o al più ~x86). Sicuramente faccio qualche errore scemo, ma quale? :?
_________________
Albert Einstein wrote:
I consider it [...] urgently necessary for [...] workers to get together, both to protect their own economic status and [...] to secure their influence in the political field.


http://www.bluescarni.info
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Fri Apr 06, 2007 7:41 pm    Post subject: Reply with quote

yardbird wrote:
Domanda veloce, visto che sono un attimo bloccato: come faccio a smascherare un pacchetto hard-masked su package.mask e keywordato "-*"? Io ho provato ad aggiungerlo a /etc/paludis/package_unmask.conf e a mettere la linea
Code:
pacchetto_bastardo -* x86 ~x86
in /etc/paludis/keywords.conf ma paludis mi vede solo le versioni stabili (o al più ~x86). Sicuramente faccio qualche errore scemo, ma quale? :?

Non so bene come aiutarti, perché non ho mai smascherato pacchetti simili.
Forse qui puoi trovare una risposta.

Probabilmente devi:
- inserire il pacchetto in package_unmask.conf
- inserire la linea
Code:
pacchetto_bastardo * x86 ~x86

(senza il - ) in keywords.conf.

Per curiosità qual é il pacchetto incriminato?
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
yardbird
l33t
l33t


Joined: 20 Apr 2002
Posts: 688
Location: nl.leiden

PostPosted: Fri Apr 06, 2007 11:11 pm    Post subject: Reply with quote

jordan83 wrote:
Probabilmente devi:
- inserire il pacchetto in package_unmask.conf
- inserire la linea
Code:
pacchetto_bastardo * x86 ~x86

(senza il - ) in keywords.conf.

Per curiosità qual é il pacchetto incriminato?

Bingo! Funziona, grazie :)

Il pacchetto incriminato è una pre-release del gcc-4.2 disponibile nel toolchain overlay. Per chiarire: so a cosa vado incontro e non intendo utilizzarlo per compilare i pacchetti di sistema :) Mi serve per cominciare a sperimentare l'utilizzo di openMP, che è supportato appunto a partire da gcc 4.2.

Grazie ancora dell'aiuto :)
_________________
Albert Einstein wrote:
I consider it [...] urgently necessary for [...] workers to get together, both to protect their own economic status and [...] to secure their influence in the political field.


http://www.bluescarni.info
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Tue Jul 10, 2007 11:24 am    Post subject: Reply with quote

Sono famoso per essere un vero poliglotta: esiste una guida in italiano per imparare ad utilizzare paludis?

\EDIT
...come vedo la dimensione dei sorgenti da scaricare con paludis? quello che in emerge si vede con emerge -pv nome_pacchetto?
...mi postate i file di configurazione ad esempio di repository diciamo un pò inusuali, come quello di uno sviluppatore (pauldv oppure drizzt), cosa di metto come indirizzo rsync?
...(ne arriveranno delle altre...)
_________________
LP
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Wed Jul 11, 2007 4:51 pm    Post subject: Reply with quote

Mi sa che ho combinato un piccolo casino... come faccio "ogni tanto" ho rimosso in contenuto in /var/tmp/* ed ora paludis non mi compila più nulla. Questo è l'eerore che ricevo provando a compilare qualsiasi pacchetto:

Code:
root@jarod {1}
> ~/paludis -i tar
Building target list... paludis@1184172574: [WARNING] In program paludis -i tar:
  ... When performing install action from command line:
  ... When adding install target 'tar':
  ... When disambiguating package name 'tar':
  ... When looking in repository 'paludis-extras':
  ... When using name cache at '/var/cache/paludis/names/paludis-extras':
  ... Names cache for 'paludis-extras' has no version information, so cannot be used. Either it was generated using an older Paludis version or it has not yet been generated.
paludis@1184172574: [WARNING] In program paludis -i tar:
  ... When performing install action from command line:
  ... When adding install target 'tar':
  ... When disambiguating package name 'tar':
  ... When looking in repository 'sunrise':
  ... When using name cache at '/var/cache/paludis/names/sunrise':
  ... Names cache for 'sunrise' has no version information, so cannot be used. Either it was generated using an older Paludis version or it has not yet been generated.

Building dependency list...

These packages will be installed:

* app-arch/tar-1.17 {:0} [R] nls -static

Total: 1 package (1 rebuild)
elog> touch: cannot touch `//var/tmp/paludis/elog.10959': No such file or directory
elog> /usr/share/paludis/hooks/install_all_pre/elog.bash: line 48: die: command not found
elog> chgrp: cannot access `//var/tmp/paludis/elog.10959': No such file or directory
elog> /usr/share/paludis/hooks/install_all_pre/elog.bash: line 50: die: command not found
elog> chmod: cannot access `//var/tmp/paludis/elog.10959': No such file or directory
elog> /usr/share/paludis/hooks/install_all_pre/elog.bash: line 51: die: command not found
paludis@1184172574: [WARNING] Hook '/usr/share/paludis/hooks/install_all_pre/elog.bash' returned failure '127'

Install error:
  * In program paludis -i tar:
  * When performing install action from command line:
  * When executing install task:
  * Install error: Install aborted by hook


Resume command: paludis --log-level qa --dl-deps-default discard --install '=app-arch/tar-1.17::gentoo' --add-to-world-spec '( app-arch/tar )'


Poi mi sa che ci sono anche altre cose che non vanno, ho provato a seguire nuovamente il wiki per la reinstallazione, ma non arrivo a risolvere...
Qualcuno mi aiuta a mettere a posto il mio paludis?
_________________
LP
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Wed Jul 11, 2007 5:06 pm    Post subject: Reply with quote

paludis scrive dati permanenti su /var/tmp?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Thu Jul 12, 2007 8:13 am    Post subject: Reply with quote

Ho risolro da solo...ho temporaneamente commentato le righe che mi davavo errore del file /usr/share/paludis/hooks/install_all_pre/elog.bash, poi ho (riemerso?-->) paludiserso :lol: il pacchetto paludis-hooks e tutto sembra funzionare di nuovo (SEMBRA!!!).

Comunque mi da un pò fastidio che rimuovendo il contenuto di /var/tmp/ ma vada tutto in casino...

PS: Voi non sapete quante volte mi ha salvato il c**o commentare le righe che durante la compilazione di un pacchetto mi davano errore!
_________________
LP
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Thu Jul 12, 2007 6:36 pm    Post subject: Reply with quote

Ma a voi funziona il resume dei download?
Lancio il fetch del mio pacchetto:
Code:
root@jarod {0}
> ~/paludis -if vanilla-sources
Building target list...
Building dependency list...

These packages will be installed:

* sys-kernel/vanilla-sources-2.6.22.1 {:2.6.22.1} [N] -build -symlink

Total: 1 package (1 new)

(1 of 1) Fetching sys-kernel/vanilla-sources-2.6.22.1::gentoo

>>> Running ebuild phase fetch as paludisbuild:paludisbuild...
>>> Starting builtin_fetch
>>> Already have patch-2.6.22.1.bz2
>>> Need to fetch linux-2.6.22.tar.bz2
wget -T 30 -t 1 -O /usr/portage/distfiles/linux-2.6.22.tar.bz2 http://distfiles.gentoo.org/distfiles/linux-2.6.22.tar.bz2
--20:24:48--  http://distfiles.gentoo.org/distfiles/linux-2.6.22.tar.bz2
           => `/usr/portage/distfiles/linux-2.6.22.tar.bz2'
Resolving distfiles.gentoo.org... 64.50.238.52, 64.50.236.52, 216.165.129.135, ...
Connecting to distfiles.gentoo.org|64.50.238.52|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 45,119,878 (43M) [application/x-tar]

 0% [                                                                                                                ] 30,118         3.54K/s  ETA 3:28:00sandbox:  Caught signal 2 in pid 6303

Caught signal 2
Waiting for children...


Exiting with failure

lo termino con ctrl+c e rilancio lo stesso comando, ma ricevo questo errore:
Code:
> ~/paludis -if vanilla-sources
Building target list...
Building dependency list...

These packages will be installed:

* sys-kernel/vanilla-sources-2.6.22.1 {:2.6.22.1} [N] -build -symlink

Total: 1 package (1 new)

(1 of 1) Fetching sys-kernel/vanilla-sources-2.6.22.1::gentoo

paludis@1184265008: [WARNING] In program paludis -if vanilla-sources:
  ... When performing install action from command line:
  ... When executing install task:
  ... When installing 'sys-kernel/vanilla-sources-2.6.22.1':
  ... When checking permissions on '/usr/portage/distfiles' for userpriv:
  ... Directory '/usr/portage/distfiles' owned by group 'root', not 'paludisbuild', so cannot enable userpriv
>>> Running ebuild phase fetch as root:root...
>>> Starting builtin_fetch
>>> Already have patch-2.6.22.1.bz2
>>> Already have linux-2.6.22.tar.bz2
 * Checking MD5 for linux-2.6.22.tar.bz2 ...                             [ !! ]
 * Checking RMD160 for linux-2.6.22.tar.bz2 ...                          [ !! ]
 * Checking SHA256 for linux-2.6.22.tar.bz2 ...                          [ !! ]
 * Checking MD5 for patch-2.6.22.1.bz2 ...                               [ ok ]
 * Checking RMD160 for patch-2.6.22.1.bz2 ...                            [ ok ]
 * Checking SHA256 for patch-2.6.22.1.bz2 ...                            [ ok ]

 * Bad digests encountered for the following components:
 *   * linux-2.6.22.tar.bz2


!!! ERROR in sys-kernel/vanilla-sources-2.6.22.1:
!!! In builtin_fetch at line 116
!!! builtin_fetch failed

!!! Call stack:
!!!    * builtin_fetch (/usr/libexec/paludis/builtin_fetch.bash:116)
!!!    * ebuild_f_fetch (/usr/libexec/paludis/builtin_fetch.bash:130)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Fetch error:
  * In program paludis -if vanilla-sources:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-kernel/vanilla-sources-2.6.22.1':
  * Fetch error: Fetch failed for 'sys-kernel/vanilla-sources-2.6.22.1::gentoo'

leggo... e quindi cambio i permessi ai distfiles:
Code:
> ~/chown -R root:paludisbuild /usr/portage/distfiles/

rilancio il fetch, ed ottengo:
Code:
> ~/paludis -if vanilla-sources
Building target list...
Building dependency list...

These packages will be installed:

* sys-kernel/vanilla-sources-2.6.22.1 {:2.6.22.1} [N] -build -symlink

Total: 1 package (1 new)

(1 of 1) Fetching sys-kernel/vanilla-sources-2.6.22.1::gentoo

>>> Running ebuild phase fetch as paludisbuild:paludisbuild...
>>> Starting builtin_fetch
>>> Already have patch-2.6.22.1.bz2
>>> Already have linux-2.6.22.tar.bz2
 * Checking MD5 for linux-2.6.22.tar.bz2 ...                             [ !! ]
 * Checking RMD160 for linux-2.6.22.tar.bz2 ...                          [ !! ]
 * Checking SHA256 for linux-2.6.22.tar.bz2 ...                          [ !! ]
 * Checking MD5 for patch-2.6.22.1.bz2 ...                               [ ok ]
 * Checking RMD160 for patch-2.6.22.1.bz2 ...                            [ ok ]
 * Checking SHA256 for patch-2.6.22.1.bz2 ...                            [ ok ]

 * Bad digests encountered for the following components:
/usr/share/paludis/hooks/eerror/elog.bash: line 43: //var/tmp/paludis/elog.7103: Permission denied
/usr/libexec/paludis/ebuild.bash@1184265185: [WARNING.EBUILD] Hook '/usr/share/paludis/hooks/eerror/elog.bash' returned failure (from /usr/portage/sys-kernel/vanilla-sources/vanilla-sources-2.6.22.1.ebuild)
 *   * linux-2.6.22.tar.bz2
/usr/share/paludis/hooks/eerror/elog.bash: line 43: //var/tmp/paludis/elog.7103: Permission denied
/usr/libexec/paludis/ebuild.bash@1184265185: [WARNING.EBUILD] Hook '/usr/share/paludis/hooks/eerror/elog.bash' returned failure (from /usr/portage/sys-kernel/vanilla-sources/vanilla-sources-2.6.22.1.ebuild)


!!! ERROR in sys-kernel/vanilla-sources-2.6.22.1:
!!! In builtin_fetch at line 116
!!! builtin_fetch failed

!!! Call stack:
!!!    * builtin_fetch (/usr/libexec/paludis/builtin_fetch.bash:116)
!!!    * ebuild_f_fetch (/usr/libexec/paludis/builtin_fetch.bash:130)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Fetch error:
  * In program paludis -if vanilla-sources:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-kernel/vanilla-sources-2.6.22.1':
  * Fetch error: Fetch failed for 'sys-kernel/vanilla-sources-2.6.22.1::gentoo'

ora che permessi deve avere /var/tmp/paludis? io c'è l'ho root:root, voi?

Poi, un'altro quesito, ho installato dall'overlay paludis-extra il pacchetto paludis-hooks-update-eix, ma dopo aver lanciato update-eix, eix non trova più i pacchetti degli overlay di paludis. Però, subito dopo un "paludis -s" sembrava funzionare bene...chi mi aiuta?
_________________
LP
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Thu Jul 12, 2007 9:53 pm    Post subject: Reply with quote

lucapost wrote:

Poi, un'altro quesito, ho installato dall'overlay paludis-extra il pacchetto paludis-hooks-update-eix, ma dopo aver lanciato update-eix, eix non trova più i pacchetti degli overlay di paludis. Però, subito dopo un "paludis -s" sembrava funzionare bene...chi mi aiuta?


Devi abilitarlo con eselect, se non lo hai già fatto.
Code:
eselect paludis-hook enable update-eix


Ps: un modo pulito per installare gli hooks, senza inserire ogni singola voce in /etc/paludis/use.conf è questo:
Code:

apocalipse ~ # cat /etc/paludis/use.conf | grep PALUDIS_HOOKS
*/* PALUDIS_HOOKS: eselect update-eix ask


Una volta aggiunta questa riga basta lanciare:
Code:
 paludis --dl-reinstall if-use-changed -i world

_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Fri Jul 13, 2007 11:50 am    Post subject: Reply with quote

è gia abilitato:
Quote:
> ~/eselect paludis-hook list
Managable hooks:
demos-elog enabled
demos-elog-eerror enabled
demos-elog-einfo enabled
demos-elog-ewarn enabled
demos-new_packages enabled
portage-utils enabled
update-eix enabled

mi sembra che però funga solamente dopo un "paludis -s", appena faccio "update-eix" non trova più gli ebuild in overlay
_________________
LP
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Fri Jul 13, 2007 12:17 pm    Post subject: Reply with quote

lucapost wrote:

mi sembra che però funga solamente dopo un "paludis -s", appena faccio "update-eix" non trova più gli ebuild in overlay


Infatti non devi piu' fare update-eix... Basta un paludis --sync per aggiornare tutto, e evere anche un bellissimo output degli aggiornamenti di eix :-)
_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Fri Jul 13, 2007 12:25 pm    Post subject: Reply with quote

topper_harley wrote:

Infatti non devi piu' fare update-eix... Basta un paludis --sync per aggiornare tutto, e evere anche un bellissimo output degli aggiornamenti di eix :-)

ma quando aggiungo un ebuild al mio overlay locale, magari un ebuild che mi sono scaricato da bugzilla, devo per forza fare un "paludis -s" per farlo vedere da eix?
_________________
LP
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Fri Jul 13, 2007 12:39 pm    Post subject: Reply with quote

lucapost wrote:

ma quando aggiungo un ebuild al mio overlay locale, magari un ebuild che mi sono scaricato da bugzilla, devo per forza fare un "paludis -s" per farlo vedere da eix?


Si, ma non devi necessariamente syncare tutto.

Nel mio caso per esempio l'overlay locale dove metto gli ebuil di bugzilla si chiama "local" (si, lo so... non sono molto fantasioso), quindi mi basta un bel:
Code:
 paludis --sync local

_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Fri Jul 13, 2007 2:08 pm    Post subject: Reply with quote

ok, eix funge correttamente, devo quindi dimenticarmi update-eix, grazie dell'aiuto.
ho anche imparato qualcosa sulla gestione degli overlay (playman...)

E per gli altri quesiti:
  • il resume dei download, a te funziona correttamente?
  • come vedo la quantità di sorgenti da dover scaricare (emerge -pv ...)?

_________________
LP
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Mon Jul 23, 2007 8:23 pm    Post subject: Reply with quote

  • il resume dei download, a te funziona correttamente?

per questo ho trovato la soluzione, bisogna passare a paludis l'opzione --safe-resume, anche se funziona solo dopo aver scaricato più di qualche centinaio di Kb di sorgente.

  • come vedo la quantità di sorgenti da dover scaricare (emerge -pv ...)?

Qui non so proprio ancora come far a meno di emerge...
_________________
LP
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Tue Aug 21, 2007 11:34 am    Post subject: Reply with quote

In alcuni thread ho letto che il supporto a paludis per visualizzare alcune informazioni sulla dimensione dei sorgenti verrà implementeto quando verrà introdotto manifest2...
_________________
LP
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Wed Dec 26, 2007 10:17 pm    Post subject: Reply with quote

Paludis 0.26.0_alpha4
Ho deciso di rispolverare questo vecchio thread e di aggiungere le ultime novità introdotte in Paludis.
Per avere informazioni più dettagliate su questo software è sufficiente visitare i link riportati al termine del post o leggere i post precedenti (soprattutto il primo).

Se guardate nella pagina delle "Release Notes" noterete che ci sono stati cambiamenti notevoli dalla versione 0.20.2, una delle ultime menzionate in questo thread.
Nel mucchio:

  • Supporto dei file di configurazione di Portage, nel caso uno volesse "facilitarsi" la migrazione. La cosa migliore ovviamente è avere dei file di configurazione originali per Paludis.
  • Maggiore rigidità nella valutazione della qualità degli ebuild.
  • Maggiore conformità al "Package Manager Specification" (per maggiori informazioni vedi qua e qua)
  • Python bindings, per scrivere applicazioni in python che possano interfacciarsi a Paludis
  • Miglioramenti vari al sistema degli hook con supporto a hook di diverso tipo.
  • Miglioramento della documentazione
  • introduzione di accerso, un client per gestire un mirror (per developers)
  • introduzione di instruo, per generare metadata (per developers)
  • introduzione di reconcilio, un client che rimpiazza revdep-rebuild
  • introduzione di importare, un client che permette di gestire pacchetti non pacchettizzati (non ho ancora ben capito a che potrebbe servire a dire il vero... :P )
  • Miglioramenti interni e degli output.
  • Aggiunta di un bel tot di opzioni, come ad esempio --dl-suggested in quanto Paludis adesso è in grado di "suggerire" dipendenze ma anche nomi di pacchetti. Ad esempio, se un certo pacchetto non viene trovato in una query:
    Code:

    $ paludis -q k3c

    Query error:
      * In program paludis -q k3c:
      * When performing query action from command line:
      * When handling query 'k3c':
      * When disambiguating package name 'k3c':
      * Could not find 'k3c'. Looking for suggestions:
    Suggestions:
      * app-cdr/k3b
      * app-i18n/kcc
      * media-gfx/k3d

    Edit 28/12/2007
    Aggiungo un altro esempio interessante. Supponiamo io voglia disinstallare python:
    Code:

    # paludis -u dev-lang/python
    Building unmerge list... done

    These packages will be uninstalled:

    [... ne ho tagliati un tot]
    * gnome-extra/libgsf-1.14.7::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * media-gfx/fontforge-20070831::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * media-gfx/graphviz-2.12::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * media-libs/lcms-1.15::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * net-fs/samba-3.0.28::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * sys-apps/paludis-0.26.0_alpha4::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * sys-apps/portage-2.1.3.19::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * sys-libs/cracklib-2.8.10::installed requires <dev-lang/python-2.4.4-r6:2.4::installed>
    * dev-lang/python-2.4.4-r6:2.4::installed


    Total: 1 package and 28 errors
    Use either --with-dependencies or --permit-unsafe-uninstalls

    Cannot continue with uninstall due to the errors indicated above

    Come vedete Paludis fa attenzione a mantenere il sistema consistente. Difficilmente vi permetterà di disinstallare per errore pacchetti di base come "python" o "gcc".
    Portage qui si sarebbe letteralmente "suicidato" senza problemi e senza battere ciglio (a meno che qualcosa non sia cambiato ultimamente, visto che non lo uso da una vita) ... ;)


Come vedete le novità sono parecchie. Paludis sta diventando un prodotto sempre più maturo e completo.
Paludis è inoltre affidabile, lo posso testimoniare io che in un anno di utilizzo non stop non ho incontrato un problema, così come i molti utenti che lo usano da tempo senza avere noie degne di nota. Se leggete il thread ufficiale in inglese potrete farvi un'idea voi stessi.

Le mancanze che personalmente riscontro al momento sono:

  • Non è possibile generare pacchetti binari
  • Per un dato pacchetto solo lo slot più recente (invece che tutti quelli installati) viene aggiornato (vedi questo bug report).

Per quanto riguarda gli sviluppatori, anche qui Paludis sta migliorando velocemente.
È diventato ancora più rigido e severo nel verificare che un ebuild sia conforme a degli standard minimi di qualità, inoltre sono stati aggiunti e/o migliorati diversi strumenti che possono semplificare la vita allo sviluppatore di ebuild.

Altra cosa secondo me interessante sono i bindings, cioè le interfacce che permettono di usare Paludis con linguaggi diversi dal C++.
Al momento sono disponibili i bindings per:


Personalmente spero si continui così, magari Paludis darà una mano a risollevare gli standard qualitativi di Gentoo... ;)
Se veniste colti dalla voglia di provarlo, sappiate che il passaggio a Paludis è praticamente indolore (vedi guida nel wiki) così come il percorso inverso nel caso cambiaste idea e voleste tornare a Portage.
Se volete contribuire...


:arrow: HOME PAGE
:arrow: Paludis Extras
:arrow: GENTOO-WIKI PAGE
:arrow: THREAD UFFICIALE IN INGLESE (per la versione corrente)
:arrow: PLANET PALUDIS
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Wed Jan 02, 2008 11:16 pm    Post subject: Reply with quote

jordan83 wrote:
Come vedete Paludis fa attenzione a mantenere il sistema consistente. Difficilmente vi permetterà di disinstallare per errore pacchetti di base come "python" o "gcc".
Portage qui si sarebbe letteralmente "suicidato" senza problemi e senza battere ciglio

Code:
# emerge -C python


!!! 'dev-lang/python' is part of your system profile.
!!! Unmerging it may be damaging to your system.

>>> Waiting 10 seconds before starting...
>>> (Control-C to abort)...
Press Ctrl-C to Stop in: 10 9 8 7 6 5 4  [...]

_________________
www.minimalblue.com
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Thu Jan 03, 2008 8:35 am    Post subject: Reply with quote

lavish wrote:
[...]

Mea culpa... avevo dimenticato il conto alla rovescia.
Comunque sia, Portage secondo me dovrebbe bloccarsi in questi casi, non dare 10 secondi di tempo per cambiare idea.
Ci dovrebbe essere uno switch tipo --force per indicare la precisa volontà dell'utente di disinstallare un pacchetto di sistema.

Così è un suicidio con il conto alla rovescia... ^_^

Un esempio (certo sempliciotto) potrebbe essere quello dove un "utonto" crede di non aver bisogno di "python" (non sa che Portage lo richiede per funzionare) e lancia un comando del tipo
Code:
emerge -uDNav world && emerge -C python

e poi va a dormire. Al risveglio ha ottime possibilità di trovarsi Gentoo inutilizzabile, a meno che Portage non si sia inchiodato durante l'aggiornamento di world.
Ci potrebbero essere molti altri casi in cui una situazione del genere può verificarsi. Non per niente, se non ricordo male, più o meno tutti i package managers si bloccano in questo tipo di situazione.
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Mon Jan 07, 2008 4:07 pm    Post subject: Reply with quote

lucapost wrote:


  • come vedo la quantità di sorgenti da dover scaricare (emerge -pv ...)?


Implementato in Paludis 0.26.0_alpha5, uscito ieri. Dalle Release Notes:
Quote:

* paludis --install --pretend will show how many bytes still need to be downloaded for a given package to be installed. Two new metadata keys, size_of_download_required and size_of_all_distfiles, have been added.

_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Sat Jan 19, 2008 11:26 am    Post subject: Reply with quote

jordan83 wrote:
lucapost wrote:


  • come vedo la quantità di sorgenti da dover scaricare (emerge -pv ...)?


Implementato in Paludis 0.26.0_alpha5, uscito ieri. Dalle Release Notes:
Quote:

* paludis --install --pretend will show how many bytes still need to be downloaded for a given package to be installed. Two new metadata keys, size_of_download_required and size_of_all_distfiles, have been added.


bene, dopo qualche mese, è il momento di dare una nuova possibilità a paludis! :D
_________________
LP
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Sat Jan 19, 2008 4:25 pm    Post subject: Reply with quote

Vorrei segnalare un'interessante script che è possibile trovare nel repository SVN di Paludis ma che non è ancora stato incluso in alcuna release.
Si tratta di config-decruft, uno script ruby che sfruttando i "ruby bindings" offerti da Paludis è in grado di permettere la pulizia dei file di configurazione di Paludis.

Io lo uso ogni tanto e devo dire che è davvero utilissimo :)

Un esempio dell'output (ho separato le diverse parti per aumentarne la leggibilità):
Code:

# ruby config-decruft --log-level warning
 * Checking /etc/paludis/keywords.conf (pass 1/2)
 * Checking /etc/paludis/keywords.conf (pass 2/2)
app-office/taskjuggler: not installed
net-voip/wengophone-bin: not installed
games-fps/worldofpadman: not installed
app-cdr/k9copy: not installed
net-im/skype: net-im/skype-2.0.0.27:0::installed installed, net-im/skype-1.4.0.118:0::gentoo available with keywords x86
kde-misc/kdmtheme: kde-misc/kdmtheme-1.2.2:0::installed installed, kde-misc/kdmtheme-1.2.2:0::gentoo available with keywords x86
x11-themes/domino: x11-themes/domino-0.4:0::installed installed, x11-themes/domino-0.4:0::gentoo available with keywords x86
app-admin/eselect: app-admin/eselect-1.0.11:0::installed installed, app-admin/eselect-1.0.10:0::gentoo available with keywords x86
dev-libs/libnl: dev-libs/libnl-1.0_pre6-r1:0::installed installed, dev-libs/libnl-1.0_pre6:0::gentoo available with keywords x86
dev-cpp/libwrapiter: not installed
=app-doc/doxygen-1.5.3: not installed
sys-fs/ntfs3g: sys-fs/ntfs3g-1.1120:0::installed installed, sys-fs/ntfs3g-1.810:0::gentoo available with keywords x86
<=media-sound/alsa-driver-1.0.15: media-sound/alsa-driver-1.0.15:0::installed installed, media-sound/alsa-driver-1.0.14-r1:0::gentoo available with keywords x86
<=media-sound/alsa-headers-1.0.15: media-sound/alsa-headers-1.0.15:0::installed installed, media-sound/alsa-headers-1.0.14:0::gentoo available with keywords x86
media-video/linux-uvc: specified more than once
games-fps/nexuiz: games-fps/nexuiz-2.3:0::installed installed, games-fps/nexuiz-2.3:0::gentoo available with keywords x86
net-im/amsn: net-im/amsn-0.97:0::installed installed, net-im/amsn-0.96-r1:0::gentoo available with keywords x86
app-emulation/vmware-player: app-emulation/vmware-player-2.0.2.59824:0::installed installed, app-emulation/vmware-player-1.0.5.56455:0::gentoo available with keywords x86
app-emulation/vmware-modules: app-emulation/vmware-modules-1.0.0.17:0::installed installed, app-emulation/vmware-modules-1.0.0.15-r1:0::gentoo available with keywords x86
app-emulation/vmware-workstation: not installed
x11-libs/libview: not installed
dev-cpp/libsexymm: not installed
kde-base/kopete: kde-base/kopete-3.5.8:3.5::installed installed, kde-base/kopete-3.5.7:3.5::gentoo available with keywords x86
app-text/acroread: app-text/acroread-8.1.1:0::installed installed, app-text/acroread-7.0.9-r1:0::gentoo available with keywords x86


 * Checking /etc/paludis/use.conf (pass 1/2)
 * Checking /etc/paludis/use.conf (pass 2/2)
*/*: aiglx not used by any matching installed packages
*/*: asf not used by any matching installed packages
*/*: dbx not used by any matching installed packages
*/*: divx not used by any matching installed packages
*/*: ethereal not used by any matching installed packages
*/*: fat not used by any matching installed packages
*/*: fbsplash not used by any matching installed packages
*/*: gatos not used by any matching installed packages
*/*: glut not used by any matching installed packages
*/*: gmedia not used by any matching installed packages
*/*: gzip not used by any matching installed packages
*/*: icq not used by any matching installed packages
*/*: jabber not used by any matching installed packages
*/*: logrotate not used by any matching installed packages
*/*: matroska not used by any matching installed packages
*/*: mbox not used by any matching installed packages
*/*: mime not used by any matching installed packages
*/*: msn not used by any matching installed packages
*/*: nowin not used by any matching installed packages
*/*: realmedia not used by any matching installed packages
*/*: userlocales not used by any matching installed packages
*/*: vhosts not used by any matching installed packages
*/*: wmp not used by any matching installed packages
*/*: xosd not used by any matching installed packages
*/*: eds not used by any matching installed packages
*/*: emboss not used by any matching installed packages
*/*: isdnlog not used by any matching installed packages
*/*: pppd not used by any matching installed packages
*/*: APACHE2_MODULES: so not used by any matching installed packages
x11-libs/gtk+: x11-libs/gtk+-1.2.10-r12:1::installed installed from gentoo, does not use doc
dev-util/eclipse-sdk: not installed
x11-libs/qt: x11-libs/qt-3.3.8-r4:3::installed installed from gentoo, does not use accessibility
games-fps/worldofpadman: not installed
media-sound/alsa-driver: media-sound/alsa-driver-1.0.15:0::installed installed from gentoo, does not use hda-intel
app-text/acroread: not installed
dev-java/swt: not installed


 * Checking /etc/paludis/package_mask.conf
<=x11-libs/qt-3.3.8-r3: installed version x11-libs/qt-3.3.8-r4:3::installed is higher than highest masked version x11-libs/qt-3.3.4-r8:3::gentoo
<x11-libs/qt-4.3.2-r1:4: installed version x11-libs/qt-4.3.2-r1:4::installed is higher than highest masked version x11-libs/qt-4.3.2:4::gentoo


 * Checking /etc/paludis/package_unmask.conf
net-wireless/iwl4965-ucode: net-wireless/iwl4965-ucode-4.44.1.20:0::installed installed, net-wireless/iwl4965-ucode-4.44.1.20:0::gentoo available and not masked
app-text/acroread: app-text/acroread-8.1.1:0::installed installed, app-text/acroread-7.0.9-r1:0::gentoo available and not masked
net-im/skype: net-im/skype-2.0.0.27:0::installed installed, net-im/skype-1.4.0.118:0::gentoo available and not masked

Ovviamente quando lanciate lo script da console l'output risulta convenientemente colorato ed è ben più leggibile... ;)
Come vedete ci sono un bel po' di entry che vanno rimosse nei vary file di configurazione, pacchetti che io avevo smascherato e che ora sono stabili e use flag che non esistono più o che non sono utilizzate nel mio sistema e che posso rimuovere.
Certo poi sta all'utente capire quali parti dell'output considerare e quali ignorare.
Un esempio potrebbe essere amsn:
Code:

net-im/amsn: net-im/amsn-0.97:0::installed installed, net-im/amsn-0.96-r1:0::gentoo available with keywords x86

Ovviamente io voglio tenere la versione 0.97 sebbene lo script mi segnali che esiste una versione non mascherata da keyword ~x86... ;)
Lo script non è certo definitivo, tuttavia funziona egregiamente già da adesso.
Lo potete trovare qua.
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Mon Jan 21, 2008 5:15 pm    Post subject: Reply with quote

in settimana provero' sicuramente paludis, mi sorge pero' spontanea una domanda: al di la' dei SET di pacchetti (che per ora non usero'), quali sono le altre condizioni per tornare in 2 click a portage? Ok che ho i miei stage4 settimanali, ma potendolo preferirei evitare ;)

Trovo paludis davvero geniale, ormai si merita almeno di essere provato anche se le comodita' e l'efficienza in piu' devono valere il numero di pacchetti che non compila causa ebuild balordi. E questo devo valutarlo di persona perche' un package manager senza package e' un po' inutile :p
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Mon Jan 21, 2008 9:23 pm    Post subject: Reply with quote

flocchini wrote:
in settimana provero' sicuramente paludis, mi sorge pero' spontanea una domanda: al di la' dei SET di pacchetti (che per ora non usero'), quali sono le altre condizioni per tornare in 2 click a portage? Ok che ho i miei stage4 settimanali, ma potendolo preferirei evitare ;)


Dunque:
- Paludis crea la sua directory per i files di configurazione in /etc/paludis
- Praticamente tutte le directory usate da Paludis sono separate da quelle di Portage (a meno che tu non decida diversamente ovviamente)

Gli unici punti in cui Portage e Paludis "collidono" sono:
- il tree di Gentoo, a meno che tu non decida di avere un tree "separato" dedicato a Paludis, che magari puoi collocare in /var/paludis/repositories/gentoo. Nel mio caso ad esempio:
Code:

$ cat /etc/paludis/repositories/gentoo.conf
location = ${ROOT}/var/paludis/repositories/gentoo
#sync = rsync://rsync.europe.gentoo.org/gentoo-portage
sync = rsync://rsync.gentoo.org/gentoo-portage
format = ebuild
names_cache = ${location}/.cache/names
write_cache = /var/cache/paludis/metadata

anche se a dire il vero io non ho due tree diversi...
Code:

$ ls -l /usr/portage
lrwxrwxrwx 1 root root 32 2007-09-04 11:10 /usr/portage -> /var/paludis/repositories/gentoo

Ho spostato il tree in quella directory perché in effetti gli sviluppatori di Paludis facevano notare che il tree è "variabile" nel tempo e il suo posto è decisamente in /var e non in /usr. Non ho potuto che dargli ragione.
Io piazzo tutti i repository (in Paludis gli overlay non sono altro che repository come lo è il tree ufficiale) in /var/paludis/repositories/.
Si tratta di scelte "filosofiche" comunque, nulla di fondamentale ;) Piazza pure la tua "roba" dove credi...

- la directory /var/db/pkg dove vengono piazzati i file relativi ai pacchetti installati + il file world. Se usi lo script portage2paludis per convertire la tua configurazione a quella di Paludis, il file world viene spostato in questa directory e viene creato un link ad esso in /var/lib/portage/world:
Code:

ls -l /var/lib/portage/world
lrwxrwxrwx 1 root portage 17 2007-09-04 11:42 /var/lib/portage/world -> /var/db/pkg/world


Quindi se decidessi di tornare indietro, a livello di "files" praticamente al max dovrai rispostare il file world e cancellare il tree che hai usato per Paludis... ;)

Se decidessi di usare i set basterà che ti ricordi di cancellarli dal file world una volta tornato a Portage (ma fidati che lui te lo ricorderà, molto probabilmente...).

Non c'è altro, almeno da quel che mi viene in mente (tieni conto che io non sono mai tornato a Portage). Dovessero proprio spuntare problemi astrusi con un pacchetto basterà ricompilarlo con Portage.
Comunque sia non ho mai letto lamentele di gente che è tornata a Portage (anche perché moltissimi non tornano a Portage :) ) nei forum.

flocchini wrote:

Trovo paludis davvero geniale, ormai si merita almeno di essere provato anche se le comodita' e l'efficienza in piu' devono valere il numero di pacchetti che non compila causa ebuild balordi. E questo devo valutarlo di persona perche' un package manager senza package e' un po' inutile :p

Non credere :)

Al momento è un po' di manica larga (si limita a stampare "warning" e "qa errors" a manica) perché sennò non lo potresti utilizzare...
Per lo stesso motivo ricordati di disabilitare il lancio delle suite di test dei pacchetti, sennò un tot di essi non compilerà:
/etc/paludis/bashrc:

export SKIP_FUNCTIONS="test"

Puoi anche disabilitare i test "selettivamente".

I problemi che riscontrerai nell'utilizzo di Paludis saranno molto probabilmente soltanto di "ambientamento".
Se hai domande/problemi sarò felice di aiutarti :)
Ormai Paludis lo conosco benone ;)
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 4 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum