Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TOOL] Gestione pulita degli overlay con EMERGE-OVERLAY
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
RollsAppleTree
Guru
Guru


Joined: 18 Feb 2005
Posts: 340
Location: Sicilia - Catania

PostPosted: Tue Apr 10, 2007 2:12 pm    Post subject: Reply with quote

l'ebuild dell'overlay gechi è corrotto.. mi pare che dia problemi nel digest ...
_________________
RollsAppleTree BLOG !!!
Documentazione in Italiano su Gentoo
F.A.Q. in Italiano su Gentoo
Back to top
View user's profile Send private message
Luca89
Advocate
Advocate


Joined: 27 Apr 2005
Posts: 2107
Location: Agrigento (Italy)

PostPosted: Tue Apr 10, 2007 5:57 pm    Post subject: Reply with quote

Corretto, avevo modificato l'ebuild senza rifare il digest, scusatemi.
_________________
Running Fast!
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Tue Jul 10, 2007 6:43 pm    Post subject: Reply with quote

sarà che oggi non è una bella giornata per me, ma non capisco una cosa, dopo aver scaricato ed installato il tool in questione, bisogna fare altro prima di lanciare
l'emerge-overlay?

quando lo lancio o sempre i seguenti errori:
Code:

sudo emerge-overlay -av knetworkmanager

[--] Creating local overlay with ebuilds...
[!!] Error during local overlay creation!


nb:premetto che ho già installato layman, in precedenza per installare compiz-fusion, ma non credo dipenda da ciò, visto che tale tool richiede layman.


ciauz
Back to top
View user's profile Send private message
mouser
Veteran
Veteran


Joined: 10 Aug 2004
Posts: 1418
Location: Milano

PostPosted: Mon Jul 23, 2007 1:36 pm    Post subject: Reply with quote

crisandbea wrote:
sarà che oggi non è una bella giornata per me, ma non capisco una cosa, dopo aver scaricato ed installato il tool in questione, bisogna fare altro prima di lanciare
l'emerge-overlay?

quando lo lancio o sempre i seguenti errori:
Code:

sudo emerge-overlay -av knetworkmanager

[--] Creating local overlay with ebuilds...
[!!] Error during local overlay creation!


nb:premetto che ho già installato layman, in precedenza per installare compiz-fusion, ma non credo dipenda da ciò, visto che tale tool richiede layman.


ciauz


Hmmm, non ho mai provato ad utilizzare il mio tool tramite sudo.... dovrei fare un pò di test per saperti dire meglio.

Comunque, riguardo al tuo problema, quell'errore viene generato in caso si verifichino due differenti situazioni:
1) Il tool non riesce a creare la directory /usr/local/portage
2) Il tool non rileva e non riesce a fare una entry nel make.conf.

Ti direi di procedere in questo modo:
Code:
# mkdir /usr/local/portage

Se non esiste già.

Successivamente prova ad inserire nel make.conf la entry:
Code:
PORTDIR_OVERLAY="$PORTDIR_OVERLAY /usr/local/portage"

Se per caso hai già dichiarato quella variabile, prova ad inserire il path assoluto di quella directory all'interno della variabile che hai già dichiarato.

Infine prova a rilanciare il comando :D

Ciriciao
mouser :wink:
_________________
Della serie: "Informatica for dummies":

Io: "Premi il tasto Invio" - Risp: "Ma il tasto Invio è quello con scritto Enter sopra?"
Io: "Scrivi T maiuscolo" - Risp: "Questa tastiera non ha le lettere maiuscole..."
Back to top
View user's profile Send private message
mouser
Veteran
Veteran


Joined: 10 Aug 2004
Posts: 1418
Location: Milano

PostPosted: Tue Jul 24, 2007 3:34 pm    Post subject: Reply with quote

Ok, dopo un periodo sabbatico, ho implementato anche la gestione delle custom eclass. Questa sera inizio a fare un pò di prove giusto per testare il codice che ho scritto.

Se tutto fila liscio rilascio una nuova versione.

Ciriciao
mouser :wink:
_________________
Della serie: "Informatica for dummies":

Io: "Premi il tasto Invio" - Risp: "Ma il tasto Invio è quello con scritto Enter sopra?"
Io: "Scrivi T maiuscolo" - Risp: "Questa tastiera non ha le lettere maiuscole..."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum