Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
some problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
schmidp
n00b
n00b


Joined: 26 Apr 2002
Posts: 5

PostPosted: Fri Apr 26, 2002 10:51 am    Post subject: some problems Reply with quote

hi,

my first problem concerns sshd: i can't login into my gentoo machine,
even if i try "ssh localhost", sshd does not accept my passwort, i'm a normal user, so it's not the permit root login option.

the other problem is caused by xterm. it't looks if it doesn't use any profiles, i only get this prompt: sh-2.05a$.

any ideas?

greets philipp
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Fri Apr 26, 2002 12:32 pm    Post subject: Re: some problems Reply with quote

schmidp wrote:
hi,

my first problem concerns sshd: i can't login into my gentoo machine,
even if i try "ssh localhost", sshd does not accept my passwort, i'm a normal user, so it's not the permit root login option.


What kind of errors are you getting in your /var/log/sshd/current log? Have you looked at your /etc/ssh/sshd_config file and made sure all the config options made sense?

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
dnaquin
n00b
n00b


Joined: 19 Apr 2002
Posts: 21
Location: Bayou Gauche, Louisiana

PostPosted: Fri Apr 26, 2002 1:10 pm    Post subject: Reply with quote

Try starting xterm with the -ls option. Like ...
Code:
$ xterm -ls

_________________
Devin Naquin
Back to top
View user's profile Send private message
schmidp
n00b
n00b


Joined: 26 Apr 2002
Posts: 5

PostPosted: Fri Apr 26, 2002 1:28 pm    Post subject: Re: some problems Reply with quote

klieber wrote:
What kind of errors are you getting in your /var/log/sshd/current log? Have you looked at your /etc/ssh/sshd_config file and made sure all the config options made sense?


when i try a "ssh localhost" and enter my password a few times, sshd logs this:

Apr 26 17:08:49 [sshd] Server listening on 0.0.0.0 port 22.
Apr 26 17:10:17 [sshd] Failed keyboard-interactive for schmidp from 127.0.0.1 port 32768 ssh2
Apr 26 17:10:27 [sshd] Disconnecting: protocol error: rcvd type 61
Apr 26 17:10:27 [sshd] Cannot release PAM authentication[4]: System error

in /etc/ssh/sshd_config i enabled the following options:

Port 22
Protocol 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
KeyRegenerationInterval 3600
ServerKeyBits 768
SyslogFacility AUTH
LogLevel INFO
LoginGraceTime 600
PermitRootLogin no
StrictModes yes
RSAAuthentication yes
PubkeyAuthentication yes
RhostsAuthentication no
IgnoreRhosts yes
RhostsRSAAuthentication no
HostbasedAuthentication no
PasswordAuthentication yes
PAMAuthenticationViaKbdInt yes
X11Forwarding yes
X11DisplayOffset 10
PrintMotd yes
KeepAlive yes
Subsystem sftp /usr/lib/misc/sftp-server

thx philipp
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Fri Apr 26, 2002 2:19 pm    Post subject: Reply with quote

Hmm..nothing leaps out at me as being problematic -- your config file looks fine.

Try the following:

Code:
ssh -v -v localhost


And see if you get any interesting error messages. (you'll get a lot of output -- please don't simply cat it all here -- just post anything that looks pertinent.)

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
aj
n00b
n00b


Joined: 25 Apr 2002
Posts: 7

PostPosted: Fri Apr 26, 2002 2:27 pm    Post subject: Reply with quote

Make sure your user has a shell entry in the /etc/passwd file.

No shell. No login.

This is in the FAQ.

-aj
Back to top
View user's profile Send private message
schmidp
n00b
n00b


Joined: 26 Apr 2002
Posts: 5

PostPosted: Fri Apr 26, 2002 2:51 pm    Post subject: Reply with quote

aj wrote:
Make sure your user has a shell entry in the /etc/passwd file.

No shell. No login.

This is in the FAQ.

-aj


yes, that's the problem.
sorry for the FAQ thing!

greets philipp
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum