Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pbbuttonsd high cpu load
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1195
Location: PB, Germany

PostPosted: Sun May 20, 2007 12:01 am    Post subject: pbbuttonsd high cpu load Reply with quote

JoseJX, once we've been talking about pbbuttonsd cpu load on #gentoo-ppc. The issue is still there (app-laptop/pbbuttonsd-0.8.0).
Sometimes after 2 days uptime pbbuttonsd process takes about 20% CPU load on the G3-600.

Now having this issue again, I killed gtkpbbuttons but didn't solve it.
I had to restart the pbbuttonsd daemon by initscript.

pbbuttonsd.cnf:
Code:
# cat /etc/pbbuttonsd.cnf |grep -v "#"

[SYSTEM]
CmdTimeout=8
autorescan=true

[MODULE DISPLAY]
LCD_Brightness=50
LCD_FadingSpeed=4200
LCD_AutoadjMode=off
LCD_AutoadjParm_onBattery=0,1,94,54
LCD_AutoadjParm_onAC=0,1,94,100
KBD_FadingSpeed=0
KBD_AutoadjMode=off
KBD_AutoadjParm_onBattery=10,100,28,0
KBD_AutoadjParm_onAC=10,100,28,0
Device_FB=/dev/fb0
UseFBBlank=false
DimFullyDark=false
CRT_MirrorKey=65 + ctrl

[MODULE CDROM]
Device=/dev/cdrom
EjectCDKey=161
EjectCDKeyDelay=0

[MODULE MIXER OSS]
Device=/dev/mixer
Channels=volume, speaker

[MODULE MIXER ALSA]
Card=default
Channels=Master, PC Speaker

[MODULE PMAC]
TPModeUpKey=225 + alt
TPModeDownKey=224 + alt
TPMode=tap
KBDMode=fkeysfirst
Batlog=none
NoTapTyping=yes

[MODULE POWERSAVE]
onAC_Policy=performance
onAC_TimerAction=suspend-to-ram
onAC_CoverAction=none
onAC_KeyAction=suspend-to-ram
onAC_SuspendTime=0
onAC_DimTime=5500
onBattery_Policy=powersave
onBattery_TimerAction=suspend-to-ram
onBattery_CoverAction=none
onBattery_KeyAction=suspend-to-ram
onBattery_SuspendTime=6000
onBattery_DimTime=1200
SleepKey=116
SleepKeyDelay=0
BWL_First=10
BWL_Second=5
BWL_Last=2
Script_PMCS=/etc/power/pmcs-pbbuttonsd %s %s %s
EmergencyAction=command
HeartbeatBeep=false
CPULoad_sleeplock=true
CPULoad_min=20
CPULoad_period=20
NETLoad_sleeplock=true
NETLoad_min=4096
NetLoad_period=60
NETLoad_device=eth1
IBAM_DataDir=/var/lib/ibam

_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G | amd64:Acer Z5610 (Core2QuadQ8200),i5-3470 | amd64-prefix:OpenSuse | Lila-Theme


Last edited by Massimo B. on Mon Aug 13, 2012 1:27 pm; edited 2 times in total
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun May 20, 2007 10:31 pm    Post subject: Reply with quote

Okay, well let's try a few things seperately:

1. Wireless?
You've set: NETLoad_device=eth1, does this device exist (wireless?)

2. Autorescan
Have you tried disabling this option? Are you hotplugging input devices?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1195
Location: PB, Germany

PostPosted: Mon May 21, 2007 4:25 am    Post subject: Reply with quote

JoseJX wrote:
1. Wireless?
You've set: NETLoad_device=eth1, does this device exist (wireless?)
Yes, it's Airport.
Quote:
2. Autorescan
Have you tried disabling this option? Are you hotplugging input devices?
Generally I don't change input devices. I disable that and keep an eye on it if it happens again.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G | amd64:Acer Z5610 (Core2QuadQ8200),i5-3470 | amd64-prefix:OpenSuse | Lila-Theme
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1195
Location: PB, Germany

PostPosted: Wed Oct 10, 2007 5:45 pm    Post subject: app-laptop/pbbuttonsd-0.8.1-r2 Reply with quote

I have to admit this annoying bug still exists with app-laptop/pbbuttonsd-0.8.1-r2, and anytime the cpu load is a bit too high the pbbuttonsd process catches my eye with about 15% load. I also have to confess to using this iBook 24/7 and it happens after day(s).

currently /etc/pbbuttonsd.cnf has...:
autorescan=false

And no gtkpbbuttons or similar is running.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G | amd64:Acer Z5610 (Core2QuadQ8200),i5-3470 | amd64-prefix:OpenSuse | Lila-Theme
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Thu Oct 11, 2007 6:39 pm    Post subject: Reply with quote

well the pmud is obsoleted ... and i have to confess it doesn't resume correctly the machine out of a sleep: 'cause sometime it fails in the resume, and i have to reboot the machine

as pmud is obsoleted i switched to the pbbuttonsd that correctly does sleep and resume
from my point of view, pbbuttonsd is the good replace of pmud

so there is no other choice: the pbbuttonsd is the must, no other choices, no one
and on my powerbook pismo, where i have only static devices, after 96 hours of continuously working & sleep i can't really appreciate this issue we are talking about
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1195
Location: PB, Germany

PostPosted: Mon Aug 13, 2012 1:21 pm    Post subject: pbbuttonsd-0.8.1-r3 high cpu load Reply with quote

Hi JoseJX, today there is app-laptop/pbbuttonsd-0.8.1-r3 and I disposed my old iBook. But I still have the G4 PowerBook in use. Especially when running with powersave governor I still noticed the high CPU usage of pbbuttonsd. For example currently emerging with MAKEOPTS="-j2" my top shows this:
Code:
1  PID USER     GROUP     PR  NI %CPU %MEM  RES SWAP    TIME+  S COMMAND
   382 portage  portage   39  19 77.8  3.2  64m  16m   0:05.93 R cc1plus                                   
  7073 root     root      20   0 16.7  0.1 1232 8880  26:23.30 S pbbuttonsd

This also happened after minutes after restarting the daemon. I disabled all NETLoad* and CPULoad*. autorescan was set to no. All *Autoadj* are set to off. The PowerBook is running without any external USB device, only Ethernet. The Lid is closed and LCDBRIGHTNESS is set to 0. There is no gtkpbbuttons connected since X stays at Slim login manager (I'm using the book externally without display via Ethernet only).
Code:
$ grep -E "^[^#]" /etc/pbbuttonsd.cnf
[SYSTEM]
autorescan=no
[MODULE DISPLAY]
LCD_Brightness=50
LCD_FadingSpeed=4200
LCD_AutoadjMode=off
LCD_AutoadjParm_onBattery=0,1,100,60
LCD_AutoadjParm_onAC=0,1,100,80
KBD_Brightness=0
KBD_FadingSpeed=4200
KBD_AutoadjMode=off
Device_FB=/dev/fb0
UseFBBlank=false
DimFullyDark=false
CRT_MirrorKey=65 + ctrl   
[MODULE CDROM]
Device=/dev/scd0
EjectCDKey=161
[MODULE MIXER OSS]
Device=/dev/mixer
Channels=volume, speaker 
[MODULE MIXER ALSA]
Card=default
Channels=Master, PC Speaker
[MODULE PMAC]
TPMode=tap
NoTapTyping=yes
KBDMode=fkeysfirst
Batlog=none
[MODULE POWERSAVE]
onAC_Policy=performance   
onAC_TimerAction=none
onAC_CoverAction=none
onAC_KeyAction=suspend-to-ram
onAC_DimTime=5500
onBattery_Policy=powersave
onBattery_TimerAction=suspend-to-ram
onBattery_CoverAction=none
onBattery_KeyAction=suspend-to-ram
onBattery_SuspendTime=6000
onBattery_DimTime=1200
Script_PMCS=/etc/power/pmcs-pbbuttonsd %s %s %s
HeartbeatBeep=true
IBAM_DataDir=/var/lib/ibam


Now reading the (good and detailed) manpage I realized my config was far outdated.
I did some effort and created a new config close to the specification and order of the man-page, only enabling the minimal variables I like to set differing from default:
Code:
cat /etc/pbbuttonsd.cnf
# Configuration file for pbbuttonsd >= version 0.8.0
# For complete list of options please see pbbuttonsd.cnf man-page.
# For description of the file format please see
#    http://freedesktop.org/Standards/desktop-entry-spec.

[SYSTEM]
#userallowed=paranoid
autorescan=false
#CmdTimeout=12

[MODULE POWERSAVE]
#onAC_Policy=performance
onAC_TimerAction=none
onAC_CoverAction=none
#onAC_KeyAction=suspend-to-ram
#onAC_SuspendTime=3000
onAC_DimTime=5500
#onBattery_Policy=powersave
#onBattery_TimerAction=suspend-to-ram
onBattery_CoverAction=none
#onBattery_KeyAction=suspend-to-ram
onBattery_SuspendTime=6000
onBattery_DimTime=1200
#SleepKey=116
#SleepKeyDelay=0
#BWL_First=20
#BWL_Second=10
#BWL_Last=3
#EmergencyAction=sleep
#HeartbeatBeep=yes
Script_PMCS=/etc/power/pmcs-pbbuttonsd %s %s %s
IBAM_DataDir=/var/lib/ibam
#CPULoad_sleeplock=true
#CPULoad_min=20
#CPULoad_period=20
#NETLoad_sleeplock=true
#NETLoad_min=4096
#NetLoad_period=60
#NETLoad_device=eth2

[MODULE DISPLAY]
LCD_Brightness=50
LCD_FadingSpeed=4200
LCD_AutoadjMode=off
#LCD_AutoadjMode=linear
#LCD_AutoadjParm_onBattery=0,1,100,60
#LCD_AutoadjParm_onAC=0,1,100,80
KBD_AutoadjMode=off
#KBD_AutoadjMode=linear
#KBD_AutoadjParm_onBattery=10,0,28,0
#KBD_AutoadjParm_onAC=0,100,28,0
#LCD_IllumUpKey=KEY_BRIGHTNESSUP
#LCD_IllumDownKey=KEY_BRIGHTNESSDOWN
#KBD_Brightness=0
#KBD_FadingSpeed=4200
#KBD_IllumUpKey=KEY_KBDILLUMUP
#KBD_IllumDownKey=KEY_KBDILLUMDOWN
#KBD_IllumOnKey=KEY_KBDILLUMTOGGLE
#Device_FB=/dev/fb0
#UseFBBlank=no
#DimFullyDark=no
#CRT_MirrorKey=KEY_F7 + CTRL

[MODULE CDROM]
#Device=/dev/cdrom
#ejectcdkey=KEY_EJECTCD
#ejectcdkeydelay=500

#[MODULE MIXER OSS]
#Device=/dev/mixer
#Channels=volume, speaker

[MODULE MIXER ALSA]
#ALSA_Card=default
#ALSA_Elements=Master

[MODULE PMAC]
#Device_ADB=/dev/adb
#Device_PMU=/dev/pmu
#TPModeUpKey=ALT+KEY_BRIGHTNESSUP
#TPModeDownKey=ALT+KEY_BRIGHTNESSDOWN
TPMode=tap
#NoTapTyping=yes
KBDMode=fkeysfirst
#batlog=none

Before I was sure autorescan was disabled, but it wasn't. Even the latest man-page is wrong here:
Quote:
autorescan = [yes | no] (default: yes)
The group must be [SYSTEM] and the setting must be false and not no. Now its really disabled according to pbbcmd. At least this issue I'll forward to the mailing list, lets see if the project is still alive...

The CPU usage seems better, always below 10% but still more than normal:
Code:
1  PID USER     GROUP     PR  NI %CPU %MEM  RES SWAP    TIME+  S COMMAND                                 
 19381 root     root      39  19 90.3  3.1  63m 9400   0:24.84 R emerge                                   
 18621 root     root      20   0  5.2  0.1 1548 8572   0:11.71 S pbbuttonsd


PS.: I'm not sure how the standard configuration is generated, it is not copied but installed like
Code:
/usr/bin/install -c -m 644 --suffix=.old -b ./pbbuttonsd.cnf /var/tmp/portage/app-laptop/pbbuttonsd-0.8.1-r3/image//etc/pbbuttonsd.cnf
Anyway, the configuration does not match the latest syntax, and should at least look like my example above.

-> pbbuttons-users@lists.sourceforge.net man page error, high CPU load, 3.* sources patch
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G | amd64:Acer Z5610 (Core2QuadQ8200),i5-3470 | amd64-prefix:OpenSuse | Lila-Theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum