Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Voikko - Vapaa soikko
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Oct 17, 2006 9:04 am    Post subject: Reply with quote

kanttu wrote:
Hain juurin uuden layoutin ja asentelin siitä app-office/openoffice-sdk-2.0.4 ebuildin mutta huonoin seurauksin

Code:
>>> Install openoffice-sdk-2.0.4 into /var/tmp/portage/app-office/openoffice-sdk-2.0.4/image/ category app-office
chmod: cannot access `/var/tmp/portage/app-office/openoffice-sdk-2.0.4/image//usr/lib/openoffice/setsdkenv_unix': No such file or directory

!!! ERROR: app-office/openoffice-sdk-2.0.4 failed.
Call stack:
  ebuild.sh, line 1564:   Called dyn_install
  ebuild.sh, line 1022:   Called src_install
  openoffice-sdk-2.0.4.ebuild, line 73:   Called die

!!! fperms failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


taaskin itselläni on /usr/lib/openoffice/program/setsdkenv_unix eli jostain syystä tuo hakee komentoa väärästä paikasta


Jaha, programhan siitä suorastaan puuttui. Jostain syystä se ei kuollut minun testissäni vaikka olisi pitänyt. Lataan kohta korjatun version.

Quote:
Myöskään sci-misc/suomi-malaga-9999 ei ole nyt moneen päivään enää toiminut

Code:
Warning: No allomorphs generated. ("joukahainen.lex", line 21915)
Warning: No allomorphs generated. ("joukahainen.lex", line 21947)
Warning: No allomorphs generated. ("atk.lex", line 92)
Source entries read:     26440
Allomorphs generated:    124058
Allomorphs per entry:    4.692
Compiling "voikko-fi_FI.mor".
"voikko-fi_FI.pro" is up to date.

!!! ERROR: sci-misc/suomi-malaga-9999 failed.
Call stack:
  ebuild.sh, line 1564:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  suomi-malaga-9999.ebuild, line 23:   Called die


SVN-versioiden buildit ovat toisinaan poissa ajantasalta, mikä on tietysti odotettavaakin. Yleensä korjaukseksi riittää katsoa tuoreimmasta versioidusta buildista eroavaisuuksia.
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Oct 17, 2006 11:05 am    Post subject: Reply with quote

Flammie wrote:
SVN-versioiden buildit ovat toisinaan poissa ajantasalta, mikä on tietysti odotettavaakin. Yleensä korjaukseksi riittää katsoa tuoreimmasta versioidusta buildista eroavaisuuksia.


Tuo osoittautui ongelmaksi upstreamissa, tiedostoja on ilmeisesti siirrelty ja suomi-malaga-pakettiin kuuluva sukija-indeksointi ei enää käänny. Kytkin sen pois päältä SVN-buildista väliaikaisesti.
Back to top
View user's profile Send private message
kanttu
n00b
n00b


Joined: 31 Aug 2005
Posts: 58

PostPosted: Tue Oct 17, 2006 12:50 pm    Post subject: Reply with quote

Sain nyt suomi-malagan taas kääntymään ja openoffice-sdk:kin asentui kiltisti. Nyt taas on uusia ongelmia:
Code:
OO_SDK_HOME=//usr/lib/openoffice
"//usr/lib/openoffice/linux/bin/cppumaker" -Gc -BUCR -O./build/hpp "//usr/lib/openoffice/program/types.rdb"
mkdir -p build/pkg/META-INF
mkdir -p build/pkg
cat config.xcu | sed 's/LF_NAMESPACE/voikko/g' > build/pkg/config.xcu
mkdir -p build/pkg
cat config.xcs | sed 's/LF_NAMESPACE/voikko/g' > build/pkg/config.xcs
//usr/lib/openoffice/linux/bin/cppumaker: error while loading shared libraries: libuno_sal.so.3: wrong ELF class: ELFCLASS64
make: *** [build/types.flag] Error 127

cppumaker tulee ilmeisesti tuon openoffice-sdk:n mukana suoraan eikä sitä käännetä, joten se on 32-bittinen, käännetyn openofficen omat binäärit kuten libuno_sal.so.3 taas ovat 64-bittisiä joten homma ei voikaan toimia.

Eikö cppumakeria voisi kääntää kuten Gentoo -ohjelmia yleensä?
_________________
AMD Athlon64 3500+
ASUS A8N-SLI deluxe
PNY GeForce 6800GT
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Oct 17, 2006 11:40 pm    Post subject: Reply with quote

kanttu wrote:
Eikö cppumakeria voisi kääntää kuten Gentoo -ohjelmia yleensä?


Minusta sen pitäisi kuulua openoffice-pakettiin. Toisaalta sen lähdekoodeja ei löydy ainakaan SDK-kotisivun lähettyviltä, joten hankala sanoa. Pitänee tutkia asiaa tarkemmin.

Lisäsin aiheesta bugin openoffice-paketoijille: bug 151798
Back to top
View user's profile Send private message
kanttu
n00b
n00b


Joined: 31 Aug 2005
Posts: 58

PostPosted: Fri Oct 27, 2006 12:55 am    Post subject: Reply with quote

Taas ongelmia, vaikka olen hakenut uusimman layoutin niin app-text/voikko-9999 ei käänny enää
Code:
configure: creating ./config.status
config.status: error: cannot find input file: Makefile.in

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/app-text/voikko-9999/work/voikko-9999/config.log

!!! ERROR: app-text/voikko-9999 failed.


sama juttu app-text/tmispell-9999
Code:
Cleaning autotools files...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
configure.ac:7: version mismatch.  This is Automake 1.9.6,
configure.ac:7: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:7: comes from Automake 1.10.  You should recreate
configure.ac:7: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
enchant/Makefile.am: installing `./depcomp'

!!! ERROR: app-text/tmispell-9999 failed.


Ilmeisesti uusi automake tuottaa ongelmia Voikon buildsysteemin kanssa...

KWord alkoi muuten toimia paremmin, nyt spelling settingseistä voi jo valita suomen, valitettavasti oikoluku ei toimi vieläkään ja valittaa että /usr/lib/ispell/finnish.hash on viallinen, itselläni se on tyhjä, en tiedä pitäisikö siellä olla mitään.

Ehkä uudet buildit voikosta ja tmispellistä auttaisivat kunhan saisin ne ensin käännettyä.
_________________
AMD Athlon64 3500+
ASUS A8N-SLI deluxe
PNY GeForce 6800GT
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Mon Oct 30, 2006 1:53 pm    Post subject: Reply with quote

kanttu wrote:
Taas ongelmia, vaikka olen hakenut uusimman layoutin niin app-text/voikko-9999 ei käänny enää
Code:
configure: creating ./config.status
config.status: error: cannot find input file: Makefile.in

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/app-text/voikko-9999/work/voikko-9999/config.log

!!! ERROR: app-text/voikko-9999 failed.


sama juttu app-text/tmispell-9999
Code:
Cleaning autotools files...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
configure.ac:7: version mismatch.  This is Automake 1.9.6,
configure.ac:7: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:7: comes from Automake 1.10.  You should recreate
configure.ac:7: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
enchant/Makefile.am: installing `./depcomp'

!!! ERROR: app-text/tmispell-9999 failed.


Ilmeisesti uusi automake tuottaa ongelmia Voikon buildsysteemin kanssa...


Noista en osaa sanoa ainakaan nyt suoraan ennen kuin pääsen käsiksi johonkin omaan järjestelmään, varmaan sopiva autoreconf tai jokin oikeassa paikassa ebuildia saattaisi auttaa asiaa.

Quote:
KWord alkoi muuten toimia paremmin, nyt spelling settingseistä voi jo valita suomen, valitettavasti oikoluku ei toimi vieläkään ja valittaa että /usr/lib/ispell/finnish.hash on viallinen, itselläni se on tyhjä, en tiedä pitäisikö siellä olla mitään.


Tämä on varmasti KWordin ominaisuus, se olettaa että olisi normaali ispell käytössä ja pystyisi itse lisäämään sanoja tai jotain vastaavaa. Tmispellin kanssa tämä ei tietysti ole mahdollista ainakaan sillä tavoin kuin perinteisissä englanninkielisissä oikoluvuissa vain lisättäisiin puuttuvat sanat. En tiedä korjataanko tuota ominaísuutta jotenkin sitten ollenkaan.
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Wed Nov 01, 2006 7:58 pm    Post subject: Reply with quote

Flammie wrote:
kanttu wrote:
Taas ongelmia, vaikka olen hakenut uusimman layoutin niin app-text/voikko-9999 ei käänny enää
Code:
configure: creating ./config.status
config.status: error: cannot find input file: Makefile.in

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/app-text/voikko-9999/work/voikko-9999/config.log

!!! ERROR: app-text/voikko-9999 failed.


sama juttu app-text/tmispell-9999
Code:
Cleaning autotools files...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
configure.ac:7: version mismatch.  This is Automake 1.9.6,
configure.ac:7: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:7: comes from Automake 1.10.  You should recreate
configure.ac:7: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
enchant/Makefile.am: installing `./depcomp'

!!! ERROR: app-text/tmispell-9999 failed.


Ilmeisesti uusi automake tuottaa ongelmia Voikon buildsysteemin kanssa...


Noista en osaa sanoa ainakaan nyt suoraan ennen kuin pääsen käsiksi johonkin omaan järjestelmään, varmaan sopiva autoreconf tai jokin oikeassa paikassa ebuildia saattaisi auttaa asiaa.


En saanut varsinaista ongelmaa toistettua, ainakin asentamalla ebuildilla emergen sijaan pääsee loppuun asti. Lisäsin overlayhin nyt autoreconfeja, joiden pitäisi ajantasaistaa autosälät, en tiedä auttaako se.
Back to top
View user's profile Send private message
kanttu
n00b
n00b


Joined: 31 Aug 2005
Posts: 58

PostPosted: Fri Nov 03, 2006 1:39 am    Post subject: Reply with quote

Sain nyt taas voikon kääntymään mutta tmispell-9999 antaa edelleen saman virheen
Code:
 *    bootstrap with a file: autogen.sh
Cleaning autotools files...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
configure.ac:7: version mismatch.  This is Automake 1.9.6,
configure.ac:7: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:7: comes from Automake 1.10.  You should recreate
configure.ac:7: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
enchant/Makefile.am: installing `./depcomp'

!!! ERROR: app-text/tmispell-9999 failed.
Call stack:
  ebuild.sh, line 1568:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  tmispell-9999.ebuild, line 35:   Called subversion_src_unpack
  subversion.eclass, line 275:   Called subversion_bootstrap
  subversion.eclass, line 258:   Called die

!!! subversion.eclass: can't execute ESVN_BOOTSTRAP.
!!! If you need support, post the topmost build error, and the call stack if relevant.


Automake 1.10:n ebuild ei ole vielä stable mutta ajan omaa gentootani testing flageillä. Mitä versiota itse käytät?
_________________
AMD Athlon64 3500+
ASUS A8N-SLI deluxe
PNY GeForce 6800GT
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Fri Nov 03, 2006 7:32 pm    Post subject: Reply with quote

kanttu wrote:
Sain nyt taas voikon kääntymään mutta tmispell-9999 antaa edelleen saman virheen
Code:
 *    bootstrap with a file: autogen.sh
Cleaning autotools files...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
configure.ac:7: version mismatch.  This is Automake 1.9.6,
configure.ac:7: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:7: comes from Automake 1.10.  You should recreate
configure.ac:7: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
enchant/Makefile.am: installing `./depcomp'

!!! ERROR: app-text/tmispell-9999 failed.
Call stack:
  ebuild.sh, line 1568:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  tmispell-9999.ebuild, line 35:   Called subversion_src_unpack
  subversion.eclass, line 275:   Called subversion_bootstrap
  subversion.eclass, line 258:   Called die

!!! subversion.eclass: can't execute ESVN_BOOTSTRAP.
!!! If you need support, post the topmost build error, and the call stack if relevant.


Automake 1.10:n ebuild ei ole vielä stable mutta ajan omaa gentootani testing flageillä. Mitä versiota itse käytät?


Käytän itse asiassa stabiileja versioita ebuildien testauskoneella, mutta käänsin tuon subversion-version paketista komennoilla ebuild unpack,compile,install ja qmerge joten jos se onkin jäänyt kesken tuossa unpack vaiheessa niin se on saattanut jotenkin mystisesti toimia silti tarpeeksi.

Code:

$ equery list automake
[ Searching for package 'automake' in all categories among: ]
 * installed packages
[I--] [  ] sys-devel/automake-1.4_p6 (1.4)
[I--] [  ] sys-devel/automake-1.5 (1.5)
[I--] [  ] sys-devel/automake-1.6.3 (1.6)
[I--] [  ] sys-devel/automake-1.7.9-r1 (1.7)
[I--] [  ] sys-devel/automake-1.8.5-r3 (1.8)
[I--] [  ] sys-devel/automake-1.9.6-r2 (1.9)
[I--] [  ] sys-devel/automake-wrapper-1-r1 (0)


Virittelemällä voi tietysti kokeilla josko autogen.sh:n jättäminen väliin ja autoreconfin forcettaminen auttaisi tai jotain sellaista. En ole ihan vielä sinut tuon auto-järjestelmän kanssa niin en osaa tarkkaan sanoa.
Back to top
View user's profile Send private message
kanttu
n00b
n00b


Joined: 31 Aug 2005
Posts: 58

PostPosted: Tue Nov 14, 2006 8:38 pm    Post subject: Reply with quote

Onko mitään tietoa milloin tämän saisi korjattua? En ole saanut käännettyä tmispelliä moneen viikkoon nyt tuon takia. Ei sitä voisi fiksata toimimaan uudemman automaken kanssa? Kaikki portagen paketit kyllä pelittävät.

Flammie wrote:
kanttu wrote:
Sain nyt taas voikon kääntymään mutta tmispell-9999 antaa edelleen saman virheen
Code:
 *    bootstrap with a file: autogen.sh
Cleaning autotools files...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
configure.ac:7: version mismatch.  This is Automake 1.9.6,
configure.ac:7: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:7: comes from Automake 1.10.  You should recreate
configure.ac:7: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
enchant/Makefile.am: installing `./depcomp'

!!! ERROR: app-text/tmispell-9999 failed.
Call stack:
  ebuild.sh, line 1568:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  tmispell-9999.ebuild, line 35:   Called subversion_src_unpack
  subversion.eclass, line 275:   Called subversion_bootstrap
  subversion.eclass, line 258:   Called die

!!! subversion.eclass: can't execute ESVN_BOOTSTRAP.
!!! If you need support, post the topmost build error, and the call stack if relevant.


Automake 1.10:n ebuild ei ole vielä stable mutta ajan omaa gentootani testing flageillä. Mitä versiota itse käytät?


Käytän itse asiassa stabiileja versioita ebuildien testauskoneella, mutta käänsin tuon subversion-version paketista komennoilla ebuild unpack,compile,install ja qmerge joten jos se onkin jäänyt kesken tuossa unpack vaiheessa niin se on saattanut jotenkin mystisesti toimia silti tarpeeksi.

Code:

$ equery list automake
[ Searching for package 'automake' in all categories among: ]
 * installed packages
[I--] [  ] sys-devel/automake-1.4_p6 (1.4)
[I--] [  ] sys-devel/automake-1.5 (1.5)
[I--] [  ] sys-devel/automake-1.6.3 (1.6)
[I--] [  ] sys-devel/automake-1.7.9-r1 (1.7)
[I--] [  ] sys-devel/automake-1.8.5-r3 (1.8)
[I--] [  ] sys-devel/automake-1.9.6-r2 (1.9)
[I--] [  ] sys-devel/automake-wrapper-1-r1 (0)


Virittelemällä voi tietysti kokeilla josko autogen.sh:n jättäminen väliin ja autoreconfin forcettaminen auttaisi tai jotain sellaista. En ole ihan vielä sinut tuon auto-järjestelmän kanssa niin en osaa tarkkaan sanoa.

_________________
AMD Athlon64 3500+
ASUS A8N-SLI deluxe
PNY GeForce 6800GT
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Wed Nov 15, 2006 8:17 am    Post subject: Reply with quote

kanttu wrote:
Onko mitään tietoa milloin tämän saisi korjattua? En ole saanut käännettyä tmispelliä moneen viikkoon nyt tuon takia. Ei sitä voisi fiksata toimimaan uudemman automaken kanssa? Kaikki portagen paketit kyllä pelittävät.


Korjailen sitten tarkemmin kun ELISA pulttaa Internetin uuteen asuntooni, en ehdi yliopiston koneilta niin hyvin säätää. Luulen kyllä että väliaikana se kääntäminen onnistuu komennoilla
Code:
ebuild tmispell-9999.ebuild unpack
ebuild tmispell-9999.ebuild compile
ebuild tmispell-9999.ebuild install
ebuild tmispell-9999.ebuild qmerge


Jos nuo ei toimi voisi yrittää kommentoida pois riviä ESVN_BOOTSTRAP="autogen.sh" ja lisätä src_compileen joitain autoreconf -f -i -juttuja, tai sitten ehkä parempi korjaus olisi lisätä ebuildiin jokin WANT_AUTO{CONF,MAKE}=x.y.z. (http://devmanual.gentoo.org/general-concepts/autotools/index.html#simple-autotools-patching-example ), jota varmaan sovellan sitten kunhan pääsen sorvin ääreen.
Back to top
View user's profile Send private message
kanttu
n00b
n00b


Joined: 31 Aug 2005
Posts: 58

PostPosted: Wed Nov 15, 2006 6:55 pm    Post subject: Reply with quote

no tuo sama virhe tulee jo heti komennon
Code:
ebuild tmispell-9999.ebuild unpack
yhteydessä
_________________
AMD Athlon64 3500+
ASUS A8N-SLI deluxe
PNY GeForce 6800GT
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Wed Nov 15, 2006 9:20 pm    Post subject: Reply with quote

kanttu wrote:
no tuo sama virhe tulee jo heti komennon
Code:
ebuild tmispell-9999.ebuild unpack
yhteydessä


Joo, mutta compile toimii silti.

Nomut, nyt sen pitäisi toimia muutenkin, ainakin ebuildit on paljon lihavammat.
Back to top
View user's profile Send private message
kanttu
n00b
n00b


Joined: 31 Aug 2005
Posts: 58

PostPosted: Thu Nov 16, 2006 5:58 pm    Post subject: Reply with quote

Flammie wrote:

Nomut, nyt sen pitäisi toimia muutenkin, ainakin ebuildit on paljon lihavammat.


No nyt se toimii! Hyvää työtä :)
_________________
AMD Athlon64 3500+
ASUS A8N-SLI deluxe
PNY GeForce 6800GT
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Feb 13, 2007 1:23 am    Post subject: Reply with quote

https://overlays.gentoo.org/proj/finnish/
Back to top
View user's profile Send private message
jannu
n00b
n00b


Joined: 15 Feb 2007
Posts: 3

PostPosted: Thu Feb 15, 2007 12:17 pm    Post subject: Ebuildi openoffice-sdk-2.1.0:lle Reply with quote

Tein tuon 2.0.4:sen pohjalta ebuildin openoffice-sdk-2.1.0:lle. Asentui ainakin mulla ihan mukavasti ja openoffice-voikko-1.2:kin asentui ihan hyvin siihen päälle

Code:

# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

OOI_SCRIPT="OOo-SDK_2.1.0_LinuxIntel_install_en-US.sh"
DESCRIPTION="Software Development Kit addition to OpenOffice.Org"
HOMEPAGE="http://download.openoffice.org/2.1.0/sdk.html"
SRC_URI="http://mirrors.dotsrc.org/openoffice/stable/${PV}/${OOI_SCRIPT}"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="java"

DEPEND="|| ( >app-office/openoffice-2 >app-office/openoffice-bin-2 )
        sys-apps/sed
        >app-arch/zip-2.3
        || ( app-arch/rpm2targz )
        java? ( >dev-java/sun-jdk-1.4.1.01 )
        "
RDEPEND="|| ( >app-office/openoffice-2 >app-office/openoffice-bin-2 )
        >app-arch/zip-2.3
        "

src_unpack() {
        mkdir "${S}"
        cd "${S}"
        # check line number from sh on update
        tail --lines=+88 "${DISTDIR}/${OOI_SCRIPT}" | tar xf -
        assert
        cd RPMS
        rpm2targz openoffice.org-sdk-${PV}-?.i586.rpm || \
                die "Unable to unrpm"
        tar zxpf openoffice.org-sdk-${PV}-?.i586.tar.gz || \
                die "Unable to untar"
        cd opt/openoffice.org2.1_sdk
        OO_SDK_JAVA_HOME=""
        if has_version dev-java/sun-jdk && use java ; then
                jdk_version=$(best_version dev-java/sun-jdk)
                OO_SDK_JAVA_HOME="${ROOT}/opt/sun-jdk-${jdk_version/-r?/}"
        fi
        sed     -e "s:@OO_SDK_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OFFICE_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OO_SDK_ZIP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_CPP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_MAKE_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_JAVA_HOME@:${OO_SDK_JAVA_HOME}:g" \
                -e "s:/usr/share/automake:${ROOT}/usr/share/automake:g" \
                "${FILESDIR}/setsdkenv_unix.sh.gentoo" > setsdkenv_unix.sh
        sed -e "s:@OO_SDK_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OFFICE_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OO_SDK_ZIP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_CPP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_MAKE_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_JAVA_HOME@:${OO_SDK_JAVA_HOME}:g" \
                -e "s:/usr/share/automake:${ROOT}/usr/share/automake:g" \
                "${FILESDIR}/setsdkenv_unix.csh.gentoo" > setsdkenv_unix.csh
}

src_install() {
        # tools, examples & api docs
        dodir /usr/lib/openoffice
        insinto /usr/lib/openoffice
        cd "${S}/RPMS/opt/openoffice.org2.1_sdk/"
        doins -r classes examples idl linux settings xml include
        doins config.*
        for f in config.* linux/bin/* ; do
                fperms a+x /usr/lib/openoffice/${f} || die "fperms failed"
        done

        # docs
        dodoc index.html README{,.html}
        dodir /usr/share/doc/${PF}
        insinto /usr/share/doc/${PF}
        doins -r docs

        # SDK env.
        insinto /usr/lib/openoffice/program/
        doins setsdkenv_unix* configure.pl
        for f in setsdkenv_unix{,.sh,.csh} ; do
                fperms a+x /usr/lib/openoffice/program/${f} || die "fperms failed"
        done
}

src_postinst() {
        elog "SDK environment variable setup scripts were installed in: "
        elog "  ${ROOT}/usr/lib/openoffice/program"
}


Nyt, kun vielä saisi väännettyä kasaan vastaavan 64-bittisenä.
Back to top
View user's profile Send private message
Nuteater
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 193
Location: Jyväskylä, Finland

PostPosted: Thu Feb 15, 2007 3:54 pm    Post subject: Reply with quote

Flammie wrote:
https://overlays.gentoo.org/proj/finnish/

Loistavaa! :) Saisikohan tuon mahdollisesti lisättyä tuonne laymanin päälistaan?
_________________
I am Nuteater, hear me roar.
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Thu Feb 15, 2007 5:20 pm    Post subject: Re: Ebuildi openoffice-sdk-2.1.0:lle Reply with quote

jannu wrote:
Tein tuon 2.0.4:sen pohjalta ebuildin openoffice-sdk-2.1.0:lle. Asentui ainakin mulla ihan mukavasti ja openoffice-voikko-1.2:kin asentui ihan hyvin siihen päälle

Nyt, kun vielä saisi väännettyä kasaan vastaavan 64-bittisenä.


Lisäilin vähän päivitetyn version. Tavoitteena on kyllä saada bug 151798 ratkottua, ettei tätä binääriä tarvitsisi säätää. Toki jos jollakulla olisi laitteistot ja kykyä säätää ja testailla ebuildeja niin overlayhin saa varmaan helpohkosti kirjoitusoikeudetkin.

nuteater wrote:

Flammie wrote:

https://overlays.gentoo.org/proj/finnish/


Loistavaa! :) Saisikohan tuon mahdollisesti lisättyä tuonne laymanin päälistaan?


Pitää kokeilla kunhan ehtii.
Back to top
View user's profile Send private message
jannu
n00b
n00b


Joined: 15 Feb 2007
Posts: 3

PostPosted: Tue Apr 17, 2007 3:50 pm    Post subject: Voikon asennus openoffice-2.2.0:lle Reply with quote

Asentelin tuossa openoffice-2.2.0:n ja huomasin, että openoffice-voikko ei enää asennukaan sen päälle ihan siististi. Ongelmana näkyy olevan, että uusi openoffice ei enää asenna libstlport_gcc.so -kirjastoa, jota tarvitaan openoffice-voikon asennuksessa.

Ratkaisuna nappasin k.o. kirjaston Fedoran RPM-paketeista ja kopsasin sen hakemistoon /usr/lib/openoffice/program/ Tämän jälkeen openoffice-voikko asentuikin ihan siististi.

Käyttämäni RPM-paketti löytyi osoitteesta:
ftp://rpmfind.net/linux/fedora/core/development/i386/os/Fedora/openoffice.org-core-2.2.0-14.5.i386.rpm

Tökkäsin tuon kirjaston myös omalle koneelleni haettavaksi osoitteesta:
http://jannu.homelinux.net/gentoo/x86/libstlport_gcc.so

Käytin asennuksessa myös uutta openoffice-sdk-2.2.0:aa, jonka ebuildi on alla:
Code:

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit java-pkg-opt-2

OOI_SCRIPT="OOo-SDK_2.2.0_LinuxIntel_install.sh"
DESCRIPTION="Software Development Kit addition to OpenOffice.Org"
HOMEPAGE="http://download.openoffice.org/2.2.0/sdk.html"
SRC_URI="http://mirrors.dotsrc.org/openoffice/stable/${PV}/${OOI_SCRIPT}"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86"

DEPEND="|| ( >app-office/openoffice-2 >app-office/openoffice-bin-2 )
        sys-apps/sed
        >app-arch/zip-2.3
        || ( app-arch/rpm2targz )
        "
RDEPEND="|| ( >app-office/openoffice-2 >app-office/openoffice-bin-2 )
        >app-arch/zip-2.3
        "

src_unpack() {
        mkdir "${S}"
        cd "${S}"
        # check line number from sh on update
        tail --lines=+88 "${DISTDIR}/${OOI_SCRIPT}" | tar xf -
        assert
        cd RPMS
        rpm2targz openoffice.org-sdk-${PV}-9134.i586.rpm || \
                die "Unable to unrpm"
        tar zxpf openoffice.org-sdk-${PV}-9134.i586.tar.gz || \
                die "Unable to untar"
        cd opt/openoffice.org2.2_sdk
        sed     -e "s:@OO_SDK_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OFFICE_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OO_SDK_ZIP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_CPP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_MAKE_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_JAVA_HOME@:${JAVA_HOME}:g" \
                -e "s:/usr/share/automake:${ROOT}/usr/share/automake:g" \
                "${FILESDIR}/setsdkenv_unix.sh.gentoo" > setsdkenv_unix.sh
        sed -e "s:@OO_SDK_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OFFICE_HOME@:${ROOT}/usr/lib/openoffice:g" \
                -e "s:@OO_SDK_ZIP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_CPP_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_MAKE_HOME@:${ROOT}/usr/bin:g" \
                -e "s:@OO_SDK_JAVA_HOME@:${JAVA_HOME}:g" \
                -e "s:/usr/share/automake:${ROOT}/usr/share/automake:g" \
                "${FILESDIR}/setsdkenv_unix.csh.gentoo" > setsdkenv_unix.csh
}

src_install() {
        # tools, examples & api docs
        dodir /usr/lib/openoffice
        insinto /usr/lib/openoffice
        cd "${S}/RPMS/opt/openoffice.org2.2_sdk/"
        doins -r classes examples idl linux settings xml include
        doins config.*
        for f in config.* linux/bin/* ; do
                fperms a+x /usr/lib/openoffice/${f} || die "fperms failed"
        done

        # docs
        dodoc index.html README{,.html}
        dodir /usr/share/doc/${PF}
        insinto /usr/share/doc/${PF}
        doins -r docs

        # SDK env.
        insinto /usr/lib/openoffice/program/
        doins setsdkenv_unix* configure.pl
        for f in setsdkenv_unix{,.sh,.csh} ; do
                fperms a+x /usr/lib/openoffice/program/${f} || die "fperms failed"
        done
}

pkg_postinst() {
        elog "SDK environment variable setup scripts were installed in: "
        elog "  ${ROOT}/usr/lib/openoffice/program"
        elog "Please note that this ugly kludge of package is only used until "
        elog "  http://bugs.gentoo.org/show_bug.cgi?id=151798"
        elog "has been resolved by kind openoffice team"
}
Back to top
View user's profile Send private message
jannu
n00b
n00b


Joined: 15 Feb 2007
Posts: 3

PostPosted: Tue Apr 17, 2007 4:10 pm    Post subject: openoffice-voikon asennus amd64:lle Reply with quote

Yritin tässä myös saada openoffice-voikon asennettua amd64:lle, mutta siitä ei ole ainakaan vielä tullut valmista. Jos joku kuitenkin haluaa yrittää tuon hieromista kuntoon, niin alla on lista vaiheista joita itse käytin.

Asensin openoffice-2.2.0:n normaalisti sekä openoffice-sdk-2.2.0:n yllä olevalla ebuildilla.

Tämän jälkeen hain Fedoran 64-bittisen openoffice-sdk RPMn osoitteesta:
ftp://rpmfind.net/linux/fedora/core/development/x86_64/os/Fedora/openoffice.org-sdk-2.2.0-14.5.x86_64.rpm

Kaivoin k.o. RPM-paketista kaikki hakemiston /usr/lib64/openoffice.org/sdk/linux/ alla olevat tiedostot ja korvasin niillä openoffice-sdk-2.2.0 ebuildin asentamat (32-bittiset) tiedostot hakemistossa /usr/lib/openoffice/linux/

Tämän jälkeen hain 64-bittisen libstlport_gcc.so -kirjaston jälleen Fedoran RPM-paketista osoitteesta:
ftp://rpmfind.net/linux/fedora/core/development/x86_64/os/Fedora/openoffice.org-core-2.2.0-14.5.x86_64.rpm

Kopion k.o. kirjaston hakemistoon /usr/lib/openoffice/program/

Tämän jälkeen yritin asentaa openoffice-voikko-1.2:sen normaalisti. Paketin kääntäminen näyttikin sujuvan ihan hyvin, mutta UNO-paketin rekisteröintivaiheessa tapahtui joku virhe, josta en vielä ole saanut ulos mitään järkevää outputtia.
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue Apr 17, 2007 11:57 pm    Post subject: Re: Voikon asennus openoffice-2.2.0:lle Reply with quote

jannu wrote:
Asentelin tuossa openoffice-2.2.0:n ja huomasin, että openoffice-voikko ei enää asennukaan sen päälle ihan siististi. Ongelmana näkyy olevan, että uusi openoffice ei enää asenna libstlport_gcc.so -kirjastoa, jota tarvitaan openoffice-voikon asennuksessa.


Huh. stlport kuulostaa tutulta ongelmalta, mutten ehdi jahtaamaan nyt (tai koko tänä keväänä).

Quote:
Käytin asennuksessa myös uutta openoffice-sdk-2.2.0:aa, jonka ebuildi on alla:


Näyttää hyvältä, päivitin ja päivitin myös voikon ja suomi-malagan.
Back to top
View user's profile Send private message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 28

PostPosted: Sat May 12, 2007 12:31 pm    Post subject: Re: Voikon asennus openoffice-2.2.0:lle Reply with quote

Koetin asentaa voikon, mutta en onnistunut. pistin tuon http://overlays.gentoo.org/proj/finnish/browser laymanin lähteeksi. layman -a finnish latasi nätistis ebuildeja. Mutta niissä tuntuu olevan virheitä. suomi-malaga ebuildin Manifest tiedosto on virheellinen. kun sain sen korjattua niin voikko ei kääntynyt. voikko-1.4_rc1 vaatisi tiedoston ibvoikko_1.4~rc1.orig.tar.gz, jota ei tunnu löytyvän enää. Jos joku viitsisi kertoa mitkä ebuildit johtaisi siihen tulokseen, jotta voikko toimisi oo2:ssa. Ubuntussa ym toimii, niin eiköhän se Gentooseenkin pitäisi saada.

Onko nuo http://www.hunspell-fi.org/gentoo/ ebuildit paremmat?
_________________
---
Sakarias
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Tue May 15, 2007 7:52 pm    Post subject: Re: Voikon asennus openoffice-2.2.0:lle Reply with quote

Sakarias wrote:
Koetin asentaa voikon, mutta en onnistunut. pistin tuon http://overlays.gentoo.org/proj/finnish/browser laymanin lähteeksi. layman -a finnish latasi nätistis ebuildeja. Mutta niissä tuntuu olevan virheitä. suomi-malaga ebuildin Manifest tiedosto on virheellinen. kun sain sen korjattua niin voikko ei kääntynyt. voikko-1.4_rc1 vaatisi tiedoston ibvoikko_1.4~rc1.orig.tar.gz, jota ei tunnu löytyvän enää. Jos joku viitsisi kertoa mitkä ebuildit johtaisi siihen tulokseen, jotta voikko toimisi oo2:ssa.


Kai ne taas toimii.

Quote:
Ubuntussa ym toimii, niin eiköhän se Gentooseenkin pitäisi saada.


Binääripaketoinnit on vähän helpompia, mutta sinänsä. Ongelmia on että unopkg-systeemi ei ole kovin helppokäyttöinen tai ymmärrettävä, ja sen selvittely on hankalaa ja vaivalloista kaiken openoffice-tauhkan keskeltä, johon ei ole hirveästi kiinnostusta paneutua, joten olisi hyvä jos lähinnä Gentoon Portage-puussa olevan openoffice-paketoinnin bugit korjaisi oikea openoffice-tiimi, joka saattaa ymmärtää siitä jotain.

Quote:
Onko nuo http://www.hunspell-fi.org/gentoo/ ebuildit paremmat?


Suunnilleen samat tai vanhemmat.
Back to top
View user's profile Send private message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 28

PostPosted: Sun May 20, 2007 12:12 pm    Post subject: Reply with quote

Pääsin vähän pidemmälle. Johtuu kai tuosta unopkg-systeemistä tai jostain kun openoffice-voikko ei asentunut. voikko-1.3, malaga ja suomi-malaga ym. sain kääntymään. Voisiko johtua siitä että odk USE muuttuja ei ole päällä. Eilen illalla pistin uudemman C:n asentumaan ja samalla OO2 kääntymään myös odk flag päällä, mutta käännös ei mennyt läpi. Voi johtua siitäkin, että tilan tarpeen takia linkkasin hakemiston /var/tmp toiselle levylle. Viimeksi kun linkitin koko /var hakemiston toiselle levylle niin hal ei enää käynnistynyt. Ihme juttu. Kun poistin linkityksen alkoi taas toimia.

Seuraavaksi linkittämisen sijasta liitän /var hakemiston jollekin toiselle levylle. Se lienee sallittua.

Eikä noista virheilmoituksista oikein ota tolkkua.
Making Module-Definitionfile : ../../unxlngi6.pro/misc/vclcanvas.uno.def
just a dummy for UNIX
cp -f /mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/work/ooo/build/OOF680_m14/solenv/src/default_description.xml ../../unxlngi6.pro/misc/vclcanvas.uno.xml
cp: cannot stat `/mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/work/ooo/build/OOF680_m14/solenv/src/default_description.xml': No such file or directory
dmake: Error code 1, while making '../../unxlngi6.pro/misc/vclcanvas.uno.xml'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/work/ooo/build/OOF680_m14/canvas/source/vcl
make: *** [stamp/build] Error 1

!!! ERROR: app-office/openoffice-2.2.0 failed.
Call stack:
ebuild.sh, line 1615: Called dyn_compile
ebuild.sh, line 972: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
openoffice-2.2.0.ebuild, line 327: Called die

!!! Build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/temp/build.log'.

!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.5 CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.5.0.11"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course, the output of emerge --info
_________________
---
Sakarias
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Wed May 23, 2007 12:01 am    Post subject: Reply with quote

Sakarias wrote:
Eikä noista virheilmoituksista oikein ota tolkkua.
Code:
Making Module-Definitionfile : ../../unxlngi6.pro/misc/vclcanvas.uno.def
just a dummy for UNIX
cp -f /mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/work/ooo/build/OOF680_m14/solenv/src/default_description.xml ../../unxlngi6.pro/misc/vclcanvas.uno.xml
cp: cannot stat `/mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/work/ooo/build/OOF680_m14/solenv/src/default_description.xml': No such file or directory
dmake:  Error code 1, while making '../../unxlngi6.pro/misc/vclcanvas.uno.xml'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /mnt/varasto/tmp/portage/app-office/openoffice-2.2.0/work/ooo/build/OOF680_m14/canvas/source/vcl
make: *** [stamp/build] Error 1


Ei näytä tutulta ongelmalta, mutta vaikuttaa että jokin tiedosto ei vain ole oikeassa paikassa tai asennusskripti yrittää käsitellä tiedostoa jota ei enää ole. Jos vika ei ole kovalevyssä tai vastaavassa niin tämä voisi olla ilmoittamisen arvoinen bugi.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum