Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(UPDATED) HOWTO: Brother MFC scan and print with sane & cups
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Nadhor
n00b
n00b


Joined: 03 Feb 2003
Posts: 46
Location: Germany

PostPosted: Wed Jan 17, 2007 12:40 am    Post subject: Reply with quote

Thanks for the guide. I installed a HL-5250DN today with Cups-1.2.6 and udev-087-r1 (udev-103 had a little bit too many problems for my liking)
With your guide I managed to install the printer just fine and cups also recognized it, but as soon as I tried to print something it gave me the error-message: "Printer not connected; will retry in 30 seconds". After a little searching I found that if the line
Code:
DeviceURI usb://Brother/HL-5250DN%20series

gets changed to
Code:
DeviceURI file:/dev/usb/lp0

in the file /etc/cups/printer.conf cups will finally print.
Thought I should mention it here, should anybody else run into the same trouble.


Last edited by Nadhor on Wed Jan 17, 2007 9:34 am; edited 1 time in total
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jan 17, 2007 8:59 am    Post subject: Reply with quote

thanks, Nadhor

this is what I forgot to add :roll:

everytime I newly install a printer I have to "modify" it under cups, since this happens rather seldom I didn't think of it, it will be added soon to my steps ...

it's also pretty strange that it sometimes works right out of the box & sometimes only with that modification ...

... but at least it works ;)
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D


Last edited by kernelOfTruth on Fri Apr 20, 2007 9:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Feb 21, 2007 5:32 pm    Post subject: watch out cups 1.2.8 doesn't work Reply with quote

hi everyone,

watch out when updating your system:

cups 1.2.8 made some changes and isn't working for me, so if you encounter problems, switch back to 1.2.7
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
dreamdreams
n00b
n00b


Joined: 25 Nov 2002
Posts: 43

PostPosted: Mon Mar 05, 2007 6:31 pm    Post subject: Re: watch out cups 1.2.8 doesn't work Reply with quote

kernelOfTruth wrote:
hi everyone,

watch out when updating your system:

cups 1.2.8 made some changes and isn't working for me, so if you encounter problems, switch back to 1.2.7


1.2.8 works fine for me. Mine is a 7820N.

BTW, did anybody get the "Scan" button on the machine work with Linux? If yes then it would be perfect. I got print/scan working already. Didn't try PC fax yet, I bet it works. Will write a how-to after I try it today.

The only things left are:
1. PC Fax receive
2. Scan button on the machine
Back to top
View user's profile Send private message
VValdo
Guru
Guru


Joined: 08 Jan 2005
Posts: 395

PostPosted: Sun Apr 15, 2007 3:23 am    Post subject: Reply with quote

I noticed that CUPS stopped working.. If i do

/etc/init.d/cupsd restart

as root it works again. I'm trying to figure out why...

W
Back to top
View user's profile Send private message
PiRmD
n00b
n00b


Joined: 22 Apr 2005
Posts: 49
Location: Daya Bay NPS-Shenzhen-China

PostPosted: Fri Apr 20, 2007 8:29 pm    Post subject: Reply with quote

I'm trying to have my new DCP-750CW work. I have followed VValdo guidelines but I still have the following trouble :
- when I launch any printing job, the printer "wakes-up" but nothing is printed
- Cups seems to consider that the job is finished successfully (the job is deleted from the queue, moreover the log in debug mode states that the job is terminated with success)
- the only strange think found in cups log is the following error
Code:
"cupsdAuthorize: Local authentication certificate not found!"
(but according to google and as far as I have understood it should not be linked to my issue)
- another strange thinks is that the files in /var/spool/cups (which I think are related to the file to be printed) belong to root:lp with permission 600 (and are filling up this directory)

The printer is connected through ethernet if it can be the root of the issue.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Apr 20, 2007 9:30 pm    Post subject: Reply with quote

PiRmD wrote:
I'm trying to have my new DCP-750CW work. I have followed VValdo guidelines but I still have the following trouble :
- when I launch any printing job, the printer "wakes-up" but nothing is printed
- Cups seems to consider that the job is finished successfully (the job is deleted from the queue, moreover the log in debug mode states that the job is terminated with success)
- the only strange think found in cups log is the following error
Code:
"cupsdAuthorize: Local authentication certificate not found!"
(but according to google and as far as I have understood it should not be linked to my issue)
- another strange thinks is that the files in /var/spool/cups (which I think are related to the file to be printed) belong to root:lp with permission 600 (and are filling up this directory)

The printer is connected through ethernet if it can be the root of the issue.

which platform are you using, if I may ask: x86 or amd64?

if you're using amd64, have you copied over files to /usr/libexec/... (if using cups 1.2*), have you installed the files manually or used rpm?

sorry, I'm a bit lazy & busy right now & in addition to that I don't know anymore what VValdo's steps were ... will have a look at them later ...
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
PiRmD
n00b
n00b


Joined: 22 Apr 2005
Posts: 49
Location: Daya Bay NPS-Shenzhen-China

PostPosted: Sat Apr 21, 2007 10:39 am    Post subject: Reply with quote

I'm running x86 platform.
I did use the rpm packages (first to install lpr drivers then the cups wrapper)
I copy the files from /usr/lib/cups/filter to /usr/libexec/cups/filter (in fact I've created a symlink from /usr/lib/cups/filter to its new cups 1.2* location before I installed the rpm).
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Apr 22, 2007 8:38 pm    Post subject: Reply with quote

I'm getting an error like the following right now on amd64, running 2.6.21-r7-git5:

http://bbs.archlinux.org/viewtopic.php?pid=244397

Quote:
I [22/Apr/2007:22:32:05 +0200] Loaded MIME database from '/etc/cups': 34 types, 38 filters...
I [22/Apr/2007:22:32:05 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [22/Apr/2007:22:32:05 +0200] Full reload complete.
E [22/Apr/2007:22:32:05 +0200] Unable to find IP address for server name "lexa-x86"!
I [22/Apr/2007:22:32:05 +0200] Listening to 127.0.0.1:631 on fd 2...
I [22/Apr/2007:22:32:05 +0200] Listening to ::1:631 on fd 3...
I [22/Apr/2007:22:32:05 +0200] Listening to /var/run/cups/cups.sock on fd 4...
I [22/Apr/2007:22:32:15 +0200] commptr=""
I [22/Apr/2007:22:32:15 +0200] Started "/usr/libexec/cups/cgi-bin/admin.cgi" (pid=10862)
I [22/Apr/2007:22:32:15 +0200] commptr="1+0+4+requested-attributes=all"
I [22/Apr/2007:22:32:15 +0200] Started "/usr/libexec/cups/daemon/cups-deviced" (pid=10863)
I [22/Apr/2007:22:32:17 +0200] commptr=""
I [22/Apr/2007:22:32:17 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10875)
I [22/Apr/2007:22:32:20 +0200] commptr=""
I [22/Apr/2007:22:32:20 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10876)
I [22/Apr/2007:22:32:30 +0200] commptr="?op=print-test-page"
I [22/Apr/2007:22:32:30 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10877)
I [22/Apr/2007:22:32:30 +0200] Adding start banner page "none" to job 6.
I [22/Apr/2007:22:32:30 +0200] Adding end banner page "none" to job 6.
I [22/Apr/2007:22:32:30 +0200] Job 6 queued on "MFC5840CN" by "guest".
I [22/Apr/2007:22:32:30 +0200] Started filter /usr/libexec/cups/filter/pstops (PID 10878) for job 6.
I [22/Apr/2007:22:32:30 +0200] Started filter /usr/libexec/cups/filter/brlpdwrapperMFC5840CN (PID 10879) for job 6.
I [22/Apr/2007:22:32:30 +0200] Started backend /usr/libexec/cups/backend/usb (PID 10880) for job 6.
E [22/Apr/2007:22:32:30 +0200] PID 10879 (/usr/libexec/cups/filter/brlpdwrapperMFC5840CN) stopped with status 22!
I [22/Apr/2007:22:32:30 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
I [22/Apr/2007:22:32:32 +0200] commptr=""
I [22/Apr/2007:22:32:32 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10881)
I [22/Apr/2007:22:32:42 +0200] commptr=""
I [22/Apr/2007:22:32:42 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10882)
I [22/Apr/2007:22:32:52 +0200] commptr=""
I [22/Apr/2007:22:32:52 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10883)
I [22/Apr/2007:22:33:02 +0200] commptr=""
I [22/Apr/2007:22:33:02 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=10884)


any help appreciated
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
netboy1977
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2005
Posts: 76
Location: Muenster/Germany

PostPosted: Wed Apr 25, 2007 2:05 pm    Post subject: Problem with MFC-425CN network scanning Reply with quote

Dear Forum,

I can't get my Brother MFC-425CN scanner working via network.
Printing via network is fine using CUPS.

Code:
 brsaneconfig2 -q
says that the scanner s found:

Code:

Devices on network
  0 MFC-425CN           "MFC-425CN"         I:192.168.178.2


Nevertheless xsane does not find any scanner.
Who can help me?
Thanks!
Dominik
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat May 05, 2007 7:22 pm    Post subject: Re: Problem with MFC-425CN network scanning Reply with quote

netboy1977 wrote:
Dear Forum,

I can't get my Brother MFC-425CN scanner working via network.
Printing via network is fine using CUPS.

Code:
 brsaneconfig2 -q
says that the scanner s found:

Code:

Devices on network
  0 MFC-425CN           "MFC-425CN"         I:192.168.178.2


Nevertheless xsane does not find any scanner.
Who can help me?
Thanks!
Dominik


did xsane work with the root account?

did you follow the gentoo wiki or did you configure it on your own? (http://gentoo-wiki.com/Brother_MFC_420CN/Sane)


I'm having problems setting up my printer (MFC5840CN) up on another system (via usb): I'm getting the infamous: "Unable to copy ppd" message, like on ubuntu-forums described:
http://ubuntuforums.org/showthread.php?t=232276

unfortunately the tips don't help, on one case the printer says "Incoming Data" (or similar; translated message), the other cups says /usr/libexec/cups/filter/brldwrapper... failed (the exact version / name of that file doesn't play a role)

did anyone encounter the same behavior & can help me? cups error log says: 'exited with error message 30' or similar, which means that lpr driver isn't installed (read this somewhere), which in fact isn't true since I copied / installed that before cupswrapper

Many thanks in advance
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
PiRmD
n00b
n00b


Joined: 22 Apr 2005
Posts: 49
Location: Daya Bay NPS-Shenzhen-China

PostPosted: Sun May 06, 2007 9:17 am    Post subject: Reply with quote

I don't know if it can help but I had to modify the permission of the brother filter in order to get rid of such complain (to have it executable by world such like the other filters).I did have to do the same for the brother ppd file in /usr/share/cups/model.

EDIT : thanks to your question, I go through most of eth files installed by Brother and I discover some other permission issues (like access to /usr/local/Brother/printer and Scanner). I change them and it fixes all my scanning and printing issues !

Thus I'm still not clear of what should be the right owner and permission setting for such files. Should it be root:root with a world r--x or root:lp with no permission for world ...
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon May 07, 2007 9:11 am    Post subject: Reply with quote

PiRmD wrote:
I don't know if it can help but I had to modify the permission of the brother filter in order to get rid of such complain (to have it executable by world such like the other filters).I did have to do the same for the brother ppd file in /usr/share/cups/model.

EDIT : thanks to your question, I go through most of eth files installed by Brother and I discover some other permission issues (like access to /usr/local/Brother/printer and Scanner). I change them and it fixes all my scanning and printing issues !

Thus I'm still not clear of what should be the right owner and permission setting for such files. Should it be root:root with a world r--x or root:lp with no permission for world ...


thanks PiRmD :)

you pointed me in the right direction :!:

ok ladies & gentlemen here are the exact permissions for the files (names may vary) how I got this pita working [thanks god I had a working system image somewhere]:

/usr/bin
Code:
-rwxr-xr-x 1 root root     22628 Mar 19 07:25 brprintconfij2


/usr/lib
Code:
lrwxrwxrwx  1 root root       21 May  7 10:56 libbrcompij2.so.1 -> libbrcompij2.so.1.0.2

-rwxr-xr-x  1 root root   725444 Mar 19 07:25 libbrcompij2.so.1.0.2


/usr/local/Brother
Code:
drwxr-xr-x  6 root root                6 Mar 19 07:26 Brother


/usr/local/Brother/
Code:
drwxr-xr-x 2 root root  4 Mar 19 07:26 cupswrapper

drwxr-xr-x 2 root root  2 Mar 19 07:26 filter

drwxrwxrwx 2 root root 12 May  3 06:56 inf

drwxr-xr-x 2 root root  5 Mar 19 07:25 lpd


/usr/local/Brother/cupswrapper
Code:
-rwxr-xr-x 1 root root 103199 Mar 19 07:26 cupswrapperMFC5840CN-1.0.0

-rw-r--r-- 1 root root 103196 Mar 19 07:25 cupswrapperMFC5840CN-1.0.0~


/usr/local/Brother/inf
Code:
-rw-r--r-- 1 root root   1468 Mar 19 07:25 brMFC5840CNfunc

-rw------- 1 lp   lp      314 May  3 06:56 brMFC5840CNrc

lrwxrwxrwx 1 root root     13 May  7 10:56 brPrintList -> brMFC5840CNrc

-rw-r--r-- 1 root root    148 Mar 19 07:25 brPrintListij2

-rw-r--r-- 1 root root 127728 Mar 19 07:25 brio04aa.bcm

-rw-r--r-- 1 root root 220536 Mar 19 07:25 brio04ab.bcm

-rw-r--r-- 1 root root 127728 Mar 19 07:25 brio04ac.bcm

-rw-r--r-- 1 root root 132440 Mar 19 07:25 brio04ad.bcm

-rw-r--r-- 1 root root    492 Mar 19 07:25 paperinfij2

-rwxr-xr-x 1 root root   1620 Mar 19 07:25 setupPrintcapij

/usr/local/Brother/lpd
Code:
-rwxr-xr-x 1 root root  1956 Mar 19 07:25 filterMFC5840CN

-rwxr-xr-x 1 root root  1884 Mar 19 07:25 psconvertij2

-rwxr-xr-x 1 root root 24656 Mar 19 07:25 rastertobrij2


/usr/libexec/cups/filter/
Code:
-rwxr-xr-x 1 root root 18240 Mar 19 07:26 brlpdwrapperMFC5840CN

_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
netboy1977
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2005
Posts: 76
Location: Muenster/Germany

PostPosted: Mon May 07, 2007 11:26 am    Post subject: Reply with quote

[quote="kernelOfTruth"]
PiRmD wrote:

thanks PiRmD :)

you pointed me in the right direction :!:

ok ladies & gentlemen here are the exact permissions for the files (names may vary) how I got this pita working [thanks god I had a working system image somewhere]:


Seems to me I have a different problem since permissions are set in the right way (Thanks for your input kernelOfTruth). All the relevant files are world readable. Are you sure root is the right owner?
Back to top
View user's profile Send private message
monsieur
n00b
n00b


Joined: 01 Jul 2005
Posts: 16

PostPosted: Thu Jul 19, 2007 6:25 pm    Post subject: Reply with quote

thank you very much for this excellent guide. :D

I have a MFC 9160 --> color scanner and b&w printer working nicely (for normal user also) with cups and xsane.

I just copy-pasted your commands ( :oops: ) and it worked perfectly. Fixed the whole thing in around 10 minutes 8)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jul 20, 2007 12:59 pm    Post subject: Reply with quote

[quote="netboy1977"]
kernelOfTruth wrote:
PiRmD wrote:

thanks PiRmD :)

you pointed me in the right direction :!:

ok ladies & gentlemen here are the exact permissions for the files (names may vary) how I got this pita working [thanks god I had a working system image somewhere]:


Seems to me I have a different problem since permissions are set in the right way (Thanks for your input kernelOfTruth). All the relevant files are world readable. Are you sure root is the right owner?


sorry for this long delay :(

I'm pretty sure that it should be root, but you could rpm2targz your rpm-files, then check out what permissions they have inside those rpms

you could also try out to set them to root:users, but leave the file(s) with lp:lp

@monsieur:

glad it helped you :D
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
RiBBiT
Apprentice
Apprentice


Joined: 18 May 2005
Posts: 215
Location: Sweden

PostPosted: Thu Sep 13, 2007 6:24 pm    Post subject: Reply with quote

Thanks for the instructions kernelOfTruth, I got my HL-2030 up and running fine.
_________________
Comix - GTK Comic Book Viewer [ http://comix.sourceforge.net ]
Back to top
View user's profile Send private message
timor
Guru
Guru


Joined: 25 May 2005
Posts: 517
Location: Poland

PostPosted: Fri Sep 28, 2007 9:37 am    Post subject: Reply with quote

PiRmD wrote:
I'm trying to have my new DCP-750CW work. I have followed VValdo guidelines but I still have the following trouble :
- when I launch any printing job, the printer "wakes-up" but nothing is printed
- Cups seems to consider that the job is finished successfully (the job is deleted from the queue, moreover the log in debug mode states that the job is terminated with success)
- the only strange think found in cups log is the following error
Code:
"cupsdAuthorize: Local authentication certificate not found!"
(but according to google and as far as I have understood it should not be linked to my issue)
- another strange thinks is that the files in /var/spool/cups (which I think are related to the file to be printed) belong to root:lp with permission 600 (and are filling up this directory)

The printer is connected through ethernet if it can be the root of the issue.

I have new DCP-130C and stuck after all installation steps ;/ My problems are similar to this above.

I've tried cups versions: 1.1.23-r8 1.2.9 1.2.10-r1 - none working,
I've tried usb://Brother/DCP-130C and file:/dev/usb/lp0 uri's
Permissions are set r+w for all files

No errors in error_log
Code:
I [28/Sep/2007:11:28:33 +0200] commptr=""
I [28/Sep/2007:11:28:33 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=12509)
I [28/Sep/2007:11:28:40 +0200] commptr="?op=print-test-page"
I [28/Sep/2007:11:28:40 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=12512)
I [28/Sep/2007:11:28:40 +0200] Adding start banner page "none" to job 36.
I [28/Sep/2007:11:28:40 +0200] Adding end banner page "none" to job 36.
I [28/Sep/2007:11:28:40 +0200] Job 36 queued on "brother" by "root".
I [28/Sep/2007:11:28:40 +0200] Started filter /usr/libexec/cups/filter/pstops (PID 12513) for job 36.
I [28/Sep/2007:11:28:40 +0200] Started filter /usr/libexec/cups/filter/brlpdwrapperdcp130c (PID 12514) for job 36.
I [28/Sep/2007:11:28:41 +0200] commptr=""
I [28/Sep/2007:11:28:41 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=12515)
I [28/Sep/2007:11:28:44 +0200] commptr="?which_jobs=all"
I [28/Sep/2007:11:28:44 +0200] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=12516)

_________________
Nie lubię chomików.... budzą we mnie agresję...
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Sep 28, 2007 9:43 am    Post subject: Reply with quote

first try to get it to print locally (usb, parallel port), then connect it to ethernet

the main thing is:

try to get right permissions on all files #4044097

that was the most often problem I always had

good luck
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Sun Oct 07, 2007 11:16 am    Post subject: Reply with quote

Hello!

I've just installed my Brother DCP-7010L A4 scanner. It works very fine with brother2 backend, but, starting xsane I see something strange.
Here's the main xsane screenshot.
As you can see in the red circle, dimensions are 21.59 cm x 35.56 cm.
My scanner is an A4 scanner, so it would be better if dimentions are 21.00 cm x 29.7 cm.
Scanned images take less then an A4 sheet actually. Expecially in PDF files.

How can I modify that values?

Thanks a lot.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Oct 07, 2007 11:32 am    Post subject: Reply with quote

in the preview window instead of "full size" select "DIN A4 port." or other as needed
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Sun Oct 07, 2007 11:50 am    Post subject: Reply with quote

Thanks a lot!
It works!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
dracozny
Tux's lil' helper
Tux's lil' helper


Joined: 04 May 2004
Posts: 86

PostPosted: Wed Nov 21, 2007 9:24 am    Post subject: Reply with quote

kernelOfTruth wrote:
ok, thanks

well, that's ok, I would stick to 1.1.23, since last time I tried out 1.2* and reverted to 1.1.23 it didn't work anymore 8O

Update:

I solved the problem thanks to VValdo's post:

just copy /usr/lib/cups/filter/brlpdwrapper* to /usr/libexec/cups/filter/brlpdwrapper*
and the printer should also work with cups-1.2*


hmm no f/usr/lib/cups doesn't exist in my setup.

using latest version of cups as well, so far I have everything running except the printer system sends data to printer which is recieved but printer discards, and cups reports success. oh and also no lpd in /etc/init.d not sure what has to be emerged there i tried search and just get selinux library.

correction after logging out and back in I no longer can scan, running xsane from terminal i get

Code:
xsane
bugchk_free(ptr=(nil))@brother_modelinf.c(467)
Aborted

_________________
“I do not think there is any thrill that can go through the human heart like that felt by the inventor as he sees some creation of the brain unfolding to success... Such emotions make a man forget food, sleep, friends, love, everything.”
-Nikola Tesla-
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Dec 26, 2007 11:11 pm    Post subject: Reply with quote

try scanning via root -

I know - I know you shouldn't do things with root,

but that's the only temporary solution - at least for me

try - it - out :wink:
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
GSValore
n00b
n00b


Joined: 26 Jan 2008
Posts: 6

PostPosted: Sat Jan 26, 2008 1:51 am    Post subject: Mfc-240c Reply with quote

I'm trying to get my MFC-240C to work, but all the suggestions thus far do not seem to help. CUPS recognizes the printer on the USB port; however, it does not seem to actually print anything. Any jobs sit as processing endlessly. The error log shows nothing.

My system is configured as amd64, and I've installed the driver and cupswrapper as per Brother's site's instructions.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum