Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xrdp howto?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
grooveman
l33t
l33t


Joined: 24 Feb 2003
Posts: 991

PostPosted: Wed Apr 11, 2007 3:11 pm    Post subject: Xrdp howto? Reply with quote

Hello.

I want to use Xrdp so that windows clients do not have to add any additional software to their machines, and because it has encryption.

However, I have discovered a shocking dearth of documentation on how to get this going.

I have my xrdp.ini
Code:

[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3389
crypt_level=low

[xrdp1]
name=sesman
lib=libvnc.so
username=ask
password=ask
ip=1x.9x.1x7.x15
port=-1


I have set xrdp to start at the default runlevel.

Since it relies on vnc, I also started that up using the "vncserver" script that comes with vnc. (I am not using tightvnc or any of the other variants, I'm trying to stick with the standard deps as drawn out in portage).

I can vnc to the box without problem.

But, when I try to rdp to the box, I get the following:
Quote:

started connecting
connecting to sesman
sending login info to sesman
receiving sesman header
receiving sesman data
sesman started a session
connecting to xx.xx.xx.xx 5910
error - problem connecting


I have been at this for hours now, and I cannot figure out what this thing wants from me.

Also, when I run vncserver, i get this for the output:
Quote:
xauth: (stdin):1: bad display name "my_unqualified_hostname:1" in "add" command

New 'my_unqualified_hostname:1 (root)' desktop is hostname:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/hostname:1.log


I also don't know where that is coming from, or if it is significant... like I said, vnc still connects...

Can someone give me a hand?

Thanks!

G
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
grooveman
l33t
l33t


Joined: 24 Feb 2003
Posts: 991

PostPosted: Fri Apr 13, 2007 11:56 pm    Post subject: Reply with quote

Okay then...

No one wants to play with me... fine.

I found the answer. I did not have an xsession defined in my rc.conf (because I login via kdm/xdm/gdm, and don't start X via startx, so it never bothered me before).

Once I put in KDE-3.5, everything works peachy! (umm. peachily? Um... very fruit-like at any rate).

G
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
stormer
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2002
Posts: 122
Location: Canada

PostPosted: Sat Apr 14, 2007 7:11 pm    Post subject: Thanks a lot Reply with quote

Thanks a lot, where 2007 now, since I wasn't require to use Windo$ before that, I had no interest in xrdp. This peace of work need a uge cleanup ...
_________________
Stormer :)
Back to top
View user's profile Send private message
mackerel
Apprentice
Apprentice


Joined: 09 Aug 2005
Posts: 167
Location: SC

PostPosted: Fri Jun 29, 2007 1:45 am    Post subject: Reply with quote

Hey thanks!!!

I too looked several hours for an answer.
_________________
Mack
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum