Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200703-21 ] PHP: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1613

PostPosted: Tue Mar 20, 2007 10:26 pm    Post subject: [ GLSA 200703-21 ] PHP: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 200703-21)
Severity: high
Exploitable: remote
Date: March 20, 2007
Updated: March 29, 2008
Bug(s): #153911
ID: 200703-21

Synopsis

PHP contains several vulnerabilities including a heap buffer overflow, potentially leading to the remote execution of arbitrary code under certain conditions.

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Affected Packages

Package: dev-lang/php
Vulnerable: < 5.2.1-r3
Unaffected: >= 5.2.1-r3
Unaffected: >= 5.1.6-r11 < 5.1.7
Unaffected: >= 4.4.6 < 4.4.7
Unaffected: >= 4.4.7 < 4.4.8
Unaffected: >= 4.4.8_pre20070816 < 4.4.9
Architectures: All supported architectures


Description

Several vulnerabilities were found in PHP by the Hardened-PHP Project and other researchers. These vulnerabilities include a heap-based buffer overflow in htmlentities() and htmlspecialchars() if called with UTF-8 parameters, and an off-by-one error in str_ireplace(). Other vulnerabilities were also found in the PHP4 branch, including possible overflows, stack corruptions and a format string vulnerability in the *print() functions on 64 bit systems.

Impact

Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak.

Workaround

There is no known workaround at this time.

Resolution

All PHP users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose "dev-lang/php"


References

CVE-2006-5465
CVE-2007-0906
CVE-2007-0907
CVE-2007-0908
CVE-2007-0909
CVE-2007-0910
CVE-2007-0911
CVE-2007-0988
CVE-2007-1286
CVE-2007-1375
CVE-2007-1376
CVE-2007-1380
CVE-2007-1383
PHP 4.4.5 Release Announcement
PHP 5.2.1 Release Announcement


Last edited by GLSA on Sat Mar 29, 2008 4:18 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum