Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Openbravo ERP
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Sun Sep 24, 2006 2:21 pm    Post subject: [HOWTO] Openbravo ERP Reply with quote

Wiki HOWTO

I've written a document explaining how to install Openbravo ERP in Gentoo. Openbravo is a web based ERP (Enterprise Resource Planning) for small and medium enterprises.
Any feedback is welcomed.


Last edited by iarwain on Fri Feb 23, 2007 4:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Sat Oct 14, 2006 9:41 am    Post subject: Reply with quote

Now ant 1.6.5 and sun-jdk-1.5 are marked as stable in portage. The HOWTO has been updated to this changes. This makes the installation easier.
Back to top
View user's profile Send private message
t7na9coose
n00b
n00b


Joined: 19 Dec 2006
Posts: 2
Location: Clearwater, FL

PostPosted: Tue Dec 19, 2006 7:01 pm    Post subject: Reply with quote

Thank for the information from the Wiki. Great How-to. I followed the directions and when installing I get an error:
Code:
org.tp23.antinstaller.InstallException: Error running the install
   at org.tp23.antinstaller.runtime.exe.AntProjectFilter.exec(Unknown Source)
   at org.tp23.antinstaller.runtime.ExecInstall.exec(Unknown Source)
   at org.tp23.antinstaller.selfextract.NonExtractor.main(Unknown Source)
Caused by: jar:file:/usr/src/openbravo_postgres/download.jar!/build.xml:183: Execute failed: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
   at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:620)
   at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
   at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
   at org.apache.tools.ant.Task.perform(Task.java:364)
   at org.apache.tools.ant.Target.execute(Target.java:341)
   at org.apache.tools.ant.Target.performTasks(Target.java:369)
   at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
   at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
   at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
   at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
   ... 3 more
Caused by: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
   at java.lang.ProcessImpl.start(ProcessImpl.java:65)
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
   at java.lang.Runtime.exec(Runtime.java:591)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
   at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
   at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
   at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:576)
   at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
   ... 12 more
--- Nested Exception ---
jar:file:/usr/src/openbravo_postgres/download.jar!/build.xml:183: Execute failed: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
   at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:620)
   at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
   at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
   at org.apache.tools.ant.Task.perform(Task.java:364)
   at org.apache.tools.ant.Target.execute(Target.java:341)
   at org.apache.tools.ant.Target.performTasks(Target.java:369)
   at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
   at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
   at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
   at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
   at org.tp23.antinstaller.runtime.exe.AntProjectFilter.exec(Unknown Source)
   at org.tp23.antinstaller.runtime.ExecInstall.exec(Unknown Source)
   at org.tp23.antinstaller.selfextract.NonExtractor.main(Unknown Source)
Caused by: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
   at java.lang.ProcessImpl.start(ProcessImpl.java:65)
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
   at java.lang.Runtime.exec(Runtime.java:591)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
   at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
   at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
   at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:576)
   at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
   ... 12 more
--- Nested Exception ---
java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
   at java.lang.ProcessImpl.start(ProcessImpl.java:65)
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
   at java.lang.Runtime.exec(Runtime.java:591)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
   at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
   at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
   at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:576)
   at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
   at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
   at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
   at org.apache.tools.ant.Task.perform(Task.java:364)
   at org.apache.tools.ant.Target.execute(Target.java:341)
   at org.apache.tools.ant.Target.performTasks(Target.java:369)
   at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
   at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
   at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
   at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
   at org.tp23.antinstaller.runtime.exe.AntProjectFilter.exec(Unknown Source)
   at org.tp23.antinstaller.runtime.ExecInstall.exec(Unknown Source)
   at org.tp23.antinstaller.selfextract.NonExtractor.main(Unknown Source)


I have done everything outlined in the wiki, what am I doing incorrectly? Do I also need to export ANT_HOME?

Of course ant is not in /usr/share/ant-core/bin but instead in /usr/share/ant-core/lib but also in /usr/share/tomcat-5.5/common/lib/, which I exported from the terminal that I started the install.

I exported the necessary parameters according to the wiki and I also configured build.xml as outlined. I am sure I am missing something, and I simply cannot get it to work.

Thanks for your help.
Back to top
View user's profile Send private message
t7na9coose
n00b
n00b


Joined: 19 Dec 2006
Posts: 2
Location: Clearwater, FL

PostPosted: Tue Dec 19, 2006 10:23 pm    Post subject: Nevermind . . . Reply with quote

Well, I did get it to work, after a couple days, and deciding to post, I finally got things squared away. Thanks for the Great How-TO!!
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Wed Dec 20, 2006 8:52 am    Post subject: Reply with quote

Hi t7na9coose, I'm glad you've found it useful.
As soon as 2.20 is released I'll update the guide with a chapter explaining how to install the SVN version.
Back to top
View user's profile Send private message
xcable
Guru
Guru


Joined: 15 Aug 2002
Posts: 424
Location: College Station, Texas

PostPosted: Tue Jan 30, 2007 10:55 pm    Post subject: Reply with quote

iarwain, have you used Openbravo much?

I'm wanting to install a ERP system at my new job (10 employees). I'm new to this job and they/we currently have nothing. I've used a couple of ERP systems before. What I'm finding is that Openbravo looks to be the move visible open source ERP system I'm finding. What I really want is BOM (bill of materials) management and parts organization. I'm a EET, doing circuit board design.

thanks,
--
heath
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Wed Jan 31, 2007 10:47 am    Post subject: Reply with quote

Hi xcable,

I'm more familiar with the Openbravo development/internals than with the functional side. It indeed has a product management and BOM module and as far as i know it works fine, you can test it yourself in the online demo. I've done many installations, so if you need any help, I'll be glad to help you. This week I'll upgrade the wiki with the latest v2.21. This version is compatible with gentoo's tomcat layout, so it's easier to install :-)
Back to top
View user's profile Send private message
xcable
Guru
Guru


Joined: 15 Aug 2002
Posts: 424
Location: College Station, Texas

PostPosted: Sun Feb 18, 2007 6:37 pm    Post subject: Reply with quote

iarwain, found you tried installing 2.22 yet? The java GUI installer does not give me option of changing the tomcat folder, and the install fails.

--
heath
Back to top
View user's profile Send private message
xcable
Guru
Guru


Joined: 15 Aug 2002
Posts: 424
Location: College Station, Texas

PostPosted: Tue Feb 20, 2007 2:37 pm    Post subject: Reply with quote

For 2.22 I don't get the option for specifying tomcat locations. Specifically the following :
Code:

PostgreSQL library path: /usr/share/tomcat-5.5/common/lib (default)
Tomcat folder: /usr/share/tomcat-5.5/
Log folder: /var/log/tomcat-5.5


I get the following error :

Code:

org.tp23.antinstaller.InstallException: Error running the install
        at org.tp23.antinstaller.runtime.exe.AntProjectFilter.exec(Unknown Source)
        at org.tp23.antinstaller.runtime.ExecInstall.exec(Unknown Source)
        at org.tp23.antinstaller.selfextract.NonExtractor.main(Unknown Source)
Caused by: jar:file:/usr/src/openbravo_postgres/download.jar!/build.xml:201: Execute failed: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:620)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        ... 3 more
Caused by: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
        at java.lang.ProcessImpl.start(ProcessImpl.java:65)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
        at java.lang.Runtime.exec(Runtime.java:591)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:576)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
        ... 12 more
--- Nested Exception ---
jar:file:/usr/src/openbravo_postgres/download.jar!/build.xml:201: Execute failed: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:620)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at org.tp23.antinstaller.runtime.exe.AntProjectFilter.exec(Unknown Source)
        at org.tp23.antinstaller.runtime.ExecInstall.exec(Unknown Source)
        at org.tp23.antinstaller.selfextract.NonExtractor.main(Unknown Source)
Caused by: java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
        at java.lang.ProcessImpl.start(ProcessImpl.java:65)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
        at java.lang.Runtime.exec(Runtime.java:591)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:576)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
        ... 12 more
--- Nested Exception ---
java.io.IOException: java.io.IOException: /usr/share/ant-core/bin/ant: not found
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
        at java.lang.ProcessImpl.start(ProcessImpl.java:65)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
        at java.lang.Runtime.exec(Runtime.java:591)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:576)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at org.tp23.antinstaller.runtime.exe.AntProjectFilter.exec(Unknown Source)
        at org.tp23.antinstaller.runtime.ExecInstall.exec(Unknown Source)
        at org.tp23.antinstaller.selfextract.NonExtractor.main(Unknown Source)
Install failed
Error running the install
Failed


--
heath
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Thu Feb 22, 2007 6:24 pm    Post subject: Reply with quote

Hi xcable,

sorry for the delay, I've just updated the HOWTO to the v2.22. Now the installer takes the tomcat-dirs from system variables: CATALINA_HOME and CATALINA_BASE. Probably that's the cause of your error.
Back to top
View user's profile Send private message
xcable
Guru
Guru


Joined: 15 Aug 2002
Posts: 424
Location: College Station, Texas

PostPosted: Thu Feb 22, 2007 6:54 pm    Post subject: Reply with quote

Thanks for the update. But...

I got it installed under Windows (after much frustration), and evaluated it for a while. It's looks to complex and would require far to much time to implement and maintain than I was looking for. The documentation lacks a lot be desired. I'm now looking at Tiny ERP and Adempiere.


--
heath
xcable
Back to top
View user's profile Send private message
bludger
Guru
Guru


Joined: 09 Apr 2003
Posts: 389

PostPosted: Fri Feb 23, 2007 2:21 pm    Post subject: Reply with quote

An ERP for SMES, eh?

IHFA*

Thank god for wikipedia.
http://en.wikipedia.org/wiki/Enterprise_resource_planning
http://en.wikipedia.org/wiki/Small_and_medium_enterprise

*I hate fucking acronyms.
Back to top
View user's profile Send private message
xcable
Guru
Guru


Joined: 15 Aug 2002
Posts: 424
Location: College Station, Texas

PostPosted: Fri Feb 23, 2007 2:30 pm    Post subject: Reply with quote

bludger to late. I've actually edited Wikipedia to include Tiny ERP and Openbarvo in there list of open source ERP software.

--
heath
xcable
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Fri Feb 23, 2007 4:15 pm    Post subject: Reply with quote

bludger: yeah right, an acronym explanation never hurts. Fixed.
xcable: you are right about the documentation, it should be much better. As I see in the wiki a part of the user's manual has been just published: http://wiki.openbravo.com/wiki/index.php/User_Manual . It is far from finished, but it's a start.
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Mon Feb 26, 2007 3:08 pm    Post subject: Reply with quote

That /usr/share/ant-core/bin/ant error is a bug in the build.xml. It has been reported and solved in SVN and the next version will have it fine. Meanwhile, there are 2 possible workarounds:

1) Create a symlink for the time being, until the new release is out:
Code:
ln -sf /usr/bin/ant /usr/share/ant-core/bin/ant

2) In the build.xml inside download.jar perform the following replacement:
Code:
${env.ANT_HOME}${separator}bin${separator}ant${ant.extension}

by
Code:
ant${ant.extension}
Back to top
View user's profile Send private message
concord
Apprentice
Apprentice


Joined: 02 Oct 2005
Posts: 191

PostPosted: Tue Mar 20, 2007 12:45 am    Post subject: Reply with quote

Thanks very much for so good how-to. I have installed openbravo on my gentoo machine. But there are still two questions need help:

1, when input openbravo's server name, just "localhost" can be used. if by IP address of domain name. the installation will stop just several seconds later in drop database stage.

2, after installation, i can login with name Openbravo and pass word "openbravo" and everything looks normal in server itself. but if I login from other computer with IE or firfox in same local network. all pictures have been replaced by panes and can not login at all. why?
_________________
AMD64 Desktop
Pentium4 Laptop
Pentium3 Server
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Tue Mar 20, 2007 10:01 am    Post subject: Reply with quote

Hi condord, I'm glad you've found it useful.

1. That's because probably your PostgreSQL is only listening on localhost, and not on your local IP. To change this, edit /var/lib/postgresql/data/postgresql.conf and uncomment and add your IP address to the "listen_addresses" line. For example, supossing your local IP is 192.168.1.120:
Code:
listen_addresses = 'localhost, 192.168.1.120'

2. It seems your images and javacript files are pointing to "localhost". To change this behavior, edit AppsOpenbravo/build.xml, and change this line:
Code:
  <property name="web.url" value="http://localhost:8080/openbravo/web"/>

into
Code:
<property name="web.url" value="http://192.168.1.120:8080/openbravo/web"/>

Then, place yourself in the AppsOpenbravo directory and recreate the war file:
Code:
ant war

And finally copy the new openbravo.war to you tomcat webapps directory:
Code:
cp AppsOpenbravo/lib/openbravo.war /var/lib/tomcat-5.5/webapps/

I hope it helps.
Back to top
View user's profile Send private message
concord
Apprentice
Apprentice


Joined: 02 Oct 2005
Posts: 191

PostPosted: Wed Mar 21, 2007 6:31 pm    Post subject: Reply with quote

Thanks very much! It works!

Could I use domain name instead of IP?

I tried it, but no good as IP instead.
_________________
AMD64 Desktop
Pentium4 Laptop
Pentium3 Server
Back to top
View user's profile Send private message
fulgas
n00b
n00b


Joined: 23 Mar 2007
Posts: 2

PostPosted: Mon Mar 26, 2007 9:23 am    Post subject: Reply with quote

I have sucessufully installed openbravo on gentoo.
I was having a hard time because of the gentoo format until i found the wiki.

thk a lot

sup
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Wed Mar 28, 2007 8:35 am    Post subject: Reply with quote

concord, the problem with using domain names is that the images, css and js files will point to that domain name. So other machines should have exactly the same name defined in their hosts file. Another possibility is to use the following:
Code:
<property name="web.url" value="@actual_url_context@/web"/>

This probably does what you want. However it has a serious flaw: the first client to access the ERP defines where the images,css and js point to. Imagine you alias your server's ip address to "myserver" in /etc/hosts. If you are the first one to enter the site, no one else will be able to access it, unless they define the same alias. You whould make sure the first client access with a "sane" name :-)

By the way, two news:

1. It seems the user manual is finished.
2. Openbravo has just released a new Bitrock based installer. Soon I'll add a chapter covering this.
Back to top
View user's profile Send private message
bravecobra
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2002
Posts: 130
Location: Planet Earth (sometimes)

PostPosted: Sun Apr 01, 2007 3:37 am    Post subject: Reply with quote

I followed the wiki and I'm getting a 404 error while trying to access http://<myserver>:8081/openbravo/security/Login_FS.html

Note the different port, since I already have a service running on port 8080. I changed the port in TomCat conf's file (/var/lib/tomcat-5.5/conf/server.xml). When running the installer I also used this 8081 port but apart from that, no differences to wiki. Any ideas?
_________________
Brave Cobra
http://www.bravecobra.com
Back to top
View user's profile Send private message
iarwain
Apprentice
Apprentice


Joined: 25 Sep 2003
Posts: 253

PostPosted: Sun Apr 01, 2007 7:18 am    Post subject: Reply with quote

bravecobra, make sure the openbravo context is there and it's started in http://<your_server>:8081/manager/html . If needed, create a user with the "manager" role in $CATALINA_BASE/conf/tomcat-users.xml.
Back to top
View user's profile Send private message
bravecobra
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2002
Posts: 130
Location: Planet Earth (sometimes)

PostPosted: Mon Apr 02, 2007 12:04 am    Post subject: Reply with quote

Tnx got it working now.. ;)
_________________
Brave Cobra
http://www.bravecobra.com
Back to top
View user's profile Send private message
concord
Apprentice
Apprentice


Joined: 02 Oct 2005
Posts: 191

PostPosted: Wed Apr 11, 2007 12:42 pm    Post subject: Reply with quote

iarwain wrote:
concord, the problem with using domain names is that the images, css and js files will point to that domain name. So other machines should have exactly the same name defined in their hosts file. Another possibility is to use the following:
Code:
<property name="web.url" value="@actual_url_context@/web"/>

This probably does what you want. However it has a serious flaw: the first client to access the ERP defines where the images,css and js point to. Imagine you alias your server's ip address to "myserver" in /etc/hosts. If you are the first one to enter the site, no one else will be able to access it, unless they define the same alias. You whould make sure the first client access with a "sane" name :-)

By the way, two news:

1. It seems the user manual is finished.
2. Openbravo has just released a new Bitrock based installer. Soon I'll add a chapter covering this.


Thanks!

I have tried bitrock on my amd64 freebsd 6.2. The main problems are exactly same as my 1st posting. And then I do exactly as your 1st answer to my 1 st posting. But no change and no work. Following is the startup procedure of catalina:

./catalina.sh run
Using CATALINA_BASE: /usr/local/tomcat5.5
Using CATALINA_HOME: /usr/local/tomcat5.5
Using CATALINA_TMPDIR: /usr/local/tomcat5.5/temp
Using JRE_HOME: /usr/local/diablo-jdk1.5.0
log4j:INFO Using URL [jar:file:/usr/local/tomcat5.5/common/lib/axis-ant.jar!/log4j.properties] for automatic log4j configuration of repository named [default].
- The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/local/diablo-jdk1.5.0/jre/lib/amd64/server:/usr/local/diablo-jdk1.5.0/jre/lib/amd64:/usr/local/diablo-jdk1.5.0/jre/../lib/amd64:/usr/lib:/usr/local/lib
- Initializing Coyote HTTP/1.1 on http-8080
- Initialization processed in 3304 ms
- Starting service Catalina
- Starting Servlet Engine: Apache Tomcat/5.5.20
- XML validation disabled
- Deploying web application archive openbravo.war
- validateJarFile(/usr/local/tomcat5.5/webapps/openbravo/WEB-INF/lib/servlet-api.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
- org.apache.webapp.balancer.BalancerFilter: init(): ruleChain: [org.apache.webapp.balancer.RuleChain: [org.apache.webapp.balancer.rules.URLStringMatchRule: Target string: News / Redirect URL: http://www.cnn.com], [org.apache.webapp.balancer.rules.RequestParameterRule: Target param name: paramName / Target param value: paramValue / Redirect URL: http://www.yahoo.com], [org.apache.webapp.balancer.rules.AcceptEverythingRule: Redirect URL: http://jakarta.apache.org]]
- ContextListener: contextInitialized()
- SessionListener: contextInitialized()
- ContextListener: contextInitialized()
- SessionListener: contextInitialized()
- Starting Coyote HTTP/1.1 on http-8080
- JK: ajp13 listening on /0.0.0.0:8009
- Jk running ID=0 time=0/25 config=null
- Find registry server-registry.xml at classpath resource
- Server startup in 19528 ms

Other 3 misc. problems are;

The Apache Tomcat Native library which allows optimal performance in production environments was not found.

XML validation disabled
before deploying

validateJarFile(/usr/local/tomcat5.5/webapps/openbravo/WEB-INF/lib/servlet-api.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class.
But if I delete servlet-avi.jar in $CATALINA_HOME/webapps/.....WEB-INF/lib, Above sentence will disappears. but main problem is still exist.

Would you please do me a favor to tell me how to deal with these problems?

Regards!
_________________
AMD64 Desktop
Pentium4 Laptop
Pentium3 Server
Back to top
View user's profile Send private message
concord
Apprentice
Apprentice


Joined: 02 Oct 2005
Posts: 191

PostPosted: Mon Apr 16, 2007 7:15 am    Post subject: Reply with quote

Solved by replace so many 127.0.0.1 with 192.168.X.X.
_________________
AMD64 Desktop
Pentium4 Laptop
Pentium3 Server
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum