Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo on big Wall Display (10kpixels) - X problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Fri Feb 09, 2007 9:24 am    Post subject: Gentoo on big Wall Display (10kpixels) - X problems Reply with quote

Hello you all,

I'm running Gentoo on a display wall. It contains 12 (4x3 - 30inches) screens (2560x1600px each), 6 hp9300 nodes (bi opterons dual cores, 16Gb RAM, with nvidia 4500) to pilot the screens, one other hp9300 to control the others.

Everything works with an infiniband network.

I'm using Xdmx to display a gnome on the wall with :


Code:
 [ebuild   R   ] x11-base/xorg-server-1.2.0  USE="dmx nptl sdl xorg (-3dfx) -debug -dri -ipv6 -kdrive -minimal -xprint" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="-apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 (-i740) -i810 (-impact) (-imstt) -mach64 -mga -neomagic (-newport) (-nsc) -nv -nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo" 9,092 kB


Here are my USE flags :

Code:
USE="xorg -dri -ipv6 -ogg 3dnowext 64bit X a52 aac aalib alsa amd amd64 arts automount avi background bash-completion -bashlogger berkdb bitmap-fonts bl bzip2 cairo chroot cli crypt css cups dbus dga dhcp dlloader dmx dvdread dvi eds elibc_glibc emboss encode esd -ethereal exif fam ffmpeg firefox -flood font-server fortran ftp gdbm gif gkrellm gnome gpm gstreamer gtk gtk2 hal -hddtemp http imagemagick input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog java jfs jpeg kde kernel_linux libg++ mad mikmod mp3 mpeg mpeg2 mmx mplayer ncurses nls nsplugin nptl nptlonly ogg opengl openssh openssl opensslcrypt oss pam pcre pda pdf pdflib perl png ppds pppd python qt3 qt4 quicktime readline reflection reiserfs samba sdl session sftp smp spell spl sse sse2 ssl tcpd tiff truetype truetype-fonts type1-fonts udev unicode userland_GNU vim vnc vorbis win32codecs x11vnc xfs xinerama xinetd xml xv zlib"


Nota bene : I know, I need to erase some.

Here is my Xdmx script :

Code:
#!/bin/bash
CONF=xdmx_wall.cfg

MY_HOME=/root/xdmx/
X_HOME=/usr/X11R6/
DMXINPUT=node01:0

Xdmx=${X_HOME}/bin/Xdmx
X=${X_HOME}/bin/X

${MY_HOME}/killX.sh

sleep 2

for i in `cat $MY_HOME/.nodes | awk '{ print $2 }'`
  do
  echo Connecting to [$i]
  ssh root@$i "rm -rf /tmp/.X*" &
  ssh root@$i "X -ac -c +bs" &
  ssh root@$i "chmod 0666 /dev/nv*" &
done

sleep 5

exec $Xdmx :1 +xinerama -configfile ${MY_HOME}/${CONF} -fontpath "tcp/node08:7100" -depth 24 -param XkbLayout "fr" -input $DMXINPUT -ac -br +bs -norender 2>/dev/null &

export DISPLAY=:1
sleep 1
echo Starting manager &
exec gnome-session &


With this configuration, I have some problems.

First, the refresh is slow. When I move a big window (something around 8000 pixel width), it's not very fluid.

Second, when I try to zoom or move a big (more than 15000 px width) picture in gimp, the refreshment is long. It's not a bandwidth problem (the infiniband bw is quite empty), but it seems to be more a XputImage and XgetImage problem (Xorg internal functions used to send images). I've found that using Xperf and gdb but I'm not a X core hacker, so, it's dificult to detect if it is those function which cause the problem. Maybe it's a gimp way to refresh, because the display is quickest with gkview for example. Does the e17 team works on those optimisations (with imlib2, ecore, .. ) ?

Third, glx doesn't works well. using glxgears, I can get 25 000fps on each node, but 500 fps using the display wall. I know that glxgears is not parallelised, but, 24000 fps it's an huge difference !! So, beryl doesn't works either (just thru the wall, it's ok on each node).

Fourth, every 3D (as openinventor, googleearth..) crash. I cannot understand why. It seems to work with only 3 nodes, but not on 6.

So, a lot of problems, but it's better and better each day.

If somebody have an idea, he's very welcome !

Thanx, and have a nice day,

Greg.

ps : scuse my english..
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Fri Feb 09, 2007 3:57 pm    Post subject: Reply with quote

Can you post these?
Code:
emerge --info

Code:
eix nvidia-drivers

Code:
eix xorg-server

_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Fri Feb 09, 2007 9:24 pm    Post subject: Reply with quote

No problem, I post that back on monday.

Just a part of the answer, I'm using the last nvidia-drivers on each node.

Have a nice weekend !

Greg.
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Mon Feb 12, 2007 8:03 am    Post subject: Reply with quote

Back in front of the wall, here is my "emerge --info" :

Code:
Portage 2.1.2-r4 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.19-gentoo-r4-kuriat x86_64)
=================================================================
System uname: 2.6.19-gentoo-r4-kuriat x86_64 Dual Core AMD Opteron(tm) Processor 285
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 25 Jan 2007 01:47:01 +0000
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.19.2-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texm     f/web2c"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo http://gentoo.mirrors.tera-byte.com http://distfiles.gentoo.org http://www.i     biblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after      --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X a52 aac aalib alsa amd amd64 arts automount avi background bash-completion berkdb bitmap-fonts bl bzip2 cairo ch     root cli cracklib crypt css cups dbus dga dhcp dlloader dmx dvdread dvi eds emboss encode esd exif fam ffmpeg firefox font-se     rver fortran ftp gdbm gif gkrellm gnome gpm gstreamer gtk gtk2 hal http iconv imagemagick isdnlog java jfs jpeg kde libg++ ma     d mikmod mp3 mpeg mpeg2 mplayer ncurses nls nptl nptlonly nsplugin ogg opengl openssh openssl opensslcrypt oss pam pcre pda p     df pdflib perl png ppds pppd python qt3 qt4 quicktime readline reflection reiserfs samba sdl session sftp smp spell spl ssl t     cpd tiff truetype truetype-fonts type1-fonts udev unicode vim vnc vorbis x11vnc xfs xinerama xinetd xml xorg xv zlib" ALSA_CA     RDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0      intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop      empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="     glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtx     orb ncurses text" USERLAND="GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Next, the "eix nvidia-drivers"' :

Code:
[I] x11-drivers/nvidia-drivers
     Available versions:  1.0.8774 1.0.8776 (~)1.0.9631 [M](~)1.0.9742 (~)1.0.9746
     Installed versions:  1.0.9746(11:08:21 01/31/07)(dlloader kernel_linux)
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA X11 driver and GLX libraries


And the "eix xorg-server" :

Code:
[I] x11-base/xorg-server
     Available versions:  1.1.1-r1 1.1.1-r4 (~)1.2.0 [M]*1.2.99.0
     Installed versions:  1.2.0(11:07:51 01/31/07)(-3dfx -debug dmx -dri -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics input_devices_evdev -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick input_devices_keyboard -input_devices_magellan -input_devices_microtouch input_devices_mouse -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_synaptics -input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse -input_devices_void -input_devices_wacom -ipv6 -kdrive -minimal nptl sdl -video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_i810 -video_cards_impact -video_cards_imstt -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc -video_cards_nv -video_cards_nvidia -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vesa -video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo xorg -xprint)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers


Thanx again, and have a nice day (it's rainy here :( ) !

Greg.
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
planet-admin
Apprentice
Apprentice


Joined: 27 Mar 2004
Posts: 212
Location: Boise, ID

PostPosted: Mon Feb 12, 2007 9:25 pm    Post subject: Reply with quote

Whilst off-topic, I just want to say, that's an impressive setup. I wouldn't mind seeing pictures of that.

Michael
_________________
Michael S. Moody
Sr. Systems Engineer
Global Systems Consulting
Web: http://www.GlobalSystemsConsulting.com
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Mon Feb 12, 2007 11:39 pm    Post subject: Reply with quote

you may get improvement from
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="nv nvidia vesa"
in make.conf and nvidia to USE and
Code:
emerge -uDN world

xorg is built with -video_cards_nv -video_cards_nvidia
You may also want your ALSA_CARDS="youralsadriver" statement too.....
_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Tue Feb 13, 2007 9:50 am    Post subject: Reply with quote

Thanx guys

Here is my actual 'make.conf' file :

Code:

CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"
ACCEPT_KEYWORDS="~amd64 amd64"
USE="xorg -dri -ipv6 -ogg -alsa 3dnowext 64bit X a52 aac aalib amd amd64 arts automount avi background bash-completion -bashlogger berkdb bitmap-fonts bl bzip2 cairo chroot cli crypt css cups dbus dga dhcp dlloader dmx dvdread dvi eds elibc_glibc emboss encode esd -ethereal exif fam ffmpeg firefox -flood font-server fortran ftp gdbm gif gkrellm gnome gpm gstreamer gtk gtk2 hal -hddtemp http imagemagick input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog java jfs jpeg kde kernel_linux libg++ mad mikmod mp3 mpeg mpeg2 mmx mplayer ncurses nvidia nls nsplugin nptl nptlonly ogg opengl openssh openssl opensslcrypt oss pam pcre pda pdf pdflib perl png ppds pppd python qt3 qt4 quicktime readline reflection reiserfs samba sdl session sftp smp spell spl sse sse2 ssl tcpd tiff truetype truetype-fonts type1-fonts udev unicode userland_GNU vim vnc vorbis win32codecs x11vnc xfs xinerama xinetd xml xv zlib"
FEATURES="parallel-fetch"

VIDEO_CARDS="nv nvidia vesa"
INPUT_DEVICES="evdev keyboard mouse"
ALSA_CARDS=""


I disabled alsa, because I don't want sound for the moment. Just a fast 2D/3D display ! I put evdev in INPUT_DEVICES because I use USB mouse (accessing with /dev/input), I thinks it's the "evdev purpose" ?

I'm recompiling and I'll give you the results. If you get other ideas, I take them !

Thanx again,

Greg.

@planet-admin : I'll post a picture with a big gentoo logo when the wall will works correctly :)
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
Lloeki
Guru
Guru


Joined: 14 Jun 2006
Posts: 437
Location: France

PostPosted: Tue Feb 13, 2007 9:55 am    Post subject: Reply with quote

did you run 'eselect opengl set nvidia' on all nodes?

and agreed, that's one hell of a setup.
_________________
Moved to using Arch Linux
Life is meant to be lived, not given up...
HOLY COW I'M TOTALLY GOING SO FAST OH F*** ;)
Back to top
View user's profile Send private message
ali3nx
Guru
Guru


Joined: 21 Sep 2003
Posts: 476
Location: Winnipeg, Canada

PostPosted: Tue Feb 13, 2007 10:37 am    Post subject: Reply with quote

Something possibly significant I noticed is you have -dri force excluded in your use flags when it's set by default in the portage profile. That may drastically reduce your xorg performance even with nvidia drivers. it could be worth testing to validate if it is indeed a contributing issue. :?
_________________
Compiling Gentoo since version 1.4
Thousands of Gentoo Installs Completed
Emerged on every continent but Antarctica
Compile long and Prosper!
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Tue Feb 13, 2007 2:21 pm    Post subject: Reply with quote

agreed you probably want dri in USE
_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Tue Feb 13, 2007 2:36 pm    Post subject: Reply with quote

Some (bad) news : No change at all.

Now, my "/etc/make.conf" is like that :

Code:
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"
ACCEPT_KEYWORDS="~amd64 amd64"
USE="xorg -ipv6 -ogg -alsa 3dnowext 64bit X a52 aac aalib amd amd64 arts automount avi background bash-completion -bashlogger berkdb bitmap-fonts bl bzip2 cairo chroot cli crypt css -cups dbus dga dhcp dlloader dmx dvdread dvi eds elibc_glibc emboss encode esd -ethereal exif fam ffmpeg firefox -flood font-server fortran ftp gdbm gif gkrellm gnome gpm gstreamer gtk gtk2 hal -hddtemp http imagemagick input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog java jfs jpeg kde kernel_linux libg++ mad mikmod mp3 mpeg mpeg2 mmx mplayer ncurses nvidia nls nsplugin nptl nptlonly ogg opengl openssh openssl opensslcrypt oss pam pcre pda pdf pdflib perl png ppds pppd python qt4 quicktime readline reflection reiserfs samba sdl session sftp smp spell spl sse sse2 ssl tcpd tiff truetype truetype-fonts type1-fonts udev unicode userland_GNU vim vnc vorbis win32codecs x11vnc xfs xinerama xinetd xml xv zlib"
FEATURES="parallel-fetch"

VIDEO_CARDS="nv nvidia vesa"
INPUT_DEVICES="evdev keyboard mouse"
ALSA_CARDS=""


eix xorg-server gives me :
Code:

[I] x11-base/xorg-server
     Available versions:  1.1.1-r1 1.1.1-r4 (~)1.2.0 [M]*1.2.99.0
     Installed versions:  1.2.0(14:20:33 02/13/07)(-3dfx -debug dmx dri -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics input_devices_evdev -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick input_devices_keyboard -input_devices_magellan -input_devices_microtouch input_devices_mouse -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_synaptics -input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse -input_devices_void -input_devices_wacom -ipv6 -kdrive -minimal nptl sdl -video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_i810 -video_cards_impact -video_cards_imstt -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc video_cards_nv video_cards_nvidia -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l video_cards_vesa -video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo xorg -xprint)


glxgears still returns 500fps on the wall, display (2D or 3D) is still looooonnngg.

I added "eselect opengl set nvidia" in my startxdmx script. But it was on nvidia.

I think I need to clean my USE list too. I'll work on that.
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org


Last edited by iero on Tue Feb 13, 2007 2:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Tue Feb 13, 2007 2:45 pm    Post subject: Reply with quote

Ok, some infos about xorg.conf.

Here is my master node xorg conf (the master just have a dual 20 inches screen) :

Code:

Section "Files"
        FontPath        "unix/:7100"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV45GL [Quadro FX 3400/4400]"
        Driver          "nvidia"
    Option         "ConnectedMonitors" "dfp,dfp"
    Option         "MetaModes" "1600x1200,1600x1200"
    Option         "TwinViewOrientation" "RightOf"
    Option         "TwinView"
    Option          "AllowGLXWithComposite" "true"
EndSection

Section "Monitor"
        Identifier      "Cinema HD"
        VendorName "Generic"
        ModelName "APPLE"
        HorizSync 31.5-160
        VertRefresh 50-160
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV45GL [Quadro FX 3400/4400]"
        Monitor         "Cinema HD"
        DefaultDepth    24

        Subsection "Display"
                depth 24
                Modes "1600x1200"
        EndSubsection
        Option          "AddARGBGLXVisuals" "True"
        Option          "DisableGLXRootClipping" "True"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        Option          "AddARGBGLXVisuals" "True"
        Option          "DisableGLXRootClipping" "True"
EndSection

Section "Extensions"
        Option   "Composite"   "enable"
EndSection


And nodes xorg.conf :

Code:

Section "Files"
        FontPath        "tcp/node0:7100"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "Device0"
        Driver          "nvidia"
        BusID           "PCI:129:0:0"
        Screen          0
EndSection

Section "Device"
        Identifier      "Device1"
        Driver          "nvidia"
        BusID           "PCI:129:0:0"
        Screen          1       
EndSection

Section "Monitor"
        Identifier      "Monitor0"
EndSection

Section "Monitor"
        Identifier      "Monitor1"
EndSection

Section "Screen"
        Identifier      "Screen0"
        Device          "Device0"
        Monitor         "Monitor0"
        DefaultDepth    24

        Subsection "Display"
                depth 24
                Modes "2560x1600"
        EndSubsection
EndSection

Section "Screen"
        Identifier      "Screen1"
        Device          "Device1"
        Monitor         "Monitor1"
        DefaultDepth    24

        Subsection "Display"
                depth 24
                Modes "2560x1600"
        EndSubsection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          0 "Screen0" 0 0
        Screen          "Screen1" LeftOf "Screen0"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection


Some notes :

- I cannot use twinview on the wall because each nvidia quadro 4500 cannot feed 2*"2560x1600" screens in this mode. I will put 4600 cards in the future.
- Screens are 30" dell and not apple, but I didn't change the name in files.
- The font server is working well.

I'm not very good for customising xorg.conf, so maybe some great improvements can be done here. It may be a clue !

Thanx again,

Greg.
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Tue Feb 13, 2007 4:40 pm    Post subject: Re: Gentoo on big Wall Display (10kpixels) - X problems Reply with quote

iero wrote:
Third, glx doesn't works well. using glxgears, I can get 25 000fps on each node, but 500 fps using the display wall.

glxgears is also slower on a single screen, when you enlarge its window. It is not a tool to measure performance, but simply shows that basic OpenGL stuff works.

Given that the number of people running display walls is rather low - and doing so on Gentoo even lower, I'd rather contact university people focussing on 3D visualization, CAE, etc. and Xorg people to track down what the limiting factor in your setup is.


ali3nx wrote:
Something possibly significant I noticed is you have -dri force excluded in your use flags when it's set by default in the portage profile. That may drastically reduce your xorg performance even with nvidia drivers.

How do you come to this idea? The Nvidia drivers don't use DRI at all, so there's no benefit enabling this flag.
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
didl
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 1106
Location: Pittsburgh, PA

PostPosted: Tue Feb 13, 2007 5:02 pm    Post subject: Re: Gentoo on big Wall Display (10kpixels) - X problems Reply with quote

Carlo wrote:

Given that the number of people running display walls is rather low - and doing so on Gentoo even lower, I'd rather contact university people focussing on 3D visualization, CAE, etc. and Xorg people to track down what the limiting factor in your setup is.


I believe NCSA (http://www.ncsa.uiuc.edu) had a a fairly large display wall up and
running at SC2006. Here's a link, maybe it is helpful.
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Tue Feb 13, 2007 5:43 pm    Post subject: Re: Gentoo on big Wall Display (10kpixels) - X problems Reply with quote

Carlo wrote:

How do you come to this idea? The Nvidia drivers don't use DRI at all, so there's no benefit enabling this flag.


I disagree completely with this no matter what you being a Developer or nvidia says and yes i have read it all.
I understand that (Option "DRI" "true") will have no effect because you will get something like
Quote:
(WW) NVIDIA(0): Option "DRI" is not used
without the dri module loaded but the dri module can
be loaded with the 97x nvidia-drivers just fine now.
Quote:
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 7.2.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension XFree86-DRI

However if xorg is not built with dri in USE and I do not have
Code:
Section "DRI"
        Group 0
        Mode 0666
EndSection

In my xorg.conf I experience many video issues that are non-existent when I have It there.
I cannot explain in detail as to why this is "fact" , because I have no idea. but it is.
Even more so when using composite and beryl or compiz but the rendering issues exist the same.
_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Wed Feb 14, 2007 8:56 am    Post subject: Reply with quote

Hi you all,

In fact, there are no project which can display correctly 2D and 3D trough a config like that. I tried a lot of projects (Chromium, IBM products, sage, ..) but no-one can get good performances and some didn't work on large display at all.

The old Xfree 4.3 was able to display 2D and 3D, but there are big regressions (I don't know if "regression" is an english world.. It is used to say "with the new version, things doesn't work anymore".

So, I try to get the maximum of xorg (and Xdmx) and I think that I'm far away from an efficient system (a lot of improvement can be done with configuration and profiling application.. For example, a recent xorg version flooded the network with debug messages..).

Maybe those improvements are not enough, but I'm digging where I can, and I will be proud to get this wall working with gentoo (The old one was in mandriva, and this one was in ubuntu) !

Thanx for any help, and have a nice wake up !

Greg.
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
Lloeki
Guru
Guru


Joined: 14 Jun 2006
Posts: 437
Location: France

PostPosted: Wed Feb 14, 2007 9:49 am    Post subject: Reply with quote

'regression' indeed exists in dev' slang, meaning exactly what you said.

you could always try to ask on the nvidia linux forums.
_________________
Moved to using Arch Linux
Life is meant to be lived, not given up...
HOLY COW I'M TOTALLY GOING SO FAST OH F*** ;)
Back to top
View user's profile Send private message
iero
n00b
n00b


Joined: 02 Jan 2007
Posts: 30

PostPosted: Wed Feb 14, 2007 10:56 am    Post subject: Reply with quote

Lloeki wrote:
'regression' indeed exists in dev' slang, meaning exactly what you said.

you could always try to ask on the nvidia linux forums.


Thanks !

I just asked on the nividia forum. Now; I'm waiting for help. I heard about a gentoo-cluster group and some members who tried to do something like me. I'm looking for this mailing list.

See ya,

Greg.
_________________
Des naïfs ne savaient pas que c'était impossible. Alors ils l'ont fait.

iero - http://www.iero.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum