Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Disk Partition problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
dereky
n00b
n00b


Joined: 30 Jan 2007
Posts: 4

PostPosted: Mon Feb 05, 2007 4:53 am    Post subject: [SOLVED] Disk Partition problem Reply with quote

Hi all,

I've just install Gentoo (kernel 2.4) on my Sun Blade 2000. I have a 73GB FC-AL disk installed, and I set up the disk partitions as such (from fdisk):

Code:
 Disk /dev/sda (Sun disk label): 24 heads, 424 sectors, 14087 cylinders
Units = cylinders of 10176 * 512 bytes

Device Flag    Start       End    Blocks   Id  System
/dev/sda1             0        98    498624   83  Linux native
/dev/sda2  u         98       245    747936   82  Linux swap
/dev/sda3             0     14087  71674656    5  Whole disk
/dev/sda4           245       638   1999584   83  Linux native
/dev/sda5           638      1031   1999584   83  Linux native
/dev/sda6          1031     14087  66428928   83  Linux native


However, when I log in to check with command df, this is my output:

Code:
Filesystem            Size  Used Avail Use% Mounted on
/dev/scsi/host0/bus0/target1/lun0/part1
                      472M   34M  414M   8% /
/dev/scsi/host0/bus0/target1/lun0/part4
                      1.9G  1.3G  530M  71% /usr
/dev/scsi/host0/bus0/target1/lun0/part5
                      1.9G  152M  1.7G   9% /var
/dev/scsi/host0/bus0/target1/lun0/part6
                      1.9G   33M  1.8G   2% /home
shm                  1009M     0 1009M   0% /dev/shm


It shows that /dev/sda6 is only 2G, when according to fdisk it should be 68G! Any ideas what's wrong here?
_________________
-Derek-


Last edited by dereky on Thu Feb 08, 2007 12:05 am; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1753

PostPosted: Mon Feb 05, 2007 6:49 am    Post subject: Reply with quote

I am using fdisk on a SATA system.
Both fdisk and du show the same.

Lately I have seen the same error somewhere else with a scsi system.
Back to top
View user's profile Send private message
dereky
n00b
n00b


Joined: 30 Jan 2007
Posts: 4

PostPosted: Thu Feb 08, 2007 12:04 am    Post subject: [SOLVED] Disk Partitioning problem Reply with quote

Hi all,

Finally solved the issue: forgot to format the partition after creating it! :roll:

Earlier partitioning had sized /dev/sda6 at 2G by mistake. It was only after
[/code]
Code:
mke2fs -j /dev/sda6


was the problem solved.

Sorry for the trouble!
_________________
-Derek-
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1753

PostPosted: Thu Feb 08, 2007 7:42 am    Post subject: Reply with quote

Code:
mke2fs -j /dev/sda6


You should use

Code:
mke2fs -j -O dir_index -O filetype /dev/sda6
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum