Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sun keyboard wasn't working(type5)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
phpasp
n00b
n00b


Joined: 01 Feb 2007
Posts: 1

PostPosted: Thu Feb 01, 2007 8:14 am    Post subject: sun keyboard wasn't working(type5) Reply with quote

Hello all,
pls help me! thx
my console keyboard wasn't working.

Ultra 5 , sun type 5 keyboard

#uname -a
Linux mail 2.6.17-gentoo-r5 #1 Fri Dec 29 10:25:43 CST 2006 sparc64 sun4u GNU/Linux

#cat /etc/conf.d/keymaps
# /etc/conf.d/keymaps
# Use KEYMAP to specify the default console keymap. There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.
KEYMAP="us"
#KEYMAP="sunkeymap"
# Should we first load the 'windowkeys' console keymap? Most x86 users will
# say "yes" here. Note that non-x86 users should leave it as "no".
SET_WINDOWKEYS="no"
# The maps to load for extended keyboards. Most users will leave this as is.
EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"
# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set UNICODE="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`
DUMPKEYS_CHARSET=""


#cat /etc/rc.conf
# /etc/rc.conf: Global startup script configuration settings
# UNICODE specifies whether you want to have UNICODE support in the console.
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
# KEYMAP in the /etc/conf.d/consolefont and /etc/conf.d/keymaps config files.
#KEYMAP="sunt5-us-cz"
EXTENDED_KEYMAPS=
KEYMAP="us"
#KEYMAP="sunkeymap"
UNICODE="yes"
# Set EDITOR to your preferred editor.
# You may use something other than what is listed here.
EDITOR="/bin/nano"
#EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"
# What display manager do you use ? [ xdm | gdm | kdm | entrance ]
#DISPLAYMANAGER="xdm"
# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit. The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to. The support scripts are smart enough to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enlightenment" can also work. This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE: 1) this behaviour is overridden when a ~/.xinitrc exists, and startx
# is called.
# 2) even if ~/.xsession exists, if XSESSION can be resolved, it will
# be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (ex: kde-3.0.2)
# Xsession - will start a terminal and a few other nice apps
#XSESSION="Gnome"

#cat /usr/src/linux/.config
.
.
.
CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ATKBD=y
CONFIG_KEYBOARD_SUNKBD=y
CONFIG_KEYBOARD_LKKBD=y
# CONFIG_KEYBOARD_XTKBD is not set
CONFIG_KEYBOARD_NEWTON=y
CONFIG_INPUT_MOUSE=y
CONFIG_MOUSE_PS2=y
CONFIG_MOUSE_SERIAL=y
CONFIG_MOUSE_VSXXXAA=y
# CONFIG_INPUT_JOYSTICK is not set
# CONFIG_INPUT_TOUCHSCREEN is not set
CONFIG_INPUT_MISC=y
CONFIG_INPUT_SPARCSPKR=y
CONFIG_INPUT_UINPUT=y
.
.
.
.

Thanks && Regards!
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Thu Feb 08, 2007 3:09 pm    Post subject: Reply with quote

A couple things come to mind. First, you shouldn't need to specify KEYMAP=xxx in rc.conf at all. Second, I'm pretty sure "us" is not a unicode font. A quick test of that would be just to use UNICODE="no".

Something else to check is /etc/conf.d/consolefont and play with the entries there (like CONSOLETRANSLATION). I know this has come up before somewhere, and I believe it was unicode related, but I don't recall the solution.

Sorry I don't have a definite solution, but I think checking UNICODE="no" is a good quick test.
Back to top
View user's profile Send private message
rsborn
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2004
Posts: 105
Location: Webster, NY

PostPosted: Fri Feb 09, 2007 11:40 pm    Post subject: Reply with quote

You have almost the exact same config as me except your unicode setup. My unicode is set to NO. There is a note about making sure you have a unicode consolefont so maybe this is your issue. I agree with ferris though, a quick test would be to turn unicode off and see if the keyboard works again.

I have a Ultra 10 with a sun type 6 keyboard (configured as a type 5)

Rick
Back to top
View user's profile Send private message
twalter
n00b
n00b


Joined: 07 Apr 2004
Posts: 62
Location: Bradford, Canada

PostPosted: Mon Feb 26, 2007 1:38 pm    Post subject: Reply with quote

Set your serial drivers to built-in instead of as a module and see if that helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum