Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EID Belgium - How to get it working ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Pol
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2003
Posts: 111

PostPosted: Fri Oct 28, 2005 8:04 am    Post subject: EID Belgium - How to get it working ? Reply with quote

Hello,

Here in Belgium, population get a brand new electronic identity card.

It looks like: http://img489.imageshack.us/img489/8158/carteidentiteelectroniquebelge.jpg

We also received a run time library for windows and Linux avaiable here: http://www.belgium.be/zip/eid_datacapture_fr.html

I'm trying to compile the Linux version but I'm having alot of problem:

Code:

pol@fujitsu1 ~/Desktop/eIDSource_2_3_13/ObjectsMultiPlatform/Platforms/Linux/Base $ make -f MakeFile

gcc -xc++ -Wall -Dlinux -I../../../Include -c -o Thread.o ../../../Src/Base/Thread.cpp
../../../Src/Base/Thread.cpp: In member function `void CThread::Kill()':
../../../Src/Base/Thread.cpp:224: error: `pthread_kill' undeclared (first use this function)
../../../Src/Base/Thread.cpp:224: error: (Each undeclared identifier is reported only once for each function it appears in.)
make: *** [Thread.o] Error 1

pol@fujitsu1 ~/Desktop/eIDSource_2_3_13/ObjectsMultiPlatform/Platforms/Linux/Base $


I'm compiling this to make a software that will allow people to register themselves automatically in a website(php+mysql+java)... I hope it is possible with that ...

If someone know something that could help me...it would be gratefull !

Thanks
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Thu Jun 29, 2006 5:37 pm    Post subject: Reply with quote

I hope this still helps you: www.godot.be
Back to top
View user's profile Send private message
Pol
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2003
Posts: 111

PostPosted: Thu Jun 29, 2006 5:47 pm    Post subject: Reply with quote

Thanks alot ;)
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Mon Aug 14, 2006 4:50 pm    Post subject: Reply with quote

It's possible to get the eID card to work, like this (sorry Pol I'm kinda hijacking your thread):

Normally you should be able to test you smartcard reader + eID card without any software via www.godot.be 's java applets (i.e. http://homes.esat.kuleuven.be/~decockd/wiki/bin/view.cgi/Main/AppletEidCardsUtilityTOC). There are also a lot of links that will bring you to anything that's eID related.

Download the middleware from http://www.belgium.be/zip/Belgian_Identity_Card_Run-time2.5.9.tar.bz2. Unpack it and follow the guide (also an online one). The only problem I had was that I have Qt4 and so qt-mt for Qt3.3 was not detected properly. To solve this comment out the relevant lines in SConstruct, like so:

Code:
 
    # QT
    # FIXME what if QT 4.x installed !?
#    if not conf.CheckPKG('qt-mt >= 3.3.3'):
#        print 'qt-mt >= 3.3.3 not found.'
#        Exit(1)


There is also a typo in the README. This:
Code:
/usr/local/bin/beid-pkcs11-tool -t -l --module /usr/local/lib/beidpkcs11.so
should be this:
Code:
/usr/local/bin/beid-pkcs11-tool -t -l --module /usr/local/lib/libbeidpkcs11.so
.

The init scripts don't seem to work, they will need a conversion to the init system used on gentoo. But ofcourse you could also load he tools manually each time.

Finally, you also need to make Firefox (or another browser) use the smartcard, again see the online guides. Both Evolution (but Thunderbird has) and Openoffice don't have support for PKCS#11 yet in linux, but this will probably change soon.

If you have any questions ask me though I'm totally not an expert.
Back to top
View user's profile Send private message
potens
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2003
Posts: 76
Location: Belgium, world's asshole

PostPosted: Wed Dec 20, 2006 4:27 pm    Post subject: Reply with quote

Hi !
I'm trying to compile the beid-2.5.9 on gentoo but I get an g++ error in the compilation process :
Code:
g++ -o src/eidlib/OpenSCReader.os -c -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -O -DNDEBUG -DNO_DEBUG -I/usr/qt/3/include -I/usr/include/PCSC -Isrc/eidlib -Isrc/newpkcs11/src/include src/eidlib/OpenSCReader.cpp
src/eidlib/OpenSCReader.cpp: In member function `virtual long int COpenSCReader::ReadFile(const unsigned char*, int, unsigned char*, long unsigned int*, BEID_Status*)':
src/eidlib/OpenSCReader.cpp:186: error: cannot convert `unsigned int*' to `size_t*' for argument `4' to `int sc_pkcs15_read_file2(sc_pkcs15_card*, const sc_path*, u8*, size_t*, sc_file**)'
scons: *** [src/eidlib/OpenSCReader.os] Error 1
scons: building terminated because of errors.
make: *** [all] Erreur 2


I've tried to compile it in 32bit mode (I'm in 64bit), 64 bit, whith g++ 3.4.6 and g++ 4.1.1

It seem's you succeed in compiling it, how do you made it ? Did you have to modify the c++ code ?
I have done modification to the SConsctruct file but I don't know anything about C++.
Any help ?

Nicolas
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Wed Dec 20, 2006 11:01 pm    Post subject: Reply with quote

It still compiles here, I'm not doing anything different then you are I suppose. I get:
Code:

g++ -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -O -DNDEBUG -DNO_DEBUG -I/usr/qt/3/include -I/usr/include/PCSC -Isrc/eidlib -Isrc/newpkcs11/src/include -c -o src/eidlib/OpenSCReader.os src/eidlib/OpenSCReader.cpp


This is my ./configure:
Code:
Checking for Python               :  /usr/bin/python
Checking for SCons                :  /usr/bin/scons
calling scons configure with parameters
scons: Reading SConscript files ...
Checking for pkg-config... ok
Checking for libpcsclite >= 1.2.9... ok
Checking for openssl >= 0.9.7... ok
Checking for QApplication qapp(0,0) in C++ library qt-mt... yes
Checking for SSLeay() in C library crypto... yes
Checking for SSL_library_init() in C library ssl... yes
Checking for main() in C library wx_gtk-2.4... no
Checking for main() in C library wx_gtk2u_core-2.6... yes
Checking for C header file openssl/bio.h... yes
Checking for C header file openssl/conf.h... yes
Checking for C header file openssl/ocsp.h... yes
Checking for C header file openssl/ssl.h... yes
Checking for C header file pcsclite.h... yes
Checking for C header file assert.h... yes
Checking for C header file ctype.h... yes
Checking for C header file float.h... yes
Checking for C header file stdarg.h... yes
Checking for C header file stdio.h... yes
Checking for C header file stdlib.h... yes
Checking for C header file string.h... yes
Checking for C++ header file algorithm... yes
Checking for C++ header file map... yes
Checking for C++ header file string... yes
Checking for C++ header file vector... yes
Checking for C header file jni.h... yes


My g++ version is:
Code:
gcc versie 3.4.6 (Gentoo 3.4.6-r1, ssp-3.4.5-1.0, pie-8.7.9)


This is the md5sum of the tarball, compare it:
Code:
md5sum Belgian_Identity_Card_Run-time2.5.9.tar.bz2
00de5e4680ee1508e99ebe3c551ce0a2  Belgian_Identity_Card_Run-time2.5.9.tar.bz2


It might have something to do with you being 64-bit, try to get hold of a 32-bit system to compare.

I also noticed the link for the tarball above is dead: but it should be somewhere on eid.belgium.be, maybe even a newer version??

Good luck!
Back to top
View user's profile Send private message
potens
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2003
Posts: 76
Location: Belgium, world's asshole

PostPosted: Wed Dec 20, 2006 11:18 pm    Post subject: Reply with quote

Thanks for your answer.

my ./configure give me an output different from yours :

where you get
Code:

Checking for main() in C library wx_gtk-2.4... no
Checking for main() in C library wx_gtk2u_core-2.6... yes


I get :

Code:

Checking for main() in C library wx_gtk-2.4... (cached) yes


Very strange, the md5sum is good, must be a 64bit problem (bad luck :'( ), I should try to find
how to mimic a full 32bit env
EDIT: you where right, if I try :
Code:

 gcc32 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -O -DNDEBUG -DNO_DEBUG -I/usr/qt/3/include -I/usr/include/PCSC -Isrc/eidlib -Isrc/newpkcs11/src/include -c -o src/eidlib/OpenSCReader.os src/eidlib/OpenSCReader.cpp

It seems to work. Now, I've to find how to set it for all the compilation.

There is no new version but the old is there :
http://www.belgium.be/zip/Belgian_Identity_Card_Run-time2.5.9.tar.bz2

Tanks a lot,
Nicolas
Back to top
View user's profile Send private message
rhican
n00b
n00b


Joined: 01 Aug 2006
Posts: 9

PostPosted: Mon Dec 25, 2006 3:33 pm    Post subject: Reply with quote

i can't entirely follow the current status of the thread, but i got it running on my 32bit system without any apparant troubles, took me a while before it saw wx_gtk but that's all solved now. so if there is any info you need let me know

kinda fun to see it working ..
Back to top
View user's profile Send private message
kurtsmaze
n00b
n00b


Joined: 11 Jun 2004
Posts: 5
Location: Gent, Belgium

PostPosted: Sat Mar 01, 2008 4:53 pm    Post subject: Reply with quote

hello,

these were my steps to read my Belgian eID card:

Code:

emerge -av ccid
revdep-rebuild --library libpcsclite.so.0
tar -xvf Belgian_Identity_Card_Run-time2.5.9.tar


edit file SConstruct: put QT stuff in comments (otherwise ./configure says qt-mt not found)
edit file src/newpkcs11/src/libopensc/reader-pcsc.c: put #define SCARD_SCOPE_GLOBAL.. in comment, and on line 509, change first parameter of function SCardEstablishContext to : SCARD_SCOPE_USER (otherwise compiler error)

Code:

./configure
make
su
make install
exit
sudo /etc/init.d/pcscd start
beidgui &


finally insert your ID card!

regards,
Kurt
Back to top
View user's profile Send private message
pivertd
Apprentice
Apprentice


Joined: 08 Feb 2004
Posts: 185
Location: Arlon, Belgium

PostPosted: Wed Jun 11, 2008 8:16 pm    Post subject: Reply with quote

Bonsoir,

Il semble que l'on ne trouve plus le fichier Belgian_Identity_Card_Run-time2.5.9.tar

En revanche, on trouve beid-2.6.0

Mais il ne trouve pas qt-mt :

Code:

bart beid-2.6.0 # ./configure
Checking for Python               :  /usr/bin/python
Checking for SCons                :  /usr/bin/scons
calling scons configure with parameters
scons: Reading SConscript files ...
Checking for pkg-config... yes
Checking for qt-mt >= 3.3.3... no
qt-mt >= 3.3.3 not found.
bart beid-2.6.0 # tail config.log
file /home/pivert/Download/beid-2.6.0/SConstruct,line 60:
        Configure(confdir = .sconf_temp)
scons: Configure: Checking for pkg-config...
pkg-config --atleast-pkgconfig-version=0.15.0
scons: Configure: yes

scons: Configure: Checking for qt-mt >= 3.3.3...
pkg-config --exists 'qt-mt >= 3.3.3'
scons: Configure: no

bart beid-2.6.0 # ls -lh /usr/qt/3/lib/libqt*
-rwxr-xr-x 1 root root  799 nov 26  2007 /usr/qt/3/lib/libqt-mt.la
-rw-r--r-- 1 root root  805 nov 26  2007 /usr/qt/3/lib/libqt-mt.prl
lrwxrwxrwx 1 root root   13 déc 30 19:18 /usr/qt/3/lib/libqt-mt.so -> libqt-mt.so.3
lrwxrwxrwx 1 root root   15 déc 30 19:18 /usr/qt/3/lib/libqt-mt.so.3 -> libqt-mt.so.3.3
lrwxrwxrwx 1 root root   17 déc 30 19:18 /usr/qt/3/lib/libqt-mt.so.3.3 -> libqt-mt.so.3.3.8
-rwxr-xr-x 1 root root 7,0M nov 26  2007 /usr/qt/3/lib/libqt-mt.so.3.3.8
lrwxrwxrwx 1 root root   11 déc 30 19:18 /usr/qt/3/lib/libqt.so -> libqt-mt.so
lrwxrwxrwx 1 root root   13 déc 30 19:18 /usr/qt/3/lib/libqt.so.3 -> libqt-mt.so.3
lrwxrwxrwx 1 root root   15 déc 30 19:18 /usr/qt/3/lib/libqt.so.3.3 -> libqt-mt.so.3.3
lrwxrwxrwx 1 root root   17 déc 30 19:18 /usr/qt/3/lib/libqt.so.3.3.8 -> libqt-mt.so.3.3.8


Any idea ?
Back to top
View user's profile Send private message
kurtsmaze
n00b
n00b


Joined: 11 Jun 2004
Posts: 5
Location: Gent, Belgium

PostPosted: Thu Jun 12, 2008 5:44 pm    Post subject: Reply with quote

in file beid-2.6.0/SConstruct, you have to put these three lines in comment:

Code:
#    if not conf.CheckPKG('qt-mt >= 3.3.3'):
#        print 'qt-mt >= 3.3.3 not found.'
#        Exit(1)
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Tue Jul 15, 2008 3:52 pm    Post subject: Reply with quote

There is a similar thread in Dutch: http://forums.gentoo.org/viewtopic.php?p=4749554#4749554 And there is a (by this time slightly old) ebuild on bugs.gentoo.org. Just crossreferencing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum