Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO]New freetype subpixel font rendering for lcd monitors
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Sat Nov 25, 2006 7:54 pm    Post subject: Reply with quote

I have submitted bug here: http://savannah.nongnu.org/bugs/index.php?18374
We will se what happens next :wink:
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
nosebleed
n00b
n00b


Joined: 13 Jan 2004
Posts: 16

PostPosted: Sat Nov 25, 2006 11:17 pm    Post subject: Reply with quote

boniek wrote:
Screenshots? If your fonts don't look as good as in "after" screenshot then obviously you did something wrong :wink: . If they look exactly the same then use what YOU like best. I'm not saying my overlay will satisfy everyone - I did it because I liked the effect and tought some people might like it too. Patches from gentoo's bugzilla and mine are very likely to come from exactly the same source so I don't think this is the problem.


http://nosebleed.info/etc/screens/spr-screen.jpg -- maybe it is just a matter or personal taste... I'm also using autohinting here, and your after screen looked exactly like the sub-pixel rendering with autohinting DISABLED. However, even when I enabled autohinting on the xeffects builds, the fonts didn't look as good as mine do (i.e. check out some of the fonts, and the e for Bitstream Vera Sans at 10pt 96dpi)
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Sun Nov 26, 2006 9:15 pm    Post subject: Reply with quote

Set everything like in point 5 of the guide and rm -rf ~/.fontconfig/
Maybe try to run firefox with: MOZ_DISABLE_PANGO=1 firefox (I don't think disabling pango will help, but it will not hurt to try :wink: )
Your fonts as provided in screenshot looks definetly different from my after screenshot and to me they look a lot worse ( e.g. check Autos link on the left - to me its almost not readable :wink: ).
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
nosebleed
n00b
n00b


Joined: 13 Jan 2004
Posts: 16

PostPosted: Sun Nov 26, 2006 9:32 pm    Post subject: Reply with quote

boniek wrote:
Set everything like in point 5 of the guide and rm -rf ~/.fontconfig/
Maybe try to run firefox with: MOZ_DISABLE_PANGO=1 firefox (I don't think disabling pango will help, but it will not hurt to try :wink: )
Your fonts as provided in screenshot looks definetly different from my after screenshot and to me they look a lot worse ( e.g. check Autos link on the left - to me its almost not readable :wink: ).


Well, it's not just firefox, everything looks the same in every app. Also, my fonts get those annoying red marks around them in spr mode... which I can't stand. With the version I'm using they appear rarely, if at all...

And "Autos" probably looks like that because I don't have autohinting disabled for bold fonts, but it looks fine to ME. What do you think of the non-bolded fonts? Anyway, like I said, it's just a matter of taste, I guess.

EDIT: Here's a screenshot with autohinting disabled for bold fonts: http://nosebleed.info/etc/spr-screen2.png
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Sun Nov 26, 2006 9:57 pm    Post subject: Reply with quote

Yes, you should stick with what your eyes are telling you is the best. YMMV :wink:
Non-bold fonts have too much grey/blue/whatever fringing to my taste. It is strange that you actually had to disable autohinting to get identical bold fonts as I have and you mention red artifacts... none of this is present in my setup so if you followed steps exactly as they are written, there is not much I can do to help you. And if you like your current config then there is no need to help at all. Just enjoy it :wink:

As for latest news concerning ebuild starting from 26.11.2006 snapshot there is new use flag called demos. It installs testing programs from ft2demos when enabled.
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
AaronPPC
Guru
Guru


Joined: 29 May 2005
Posts: 520
Location: Tucson, AZ

PostPosted: Sun Nov 26, 2006 10:08 pm    Post subject: Reply with quote

My fonts look great! Thanks boniek!
_________________
--Aaron
Back to top
View user's profile Send private message
nosebleed
n00b
n00b


Joined: 13 Jan 2004
Posts: 16

PostPosted: Sun Nov 26, 2006 10:09 pm    Post subject: Reply with quote

boniek wrote:
Yes, you should stick with what your eyes are telling you is the best. YMMV :wink:
Non-bold fonts have too much grey/blue/whatever fringing to my taste. It is strange that you actually had to disable autohinting to get identical bold fonts as I have and you mention red artifacts... none of this is present in my setup so if you followed steps exactly as they are written, there is not much I can do to help you. And if you like your current config then there is no need to help at all. Just enjoy it :wink:

As for latest news concerning ebuild starting from 26.11.2006 snapshot there is new use flag called demos. It installs testing programs from ft2demos when enabled.


Thanks, I just noticed that when I updated the overlay, I'm going to try it your way to see if it works better for me. Thanks.

EDIT: FYI, cairo 1.2.6 is out if you intend on updated that ebuild in your overlay ;)
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Mon Nov 27, 2006 8:04 am    Post subject: Reply with quote

I will do so when new cairo will hit ~arch. I believe that less hardmasked packages in our systems is better for our sanity :wink:
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
yagami
Apprentice
Apprentice


Joined: 12 May 2002
Posts: 221
Location: Leiria, Portugal

PostPosted: Mon Nov 27, 2006 11:59 am    Post subject: Reply with quote

well , it is nice ( the newspr ) , but its very very slow rendering text !
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Mon Nov 27, 2006 2:31 pm    Post subject: Reply with quote

Could you post more details? It's all snappy here (athlon xp 1700+, radeon 9500 on floss drivers, xorg 7.1, gnome 2.16).
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
yagami
Apprentice
Apprentice


Joined: 12 May 2002
Posts: 221
Location: Leiria, Portugal

PostPosted: Mon Nov 27, 2006 4:05 pm    Post subject: Reply with quote

with subpixel font rendering , i can see the fonts being drawn ( in menu's and etc )

without it , they are instant and cant be seen being drawn.

i have an nvidia 6600 gt , with nvidia drivers
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Mon Nov 27, 2006 4:36 pm    Post subject: Reply with quote

It seem's like nvidia driver problem to me if you have RENDER acceleration enabled already.
http://www.nvnews.net/vbulletin/showthread.php?t=44317 guys there are having similar problems. If that is the case then I can't really help you, and you should nag Nvidia about it :wink:
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Wed Dec 06, 2006 7:31 pm    Post subject: Reply with quote

mxhost d3n # layman -a xeffects
* Overlay "xeffects" does not exist!


?
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Wed Dec 06, 2006 8:28 pm    Post subject: Reply with quote

deno wrote:
mxhost d3n # layman -a xeffects
* Overlay "xeffects" does not exist!


?


Make sure you have layman -L.. Other than that, the only thing to fix it would be to change the contact attribute check to be off.
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Wed Dec 06, 2006 8:41 pm    Post subject: Reply with quote

Thanks, now it is working.
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Wed Dec 06, 2006 9:27 pm    Post subject: Reply with quote

one more question. how to set smoothing mode to subpixel, hinting mode to medium or full and subpixel order to rgb?
this is my .font.conf file:

?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match target="font" >
<edit mode="assign" name="rgb" >
<const>none</const>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="hinting" >
<bool>true</bool>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="hintstyle" >
<const>hintmedium</const>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="antialias" >
<bool>true</bool>
</edit>
</match>
</fontconfig>

does it look ok?
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Wed Dec 06, 2006 9:46 pm    Post subject: Reply with quote

...eh, i have just noticed that it returned to defaults except 4. line.
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Wed Dec 06, 2006 10:05 pm    Post subject: Reply with quote

i think that i have enabled newspr use flag but when i run

mxhost d3n # emerge -pv cairo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/cairo-1.2.4 USE="X directfb png -doc -glitz -pdf -svg" 0 kB

Total size of downloads: 0 kB
mxhost d3n # emerge -pv freetype

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] media-libs/freetype-2.1.10-r2 USE="zlib -bindist -doc" 0 kB

dont't see that such flag exists.
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Thu Dec 07, 2006 12:26 am    Post subject: Reply with quote

All packages (revelant to this topic) are ~arch, and freetype is M~arch. Unmask freetype in /etc/portage/package.unmask and, if you are using stable tree, set appropriate keywords for corresponding packages in /etc/portage/package.keywords (more details about how to use portage is found here). Also remember to add
Code:
source /usr/portage/local/layman/make.conf

line at the end of your /etc/make.conf to make overlays added by layman visible to emerge.
deno wrote:
one more question. how to set smoothing mode to subpixel, hinting mode to medium or full and subpixel order to rgb?

In Gnome it is in System/Preferences/Font.
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
boniek
Guru
Guru


Joined: 26 Mar 2005
Posts: 373

PostPosted: Thu Dec 07, 2006 12:48 am    Post subject: Reply with quote

Nvidia has problems with performance and antialiased font rendering:
http://lists.freedesktop.org/archives/xorg/2006-December/020265.html
Updated guide a bit to reflect this and added other small things.
_________________
[HOWTO]New freetype subpixel font rendering for lcd monitors
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Thu Dec 07, 2006 10:26 am    Post subject: Reply with quote

Hm in KDE is no such option to set smoothing mode to subpixel, or at least I can't see it. BUT :D this is much much better. thanks!
Back to top
View user's profile Send private message
Bloodsurfer
Guru
Guru


Joined: 07 Dec 2005
Posts: 359
Location: Germany (Saarland)

PostPosted: Fri Dec 08, 2006 8:21 pm    Post subject: Reply with quote

deno wrote:
Hm in KDE is no such option to set smoothing mode to subpixel, or at least I can't see it.

Yes there is, you have to look in your control center under "appearance" and "fonts" or something similar (I use german language and can't give you the exact translation, but it should be something like that). There you can enable it.
_________________
SiberianSniper: my girlfriend's name ends with .c
Clete2: Uber geek! W00t! I'd rather have it end in .cpp... <insert name>.cpp
Dralnu: ...why not <name>.o? Then she's ready for linking...
SiberianSniper: or <name>.ko, so she's ready for insertion?
Back to top
View user's profile Send private message
m42
n00b
n00b


Joined: 03 Aug 2006
Posts: 5

PostPosted: Mon Dec 11, 2006 1:34 pm    Post subject: Reply with quote

In kde, go to the control center. Look under "Appearance & Themes>Fonts" Then click configure next to "Use anti-aliasing fonts". You can enable it from there.

And thanks boniek, these fonts really do look alot better!
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 405

PostPosted: Mon Dec 11, 2006 10:51 pm    Post subject: Reply with quote

m42 wrote:
In kde, go to the control center. Look under "Appearance & Themes>Fonts" Then click configure next to "Use anti-aliasing fonts". You can enable it from there.

And thanks boniek, these fonts really do look alot better!


Anti aliasing fonts... Is that the same as seting smoothing mode to subpixel? If yes, thanks, I did it.
Back to top
View user's profile Send private message
peka
l33t
l33t


Joined: 16 Mar 2005
Posts: 773
Location: Płońsk, Poland

PostPosted: Thu Dec 14, 2006 10:34 pm    Post subject: Reply with quote

Thank You boniek! :)
_________________
p3k4

Seize the time, Meribor. Live now; make now always the most precious time. Now will never come again...
Jean-Luc Picard, Star Trek TNG - The Inner Light
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, ... 28, 29, 30  Next
Page 2 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum