Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IDE Brenner & Co.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
spaci76
n00b
n00b


Joined: 01 Jul 2002
Posts: 55

PostPosted: Sat Jul 06, 2002 11:16 am    Post subject: IDE Brenner & Co. Reply with quote

hi,

also ich hab im kernel scsi-emulation; scsi; aktiviert und auch in den grub hdc=ide-scsi eingetragen

nun wollt ich wissen wo der brenner eingetragen ist "cdrecord -scanbus" doch dann bringt er ne fehlermeldung das er das dev.

cdrecord: No such file or directory. Cannot open /dev/pg*. cannot open SCSI Driver.

in fstab steht der brenner so drin ..

/dev/hdc /mnt/brenner iso9660 noauto,rw

hmm kann mir jemand helfen ..

cu spaci76
:roll:
_________________
"Sein oder nicht sein, das ist hier die Frage"

Radio Jule :: See better R@dio

WebSite: http://www.radio-jule.de
Winamp-Stream : http://live.videomp4.de
Back to top
View user's profile Send private message
franco
n00b
n00b


Joined: 05 Jul 2002
Posts: 20
Location: Jena/Germany

PostPosted: Sat Jul 06, 2002 12:29 pm    Post subject: Reply with quote

Hi,

also /etc/fstab hat AFAIK garnichts mit cdrecord zu tun, sondern ist nur dafuer da, dass man Geraete mounten kann. Mit Deiner Zeile koenntest Du also jetzt

mount /mnt/brenner

machen und er wuerde dann Deine Zeile benutzen und das Geraet (wenn eine gebrannte iso9660 CD drinliegt) mit einer Warnung mounten. Weil rw ja nunmal als Option dort nicht sinnvoll ist. Der CD-Brenner wird ueber generic Device angesprochen. Ich habe fuer meinen SCSI-Brenner damals als Option fuer cdrecord dev 0,3,0 benutzt, also Bus 0, Geraet 3, LUN 0. Vielleicht hilft Dir die Syntax ja weiter...

Gruesse,
Franco
Back to top
View user's profile Send private message
franco
n00b
n00b


Joined: 05 Jul 2002
Posts: 20
Location: Jena/Germany

PostPosted: Sat Jul 06, 2002 2:17 pm    Post subject: Reply with quote

So, Dein /dev/pg* fand ichd ann doch etwas komisch. In /usr/src/linux/Documentation/devices.txt steht dazu folgendes:

97 char Parallel port generic ATAPI interface
0 = /dev/pg0 First parallel port ATAPI device
1 = /dev/pg1 Second parallel port ATAPI device
2 = /dev/pg2 Third parallel port ATAPI device
3 = /dev/pg3 Fourth parallel port ATAPI device

Also irgendwie ist das die falsche Geraeteklasse :) Ich hab mal unter
http://www.tldp.org/HOWTO/CD-Writing-HOWTO.html etwas herumgestoebert, aber nachdem was Du so geschrieben hast, scheinst Du die Quelle ja schon zu nutzen. u.a. steht da drin, dass Du ueber den Scsi-Treiber Dein CD-Laufwerk (hdc) ueber /dev/scd0 ansprechen koennen muesstest. Kannst ja mal schauen, ob wenigstens das klappt. Dann funktioniert schonmal die Emulation.

Hast Du Scsi-Unterstuetzung und Emulation fest in den Kernel eingebaut oder als Module? Soweit ich weiss brauchst Du in der Scsi-Sektion zB auch SCSI Generic Support, weil der Brenner zum Schreiben ja ueber /dev/sg* angesprochen wird und nicht als Platte /dev/sd* oder CDROM /dev/scd*.

Interessant in der CD-Writing HOWTO sind auch die Zeilen fuer /etc/modules.conf. Ich denke, da wirst Du auch noch was anpassen muessen. Ansonsten kannst Du einfach mal versuchen, mit cdrecord dev=0,x,0 die Geraetenummern mal durchzuprobieren (0-6). Vielleicht findest Du den Brenner ja schon...

Falls mir nochwas einfaellt, meld ich mich nochmal :)

Gruesse,
Franco
Back to top
View user's profile Send private message
maystorm
Apprentice
Apprentice


Joined: 02 Jun 2002
Posts: 213
Location: Germany, not far away

PostPosted: Sat Jul 06, 2002 2:44 pm    Post subject: Reply with quote

Damit cdrecord bei mir funzt, müssen folgende Module geladen sein:

Code:
sg                     24196   0 (autoclean)
sr_mod                 11576   0 (autoclean) (unused)
ide-scsi                7424   0
scsi_mod               51996   3 [sg sr_mod ide-scsi]


Haste die auch?
_________________
Linux user #216018
Back to top
View user's profile Send private message
franco
n00b
n00b


Joined: 05 Jul 2002
Posts: 20
Location: Jena/Germany

PostPosted: Sat Jul 06, 2002 2:53 pm    Post subject: Reply with quote

Hi,

ich denke, der entscheidende Tip kommt aus:

/var/tmp/portage/cdrtools-1.11.24/work/cdrtools-1.11/README.ATAPI

Dort steht, dass man dev=ATAPI: benutzen soll. Und seit dem klappt es bei mir auch, also zB:

playstation linux # cdrecord -scanbus dev=ATAPI:
Cdrecord 1.11a24 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
WARNING: device not valid, trying to use default target...
scsidev: 'ATAPI:'
devname: 'ATAPI'
scsibus: 0 target: 6 lun: 0
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.6'
scsibus0:
0,0,0 0) 'TOSHIBA ' 'CD-ROM XM-6702B ' '1007' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
playstation linux #

Ich koennte also offenbar mit

cdrecord dev=ATAPI:0,0,0 image.iso

CDs brennen (wenn das ein Brenner waere).

Hoffe, das hilft.

Gruesse,
Franco
Back to top
View user's profile Send private message
Paidhi
n00b
n00b


Joined: 11 Jun 2002
Posts: 47
Location: Vienna, Austria

PostPosted: Sat Jul 06, 2002 4:27 pm    Post subject: Re: IDE Brenner & Co. Reply with quote

Hi!

Ich hatte auch Probleme mit meinem Brenner. Mit der selben Fehlermeldung.
Bei mir war's die /etc/devfsd.conf

Ich habe u.a. folgende Einträge:

Code:

# Give the cdrw group write permissions to /dev/sg0
# This is done to have non root user use the burner (scan the scsi bus)
REGISTER        ^sg0$       PERMISSIONS root.cdrw 660


# General note for the following auto creation of symlinks:
#
#    If you change the device that the symlink points to,
#    you should also remove the symlink before restarting
#    devfsd

# Create /dev/cdrom for the first cdrom drive
LOOKUP          ^cdrom$          CFUNCTION GLOBAL mksymlink cdroms/cdrom0 cdrom
REGISTER        ^cdrom/cdrom0$   CFUNCTION GLOBAL mksymlink $devname cdrom
UNREGISTER      ^cdrom/cdrom0$   CFUNCTION GLOBAL unlink cdrom


# Create /dev/dvd for the second cdrom drive
# (change 'cdroms/cdrom1' to suite your setup)
LOOKUP          ^dvd$           CFUNCTION GLOBAL mksymlink cdroms/cdrom0 dvd
REGISTER        ^cdrom/cdrom0$  CFUNCTION GLOBAL mksymlink $devname dvd
UNREGISTER      ^cdrom/cdrom0$  CFUNCTION GLOBAL unlink dvd

# Create /dev/cdrw for the first cdrom on the scsi bus
# (change 'sr0' to suite your setup)
LOOKUP          ^cdrw$          CFUNCTION GLOBAL mksymlink sr0 cdrw
REGISTER        ^sr0$           CFUNCTION GLOBAL mksymlink $devname cdrw
UNREGISTER      ^sr0$           CFUNCTION GLOBAL unlink cdrw


Den entscheidenden Tip habe ich mir aus dem Forum geholt. Weiß nicht mehr genau welcher Thread. Wirf einfach mal <Search> an.


-Paidhi-
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum