Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The right way to fix my environment...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mverrilli
n00b
n00b


Joined: 04 Jul 2002
Posts: 40
Location: Atlanta, GA

PostPosted: Fri Jul 05, 2002 5:51 pm    Post subject: The right way to fix my environment... Reply with quote

Ok, I finally figured out why a lot of my python and java apps aren't running properly. I've been running them from Konsole...

I telnetted back to myself, logged in, set my DISPLAY, and all my python/java programs are running now. So I assume my environment isn't correct in a regular shell, but it is correct in telnet/ssh.

So my questions are...

1. Is it not normal to want to drop a shell and run an X app?

2. I assume it is, so what is the proper way to fix my environment so it matches that of when I log in through telnet or ssh?
Back to top
View user's profile Send private message
Guest






PostPosted: Fri Jul 05, 2002 6:25 pm    Post subject: Re: The right way to fix my environment... Reply with quote

Since it sounds like you use kde, please look at this thread:
http://forums.gentoo.org/viewtopic.php?t=7060
mverrilli wrote:
Ok, I finally figured out why a lot of my python and java apps aren't running properly. I've been running them from Konsole...

I telnetted back to myself, logged in, set my DISPLAY, and all my python/java programs are running now. So I assume my environment isn't correct in a regular shell, but it is correct in telnet/ssh.

So my questions are...

1. Is it not normal to want to drop a shell and run an X app?

2. I assume it is, so what is the proper way to fix my environment so it matches that of when I log in through telnet or ssh?
Back to top
mverrilli
n00b
n00b


Joined: 04 Jul 2002
Posts: 40
Location: Atlanta, GA

PostPosted: Fri Jul 05, 2002 8:47 pm    Post subject: Reply with quote

That fixed a lot of my problems. Python programs are working perfectly, java programs are well... not working, but getting further along than what they were. I'll post a second thread on my java issue.

By the way, for forum's search engine's sake, I was getting a Segmentation Fault in python whenever running programs that used wxPython. And in java, I was getting exceptions all over the place (missing classes, TargetInvocationException, etc).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum