Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[hme] onboard hme ethernet issues (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
Adrien
Advocate
Advocate


Joined: 13 Jul 2004
Posts: 2249
Location: Paris - France

PostPosted: Tue Aug 22, 2006 9:10 pm    Post subject: [hme] onboard hme ethernet issues (solved) Reply with quote

Hi again! :)
I'm experiencing problems at the moment with my happy meal onboard ethernet.
When it's under high load, the interface suddenly stops working to the point I have to restart it with /etc/init.d/net.eth0 restart. For example when downloading a "big" package (more than 3 Mb) the download suddenly stops and I can't even ping anything if I don't restart it. Otherwise, the NIC seems to work fine when there are no big data transfers.
I disabled it for the moment (using my quad ethernet instead) but found out some people have the same problem:
Code:
NETDEV WATCHDOG: eth0: transmit timed out
eth0: transmit timed out, restting
eth0: Happy Status 03010000 TX[000003ff:00000101]
eth0: Link is up using internal tranceiver at 100Mb/s, Half Duplex


I've heard there's a similar well-know and fixed bug on ultra 1 stations with onboard hme. There's even a kernel USE flag allowing to fix it on ultra 1 but it didn't work for me:

[ebuild R ] sys-kernel/sparc-sources-2.4.32-r6 USE="-build -livecd -symlink -ultra1*" 0 kB

I also tried the patch proposed in the link but I'm not to sure about the command that should be run for this, I tried with patch -Np0 and it didn't work either.

Any hints/fixes for this?


Last edited by Adrien on Fri Aug 25, 2006 12:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Wed Aug 23, 2006 1:44 am    Post subject: Reply with quote

You have to enable the Ultra 1 use flag to get the patch. Based on what you posted, it is currently disabled.
Back to top
View user's profile Send private message
Adrien
Advocate
Advocate


Joined: 13 Jul 2004
Posts: 2249
Location: Paris - France

PostPosted: Wed Aug 23, 2006 10:37 am    Post subject: Reply with quote

Weeve wrote:
You have to enable the Ultra 1 use flag to get the patch. Based on what you posted, it is currently disabled.

:lol: Yeah! I know, 'cause I disabled it again after I tried. But even when enabling the flag and completely reinstalling and recompiling the kernel, it didn't work either, at least on parc-sources-2.4. I should try with 2.6 though. :roll:
Just in case it wouldn't work with 2.6, any other hints? :)

EDIT: Does not work with 2.6 :cry:
EDIT2: Dead switch....that's why! :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum