Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ahtlon-tbird
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
nempo
Guru
Guru


Joined: 16 Apr 2002
Posts: 360
Location: Linkoping, Sweden

PostPosted: Mon Jul 01, 2002 12:33 pm    Post subject: ahtlon-tbird Reply with quote

Maybe this isnt a gcc3 problem but you cant finish bootstrap with the 'athlon-tbird' cflag. It failes somewhere saying that flag is valid to c++ but not the 'current' language (?).
Back to top
View user's profile Send private message
abhishek
Retired Dev
Retired Dev


Joined: 28 Jun 2002
Posts: 393
Location: Los Angeles, CA

PostPosted: Mon Jul 01, 2002 4:56 pm    Post subject: Reply with quote

I compiled with
Code:

CFLAGS="-march=athlon-tbird -O3"
CXXFLAGS="-march=athlon-tbird -O3"
Back to top
View user's profile Send private message
nempo
Guru
Guru


Joined: 16 Apr 2002
Posts: 360
Location: Linkoping, Sweden

PostPosted: Tue Jul 02, 2002 12:41 am    Post subject: Reply with quote

hmm, thats strange.
Back to top
View user's profile Send private message
dook43
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2002
Posts: 114
Location: Baton Rouge, LA

PostPosted: Tue Jul 02, 2002 1:27 am    Post subject: :o Reply with quote

flags:

CFLAGS="-march=athlon-tbird -m3dnow -mmmx -O3 -pipe"
CXXFLAGS="-march=athlon-tbird -m3dnow -mmmx -O3 -pipe"
_________________
"We who are about to die salute you!"
Back to top
View user's profile Send private message
Pigeon
Guru
Guru


Joined: 21 Jun 2002
Posts: 307

PostPosted: Tue Jul 02, 2002 4:11 pm    Post subject: Reply with quote

"-march=athlon-tbird -m3dnow -mmmx -fomit-frame-pointer -O3 -pipe" works fine here....

are you sure you're using "-march=athlon-tbird" or "-mcpu=athlon-tbird"? "-athlon-tbird" won't work. (despite the fact things like "-pentium2" or "-pentiumpro" will work)

It would be nice to know your entire cflags/cxxflags...
Back to top
View user's profile Send private message
nempo
Guru
Guru


Joined: 16 Apr 2002
Posts: 360
Location: Linkoping, Sweden

PostPosted: Tue Jul 02, 2002 11:53 pm    Post subject: Reply with quote

im sure, well, im not using it atm cause it failed on me the last time, running with march=i686 now.
Back to top
View user's profile Send private message
abhishek
Retired Dev
Retired Dev


Joined: 28 Jun 2002
Posts: 393
Location: Los Angeles, CA

PostPosted: Wed Jul 03, 2002 12:17 am    Post subject: Reply with quote

here it is:
Code:

# Pentium Pro/Pentium II/Pentium III+/Pentium 4/Athlon exclusive (binaries
# will use the P6 instruction set and only run on P6+ systems)
CHOST="i686-pc-linux-gnu"
CFLAGS="-march=athlon-tbird -O3 -pipe"
CXXFLAGS="-march=athlon-tbird -O3 -pipe"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum