Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ipw3945 wireless drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 30, 31, 32  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
YourDoom123
Apprentice
Apprentice


Joined: 06 Mar 2004
Posts: 163

PostPosted: Mon Jun 05, 2006 3:05 am    Post subject: Reply with quote

yep... no joy. again, any help is apreciated..
_________________
Acer Aspire 5672
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Mon Jun 05, 2006 3:06 pm    Post subject: Reply with quote

Since GCC 4.x is currently either masked or unstable, I'd recommend at least trying with the latest stable version, 3.4.6-r1.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
YourDoom123
Apprentice
Apprentice


Joined: 06 Mar 2004
Posts: 163

PostPosted: Mon Jun 05, 2006 9:33 pm    Post subject: Reply with quote

wait what? gcc 4.1 made is in portage now. Its no longer masked, at least, I don't think so. I'll try 3.4.6, but idk...
_________________
Acer Aspire 5672
Back to top
View user's profile Send private message
dmartinsca
Guru
Guru


Joined: 09 Dec 2005
Posts: 303
Location: Ontario, Canada

PostPosted: Tue Jun 06, 2006 12:46 am    Post subject: Reply with quote

gcc-3.4.6-r1 is the latest stable version, 4.1.0-r1 and 4.1.1 are both in testing for x86
Back to top
View user's profile Send private message
th1nk3r
n00b
n00b


Joined: 04 Dec 2003
Posts: 15
Location: Valencia (Spain)

PostPosted: Tue Jun 06, 2006 4:14 pm    Post subject: Working Reply with quote

Works for me in my Asus A6J with:

- gentoo-sources-2.6.16-r9
- gcc-4.1.1
- baselayout-1.12.0-r1
- ieee80211-1.1.13-r1
- ipw3945-1.0.5
- ipw3945d-1.7.18
- ipw3945-ucode-1.13

There is only a bug with the wifi led. When connect to the AP, the wifi led starts blinking very fast and only stops if I disconnect the wifi. Anybody knows how to stop the blinking?
Thanks
_________________
GCS d- s:+ a- C++++ UL+++ P+ L+++ E- W+++ N+ o K++ w-- O- M- V-- PS+ PE- Y++ PGP+ t-- 5- X++ R+++ tv- b+ DI+++ D++ G-- e* h++ r++ z+++
Back to top
View user's profile Send private message
antoine_
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2006
Posts: 103
Location: Paris ou Bordeaux

PostPosted: Thu Jun 08, 2006 9:32 pm    Post subject: Reply with quote

Hi
I have a laptop with an Intel 3945 card.
I installed the drivers, as said in this thread. It worked. Now, I can load the module :

Code:

mini_syrt linux # modprobe ipw3945
mini_syrt linux # lsmod
Module                  Size  Used by
ipw3945               124584  -
[...]


I also launch the daemon :

Code:

mini_syrt linux # ipw3945d
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.18
Intel PRO/Wireless 3945ABG Network Connection found at:
 /sys/bus/pci/drivers/ipw3945/0000:02:00.0
Daemon launched as pid 27775.  Exiting.


But iwconfig does not show me any wireless interface :

Code:

mini_syrt linux # iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

sit0      no wireless extensions.

ip6tnl0   no wireless extensions.


I have no idea about what to do. Any hints ?

Thanks !
Back to top
View user's profile Send private message
dmartinsca
Guru
Guru


Joined: 09 Dec 2005
Posts: 303
Location: Ontario, Canada

PostPosted: Mon Jun 12, 2006 9:41 pm    Post subject: Reply with quote

Is eth0 your wireless card? I would guess not. Try ifconfig eth1 up - normally this is handled by /etc/init.d/net.*
Back to top
View user's profile Send private message
viniciusferrao
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2005
Posts: 83

PostPosted: Tue Jun 13, 2006 5:18 pm    Post subject: Reply with quote

agnitio wrote:
I've had the same problem on my Asus A6J. My solution was a simple init-script that started the daemon:

/etc/init.d/ipw3945d:
Code:

#!/sbin/runscript
depend() {
        before net
}

start() {
        ebegin "Starting ipw3945d"
        start-stop-daemon --start --quiet --exec /sbin/ipw3945d
        eend $?
}

stop() {
        ebegin "Stopping ipw3945d"
        start-stop-daemon --stop --quiet --pidfile /var/run/ipw3945d.pid
        eend $?
}


I'm not sure I got the depend part right though because it seems it does not start until after my network interfaces, although it's early enough to make stuff work.


I'm using your script, and this works perfectly!
Back to top
View user's profile Send private message
gtranche
n00b
n00b


Joined: 29 May 2006
Posts: 11

PostPosted: Wed Jun 14, 2006 8:46 pm    Post subject: Reply with quote

hi,
first, sorry for my poor english.
i have some problems with my ipw3945

i can load the module,
the daemon start perfectly
but with my netgear router, i have after 10 15 minutes a disconnection
and in my dmesg i have this:

ipw3945: Error sending cmd #08 to daemon: time out after 500ms.

i have to reboot my computer to have this worked.

On another router ( livebox ) i do not have any problem.
I have tested the 1.0.3 and the 1.0.5 driver

any one have an idea?
thanks
Back to top
View user's profile Send private message
Aesthetics
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2004
Posts: 91

PostPosted: Wed Jun 21, 2006 4:52 pm    Post subject: Reply with quote

excuse me, it's possible to load ipw3945d at boot?
because i must launch ipw3945d always in console when i want to use wireless
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Wed Jun 21, 2006 5:02 pm    Post subject: Reply with quote

Aesthetics wrote:
excuse me, it's possible to load ipw3945d at boot?
because i must launch ipw3945d always in console when i want to use wireless

Sure. Make sure /etc/modules.d/ipw3945d says:
Code:
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945  /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945

However it seems many people see it doesn't always work. It does on my laptop so you might give it a try. Just make sure you have the latest version of wireless-tools, baselayout, udev and kernel.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”


Last edited by VinzC on Thu Jun 29, 2006 8:58 am; edited 1 time in total
Back to top
View user's profile Send private message
Aesthetics
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2004
Posts: 91

PostPosted: Wed Jun 21, 2006 5:20 pm    Post subject: Reply with quote

i've test it and it doesn't work :(
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Thu Jun 22, 2006 5:27 am    Post subject: Reply with quote

So see viniciusferrao's above post.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Thu Jun 29, 2006 8:00 am    Post subject: Freeze on a Dell i9400 laptop when closing the lid Reply with quote

I have a big freeze when I close the lid if both the following conditions are true:
  • WiFi is active
  • the current console is in graphics mode (Xorg)
If I switch to a text console and close the lid the laptop doesn't hang. If I disable the WiFi (Fn+F2) the laptop doesn't freeze either. If I enable WiFi and switch to XOrg and close the lid the computer freezes and the screen remains black when reopened. I must power off the computer.

I have a Dell Inspiron 9400, Xorg-7.0-r1, ipw3945-1.0.5, ipw3945-ucode-1.13 and ipw3945d-1.7.18. Did anyone run into the same trouble?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Thu Jun 29, 2006 8:54 am    Post subject: Reply with quote

For your information

I found an unexpected file in /etc/modules.d/: ipw3945d (mind the ending d). Its content is as follows:
Code:
# cat /etc/modules.d/ipw3945d
install ipw3945 /sbin/modprobe --ignore-install ipw3945; sleep 0.5; /sbin/ipw3945d --quiet
remove ipw3945 /sbin/ipw3945d --kill; /sbin/modprobe -r --ignore-remove ipw3945

It looks like portage's ipw3945 (not my ebuild) does put that file there to address Intel's recommendations on loading the regulatory daemon automatically:
Code:
# equery b ipw3945d
[ Searching for file(s) ipw3945d in *... ]
net-wireless/ipw3945d-1.7.18 (/etc/modules.d/ipw3945d)
net-wireless/ipw3945d-1.7.18 (/sbin/ipw3945d)


To all people who reported the daemon doesn't automatically load at boot

... ignore the line where you're told to add the above lines to /etc/modules.d/ipw3945. Don't change that file and use the defaults instead. After a couple of tests, it turns out the daemon is responsible for bringing up the interface when pressing Fn+F2 (aka the RF-Kill switch) to turn WiFi back on. The module doesn't load automatically when WiFi comes back on if the regulatory deamon is not running.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Stormblazer
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2005
Posts: 76
Location: Colorado

PostPosted: Tue Jul 04, 2006 9:17 pm    Post subject: Reply with quote

Working great with an HP Pavillion dv5000, even the wifi on/off switch works.

My only complaint is that if the wifi switch was set to off on boot, and i try to load the daemon, and I'm in range of an encrypted network, the keyboard stops responding completely.
_________________
The vast majority of errors are stupid mistakes that you end up kicking yourself for later.
Back to top
View user's profile Send private message
iplayfast
l33t
l33t


Joined: 08 Jul 2002
Posts: 642
Location: Cambridge On,CA

PostPosted: Thu Jul 06, 2006 8:25 pm    Post subject: Reply with quote

Fn-F2 starts the led doing a slow flash (once a second) but my computer seems locked up.
After rebooting...

lsmod shows
eth1394
ipw3945
ohci1394

ifconfig shows eth0 eth1 and lo
eth1 (the wireless) shows
Link encap:UNSPEC


running /sbin/ipw3945d
looks happy

ifconfig shows no change

iwconfig shows
lo no wireless extensions.
eth0 no wireless extensions.
eth1 no wireless extensions.

dmesg shows (at the end)
ipw3945: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.


Any ideas?
Back to top
View user's profile Send private message
agnitio
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2004
Posts: 136

PostPosted: Mon Jul 17, 2006 8:17 pm    Post subject: Reply with quote

My ipw3945 recently stopped working. I updated to the latest version 1.1.0_pre2 and also the latest ipw3945d. Now my computer hard freezes whenever ipw3945d is loaded. I tried downgrading both the driver and the daemon but the error persists, wich suggests that there is something else causing the problem. Probably after my last sync/update. Has anyone else been having problems with the driver recently?
As of now I can't get any debug info. /var/log/messages remains untouched and since the computer freezes entirely I can't read dmesg. I don't have a clue what to do.
Back to top
View user's profile Send private message
iplayfast
l33t
l33t


Joined: 08 Jul 2002
Posts: 642
Location: Cambridge On,CA

PostPosted: Mon Jul 17, 2006 8:24 pm    Post subject: Reply with quote

If you go on the site and get their drivers manually you can get newer versions which don't hang your system. I can't get it to work (never have) but at least your system won't hang.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Wed Jul 19, 2006 12:26 pm    Post subject: Reply with quote

agnitio wrote:
My ipw3945 recently stopped working. I updated to the latest version 1.1.0_pre2 and also the latest ipw3945d. Now my computer hard freezes whenever ipw3945d is loaded. I tried downgrading both the driver and the daemon but the error persists, wich suggests that there is something else causing the problem. Probably after my last sync/update. Has anyone else been having problems with the driver recently?

Since the drivers are in portage I always used the stable versions and experienced no problems of this kind. Here's what I have now:
Code:
$ equery l ipw
[ Searching for package 'ipw' in all categories among: ]
 * installed packages
[I--] [  ] net-wireless/ipw3945-1.0.5 (0)
[I--] [  ] net-wireless/ipw3945-ucode-1.13 (0)
[I--] [  ] net-wireless/ipw3945d-1.7.18 (0)

Code:
$ equery l baselayout
[ Searching for package 'baselayout' in all categories among: ]
 * installed packages
[I--] [ ~] sys-apps/baselayout-1.12.1 (0)

Code:
$ equery l wireless
[ Searching for package 'wireless' in all categories among: ]
 * installed packages
[I--] [  ] net-wireless/wireless-tools-28 (0)

_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
emitrax
Apprentice
Apprentice


Joined: 03 Nov 2004
Posts: 166

PostPosted: Wed Jul 19, 2006 2:56 pm    Post subject: Reply with quote

I did too have problems loading the ipw3945 after an update of the system. The problem was due to hotplug , so I fixed the problem by running the following command as someone suggested in this thread
Code:

echo `which hotplug` > /proc/sys/kernel/hotplug


The module now load no problems, but no new interface is created. I get the following from the kernel

Code:
[4299079.094000] ipw3945: Radio Frequency Kill Switch is On:
[4299079.094000] Kill switch must be turned off for wireless networking to work.


Thanks in advance for your help
emitrax
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Wed Jul 19, 2006 3:55 pm    Post subject: Reply with quote

iplayfast wrote:
ipw3945: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.

emitrax wrote:
[4299079.094000] ipw3945: Radio Frequency Kill Switch is On:
[4299079.094000] Kill switch must be turned off for wireless networking to work.

And then there were two... :roll:

On my laptop:
Code:
# cat /proc/sys/kernel/hotplug

# which hotplug
/sbin/hotplug

BTW: what version of udev do you both use? I'm running udev-079-r2 (I have masked udev-087*).
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
emitrax
Apprentice
Apprentice


Joined: 03 Nov 2004
Posts: 166

PostPosted: Wed Jul 19, 2006 4:04 pm    Post subject: Reply with quote

udev 087-r1

I don't know where to put the echo command to fix hotplug. I tried in the start script of the ipw3945 script that somebody suggest, but I'm looking for a better solution.

I still don't know how to disable the "kill switch" in order to make the card working.

EDIT: Problem solved. After I set some of the special keys with gnome keyshorcuts, fn+F2 starts working. May it be a coincidence?

Thanks for your help.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4683
Location: Theux (Belgium)

PostPosted: Thu Jul 20, 2006 9:03 am    Post subject: Reply with quote

emitrax wrote:
udev 087-r1

If you can bear the UDEV warning message at boot, it's Ok.

emitrax wrote:
I don't know where to put the echo command to fix hotplug. I tried in the start script of the ipw3945 script that somebody suggest, but I'm looking for a better solution.

Well I don't know either for I never had to fix hotplug. About the init script, yes, it should be not required. The daemon should load automagically. The only explanation that makes sense is that Intel prerequisites are not met with at least one of these packages: wireless-tools, kernel sources and version, ieee80211 version, baselayout.

emitrax wrote:
I still don't know how to disable the "kill switch" in order to make the card working.

EDIT: Problem solved. After I set some of the special keys with gnome keyshorcuts, fn+F2 starts working. May it be a coincidence?

Thanks for your help.

The fixes that I saw with Google were to disable the Kill-Switch using the BIOS. I never had to do such manipulation on my Dell i9k4. I'm glad it works for you now.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
inode77
Veteran
Veteran


Joined: 20 Jan 2004
Posts: 1303
Location: Heart of Europe

PostPosted: Tue Jul 25, 2006 11:40 am    Post subject: Reply with quote

antoine_ wrote:
Hi
I have a laptop with an Intel 3945 card.
I installed the drivers, as said in this thread. It worked. Now, I can load the module :

Code:

mini_syrt linux # modprobe ipw3945
mini_syrt linux # lsmod
Module                  Size  Used by
ipw3945               124584  -
[...]


I also launch the daemon :

Code:

mini_syrt linux # ipw3945d
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.18
Intel PRO/Wireless 3945ABG Network Connection found at:
 /sys/bus/pci/drivers/ipw3945/0000:02:00.0
Daemon launched as pid 27775.  Exiting.


But iwconfig does not show me any wireless interface :

Code:

mini_syrt linux # iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

sit0      no wireless extensions.

ip6tnl0   no wireless extensions.


I have no idea about what to do. Any hints ?

Thanks !


Check if you've got wireless support enabled in your kernel.
Code:
CONFIG_NET_WIRELESS=y
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 30, 31, 32  Next
Page 8 of 32

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum