Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[astuce] Eviter le démarrage automatique des services net
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sebtx
Tux's lil' helper
Tux's lil' helper


Joined: 02 Nov 2005
Posts: 131
Location: France, Eure-et-loir

PostPosted: Fri Jun 23, 2006 7:49 pm    Post subject: [astuce] Eviter le démarrage automatique des services net Reply with quote

Salut à vous gentooistes :)

Ce post a pour but d'aider ceux qui sont confrontés au problème que j'ai eu lors de mes derniers updates.
En effet depuis quelques temps, un message du type "Device initiated services: net.eth0, net.wlan0" apparaissait au boot. Peu après,
les services net.eth0 et net.wlan0 démarraient tout seul alors que je ne voulais pas que ça soit le cas. La solution est dans la partie anglophone de ce forum. Mais comme tout le monde n'est pas à l'aise avec cette langue,
je poste ici la solution, en espérant que ça aide pas mal de monde.

En fait, pour éviter le lancement de ces services, il suffit d'éditer /etc/conf.d/rc
Code:
nano /etc/conf.d/rc

et de remplacer
Code:
RC_COLDPLUG="yes"
par
Code:
RC_COLDPLUG="no"

Une fois ce changement effectué, au prochain reboot, plus de problème avec les services qui se lancent tout seuls.

En espérant que ce post n'est pas inutile pour tout le monde :p
_________________
Linux gigalaptop 2.6.21-suspend2-r5 #5 SMP PREEMPT Thu May 31 23:32:15 UTC 2007 i686 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Fri Jun 23, 2006 10:45 pm    Post subject: Reply with quote

ca tombe bien, j'allais jsutement bientot me pencher sur la question ^^

Merci bien :D
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 899
Location: France

PostPosted: Fri Jun 23, 2006 10:49 pm    Post subject: Reply with quote

Génial l'astuce.
Sur une config, j'ai fait le bourain et modifié les script a la main pour éviter de le lancer.

Par contre, la poster dans le bon forum aurait été mieux.
Back to top
View user's profile Send private message
mardi_soir
Apprentice
Apprentice


Joined: 08 Dec 2004
Posts: 215

PostPosted: Sat Jun 24, 2006 1:33 am    Post subject: Reply with quote

salut !

je ne sais pas si c'ets très "propre" mais je deplace pour ma part les liens presents dans /etc/init.d/ que je ne veux pas lancer dans .. /root/services_deplacés/
ca marche aussi.. (genre les net.XXX qui font chier )

voilà !

sinon je prend note de la technique sus mentionée
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3756
Location: Lyon, France

PostPosted: Sat Jun 24, 2006 7:01 am    Post subject: Reply with quote

Le mieux serai de remplir la variable RC_PLUG_SERVICES dans /etc/conf.d/rc.
Example tiré du fichier pour démarrer net.wlan et aucune autre interface :
Code:
RC_PLUG_SERVICES="net.wlan !net.*"

Et faut laisser RC_COLDPLUG="yes" quand même.

Voilà :)
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Sat Jun 24, 2006 7:36 am    Post subject: Reply with quote

pierreg wrote:
Le mieux serai de remplir la variable RC_PLUG_SERVICES dans /etc/conf.d/rc.
Example tiré du fichier pour démarrer net.wlan et aucune autre interface :
Code:
RC_PLUG_SERVICES="net.wlan !net.*"

Et faut laisser RC_COLDPLUG="yes" quand même.

Voilà :)

+1
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Jun 24, 2006 7:54 am    Post subject: Reply with quote

Super le truc, je l'avais résolu de manière bien plus sale. :oops:
Back to top
View user's profile Send private message
mardi_soir
Apprentice
Apprentice


Joined: 08 Dec 2004
Posts: 215

PostPosted: Sat Jun 24, 2006 8:11 am    Post subject: Reply with quote

j'adore la notion de sale/propre pour ce qui est de bricoler des bidouilles :mrgreen:
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Jun 24, 2006 8:12 am    Post subject: Reply with quote

Dison qu'il y celle prévues par les développeurs et les autres. :D
Back to top
View user's profile Send private message
Anthyme
Guru
Guru


Joined: 25 Jun 2004
Posts: 498

PostPosted: Mon Jun 26, 2006 2:11 pm    Post subject: Reply with quote

tiens une question me passe en tete en rapport avec ces problemes ... quand je vais à l'ecole le serveur DHCP met 45 s a donner une adresse ... c'est tres long ... serai t'il possible d'activer les interfaces réseaux APRES avoir lancer l'interface graphique ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum