Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200606-08 ] WordPress: Arbitrary command execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Fri Jun 09, 2006 10:26 pm    Post subject: [ GLSA 200606-08 ] WordPress: Arbitrary command execution Reply with quote

Gentoo Linux Security Advisory

Title: WordPress: Arbitrary command execution (GLSA 200606-08)
Severity: high
Exploitable: remote
Date: June 09, 2006
Updated: June 10, 2006
Bug(s): #134397
ID: 200606-08

Synopsis

WordPress fails to sufficiently check the format of cached username data.

Background

WordPress is a PHP and MySQL based content management and publishing system.

Affected Packages

Package: www-apps/wordpress
Vulnerable: < 2.0.3
Unaffected: >= 2.0.3
Architectures: All supported architectures


Description

rgod discovered that WordPress insufficiently checks the format of cached username data.

Impact

An attacker could exploit this vulnerability to execute arbitrary commands by sending a specially crafted username. As of Wordpress 2.0.2 the user data cache is disabled by default.

Workaround

There are no known workarounds at this time.

Resolution

All WordPress users should upgrade to the latest available version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.3"


References

CVE-2006-2667
CVE-2006-2702


Last edited by GLSA on Sun Jul 30, 2006 4:18 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum