Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Direct rendering (DRI) using X11-DRM HOWTO
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
eightbit
n00b
n00b


Joined: 30 May 2006
Posts: 24

PostPosted: Wed Jun 07, 2006 7:33 am    Post subject: Reply with quote

i had success getting Xorg 7.0 and now 7.1 to use direct rendering with the x11-drm drivers on a laptop with a ATI Mobility M6 LY. The 2.16.6-r7 kernel drm driver didn't work out so well. Also when I use XGL glxinfo reports direct rendering disabled although Xorg log shows direct rendering was enabled. 8O
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Thu Jun 08, 2006 12:40 pm    Post subject: Reply with quote

eightbit wrote:
i had success getting Xorg 7.0 and now 7.1 to use direct rendering with the x11-drm drivers on a laptop with a ATI Mobility M6 LY. The 2.16.6-r7 kernel drm driver didn't work out so well. Also when I use XGL glxinfo reports direct rendering disabled although Xorg log shows direct rendering was enabled. 8O


This it isn't working. Let me explain,

Xorg.0.log is for X server, so called Server Side. If Direct Rendering is enabled there, it's only a first step.
glxinfo reports client messages (Mesa DRI, or NVidia, or fglrx, or whatever drivers one is using)

So by having Direct Rendering enabled only in _server side_ but not in _client side_ means it's not working.

Here is how you can get valid error message from glxinfo:

Type in terminal/bash, as normal user inside X this command: LIBGL_DEBUG=verbose glxinfo

And look at the top of it.
Back to top
View user's profile Send private message
eightbit
n00b
n00b


Joined: 30 May 2006
Posts: 24

PostPosted: Thu Jun 08, 2006 6:39 pm    Post subject: Reply with quote

SamuliSuominen wrote:
eightbit wrote:
i had success getting Xorg 7.0 and now 7.1 to use direct rendering with the x11-drm drivers on a laptop with a ATI Mobility M6 LY. The 2.16.6-r7 kernel drm driver didn't work out so well. Also when I use XGL glxinfo reports direct rendering disabled although Xorg log shows direct rendering was enabled. 8O


This it isn't working. Let me explain,

Xorg.0.log is for X server, so called Server Side. If Direct Rendering is enabled there, it's only a first step.
glxinfo reports client messages (Mesa DRI, or NVidia, or fglrx, or whatever drivers one is using)

So by having Direct Rendering enabled only in _server side_ but not in _client side_ means it's not working.

Here is how you can get valid error message from glxinfo:

Type in terminal/bash, as normal user inside X this command: LIBGL_DEBUG=verbose glxinfo

And look at the top of it.


Ah! thank you for the info!
Back to top
View user's profile Send private message
icest0rm
n00b
n00b


Joined: 03 Feb 2005
Posts: 35

PostPosted: Fri Jul 14, 2006 10:17 pm    Post subject: Reply with quote

Hi all,
I've a laptop with a Radeon Mobility 7500 LW

Quote:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]


I've Xorg 7.0r1 with this config:

Quote:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
Load "radeon"
Load "drm"
Load "GLcore"
Load "synaptics"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
#Driver "ati"
VendorName "Videocard vendor"
BoardName "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
Option "SWCursor" "true"
Option "DynamicClocks" "true"
Option "BusType" "AGP"
Option "RenderAccel" "true"
Option "SubPixelOrder" "RGB"
Option "AGPMode" "4"
#Option "AGPFastWrite" "true" (not supported by MB/VC)
Option "EnablePageFlip" "true"
Option "DDCMode" "true"
BusID "PCI:1:0:0"
EndSection


I've installed latest x11-drm but I still have low 3D perfomances...

here's glxgears FPS:
1907 frames in 5.2 seconds = 365.614 FPS
1938 frames in 5.0 seconds = 387.363 FPS
1938 frames in 5.0 seconds = 387.329 FPS

I've heard that ppl with this videocard reached 1300~1600 FPS
with DRI enabled...

but here all seems ok...have a look:

Quote:

(II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP),
(II) RADEON(0): MMIO registers at 0x40300000
(II) RADEON(0): PCI bus 1 card 0 func 0
(**) RADEON(0): Depth 16, (--) framebuffer bpp 16
(II) RADEON(0): Pixel depth = 16 bits stored in 2 bytes (16 bpp pixmaps)
(==) RADEON(0): Default visual is TrueColor
(**) RADEON(0): Option "SWcursor" "true"
(**) RADEON(0): Option "BusType" "AGP"
(**) RADEON(0): Option "AGPMode" "4"
(**) RADEON(0): Option "EnablePageFlip" "true"
(**) RADEON(0): Option "DDCMode" "true"
(**) RADEON(0): Option "RenderAccel" "true"
(**) RADEON(0): Option "SubPixelOrder" "RGB"
(**) RADEON(0): Option "DynamicClocks" "true"
(II) RADEON(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(==) RADEON(0): RGB weight 565
(II) RADEON(0): Using 6 bits per RGB (8 bit DAC)
(II) RADEON(0): initializing int10
(II) RADEON(0): Primary V_BIOS segment is: 0xc000
(--) RADEON(0): Chipset: "ATI Radeon Mobility M7 LW (AGP)" (ChipID = 0x4c57)
(--) RADEON(0): Linear framebuffer at 0x48000000
(--) RADEON(0): VideoRAM: 32768 kByte (128 bit DDR SDRAM)
(II) RADEON(0): AGP card detected
(**) RADEON(0): Forced into AGP mode
(II) RADEON(0): Color tiling enabled by default
(II) RADEON(0): I2C bus "DDC" initialized.
(II) RADEON(0): Legacy BIOS detected
(WW) RADEON(0): LCD DDC Info Table found!
(II) RADEON(0): Connector0: DDCType-4, DACType-1, TMDSType-0, ConnectorType-4
(II) RADEON(0): Connector1: DDCType-3, DACType-0, TMDSType--1, ConnectorType-2
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 4, Detected Type: 2
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 3, Detected Type: 0
(II) RADEON(0): EDID data from the display on port 1 ----------------------
(II) RADEON(0): Manufacturer: LGP Model: 9846 Serial#: 0
(II) RADEON(0): Year: 1990 Week: 0
(II) RADEON(0): EDID Version: 1.3
(II) RADEON(0): Digital Display Input
(II) RADEON(0): Max H-Image Size [cm]: horiz.: 29 vert.: 21
(II) RADEON(0): Gamma: 2.20
(II) RADEON(0): DPMS capabilities: Off; RGB/Color Display
(II) RADEON(0): First detailed timing not preferred mode in violation of standard!(II) RADEON(0): redX: 0.579 redY: 0.329 greenX: 0.310 greenY: 0.538
(II) RADEON(0): blueX: 0.151 blueY: 0.128 whiteX: 0.313 whiteY: 0.328
(II) RADEON(0): Manufacturer's mask: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 65.0 MHz Image Size: 286 x 214 mm
(II) RADEON(0): h_active: 1024 h_sync: 1048 h_sync_end 1696 h_blank_end 1344 h_border: 0
(II) RADEON(0): v_active: 768 v_sync: 771 v_sync_end 777 v_blanking: 806 v_border: 0
(II) RADEON(0):
(II) RADEON(0): Primary:
(II) RADEON(0): Secondary:
(II) RADEON(0): PLL parameters: rf=2700 rd=12 min=12000 max=35000; xclk=17575
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled(==) RADEON(0): Using gamma correction (1.0, 1.0, 1.0)
(II) RADEON(0): Validating modes on Primary head ---------
(II) RADEON(0): Panel ID string: LGP
(II) RADEON(0): Panel Size from BIOS: 1024x768
(II) RADEON(0): BIOS provided dividers will be used.
(II) RADEON(0): Valid Mode from Detailed timing table: 1024x768
(II) RADEON(0): Total of 1 mode(s) found.
(II) RADEON(0): Total number of valid DDC mode(s) found: 1
(II) RADEON(0): Valid mode using on-chip RMX: 1024x768
(II) RADEON(0): Valid mode using on-chip RMX: 800x600
(II) RADEON(0): Valid mode using on-chip RMX: 640x480
(II) RADEON(0): Total number of valid FP mode(s) found: 3
(--) RADEON(0): Virtual size is 1024x768 (pitch 1024)
(**) RADEON(0): *Mode "1024x768": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "1024x768" 65.00 1024 1040 1688 1344 768 771 777 806
(**) RADEON(0): *Mode "800x600": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "800x600" 65.00 800 1040 1688 1344 600 771 777 806
(**) RADEON(0): *Mode "640x480": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "640x480" 65.00 640 1040 1688 1344 480 771 777 806
(**) RADEON(0): Default mode "640x350": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "640x350" 65.00 640 1040 1688 1344 350 771 777 806
(**) RADEON(0): Default mode "640x400": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "640x400" 65.00 640 1040 1688 1344 400 771 777 806
(**) RADEON(0): Default mode "720x400": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "720x400" 65.00 720 1040 1688 1344 400 771 777 806
(**) RADEON(0): Default mode "832x624": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
(II) RADEON(0): Modeline "832x624" 65.00 832 1040 1688 1344 624 771 777 806
(--) RADEON(0): Display dimensions: (290, 210) mm
(--) RADEON(0): DPI set to (89, 92)
(==) RADEON(0): Using XAA acceleration architecture
(**) RADEON(0): AGP 4x mode is configured
(II) RADEON(0): AGP Fast Write disabled by default
(II) RADEON(0): Page flipping enabled
(II) RADEON(0): Will try to use DMA for Xv image transfers
(II) RADEON(0): No MM_TABLE found - assuming CARD is not TV-in capable.
(!!) RADEON(0): For information on using the multimedia capabilities
(II) RADEON(0): Dynamic Clock Scaling Enabled
(II) RADEON(0): BIOS HotKeys Disabled
(II) RADEON(0): [drm] loaded kernel module for "radeon" driver
(II) RADEON(0): [drm] DRM interface version 1.2
(II) RADEON(0): [drm] created "radeon" driver at busid "pci:0000:01:00.0"
(II) RADEON(0): [drm] added 8192 byte SAREA at 0xe0d18000
(II) RADEON(0): [drm] mapped SAREA 0xe0d18000 to 0xb7fac000
(II) RADEON(0): [drm] framebuffer handle = 0x48000000
(II) RADEON(0): [drm] added 1 reserved context for kernel
(II) RADEON(0): [agp] Mode 0x1f000207 [AGP 0x8086/0x1a30; Card 0x1002/0x4c57]
(II) RADEON(0): [agp] 8192 kB allocated with handle 0x00000001
(II) RADEON(0): [agp] ring handle = 0x60000000
(II) RADEON(0): [agp] Ring mapped at 0xb56c6000
(II) RADEON(0): [agp] ring read ptr handle = 0x60101000
(II) RADEON(0): [agp] Ring read ptr mapped at 0xb56c5000
(II) RADEON(0): [agp] vertex/indirect buffers handle = 0x60102000
(II) RADEON(0): [agp] Vertex/indirect buffers mapped at 0xb54c5000
(II) RADEON(0): [agp] GART texture map handle = 0x60302000
(II) RADEON(0): [agp] GART Texture map mapped at 0xb4fe5000
(II) RADEON(0): [drm] register handle = 0x40300000
(II) RADEON(0): [dri] Visual configs initialized
(II) RADEON(0): Depth moves disabled by default
(II) RADEON(0): CP in BM mode
(II) RADEON(0): Using 8 MB GART aperture
(II) RADEON(0): Using 1 MB for the ring buffer
(II) RADEON(0): Using 2 MB for vertex/indirect buffers
(II) RADEON(0): Using 5 MB for GART textures
(II) RADEON(0): Memory manager initialized to (0,0) (1024,8191)
(II) RADEON(0): Reserved area from (0,768) to (1024,770)
(II) RADEON(0): Largest offscreen area available: 1024 x 7421
(II) RADEON(0): Will use back buffer at offset 0x600000
(II) RADEON(0): Will use depth buffer at offset 0x780000
(II) RADEON(0): Will use 23552 kb for textures at offset 0x900000
(II) RADEON(0): Render acceleration enabled
(II) RADEON(0): Using XFree86 Acceleration Architecture (XAA)
(II) RADEON(0): Acceleration enabled
(==) RADEON(0): Backing store disabled
(==) RADEON(0): Silken mouse enabled
(II) RADEON(0): Using software cursor
(**) RADEON(0): DPMS enabled
(II) RADEON(0): Detected Radeon Mobility M7, disabling multimedia i2c
(II) RADEON(0): no multimedia table present, disabling Rage Theatre.
(II) RADEON(0): X context handle = 0x1
(II) RADEON(0): [drm] installed DRM signal handler
(II) RADEON(0): [DRI] installation complete
(II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
(II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
(II) RADEON(0): [drm] dma control initialized, using IRQ 11
(II) RADEON(0): [drm] Initialized kernel GART heap manager, 5111808
(II) RADEON(0): Direct rendering enabled


even if glxinfo says:
direct rendering: No

should I believe glxinfo seeing this low performances?
any hints?

thanx
Back to top
View user's profile Send private message
Lethality
Tux's lil' helper
Tux's lil' helper


Joined: 28 Mar 2006
Posts: 118

PostPosted: Tue Dec 12, 2006 9:22 pm    Post subject: Reply with quote

:| I can't get this to work. Been trying all day with no success. No HW accelleration and no way a newb like me can fix this.

http://forums.gentoo.org/viewtopic-t-523839.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8
Page 8 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum