Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ PRELINK ] " perte "de l'utilisateur root ( résolu )
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pilou254
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2006
Posts: 120
Location: nice - France

PostPosted: Sun Apr 30, 2006 2:06 pm    Post subject: [ PRELINK ] " perte "de l'utilisateur root ( ré Reply with quote

Bonjour à tous.
Je viens de " prelinker " le système, tout c'est bien passé, seuls quelques fichiers de configuration doivent être remplacés manuellement, rien de compliqué. Seulement voila, au moment ou, dans une console, je cherche à procéder aux dernières modifs à la main, en root, voila le message que je reçois :

" pilou254@localhost ~ $ su
Password:
su: Permission denied
configuration error - unknown item 'FAILLOG_ENAB' (notify administrator)
configuration error - unknown item 'LASTLOG_ENAB' (notify administrator)
configuration error - unknown item 'MOTD_FILE' (notify administrator)
configuration error - unknown item 'FTMP_FILE' (notify administrator)
configuration error - unknown item 'ENV_ROOTPATH' (notify administrator)
configuration error - unknown item 'PASS_MIN_LEN' (notify administrator)
configuration error - unknown item 'CHFN_AUTH' (notify administrator)
Sorry.
pilou254@localhost ~ $ "
Je ne peux plus me connecter en root sur ma machine. Que s'est-il passé à votre avis ?
Merci d'avance.


Last edited by pilou254 on Mon May 08, 2006 12:27 am; edited 1 time in total
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2364
Location: Paris

PostPosted: Sun Apr 30, 2006 2:32 pm    Post subject: Reply with quote

Salut à toi ..


et dans une autre console ca fonctionne ou pas ?

et les connexions ssh ?

si ca merdoie vraiment .. je vais peut etre dire une connerie mais reboot sur le cd d'installation , chroote das le système et emerge shadow pour voir ....

a verifier avant de faire aupres des collegues présents ici memes
Back to top
View user's profile Send private message
pilou254
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2006
Posts: 120
Location: nice - France

PostPosted: Sun Apr 30, 2006 3:07 pm    Post subject: Reply with quote

dapsaille wrote:


et dans une autre console ca fonctionne ou pas ?
et les connexions ssh ?
si ca merdoie vraiment .. je vais peut etre dire une connerie mais reboot sur le cd d'installation , chroote das le système et emerge shadow pour voir ....
a verifier avant de faire aupres des collegues présents ici memes


oui, cest la même chose dans toutes les consoles, pour ssh, je ne sais pas trop comment l'utiliser, la on sent le débutant ..., que veux tu que je fasses avec ?
Merci
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sun Apr 30, 2006 3:19 pm    Post subject: Reply with quote

Déja vu ce problème dans le forumn j'essai de retoruver

edit : http://forums.gentoo.org/viewtopic-t-366499.html

edit 2 : http://forums.gentoo.org/viewtopic-t-452243-highlight-faillogenab.html

http://forums.gentoo.org/viewtopic-t-443137-highlight-faillogenab.html


Last edited by BuBuaBu on Sun Apr 30, 2006 3:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
Ey
l33t
l33t


Joined: 07 Apr 2005
Posts: 863
Location: Paris

PostPosted: Sun Apr 30, 2006 3:21 pm    Post subject: Reply with quote

pilou254 wrote:
oui, cest la même chose dans toutes les consoles, pour ssh, je ne sais pas trop comment l'utiliser, la on sent le débutant ..., que veux tu que je fasses avec ?
Merci

Ce qu'il voulait dire par une autre console c'est un virtual terminal ie CTRL+ALT+F2 par exemple. Ca devrait marcher à priori là.
Back to top
View user's profile Send private message
pilou254
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2006
Posts: 120
Location: nice - France

PostPosted: Sun Apr 30, 2006 3:57 pm    Post subject: Reply with quote

Ey wrote:
pilou254 wrote:
oui, cest la même chose dans toutes les consoles, pour ssh, je ne sais pas trop comment l'utiliser, la on sent le débutant ..., que veux tu que je fasses avec ?
Merci

Ce qu'il voulait dire par une autre console c'est un virtual terminal ie CTRL+ALT+F2 par exemple. Ca devrait marcher à priori là.


oui, pour les consoles c'est ok, j'ai le même pb dans les consoles 1 à 6, c'est juste les manips avec ssh que je ne maitrise pas...
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sun Apr 30, 2006 4:05 pm    Post subject: Reply with quote

se connecté a une machine via ssh : ssh user@machine exemple : ssh root@localhost
Back to top
View user's profile Send private message
pilou254
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2006
Posts: 120
Location: nice - France

PostPosted: Sun Apr 30, 2006 5:05 pm    Post subject: Reply with quote

BuBuaBu wrote:
se connecté a une machine via ssh : ssh user@machine exemple : ssh root@localhost


ok, voila ce que j'obtient :
pilou254@localhost ~ $ ssh root@localhost
ssh: connect to host localhost port 22: Connection refused
pilou254@localhost ~ $

que dois-je en conclure ?
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sun Apr 30, 2006 5:41 pm    Post subject: Reply with quote

Il reste plus qu'a faire une chroot, etc-update, (puis si les symptome persiste emerge pam-login && etc-update).
Back to top
View user's profile Send private message
Ey
l33t
l33t


Joined: 07 Apr 2005
Posts: 863
Location: Paris

PostPosted: Sun Apr 30, 2006 10:16 pm    Post subject: Reply with quote

Essaie de démarrer en mode single (ajoute single à la ligne de ton noyau dans grub)
Back to top
View user's profile Send private message
pilou254
Tux's lil' helper
Tux's lil' helper


Joined: 29 Mar 2006
Posts: 120
Location: nice - France

PostPosted: Mon May 08, 2006 12:26 am    Post subject: Reply with quote

Je reprend le train en marche.
Bon la réparation est ok ( boot sur live cd + montage partition + chroot + emerge shadow pam-login ).
merci pour le coup de main.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum