Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub Error Collection [Part 5]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 13, 14, 15  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rakeyry
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 210
Location: Ont. Canada

PostPosted: Fri Apr 14, 2006 1:15 am    Post subject: Reply with quote

New problem.

I've finished initializing, rebooted, removed live boot cd and boot up pc. I get this. What do I type?


Code:
The root block device is upsecified or not detected.
Please specify a root block device or type "shell" for a shell"

Boot( ) : :


Also, I used genkernel, for your information.
_________________
The box said Windows XP or better, so I installed Linux.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Fri Apr 14, 2006 2:24 am    Post subject: Reply with quote

rakeyry,

did you remember to include an initrd line in grub.conf? Post your Gentoo section of grub.conf.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
rakeyry
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 210
Location: Ont. Canada

PostPosted: Fri Apr 14, 2006 2:39 am    Post subject: Reply with quote

Code:
default 0
timeout 30
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo
root (hd0,0)
kernel /kernel-2.6.15-gentoo-r1 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hdb3 udev
initrd /initrd-2.6.15-gentoo-r1


That's it
_________________
The box said Windows XP or better, so I installed Linux.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Fri Apr 14, 2006 3:00 am    Post subject: Reply with quote

Try using the following in your grub.conf file:
Quote:
kernel /kernel-2.6.15-gentoo-r1 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hdb3 udev

Notice the extra '3'.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
chrisstankevitz
Guru
Guru


Joined: 14 Dec 2003
Posts: 472
Location: Santa Barbara, CA, USA

PostPosted: Sun Apr 16, 2006 4:45 am    Post subject: Grub root hd command. Not sure which numbers to put. [SOLVE Reply with quote

Trial and error:

Windows /dev/sda
hd(0,1)

Gentoo /dev/sdb
hd(1,0)
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Apr 16, 2006 8:38 am    Post subject: Error in grub howto Reply with quote

Just done a fresh install and noticed that in the howto for setting up grub the kernel line in grub.conf reads:

Quote:
kernel /boot/kernel-version


This results in an 'error 15' when grub tries to boot

Now, i'm no expert, but have been using gentoo for a while now and have always used

Quote:
kernel /kernel-version


which grub will happily except.

Just thought i'd mention it, As it could cause hours of misery for first-timer's. :lol:


EDIT: Just read the sticky on grub, And i see that the '/boot' is telling grub about the symlink. In my experience though, This doesn't work, even though i have the boot symlink. I still think, It should be noted in the howto though.
Back to top
View user's profile Send private message
MacBouba
n00b
n00b


Joined: 10 Apr 2006
Posts: 26

PostPosted: Sun Apr 16, 2006 9:26 am    Post subject: Reply with quote

Yeah that's true, I have always done like you said to make grub working
A part of my "grub.conf" is like this:
Quote:

...
splashimage=(hd0,2)/grub/splash.xpm.gz

# For booting GNU/Linux
title=Gentoo Linux 2.6.15-r1
root (hd0,2)
kernel /kernel-2.6.15-gentoo-r1 root=/dev/sda6
...

I think that the fact you specify "root(hd0,2)" means that when you start a path with "/", you are starting from "/boot/".
Thus by typing "/boot/kernel-version", you are actually pointing to /boot/boot/kernel-version; which is a wrong path.
Maybe I'm wrong, but it works for me.
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Apr 16, 2006 9:57 am    Post subject: Reply with quote

[quote="MacBouba"]Yeah that's true, I have always done like you said to make grub working
A part of my "grub.conf" is like this:
Quote:

...
splashimage=(hd0,2)/grub/splash.xpm.gz

# For booting GNU/Linux
title=Gentoo Linux 2.6.15-r1
root (hd0,2)
kernel /kernel-2.6.15-gentoo-r1 root=/dev/sda6
...

I think that the fact you specify "root(hd0,2)" means that when you start a path with "/", you are starting from "/boot/".
Thus by typing "/boot/kernel-version", you are actually pointing to /boot/boot/kernel-version; which is a wrong path.
Maybe I'm wrong, but it works for me.


I use (hd0,0) Just to clarify
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Sun Apr 16, 2006 1:24 pm    Post subject: Re: Error in grub howto Reply with quote

Hi.
cybermonkey wrote:
Just done a fresh install and noticed that in the howto for setting up grub the kernel line in grub.conf reads:
Code:
kernel /boot/kernel-version

Now, i'm no expert, but have been using gentoo for a while now and have always used
Code:
 kernel /kernel-version

EDIT: Just read the sticky on grub, And i see that the '/boot' is telling grub about the symlink. In my experience though, This doesn't work, even though i have the boot symlink. I still think, It should be noted in the howto though.

If after adding the symlink it still doesn't work, you need to look at the symlink again. It must work.
Code:
atl64 misc # ls -l /boot/boot
lrwxrwxrwx 1 root root 1 2006-01-02 03:14 /boot/boot -> .
atl64 misc # 

Both paths work. Although one can argue that /kernel-version is simpler, smaller and more "correct", /boot/kernel-version has its merits. When we suggest /boot/kernel-version, we do so mostly because it works whether you have a /boot partition or not and it remains valid if you decide to later change your option.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Apr 16, 2006 2:12 pm    Post subject: Reply with quote

Merged above.
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Apr 16, 2006 4:21 pm    Post subject: Re: Error in grub howto Reply with quote

Thanks for the merge marc.

jmbsvicetto wrote:
Hi.
cybermonkey wrote:
Just done a fresh install and noticed that in the howto for setting up grub the kernel line in grub.conf reads:
Code:
kernel /boot/kernel-version

Now, i'm no expert, but have been using gentoo for a while now and have always used
Code:
 kernel /kernel-version

EDIT: Just read the sticky on grub, And i see that the '/boot' is telling grub about the symlink. In my experience though, This doesn't work, even though i have the boot symlink. I still think, It should be noted in the howto though.

If after adding the symlink it still doesn't work, you need to look at the symlink again. It must work.
Code:
atl64 misc # ls -l /boot/boot
lrwxrwxrwx 1 root root 1 2006-01-02 03:14 /boot/boot -> .
atl64 misc # 

Both paths work. Although one can argue that /kernel-version is simpler, smaller and more "correct", /boot/kernel-version has its merits. When we suggest /boot/kernel-version, we do so mostly because it works whether you have a /boot partition or not and it remains valid if you decide to later change your option.


I've checked the symlink and get the same output as you have there. However '/boot/kernel-version' refuses to work for me.
Thanks for the explanation on why /boot is used, interstingly i've just gon through 'info grub' and there method is the use 'kernel (hd0,0)/vmlinuz'
Intersting that there are 3 ways of booting linux, But strange how /boot/kernel-version won't work for me :?
I'll give the 'kernel (hd0,0)' a shot when i've finnished compiling.
Glad it's not an error in the howto's, As gentoo's howto's are spot on.
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Apr 16, 2006 6:00 pm    Post subject: Reply with quote

Okay, doing
Code:
kernel (hd0,0)/gentoo root=/dev/hde1 vga=794


Works with no probs. Hope it helps someone :wink:
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Sun Apr 16, 2006 8:55 pm    Post subject: Reply with quote

cybermonkey wrote:
Okay, doing
Code:
kernel (hd0,0)/gentoo root=/dev/hde1 vga=794

Works with no probs. Hope it helps someone :wink:

In that case, if you try using the following it must also work.
Code:
kernel (hd0,0)/boot/gentoo root=/dev/hde1 vga=794

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Apr 16, 2006 9:21 pm    Post subject: Reply with quote

jmbsvicetto wrote:
cybermonkey wrote:
Okay, doing
Code:
kernel (hd0,0)/gentoo root=/dev/hde1 vga=794

Works with no probs. Hope it helps someone :wink:

In that case, if you try using the following it must also work.
Code:
kernel (hd0,0)/boot/gentoo root=/dev/hde1 vga=794


I'm afraid not :(

For the record i'm using grub-0.96-r2, though i don't think that's my unique problem.
I'm not too bothered about fault finding this problem, Maybe this could be a system thing?.
I've tried re-compilling grub but still same
My system is:
1.4 Duron
Asus KD7 mobo
4 HD's ( 2 attached to IDE 1 & 2 attached to promise ultra 133 tx2 PCI IDE card )

This same system had a 1.8 Athlon with same symptom untill i fried it in windows using their virtualisation server. :twisted:
Back to top
View user's profile Send private message
brievolz84
n00b
n00b


Joined: 09 Apr 2006
Posts: 30
Location: Hburg, Va

PostPosted: Mon Apr 17, 2006 8:41 am    Post subject: Error message GRUB Reply with quote

root (hd0,0)
filesystem type is ext2fs, partition type 0x83
initrd /boot/initramfs-genkernel-x86_64-2.6.15-gentoo-r7

Error 19: linux kernel must be loaded before initrd
_________________
Master Jedi
MSI K8N Neo Platinum
AMD Athlon 64
1.2 GB of ddr ram
GeForce 6800GT
Sound Blaster Audigy 2 (value)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32166
Location: 56N 3W

PostPosted: Mon Apr 17, 2006 10:26 am    Post subject: Reply with quote

brievolz84,

Your grub.conf contains the
Code:
kernel /boot/<very-long-line-for-kernel>
initrd /boot/<initrd-file-name>
either in the wrong order, or your <very-long-line-for-kernel> is not one very long line.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Mon Apr 17, 2006 11:11 pm    Post subject: Reply with quote

Previous posts were split to the following thread: http://forums.gentoo.org/viewtopic-t-454696.html
Back to top
View user's profile Send private message
remix
l33t
l33t


Joined: 28 Apr 2004
Posts: 797
Location: hawaii

PostPosted: Thu Apr 20, 2006 9:23 am    Post subject: grub won't boot windows Reply with quote

i have 1 ata hd on its own ide channel.
i have 1 sata hd on 1st sata channel.

to grub, /dev/sda is hd0 and /dev/hda is hd1

i can boot gentoo just fine, but if i choose windows, it shows this:
Code:

rootnoverify (hd1,0)
makeactive
chainloader +1

Invalid or unsupported executable format

and halts, i have to ctrl+alt+delete out...

heres my grub.conf

Code:

default 0
timeout 7
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.15-r7 64bit
root(hd0,0)
#kernel /boot/kernel-2.6.15-gentoo-r7 root=/dev/sda3 vga=0x318 vga=792
kernel /boot/kernel-2.6.15-gentoo-r7 root=/dev/sda3 vga=0x318 splash=silent,the$ ...

title=RemixFX 32bit
rootnoverify (hd1,0)
makeactive
chainloader +1



anyone know what could cause this? or how to fix this?

tia
_________________
help the needy
Back to top
View user's profile Send private message
syg00
l33t
l33t


Joined: 23 Aug 2004
Posts: 907
Location: Brisbane, AUS

PostPosted: Thu Apr 20, 2006 9:58 am    Post subject: Reply with quote

Windows needs to boot from the primary drive. Use the following (after the rootnoverify) to fool it;
Code:
map (hd0) (hd1)
map (hd1) (hd0)


[Edit] D'oh - hope you didn't use my original post - try the amended version
Back to top
View user's profile Send private message
remix
l33t
l33t


Joined: 28 Apr 2004
Posts: 797
Location: hawaii

PostPosted: Fri Apr 21, 2006 3:55 am    Post subject: Reply with quote

cool thanks syg00, that works!
_________________
help the needy
Back to top
View user's profile Send private message
Slalomsk8er
Apprentice
Apprentice


Joined: 03 May 2003
Posts: 228
Location: Münchenstein, Switzerland

PostPosted: Fri Apr 21, 2006 11:15 am    Post subject: Reply with quote

Well, I have the same problem but my setup is a little bit different. Gentoo is on the IDE Harddisk and Windows XP on the SATA Harddisk (faster disk for games).

The error or the lack of it looks like this:
Code:
    Booting 'Windows XP'

rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1


Nothing more or less and Ctrl+Alt+Delete does not work I have to press the reset button.

Some info about my setup:

Code:
fdisk -l /dev/hda

Platte /dev/hda: 60.0 GByte, 60040544256 Byte
255 Köpfe, 63 Sektoren/Spuren, 7299 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/hda1   *           1           9       72261   83  Linux
/dev/hda2              10        7299    58556925    5  Erweiterte
/dev/hda5              10         134     1004031   82  Linux Swap / Solaris
/dev/hda6             135        2625    20008926   83  Linux
/dev/hda7            2626        7299    37543873+  83  Linux


Code:
fdisk -l /dev/sda

Platte /dev/sda: 37.0 GByte, 37019566080 Byte
255 Köpfe, 63 Sektoren/Spuren, 4500 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *           1        4499    36138186    7  HPFS/NTFS


Code:
cat /boot/grub/device.map
(fd0)   /dev/fd0
(hd0)   /dev/hda
(hd1)   /dev/sda


Code:
cat /boot/grub/grub.conf
timeout 05
default 0
fallback 1
splashimage=(hd0,0)/grub/splash.xpm.gz

title Gentoo
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda6 video=vesafb:ywrap,mtrr,1280x1024-32@60
initrd /boot/fbsplash-Emergence-1280x1024

title Gentoo old kernel
root (hd0,0)
kernel /boot/vmlinuz.old root=/dev/hda6 video=vesafb:ywrap,mtrr,1280x1024-32@60
initrd /boot/fbsplash-Emergence-1280x1024

title=Windows XP
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1


If I change the boot order in the BIOS Windows XP boots.

The Mainboard is a ASUS A7N8X-Delux with a Silicon Image, Inc. SiI 3112 [SATALink/SATARaid] Serial ATA Controller (rev 02).

After a Day of useless playing with grub I did not have found a grub.conf that looks more "right" or works :cry:
Back to top
View user's profile Send private message
syg00
l33t
l33t


Joined: 23 Aug 2004
Posts: 907
Location: Brisbane, AUS

PostPosted: Fri Apr 21, 2006 11:14 pm    Post subject: Reply with quote

Tried the obvious - ??? take the "=" sign out of the XP title.

Sounds silly but might work - grub is sensitive to the "title" line as well.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Sat Apr 22, 2006 1:55 am    Post subject: Reply with quote

Hi.
Slalomsk8er wrote:

Code:
fdisk -l /dev/hda
/dev/hda1   *           1           9       72261   83  Linux

Code:
fdisk -l /dev/sda
/dev/sda1   *           1        4499    36138186    7  HPFS/NTFS


Remove the boot flag from /dev/hda1. Does Windows boot now?
Slalomsk8er wrote:

Code:
cat /boot/grub/grub.conf
title=Windows XP
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1


If not, try using the following for your windows entry
Code:
title=Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
tom-snj
n00b
n00b


Joined: 19 Apr 2006
Posts: 23
Location: clayton, nj

PostPosted: Sat Apr 22, 2006 2:22 am    Post subject: grub error 15 [solved] Reply with quote

I read the post from, jmbsvicetto and rakeyry, back on the 14th of this month. Adding the initd entry to grub.conf file, seems to have done the trick. I'm using the 2005.1 cd and the handbook doesn't mention anything about, "initd" at all, except for creating a link for 2 or more network adpters.

Where does this (initd) come from??

Partitioning info:
hda1 * /boot ext2
hda2 swap
hda3 / ext3
hda4 extended
hda5 /home ext3
hda6 /usr ext3
hda7 /var ext3

grub.conf
default
timeout
splashimage=(hd0,0) /boot/grub/splash.xpm.gz
root (hd0,0)
kernel /boot/kernel-gentoo-2.6.12-r6 root=/dev/hda3 vga=0x31B

This is the most successful I've been in several attempts.

Regards,
Tom


Last edited by tom-snj on Sun Apr 23, 2006 2:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32166
Location: 56N 3W

PostPosted: Sat Apr 22, 2006 10:43 am    Post subject: Reply with quote

tom-snj,

The initrd option in grub.conf is err .. optional. Weather you need it or not, depends on how you build your kernel.
The initrd file is a complete miniture root filesystem in a file. When you have a fully modular kernel (absoulely nothing build in)
the initrd provides a home for the modules needed to mount the real root filesystem. It breaks the circular dependancy that the kernel cannot read the drive becuse it needs modules stored on the drive that it cannot read ...
The initrd is loaded by grub before the kernel is started an attached at /dev/ram0 for the kernel to read.

When you build your kernel, providied you include as built in, all the modules needed to read your root filesystem and initrd is not needed. These include the low level chipset driver for your disk, the high level driver for your disk and the root filesystem.

Typically, Genkernel prodices a fully modular kernel, since it has to work for everyone, on a wide varity of hardware and individual users build a kernel to suit there hardware which includes everthing needed to boot, so a initrd is not required.

Where does an initrd come from?
There is a script on the system somewhere to build it. I'm in the second group, so I've not used it ever.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2, 3 ... 13, 14, 15  Next
Page 1 of 15

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum