Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ipw3945 wireless drivers
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 30, 31, 32  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Fri Feb 17, 2006 5:40 pm    Post subject: ipw3945 wireless drivers Reply with quote

Since there is no thread about this I figured I would start one. Anyone that buys a notebook with the new Intel Centrino Core Duo will have an IPW3945 wireless card. Intel's site says drivers will be available Q1 2006. The sourceforge project the ipw3945 drivers was just registered at the beginning of the month. Here is a link to the sourceforge project for those that are interested:

http://sourceforge.net/projects/ipw3945/
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
moscwolf
n00b
n00b


Joined: 18 Feb 2006
Posts: 3
Location: Hamburg (Germany)

PostPosted: Sat Feb 18, 2006 4:32 pm    Post subject: Reply with quote

i'm waiting also
if anyone needs more information or beta-tester - post it :lol:

i have some more problems on my inspiron, but most import is the wireless-connection.

(: 0c:00.0 Network controller: Intel Corporation Unknown device 4222 (rev 02) :)

i have tried the way to patch the kernel to be able to work with 16k stacks and got the card activated while using ndiswrapper with the w39n51.inf from intel, but that was not totalay working - it only seems to be ;-)
but the ap never get locked withe the card .. and it was very unstable and sometimes the maschine completly freezes - so i have paused testing that way :-(

here is lspci output, mabe needful :?:

Code:

Gentoo linux # lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0098 (rev a1)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832
03:01.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
0c:00.0 Network controller: Intel Corporation Unknown device 4222 (rev 02)

_________________
INSPIRON 9400
Intel(R) Core Duo
Genuine Intel(R) CPU T2600 @ 2.16GHz GenuineIntel GNU/Linux
Linux Gentoo 2.6.15 #1 SMP PREEMPT Fri Feb 17 00:01:35 GMT 2006 i686
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Mon Feb 20, 2006 7:24 pm    Post subject: Reply with quote

Eagerly waiting for the drivers too... I have a Dell Inspiron 9400 with an nVidia 7800 Go. Fortunately only WiFi and the SD card reader do not work.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
trautenberg
n00b
n00b


Joined: 22 Feb 2006
Posts: 4
Location: Prague

PostPosted: Wed Feb 22, 2006 3:28 pm    Post subject: Dell 9400 Reply with quote

Hey,

I have got the same problem with my wireless card on my Dell Inspiron 9400, which I got two weeks ago. I also tried to patch the kernel, but trying to insert the module gave me an error, that the ndiswrapper.ko is of invalid format. It was independent on whether or not the SMP was on.

I haven't yet tried to make SD card reader to work. Moreover i have troubles with screen resolution and audio control. Unfortunately I have bought a crapy graphic card - Intel Media Accelerator 900 Graphics. I cannot force it to work properly with xorg using VESA. It stretches the display as its natural resolution is 1440x900 which is unreachable for me... 8O Anyway, did somebody of you managed to get xorg with 1440x900 working, please post your xorg.conf?
The problem with sound I have seems to be general for all users of Intel HDA... When I plug in the headphones the sound is still coming also through the internal speakers of the laptop. This is really bad, if I want to listen to music while working at the office without annoying my colleges... :( Has somebody solved this problem???
Back to top
View user's profile Send private message
moscwolf
n00b
n00b


Joined: 18 Feb 2006
Posts: 3
Location: Hamburg (Germany)

PostPosted: Thu Feb 23, 2006 9:44 am    Post subject: Reply with quote

unfortunatly or not i have another grphic-card in my 9400, i choosed the 7800 go, which work fine with the nvidia-driver
for my audio i have choosen the way over alsa-driver ( type into /etc/make.conf "ALSA_CARDS="hda-intel" - emerge alsa-driver and execute alsaconf)
i got sound, but not from the subwoofer. :?
_________________
INSPIRON 9400
Intel(R) Core Duo
Genuine Intel(R) CPU T2600 @ 2.16GHz GenuineIntel GNU/Linux
Linux Gentoo 2.6.15 #1 SMP PREEMPT Fri Feb 17 00:01:35 GMT 2006 i686
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Thu Feb 23, 2006 4:29 pm    Post subject: Reply with quote

Please bear with the original poster. This thread should talk about Wireless NIC 3945 drivers and issues. For more general questions and support on the Dell Inspiron 9400, use the dedicated i9k4 thread instead.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Sun Feb 26, 2006 3:37 pm    Post subject: Reply with quote

Hi people.

I've just created and tested my own ebuilds for ipw3945.

Preliminary notes

Intel Licences

The driver is a set of three packages from Intel: the driver module, the microcode and a regulatory daemon. Only the driver module is GPL'd. The other two are Intel-specific licenses. Hence the presence of two Intel licenses in the tarball. These licenses are provided with Intel's packages, which we can find at sourceforge.

My ebuilds do reference these licenses. Hence they must exist in /usr/portage/licenses before the ebuilds are used. They're included in the tarball and will therefore be extracted to the required directory.

Unofficial ebuilds

Since these are not official ebuilds they will be placed in a portage overlay directory. In my example I'll assume the portage overlay resides in /usr/local/portage/. See Gentoo Wiki on how to create and use third-party ebuilds with portage overlays.

Install Instructions

Download and extract the tarball from the above link:
Code:
# cd
wget http://www.teledisnet.be/web/vca08867/linux/ipw3945/ipw3945-ebuildset.tar.bz2
tar -xjvf ipw3945-ebuildset.tar.bz2 -C /

You will have a new portage overlay directory and two license files:
Code:
# ls -lR /usr/local/portage/net-wireless/
/usr/local/portage/net-wireless/:
total 0
drwxr-xr-x  3 root root 136 fév 25 19:06 ipw3945
drwxr-xr-x  3 root root 136 fév 26 12:43 ipw3945d
drwxr-xr-x  3 root root 144 fév 25 11:17 ipw3945-firmware

/usr/local/portage/net-wireless/ipw3945:
total 8
drwxr-xr-x  2 root root      88 fév 25 19:06 files
-rw-r--r--  1 root root    1971 fév 26 12:50 ipw3945-0.0.69.ebuild
-rw-rw-r--  1 root portage  132 fév 26 12:54 Manifest

/usr/local/portage/net-wireless/ipw3945/files:
total 4
-rw-rw-r--  1 root portage 63 fév 26 12:54 digest-ipw3945-0.0.69

/usr/local/portage/net-wireless/ipw3945d:
total 8
drwxr-xr-x  2 root root     88 fév 26 12:43 files
-rw-r--r--  1 root root    492 fév 26 13:39 ipw3945d-0.7.16.ebuild
-rw-rw-r--  1 root portage 133 fév 26 13:39 Manifest

/usr/local/portage/net-wireless/ipw3945d/files:
total 4
-rw-rw-r--  1 root portage 63 fév 26 13:39 digest-ipw3945d-0.7.16

/usr/local/portage/net-wireless/ipw3945-firmware:
total 8
drwxr-xr-x  2 root root     96 fév 25 11:17 files
-rw-r--r--  1 root root    605 fév 25 12:15 ipw3945-firmware-1.13.ebuild
-rw-rw-r--  1 root portage 145 fév 25 12:15 Manifest

/usr/local/portage/net-wireless/ipw3945-firmware/files:
total 4
-rw-rw-r--  1 root portage 66 fév 25 12:15 digest-ipw3945-firmware-1.13

Code:
# ls -l /usr/portage/licenses/ | egrep 'Intel-bin|ipw3945'
-rw-r--r--  1 root root   2109 fév 26 12:25 Intel-bin
-rwxr-xr-x  1 root root   2109 fév 25 10:56 ipw3945-fw

Now you can search portage for the new ebuilds:
Code:
# emerge -s ipw3945
Searching...
[ Results for search key : ipw3945 ]
[ Applications found : 3 ]

*  net-wireless/ipw3945 [ Masked ]
      Latest version available: 0.0.69
      Latest version installed: 0.0.69
      Size of downloaded files: 155 kB
      Homepage:    http://ipw3945.sourceforge.net
      Description: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux
      License:     GPL-2

*  net-wireless/ipw3945-firmware [ Masked ]
      Latest version available: 1.13
      Latest version installed: 1.13
      Size of downloaded files: 59 kB
      Homepage:    http://ipw3945.sourceforge.net
      Description: Microcode for the Intel PRO/Wireless 3945ABG Network Connection Adapter
      License:     ipw3945-fw

*  net-wireless/ipw3945d [ Masked ]
      Latest version available: 0.7.16
      Latest version installed: 0.7.16
      Size of downloaded files: 55 kB
      Homepage:    http://ipw3945.sourceforge.net
      Description: Intel PRO/Wireless 3945ABG Network Connection Regulatory Daemon
      License:     Intel-bin

Unmask them so that you can use them; you will also have to unmask ieee80211-1.1.11 and later since it is a dependency of Intel driver:
Code:
# grep net-wireless /etc/portage/package.keywords
>=net-wireless/ieee80211-1.1.11 ~x86
=net-wireless/ipw3945d-0.7.16 ~x86
net-wireless/ipw3945-firmware ~x86
net-wireless/ipw3945 ~x86

Note: if you are using a recent kernel you'll have to remove ieee802.11 built-in support. Do so by running the following command:
Code:
/bin/sh /usr/portage/net-wireless/ieee80211/files/remove-old /usr/src/linux

If you don't do that now portage will prompt you with an error message when you install ieee80211:
Code:
Your kernel source contains an incompatible version of the
ieee80211 subsystem, which needs to be removed before
ieee80211-1.1.12 can be installed. This can be accomplished by running:

  # /bin/sh /usr/portage/net-wireless/ieee80211/files/remove-old /usr/src/linux

Please note that this will make it impossible to use some of the
in-kernel IEEE 802.11 wireless LAN drivers (eg. orinoco).

Now emerge ipw3945. It will bring down or update packages ipw3945d, ipw3945-firmware and ieee80211:
Code:
# emerge -av ipw3945

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] net-wireless/ieee80211-1.1.12  -debug 65 kB
[ebuild  N    ] net-wireless/ipw3945-firmware-1.13  60 kB [1]
[ebuild  N    ] net-wireless/ipw3945d-0.7.16  56 kB [1]
[ebuild  N    ] net-wireless/ipw3945-0.0.69  156 kB [1]

Total size of downloads: 337 kB
Portage overlays:
 [1] /usr/local/portage

Do you want me to merge these packages? [Yes/No]


Post Installation Instructions

The regulatory daemon is responsible for lighting the LED and activating the wireless adapter. You must run it after you load the driver:
Code:
# modprobe ipw3945
# /sbin/ipw3945d # The wireless LED is put on, the card activated and the initscript launched

As I already had my /etc/conf.d/net configuration file prepared I didn't have anything to do - I copied my system from another laptop, a Dell Inspiron 6000, which I already had configured for wireless. Refer to Gentoo Wireless Guide otherwise.

Intel documentation says there is a way to automatically run the daemon while loading the driver.
Intel's ipw3945 Install wrote:
3. AUTOMATIC DAEMON LOADING VIA MODPROBE
-----------------------------------------------

There are some typical steps that are fairly generic in order
to automate the launching of the daemon you can use your
distribution's modprobe configuraiton. To do this, you need to copy
ipw3945.ko into your depmod path. This is typically done via:

# cp ipw3945.ko /lib/modules/$(uname -r)
# depmod -a

Now, when you run modprobe it will load the module (and any depdencies,
such as ieee80211.ko) and modprobe -r will remove the module. The next
step is to automate the launching and unloading of the regulatory
daemon. To do this, you typically place the following two lines into
your /etc/modprobe.conf or into a new file /etc/modules.d/ipw3945:

# echo install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; \
sleep 0.5 ; /sbin/ipw3945d --quiet >> /etc/modules.d/ipw3945

# echo remove ipw3945 /sbin/ipw3945d --kill ; \
/sbin/modprobe -r --ignore-remove ipw3945 >> /etc/modules.d/ipw3945

NOTE: The \ above is to continue the entered line to the next line (the
lines added to the file are wider than 80 columns and so would wrap)

On some distributions you then may need to run the 'modules-update'
script.

To verify if the above is working, you can type:

# modprobe ipw3945
# ps -C ipw3945d

If you see a running 'ipw3945d' then it launched the daemon for you.

I appended the following lines to /etc/modules.d/ipw3945
Code:
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945  /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945

Loading the module automatically runs the daemon. Run modprobe -r ipw3945 to unload the deamon.

Using the RF-Kill switch only requires to restart /etc/init.d/net.eth1 when the wireless interface is back On. Another cool feature is that the WiFi led blinks rapidly while the interface is acquiring its IP address.

I tested the driver on my system and it's running fine ever since. Here are my main packages:
  • Gentoo Sources 2.6.15-r5
  • udev-079-r1
  • baselayout-1.12.0_pre16-r3 (~x86)
  • bash-3.1_p14 or above (~x86)
  • netplug-1.2.9-r1 or above
Note: baselayout 1.12 now requires bash >=3.1. And since netplug requires baselayout >=1.12... This has the main advantage not requiring any net script to be added to any runlevel again. baselayout 1.12.xx now attempts to start network init scripts as soon as the corresponding module is loaded.

How do I upgrade the driver?

To upgrade driver 0.0.69 to version 0.0.70 (released March 2nd):
Code:
cd /usr/local/portage/net-wireless/ipw3945
cp ipw3945-0.0.69.ebuild ipw3945-0.0.70.ebuild
ebuild ipw3945-0.0.70.ebuild digest
emerge -av ipw3945

Hope this will help. Comments welcome 8) .

Status

  • I've had to downgrade baselayout to version 1.11.14-r6 after I upgraded my system a couple of days ago. Note this implies adding net.eth1 to the default runlevel for it doesn't start automatically anymore once module ipw3945 is loaded - unlike 1.12.0xxx series .
  • Added the Driver upgrade section.
  • Upgraded again to baselayout 1.12 series and upgraded bash to 3.1.

_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”


Last edited by VinzC on Tue Jul 25, 2006 11:56 am; edited 6 times in total
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Sun Feb 26, 2006 7:57 pm    Post subject: Reply with quote

i have not tried your e-build but I do have ipw3945 working with 2.6.16-rc4-mm2, thanks for beating me to ebuild, i will try it out!

/etc/modules.d/ipw3945
Code:
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945  /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945


^^^--- this works great by the way, i recommend it
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Sun Feb 26, 2006 8:56 pm    Post subject: Reply with quote

rmh3093 wrote:
i have not tried your e-build but I do have ipw3945 working with 2.6.16-rc4-mm2, thanks for beating me to ebuild, i will try it out!

It was a real pleasure ;) . So Andrew Morton sources include built-in support for ipw3945?

/etc/modules.d/ipw3945
Code:
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945  /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945

I have tried it too. It works at least when loading the module while rmmod ipw3945 produces an error message saying the module is in use. But in turn the RF-Kill switch works without unloading the module. You just have to restart the init script when the wireless is enabled again.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Mon Feb 27, 2006 2:21 am    Post subject: Reply with quote

VinzC wrote:
rmh3093 wrote:
i have not tried your e-build but I do have ipw3945 working with 2.6.16-rc4-mm2, thanks for beating me to ebuild, i will try it out!

It was a real pleasure ;) . So Andrew Morton sources include built-in support for ipw3945?

/etc/modules.d/ipw3945
Code:
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945  /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945

I have tried it too. It works at least when loading the module while rmmod ipw3945 produces an error message saying the module is in use. But in turn the RF-Kill switch works without unloading the module. You just have to restart the init script when the wireless is enabled again.


you have to remove the module with 'modprobe -r ipw3945"

and no -mm sources doesnt have support yet, i copied the source from ieee80211 and ipw3945 into the kernel and adjusted the Kconfig and Makefile so that I could compile it with the kernel, for some reason ieee80211 wont emerge on my system
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
echalon
n00b
n00b


Joined: 10 Oct 2005
Posts: 24

PostPosted: Thu Mar 02, 2006 12:25 am    Post subject: Reply with quote

I'm not sure why, but I had to create an init script to manually delete the /var/run/ipw3945d.pid file at shutdown or else it would not start up automatically with the automatic modprobe at boot.

Thanks for your work!
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Thu Mar 02, 2006 1:38 pm    Post subject: Reply with quote

echalon wrote:
I'm not sure why, but I had to create an init script to manually delete the /var/run/ipw3945d.pid file at shutdown or else it would not start up automatically with the automatic modprobe at boot.

Wierd. You could perhaps use /etc/init.d/local.stop to wipe the file out after the driver is removed.

echalon wrote:
Thanks for your work!

It's my very first, big contribution and I have submited three ebuilds to Gentoo Bugzilla. I'm glad I could help.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
djtreble
n00b
n00b


Joined: 09 Jan 2006
Posts: 39
Location: Brisbane, Australia

PostPosted: Sat Mar 04, 2006 7:15 am    Post subject: Reply with quote

Thanks for all your help VinzC, I'm slowly getting there with my 6400.

Has anyone got wpa working with this card?

I'm getting
Quote:

* Starting eth1
* Starting wpa_supplicant on eth1 ...
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
[ ok ] * Starting wpa_cli on eth1 ...
[ ok ] * Backgrounding ...


Using the ipw driver in /etc/conf.d/net
Code:
wpa_supplicant_eth1="-Dipw"

Also tried the "-Dext" driver, without any joy.

My driver is loaded, my demon is started and the led is flashing.

Any ideas?

Thanks

Dan
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Sat Mar 04, 2006 10:41 pm    Post subject: Reply with quote

As per Intel requirements, use the latest version of wireless-tools - you might have to unmask it. You might have to use an unmasked version of wpa supplicant as well.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
djtreble
n00b
n00b


Joined: 09 Jan 2006
Posts: 39
Location: Brisbane, Australia

PostPosted: Sun Mar 05, 2006 1:50 pm    Post subject: Reply with quote

Solved it, I was trying -Dext instead of -Dwext.

-Dwext works like a charm. Thank you.

P.S. There is a new version of the driver out :-)
Back to top
View user's profile Send private message
AlexSuslov
n00b
n00b


Joined: 06 Jan 2005
Posts: 34

PostPosted: Sun Mar 05, 2006 2:19 pm    Post subject: Asus V6X00J IPW3945ABG WPA-PSK Reply with quote

Hi!
I can't connect by IPW3945ABG to wifi AP.

lspci

03:00.0 Network controller: Intel Corporation Unknown device 4222 (rev 02)

I use my old working wpa_supplicant.conf
But
wpa_supplicant -w -i eth2 -c /etc/wpa_supplicant.conf -Dwext
say only
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
what's the problem?
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Mon Mar 06, 2006 4:16 am    Post subject: Reply with quote

VinzC: I still haven't been able to try your ebuild since I cant emerge ieee80211 but I was poking around and notice that the default Makefile comments out support for monitor mode and qos support. It an easy tweak for people using the ebuild, maybe you wanted to include it as a use flag option or something.

Anyway, I hate using ebuilds for kernel drivers so I made a patch for the 2.6 kernel series which adds IPW3945 support. There are config options to add support for QoS and promiscuous mode. :)

Code:
eth1      Available private ioctls :
          set_power        (8BE0) : set   1 int   & get   0
          get_power        (8BE1) : set   0       & get  80 char
          set_mode         (8BE2) : set   1 int   & get   0
          get_mode         (8BE3) : set   0       & get  80 char
          set_preamble     (8BE4) : set   1 int   & get   0
          get_preamble     (8BE5) : set   0       & get  16 char
          reset            (8BE7) : set   0 int   & get   0
          monitor          (8BE6) : set   2 int   & get   0


Here is the kernel patch: ipw3945-0.0.70.patch.bz2

* This patch applies cleanly against 2.6.15 and 2.6.16-rc5-mm2 so it should work with everything else. The IEEE80211 support in these kernels seems to be sufficient.

To apply this patch to your current kernel source:
Code:
cd /usr/src/linux
bzcat <path_to>/ipw3945-0.0.70.patch.bz2 | patch -p1

_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
AlexSuslov
n00b
n00b


Joined: 06 Jan 2005
Posts: 34

PostPosted: Mon Mar 06, 2006 8:07 am    Post subject: Some errors with the kernel patch: ipw3945-0.0.70.patch.bz2 Reply with quote

genkernel --menuconfig all
some erors

In file included from drivers/net/wireless/ipw3945.c:68:
drivers/net/wireless/ipw3945.h:1991: error: field `action' has incomplete type
CC [M] drivers/usb/input/xpad.o
drivers/net/wireless/ipw3945.c: In function `ipw_add_power_capability':
drivers/net/wireless/ipw3945.c:3192: warning: implicit declaration of function `ieee80211_get_channel'
drivers/net/wireless/ipw3945.c:3192: warning: initialization makes pointer from integer without a cast
drivers/net/wireless/ipw3945.c: In function `ipw_add_supported_channels':
drivers/net/wireless/ipw3945.c:3222: warning: implicit declaration of function `ieee80211_get_channel_flags'
drivers/net/wireless/ipw3945.c: In function `ipw_best_network':
drivers/net/wireless/ipw3945.c:7090: error: `NETWORK_HAS_IBSS_DFS' undeclared (first use in this function)
drivers/net/wireless/ipw3945.c:7090: error: (Each undeclared identifier is reported only once
drivers/net/wireless/ipw3945.c:7090: error: for each function it appears in.)
drivers/net/wireless/ipw3945.c:7099: error: `NETWORK_HAS_POWER_CONSTRAINT' undeclared (first use in this function)
drivers/net/wireless/ipw3945.c:7108: error: `NETWORK_HAS_TPC_REPORT' undeclared (first use in this function)
drivers/net/wireless/ipw3945.c: In function `ipw_handle_reply_rx':
drivers/net/wireless/ipw3945.c:9820: error: unknown field `tsf' specified in initializer
drivers/net/wireless/ipw3945.c:9821: error: unknown field `beacon_time' specified in initializer
drivers/net/wireless/ipw3945.c:9821: warning: excess elements in struct initializer
drivers/net/wireless/ipw3945.c:9821: warning: (near initialization for `stats')
drivers/net/wireless/ipw3945.c: In function `ipw_build_tx_cmd_hwcrypto':
drivers/net/wireless/ipw3945.c:13227: error: too many arguments to function
drivers/net/wireless/ipw3945.c: In function `ipw_pci_probe':
drivers/net/wireless/ipw3945.c:14734: warning: assignment from incompatible pointer type
make[3]: *** [drivers/net/wireless/ipw3945.o] Error 1
make[2]: *** [drivers/net/wireless] Error 2
make[1]: *** [drivers/net] Error 2
Back to top
View user's profile Send private message
AlexSuslov
n00b
n00b


Joined: 06 Jan 2005
Posts: 34

PostPosted: Mon Mar 06, 2006 8:32 am    Post subject: Reply with quote

iwpriv eth2
eth2 Available private ioctls :
set_power (8BE0) : set 1 int & get 0
get_power (8BE1) : set 0 & get 80 char
set_mode (8BE2) : set 1 int & get 0
get_mode (8BE3) : set 0 & get 80 char
set_preamble (8BE4) : set 1 int & get 0
get_preamble (8BE5) : set 0 & get 16 char
reset (8BE7) : set 0 int & get 0
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4663
Location: Theux (Belgium)

PostPosted: Mon Mar 06, 2006 9:07 am    Post subject: Reply with quote

rmh3093 wrote:
VinzC: I still haven't been able to try your ebuild since I cant emerge ieee80211 but I was poking around and notice that the default Makefile comments out support for monitor mode and qos support. It an easy tweak for people using the ebuild, maybe you wanted to include it as a use flag option or something.

I'm sorry, I'm not sure I understand everything :oops: . What Makefile are you talking about? The Makefile for ebuild >=ieee80211-1.1.11?

rmh3093 wrote:
Anyway, I hate using ebuilds for kernel drivers so I made a patch for the 2.6 kernel series which adds IPW3945 support. There are config options to add support for QoS and promiscuous mode. :)

Code:
eth1      Available private ioctls :
          set_power        (8BE0) : set   1 int   & get   0
          get_power        (8BE1) : set   0       & get  80 char
          set_mode         (8BE2) : set   1 int   & get   0
          get_mode         (8BE3) : set   0       & get  80 char
          set_preamble     (8BE4) : set   1 int   & get   0
          get_preamble     (8BE5) : set   0       & get  16 char
          reset            (8BE7) : set   0 int   & get   0
          monitor          (8BE6) : set   2 int   & get   0


Here is the kernel patch: ipw3945-0.0.70.patch.bz2

* This patch applies cleanly against 2.6.15 and 2.6.16-rc5-mm2 so it should work with everything else. The IEEE80211 support in these kernels seems to be sufficient.

To apply this patch to your current kernel source:
Code:
cd /usr/src/linux
bzcat <path_to>/ipw3945-0.0.70.patch.bz2 | patch -p1

A big thanks indeed. Note you don't seem to have any problems compiling the driver while using the kernel built-in ieee80211 support. Is the kernel module of the latest version (>=1.1.11) - I mean does the built-in ieee80211 meet ipw3945 requirements? BTW how do you check a kernel module's version?

Also I suppose you adjusted ipw3945 source files to use the built-in ieee80211? When I compiled the module using the ebuild I first tried skipping the ieee80211 module to see if the kernel one was enough. Compillation failed as I saw there were references to the include branch in /usr/include (instead of the usual /usr/src/linux/include for kernel modules) so I suppose you fixed that too?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Mon Mar 06, 2006 2:18 pm    Post subject: Reply with quote

VinzC: when installing ieee80211, after i remove the old headers and then the ebuild extracts the source ,appllies the patches then just before it builds the ieee80211 modules the build fails and it complains about missing files. When i try to do the install manually (i extract the ieee80211 bz2 file to a tmp dir and run the install) after i type 'make' all the files in the working dir dissapear, i dont know where they go but that is what is keeping from using he ieee80211 outside of the kernel tree
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
djtreble
n00b
n00b


Joined: 09 Jan 2006
Posts: 39
Location: Brisbane, Australia

PostPosted: Tue Mar 07, 2006 1:55 pm    Post subject: Reply with quote

One out of three times the /sbin/ipw3945d --quiet fails to start, the module however loads fine.

I increased the sleep to 1.0, but that hasn't fixed it.

Is it just me?
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Mar 07, 2006 2:06 pm    Post subject: Reply with quote

djtreble wrote:
One out of three times the /sbin/ipw3945d --quiet fails to start, the module however loads fine.

I increased the sleep to 1.0, but that hasn't fixed it.

Is it just me?


actually when I first started using this module I had no problems getting ipw3945d to start via the entry in /etc/modules.d/ipw3945 but now it never starts, when my computer is done booting I can see ipw3945 is loaded.... weird.... i dont know what chould be causing this one
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Wed Mar 08, 2006 5:13 am    Post subject: Reply with quote

for those having problems getting the ipw3945d started at boot using /etc/modules.d/ipw3945 I made an rc script to start and stop the daemon

/etc/init.d/ipw3945d
Code:
#!/sbin/runscript
depend() {
  need bootmisc localmount
  after modules coldplug hotplug
  before net
}
checkconfig() {
  if !(test -d /sys/bus/pci/drivers/ipw3945); then
    eerror "Could not find Intel PRO/Wireless 3945ABG Network Connection"
    eerror "Load the 'ipw3945' module"
    return 1
  fi
}
start() {
  checkconfig || return 1
  ebegin "Starting ipw3945d"
    /sbin/ipw3945d --quiet
  eend $? "Error loading ipw3945d"
}
stop() {
  ebegin "Stopping ipw3945d"
    /sbin/ipw3945d --kill
  eend $? "Error loading ipw3945d"
}

_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.


Last edited by rmh3093 on Wed Mar 08, 2006 1:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Wed Mar 08, 2006 1:00 pm    Post subject: can't find iwp3945 Reply with quote

Quote:
Hey,

am I missing something? When I try to emerge ipw3945, emerge fails to find the packages on the server. Any ideas?
Sorry if this is too obvious.


EDIT:

Now it works, I reinstalled the archive and ran emerge again.
Well, it doesn't work. gzip: stdin not in gzip format when trying to install ipw3945-ucode-1.13.tgz (apparently in ipw3945-firmware)


Last edited by Jobbe on Wed Mar 08, 2006 2:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2, 3 ... 30, 31, 32  Next
Page 1 of 32

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum