Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Network freezing (NAT/DSL)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
iluvatar
n00b
n00b


Joined: 16 Jun 2002
Posts: 13

PostPosted: Thu Jun 27, 2002 1:11 am    Post subject: Network freezing (NAT/DSL) Reply with quote

I've just finished setting up a new box to replace my old windows XP nat box... This box has everything iptables/nat releated as modules and iptables/etc seems to work fine where eth1 is connected to my dsl modem and eth0 is connected to the computer I'm writing this on via coax cable. Both internal cards are ne2k-pci-compliant while the dsl one is a 3com 3c59x-ish one.

I can surf the web, use ssh, do anything.

BUT: and this is a big but; The connection between the boxes has a tendency to freeze for up to a minute or so then come back again out of nowhere, regardless of what I'm doing - be it surfing the web or ssh'ing or quake3'ing...

does anyone have an idea as to what is causing this problem?

here's an example ping (-i 5) run I had from this box to the gateway one
Code:
64 octets from 192.168.0.1: icmp_seq=45 ttl=255 time=0.5 ms
64 octets from 192.168.0.1: icmp_seq=46 ttl=255 time=0.5 ms
64 octets from 192.168.0.1: icmp_seq=47 ttl=255 time=0.4 ms
64 octets from 192.168.0.1: icmp_seq=66 ttl=255 time=68.5 ms
64 octets from 192.168.0.1: icmp_seq=67 ttl=255 time=0.7 ms
64 octets from 192.168.0.1: icmp_seq=77 ttl=255 time=1159.0 ms
wrong data byte #0 should be 0xbc but was 0xbbbb 61 1a 3d 88 97 b 0
   8 9 a b c d e f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f 20 21 22 23 24 25 26 27
   28 29 2a 2b 2c 2d 2e 2f
64 octets from 192.168.0.1: icmp_seq=78 ttl=255 time=159.2 ms
64 octets from 192.168.0.1: icmp_seq=79 ttl=255 time=0.5 ms
64 octets from 192.168.0.1: icmp_seq=80 ttl=255 time=0.5 ms


A freezeup obviously occured while the ping was a farking whole second... if I run the ping for an extensive period I get around 40% packetloss, something I find quite scary...
_________________
Corona Extra is your friend.


Last edited by iluvatar on Thu Jun 27, 2002 5:28 pm; edited 2 times in total
Back to top
View user's profile Send private message
iluvatar
n00b
n00b


Joined: 16 Jun 2002
Posts: 13

PostPosted: Thu Jun 27, 2002 2:56 pm    Post subject: Reply with quote

Could the mtu setting on the different cards have anything to do with it?
_________________
Corona Extra is your friend.
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Thu Jun 27, 2002 3:20 pm    Post subject: Reply with quote

Are the MTU settings on the cards different?

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
iluvatar
n00b
n00b


Joined: 16 Jun 2002
Posts: 13

PostPosted: Thu Jun 27, 2002 5:27 pm    Post subject: Reply with quote

eth1 gateway = 1500
ppp0 gateway = 1492
eth0 gateway = 1452

eth0 desktop = 1452


Should all those be the same?
_________________
Corona Extra is your friend.
Back to top
View user's profile Send private message
iluvatar
n00b
n00b


Joined: 16 Jun 2002
Posts: 13

PostPosted: Thu Jun 27, 2002 9:21 pm    Post subject: Reply with quote

n/m ...

I can't seem to figure out why... I've tried every possible mtu configurations and tested all nics and cable for errors and come up with nothing...

I'm going back to winXP as my gateway until I can figure out how to set up a _proper_ fully working linux-only network....
_________________
Corona Extra is your friend.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum