Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel panics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Sat Feb 18, 2006 8:03 pm    Post subject: kernel panics Reply with quote

trying to get a stable system.
ive got
"kernel /boot/bzImage pci=noapci apic root=/dev/hda3"
as my boot line in grub.conf


Code:

chickcam ~ # lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 05)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
00:11.0 ISA bridge: VIA Technologies, Inc. VT8231 [PCI-to-ISA Bridge] (rev 10)
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1e)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1e)
00:11.4 Bridge: VIA Technologies, Inc. VT8235 ACPI (rev 10)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 51)
00:14.0 Network controller: Linksys ADMtek ADM8211 802.11b Wireless Interface (rev 11)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 6a)
chickcam ~ #




ive modprobed ndiswrapper and adm8211 and then it falls over after an irregular period ( usually several 10s of minutes) like this


with ndiswrapper and adm8211 modprobed
Code:
Call Trace:
[<c8833029>] adm8211_interrupt+0x59/0x210 [adm8211]
[<c0125571>]handle_IRQ_event+0x21/0x50
[<c01255ed>]__do_IRQ+0x4d/0x90
[<c01039e9]do_IRQ+0x19/0x30
[<c010277a>]common_interrupt+0x1a/0x20
[<c01000a60>]default_idle+0x0/0x30
[<c01000a83>]default_idle+0x0/0x30
[<c01000aed>]cpu_idle+0x2d/0x50
[<c01000aed>]start_kernel+0x113/0x140
Kernel panic -not syncing:Fatal exception in interrupt


Code:
call trace:
[<c88810c1>] adm81211_interrupt+0x61/0x22o [adm8211]
[<c0124b40>] handle_irq_event2+0x20/0x50
[<c0124bbdd>]__do_IRQ+0x4d/0x90
[<c0103a49>]do_IRQ+0x19/0x30
[<c01027da>]common_interrupt+0x1a/0x20
[<c01000a80>]default_idle+0x0/0x30
[<c01000aa3>]default_idle+0x0/0x30
[<c01000b0d>]cpu_idle+0x2d/0x50
[<c02ee6b9>]start_kernel+0x113/0x140


if no modules are loaded it appears stable.

Ive had it lockup ( blank screen needing a power-off restart) with just ndiswrapper loaded. Ndiswrapper is needed for the wired nw card.
Ive activated kernel hacking - happy to post output is someone tells me what im looking for

looking at dmesg after modprobing adm8211 and ndiswrapper is this - suspicious ?
Code:
dm8211: version magic '2.6.14-gentoo-r5 CYRIXIII gcc-3.4' should be '2.6.14-gentoo-r5 CYRIXIII 4KSTACKS gcc-3.4'
adm8211: version magic '2.6.14-gentoo-r5 CYRIXIII gcc-3.4' should be '2.6.14-gentoo-r5 CYRIXIII 4KSTACKS gcc-3.4'
kobject adm8211: registering. parent: <NULL>, set: module
fill_kobj_path: path = '/module/adm8211'
kobject_hotplug: /sbin/udevsend module seq=335 HOME=/ PATH=/sbin:/bin:/usr/sbin:/usr/bin ACTION=add DEVPATH=/module/adm8211 SUBSYSTEM=module
adm8211: Copyright 2003, Jouni Malinen <jkmaline@cc.hut.fi>; Copyright 2004-2005, Michael Wu <flamingice@sourmilk.net>
adm8211: release 20050620
kobject adm8211: registering. parent: <NULL>, set: drivers
fill_kobj_path: path = '/bus/pci/drivers/adm8211'
kobject_hotplug: /sbin/udevsend drivers seq=336 HOME=/ PATH=/sbin:/bin:/usr/sbin:/usr/bin ACTION=add DEVPATH=/bus/pci/drivers/adm8211 SUBSYSTEM=drivers
0000:00:14.0 (adm8211): EEPROM type 93C46
0000:00:14.0 (adm8211): Channel range: 1 - 13
0000:00:14.0 (adm8211): RFtype=1 BBPtype=1 Specific BBP=0 Transceiver=0
chickcam ~ #



there is an option in the kernel config about 4 stacks - relevant ?

BTW This is a non-GUI server - is there any way I con stop the console screen blanking , so I can hopefully see any more error messages that appear ?
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4727
Location: Angra do Heroísmo (PT)

PostPosted: Sat Feb 18, 2006 8:34 pm    Post subject: Reply with quote

Hi.

To prevent the console screen from blanking, you just need to run setterm -blank 0. If you want to keep the setting after rebooting, you should do
Code:
# echo “setterm –blank n” >> /etc/conf.d/local.start

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
tehminkeh
n00b
n00b


Joined: 22 Nov 2005
Posts: 22

PostPosted: Sat Feb 18, 2006 10:54 pm    Post subject: Reply with quote

I've heard of a lot of problems where ndiswrapper breaks because it overflows the kernel stack. I assume this is whats happening because it is occuring after a seemingly random period of time. I reccomend either getting a new wireless card or downloading a kernel with a 16k stack patch. Try googling for some.
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Sun Feb 19, 2006 9:07 am    Post subject: Reply with quote

but it locks up without ndiswrapper.

Currently its locks with via_rhine,adm8211, quickcam/videodev modprobed. Im going though them to see if any particular combination , but it seems to be ANY module.

Ive activated the kernel hacking debugging stuff and doing tail -f /var/log/everything/current to see if it catches anything but nothing is coming up
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Tue Feb 21, 2006 8:13 pm    Post subject: BUG spinlock lockup up CPU#0 Reply with quote

it fell over again.
On power off restart it came up with this (copied, as it locked up at this point )

Quote:
BUG : spinlock lockup on CPU#0, events/0/4, c7dee15c
dump_stack+0x16/0x20
__spin_lock_debug+0x76/0x90
_raw_spin_lock+0x5e/0x80
_spin_lock_0x9/0x10
cache_flusharray+0x3c/0x110
kmem_cache_free+0x46/0x60
slab_destroy+0c12d/0x140
cache_reap+0x11f/0x170
worker_thread+0x17c/0x200
kthread+0x6f/0xa0
kernel_thread_helper+0x5/0x18


ive also noticed that ssh sessions from a remote machine appear to hang and then kick in after ?30 secs

and also this
h-3.00$ ping chickcam
P
Quote:
ING chickcam (192.168.0.13) 56(84) bytes of data.
64 bytes from chickcam.home.nw (192.168.0.13): icmp_seq=4 ttl=64 time=1170 ms
64 bytes from chickcam.home.nw (192.168.0.13): icmp_seq=5 ttl=64 time=171 ms
64 bytes from chickcam.home.nw (192.168.0.13): icmp_seq=6 ttl=64 time=1.83 ms
64 bytes from chickcam.home.nw (192.168.0.13): icmp_seq=7 ttl=64 time=2.32 ms
64 bytes from chickcam.home.nw (192.168.0.13): icmp_seq=8 ttl=64 time=1.78 ms


ie takes ages to get going

anyone any ideas whats wrong ?
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Sun Feb 26, 2006 9:05 pm    Post subject: Reply with quote

still struggling

If I modprobe ndiswrapper, via_rhine or adm8211 modules, run top and leave it , the machine locks up after between 1 hr 14mins and 1 hr 20mins.

Ive taken the top off and got lots of airflow and had a desk fan blowing over it and it still locks up

latest error message Ive caught:
Code:
[<c0102ce4>] show_stack+0x74/0x80
[<c0102df8>] show_registers+0xe8/0x160
[<c0102fbe>] die+0xce/0x150
[<c028aa33>]do_page_fault+0x3a3/0x550
[<c010298f>]error_code+0x4f/0x60
[<c888140e1>] adm81211_interrupt+0x61/0x22o [adm8211]
[<c0129306>] handle_IRQ_event+0x20/0x50
[<c01293b3>]__do_IRQ+0x73/0xd0
[<c0103c55>]do_IRQ+0x45/0x60
[<c010292a>]common_interrupt+0x1a/0x20
[<c01000b20>]cpu_idle+0x2d/0x50
[<c0100261>] _stext+0x21/0x30
[<c02ee6b9>]start_kernel+0x113/0x140
[<c0100199>]0xc010099
Code: ff 86  d8 01 00 eb 19 etc etc

[/code]
BIOS without apci makes no difference
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Sun Feb 26, 2006 9:45 pm    Post subject: Reply with quote

and another
Quote:

[<c0102fbe>] die+0xce
[<c028aa33>]do_page_fault+0x3a3/0x550
[<c010298f>]error_code+0x4f/0x60
[<c888140e1>] adm81211_interrupt+0x61/0x22o [adm8211]
[<c0129306>] handle_IRQ_event+0x20/0x50
[<c01293b3>]__do_IRQ+0x73/0xd0
[<c0103c55>]do_IRQ+0x45/0x60
[<c010292a>]common_interrupt+0x1a/0x20
[<c010292a>]common_interrupt+0xa/0x20
[<c8813793>]adm8211_set_rx_mode+0x153/0x60[adm8211]
[<c023fa10>]__dev_mc_upload+0x20/0x30
[<c023fa3b>]dev_mc_upload+0x1b/0x30
[<c023d3fb>]dev_change_flags+0x2b/0x100
[<c026cf97>]devinet_ioctl+0x267/0x4d0
[<c026eb97>]inet_ioctl+0x77/0xb0
[<c027952d>]packet_ioctl+0xbd/0xd0
[<c023461b>]sock_ioctl+0x1fb/0x210
[<c0154e76>]do_ioctl+0x26/0x60
[<c01550d5>]vfs_ioctl+0x165/0x180
[<c015511c>]sys_ioctl+0x2c/0x50
[<c01026b9>]syscall_calll+0x7/0xb
Code : 86 b0 01 00 00 a9 00 00 00 11 74 etc etc etc
Kernel panic - not syncing :fatal exception in interrupt


Does anyone know what this means or how to fix it ??
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
linuxtuxhellsinki
l33t
l33t


Joined: 15 Nov 2004
Posts: 692
Location: Hellsinki

PostPosted: Sun Feb 26, 2006 9:55 pm    Post subject: Reply with quote

Quote:
BIOS without apci makes no difference


It's acpi !! So try with pci=noacpi or was it acpi=off :roll:

Check /usr/src/linux/Documentation/kernel-parameters.txt
_________________
1st use 'Search' & lastly add [Solved] to
the subject of your first post in the thread.
Back to top
View user's profile Send private message
sundialsvc4
Guru
Guru


Joined: 10 Nov 2005
Posts: 436

PostPosted: Mon Feb 27, 2006 4:39 pm    Post subject: Reply with quote

Are you doing anything on this machine with virtual file-systems? Accessing a server?

Let's start by trying to 'box in' the problem. Under what conditions is the machine known to be completely stable, for hours on end? List them all...

Also... can you, from the traceback etc, locate the exact points in the kernel source-code where the system is going down? Map these addresses, traceback instruction-dumps and so forth back to the source-code.
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Mon Feb 27, 2006 6:31 pm    Post subject: Reply with quote

the grub boot line is
kernel /boot/bzImage pci=noacpi apic root=/dev/hda3
sorry for typos
ACPI is disabled in the bios ( and I get a dmesg message to that effect as it starts up )

its unstable if the modules ndiswrapper,via-rhine or adm8211 are modprobed singly
its stable if there are no modules or only ieee_crypt_wep is modprobed

it locks if via-rhine is compiled in the kernel

edit :[/quote]more info

Quote:
chickcam ~ # cat /etc/fstab |grep -v '#'
/dev/hda1 /boot ext3 noauto,noatime 1 2
/dev/hda3 / ext3 noatime 0 1
/dev/hda2 none swap sw 0 0
proc /proc proc defaults 0 0
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0

chickcam ~ #
hickcam ~ # lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 05)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
00:11.0 ISA bridge: VIA Technologies, Inc. VT8231 [PCI-to-ISA Bridge] (rev 10)
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1e)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1e)
00:11.4 Bridge: VIA Technologies, Inc. VT8235 ACPI (rev 10)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 51)
00:14.0 Network controller: Linksys ADMtek ADM8211 802.11b Wireless Interface (rev 11)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 6a)

_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Wed Mar 01, 2006 8:34 pm    Post subject: Reply with quote

stable with smbfs,videodev,quickcam,ieee80211_crypt_wep and ieee80211_cypt modprobed .
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Fri Mar 03, 2006 8:14 pm    Post subject: Reply with quote

and falls over after 2 hrs or so after adm8211 modprobed
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Sun Mar 05, 2006 4:07 pm    Post subject: and with knoppix Reply with quote

it it locked up with a system booted with knoppix.
is my problem similar to these ?

http://www.linuxhq.com/kernel/v2.6/15/drivers/net/via-rhine.c
http://linux.derkeiler.com/Mailing-Lists/Kerne/2004-07/2591.html

googling linux 2.6 kernel and via-rhine brings up quite a bit that all refers to problems.

I dont know why my system falls over when via-rhine is loaded though .

Who should I pas this information on to ?[/gwn]
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum