Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
xfreece
n00b
n00b


Joined: 20 Feb 2005
Posts: 23

PostPosted: Tue Feb 14, 2006 4:38 pm    Post subject: Emerge problem Reply with quote

Vad vill den?

Code:

# emerge www/apache-2
Calculating dependencies

!!! Problem in www/apache-2 dependencies.
!!! "Specific key requires an operator (www/apache-2) (try adding an '=')" exceptions


Varför?
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Tue Feb 14, 2006 4:53 pm    Post subject: Reply with quote

Jag har för mig dom ändrat på apache - emerge strukturen.

Sä här ser det ut hos mig:

net-www/apache-2.0.55-r1.

Dvs: www/apache-2 är ogiltligt och emerge apache fungerar för mig.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Tue Feb 14, 2006 9:56 pm    Post subject: Reply with quote

Det har ingenting med några eventuellt ändrade strukturer. Emerge www/apache-2 innehåller två fel. Dels har du specificerat en kategori som inte finns, www istället for net-www, dels har du specificerat ett versionsnummer utan att ha med en operator som beskriver exakt hur portage ska behandla det. Som operator kan du använda >, >=, =, <=, < och ~. Vidare behöver man normalt inte ange kategorin. Ett korrekt kommando med versionsnummer är exempelvis
Code:
emerge ">=apache-2"

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Wed Feb 15, 2006 5:37 am    Post subject: Reply with quote

Kallamej:

Jag har behövt ändra emerge-syntax förut efter förändringar. I bland annat detta fallet (mitt minne kan svika mig här). apache2 eller bara apache beroende på om man ville ha 2.x eller 1.x. Sådana här små förändringar har även hänt innan. Vissa paket har bytts ut och försvunnit osv.
_________________
update world set ignorance=off where religion=on
Back to top
View user's profile Send private message
hoggern
n00b
n00b


Joined: 09 Sep 2005
Posts: 25
Location: Bærum, Norway

PostPosted: Wed Feb 15, 2006 7:49 am    Post subject: Reply with quote

Prøv å skriv:
Code:
emerge -av apache

og se om den finner pakken.
_________________
#402222 @ http://counter.li.org/
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Wed Feb 15, 2006 9:05 pm    Post subject: Reply with quote

patrix_neo wrote:
Kallamej:

Jag har behövt ändra emerge-syntax förut efter förändringar. I bland annat detta fallet (mitt minne kan svika mig här). apache2 eller bara apache beroende på om man ville ha 2.x eller 1.x. Sådana här små förändringar har även hänt innan. Vissa paket har bytts ut och försvunnit osv.

Ja, en gång för länge sen fanns det en apache2 ebuild, men ett namnbyte på ett paket är ju inte en syntaxfråga. Notera att versionsnummer alltid föregås av '-'.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Thu Feb 16, 2006 5:53 am    Post subject: Reply with quote

Code:
 Notera att versionsnummer alltid föregås av '-'.

Precis som apache och apache-2 är olika versioner? (j/k)
Jag utgick ifrån att xfreece emerge:at apache förut och därmed att syntaxen var ogiltlig pga...

Självklart har du rätt. Jag ger mig :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum