Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EBUILDS+HOWTO: installation of Catalyst Framework 5.80029
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Wed Jan 04, 2006 11:37 pm    Post subject: EBUILDS+HOWTO: installation of Catalyst Framework 5.80029 Reply with quote

ANONYMOUS GIT REPOSITORY:

Web access: http://git.overlays.gentoo.org/gitweb/?p=proj/perl-overlay.git;a=summary

GIT access: git://git.overlays.gentoo.org/proj/perl-overlay.git

Anonymous access is read-only, if you want to contribute please contact me (however, the only thing I can do is point you to one of the overlay admins, so you might contact them directly as well).


This overlay is accessible via layman for users. This is the recommended way to use it.

The HOWTO is here: http://en.gentoo-wiki.com/wiki/Catalyst_Framework

If there are ebuilds you'd like to be added to this repository, please leave a note in this topic.

Hello!

I've been using Catalyst - the Perl-based elegant MVC framework - for a while now. The installation on Gentoo Linux is not always straightforward, especially if one wants a full-featured installation and desires to use emerge to handle everything. There's no ebuild in portage for most of the modules, and g-cpan doesn't always behave well.

While we work our way to mainstream, the preferred way to get them is layman, with SVN as an alternative. Take a look at the HowTo linked at the top of this message for more information.

I hope there will be enough success reports which will allow to at least declare stable most of the modules that are in portage, so one won't have to clobber his keywords file too much.

Needless to say, I take no responsibility for any damage these ebuilds may do to your system. But - hey - they're just Perl modules. ;-)

If you'd like a Catalyst or related Perl module to be added to this overlay, just contact me.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/


Last edited by LordArthas on Tue Oct 12, 2010 10:43 am; edited 92 times in total
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Thu Jan 05, 2006 12:28 am    Post subject: Reply with quote

I just love Catalyst :D I'm very sad not to find this beauty earlier... Thank you for your howto! 8)
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sat Jan 07, 2006 9:08 am    Post subject: Reply with quote

Hi all!

I just uploaded version 5.61-r1. The following ebuilds were updated:

Code:

Catalyst-Plugin-Session-Store-File: 0.07 [0.05]
Catalyst-Plugin-StackTrace: 0.02 [0.01]
HTML-Prototype: 1.40 [1.38]
DBIx-Class-Loader: 0.11 [0.10]
Module-Install: 0.52 [0.51]
Data-FormValidator: 4.12 [4.10]


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun Jan 08, 2006 5:42 pm    Post subject: Reply with quote

BUG 117587 (mod_perl was pulled in no matter what) has been resolved, so I'm removing that from the caveats.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Jan 19, 2006 3:59 pm    Post subject: Reply with quote

5.62-pre1 is out!

CHANGES:

The main change is the upgrade to Catalyst 5.62 and the addition of a catalystframework-most ebuild which pulls in a bit more things. See first post of the topic for more information.

These ebuilds where added/updated/deleted:

Code:

Updated ebuilds:
----------------
Catalyst: 5.62 [ 5.61 ]
catalystframework: 5.62 [ 5.61 ]
catalystframework-most: 5.62 [ 5.61 ]
Module-Install: 0.54 [ 0.52 ]
Catalyst-Plugin-I18N: 0.05 [ 0.04 ]
DBIx-Class-Loader: 0.12 [ 0.11 ]
HTTP-Request-AsCGI: 0.3 [ 0.2 ]
HTTP-Body: 0.6 [ 0.5 ]
UNIVERSAL-can: 1.03 [ 1.01 ]
HTML-Prototype: 1.41 [ 1.40 ]
Text-SimpleTable: 0.03 [ 0.02 ]
Catalyst-Engine-Apache: 1.06 [ 1.05 ]

Additions:
----------
Catalyst-Plugin-Unicode
Catalyst-Plugin-Authentication
Catalyst-Plugin-Authentication-Store-DBIC
Catalyst-Plugin-Email
PAR
+ the dependecies for all these

Removals:
---------
Catalyst-Plugin-Config-YAML (it's core Catalyst now)


Important: take a look at the packages you need to unmask, as I had to add some more.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
jmanning
n00b
n00b


Joined: 22 Oct 2003
Posts: 27

PostPosted: Thu Jan 19, 2006 5:24 pm    Post subject: Portage Overlay? Reply with quote

Can we put this overlay into a subversion repository somewhere?
Maybe the catalyst devs would be willing to include it in the main repository. If not, I have one I could make public.
It would be much easier to maintain and develop there.
Code:
cd /usr/local/overlays/
svn co http://someserver/repos/catalystframework

PORTAGE_OVERLAY="/usr/local/portage /usr/local/overlays/catalystframework"

It's similar in structure and update mechanism to the other overlays at http://gentoo-wiki.com/TIP_Overlays

~J
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Jan 19, 2006 7:47 pm    Post subject: Re: Portage Overlay? Reply with quote

Hello!

jmanning wrote:
Can we put this overlay into a subversion repository somewhere?
Maybe the catalyst devs would be willing to include it in the main repository. If not, I have one I could make public.


I was about to set one up, but spare time is what it is, so if anybody can do that in a shorter time than me that woul be great. ;-)

If not, I'll probably work on it at the beginning of February.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon Jan 23, 2006 10:58 am    Post subject: Reply with quote

Hello folks!

Version 5.63 is available.

CHANGES:

Code:

New unmaskings needed:
----------------------
dev-perl/yaml
dev-perl/Spiffy
dev-perl/Class-Spiffy
dev-perl/Test-Base

Updated ebuilds:
----------------
Catalyst: 5.63 [ 5.62 ]
catalystframework: 5.63 [ 5.62 ]
catalystframework-most: 5.63 [ 5.62 ]
HTTP-Request-AsCGI: 0.05 [0.03]
Test-WWW-Mechanize-Catalyst: 0.35 [0.34]


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Tue Jan 24, 2006 12:26 pm    Post subject: Missing requirement in Object::Signature Reply with quote

Hi,
Object::Signature fails to build, with an access violation, because it was missing Storable being listed as a requirement.

Edit dev-perl/Object-Signature-1.03.ebuild, and add >=perl-core/Storable-2.11 to the dependancies:
ie. It now reads:

DEPEND="perl-core/Test-Simple
>=perl-core/Storable-2.11"
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Tue Jan 24, 2006 12:46 pm    Post subject: Bug in Test::WWW::Mechanize::Catalyst ebuild Reply with quote

The SRC_URI appears to be wrong. To fix it, I changed it to:

SRC_URI="http://search.cpan.org/CPAN/authors/id/L/LB/LBROCARD/${P}.tar.gz"
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Tue Jan 24, 2006 2:08 pm    Post subject: Reply with quote

Hello wintrmute!

Object-Signature:

It builds with no problem for me, with perl 5.8.7 (Storable is core, and in a recent enough version). I think I'll add that dependency anyway, for who's using an older Perl. What version of the interpreter are you using?

Test-WWW-Mechanize:

It downloads here also with the mirror://... SRC_URI. The problem was probably that the 0.35 version is very recent, so your (autoselected) mirror was probably still without it.

Thanks for reporting, Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/


Last edited by LordArthas on Tue Jan 24, 2006 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Tue Jan 24, 2006 2:14 pm    Post subject: Reply with quote

Mifiele wrote:
It builds with no problem for me, with perl 5.8.7 (Storable is core, and in a recent enough version).
...
What version of the interpreter are you using?


Ah, botheration!
I'm running 5.8.7 as well - and yes, Storable is in core. However, Gentoo had, at some point in my past, installed perl-core/Storable, but an older version, which was then masking the newer one.

I've had this happen a few times before too, with perl-core/* modules getting installed (because they're listed as pre-requisites elsewhere) and masking newer versions.

Thanks,
Toby
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Wed Jan 25, 2006 8:35 am    Post subject: Reply with quote

Hello!

wintrmute wrote:

I'm running 5.8.7 as well - and yes, Storable is in core. However, Gentoo had, at some point in my past, installed perl-core/Storable, but an older version, which was then masking the newer one.
I've had this happen a few times before too, with perl-core/* modules getting installed (because they're listed as pre-requisites elsewhere) and masking newer versions.


This is becoming a real problem with all the perl-core thing. In my packages I try not to depend on any perl-core package except when the version is superior to the one of perl 5.8.7. However, not all of my (Catalyst) packages behave this way yet.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Tue Jan 31, 2006 1:09 pm    Post subject: PPC keyword Reply with quote

BTW, I think all the packages are safe for use on PPC, but none have the keyword (or even ~ppc) added.
Back to top
View user's profile Send private message
casret
n00b
n00b


Joined: 02 Mar 2004
Posts: 6

PostPosted: Tue Jan 31, 2006 7:29 pm    Post subject: Reply with quote

This is very cool, thanks for your work on it. Looks like the File-Copy-Recursive moved a couple versions since last week, and your version is now gone, I just had to copy and generate the digest.
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Wed Feb 01, 2006 2:50 pm    Post subject: Using this overlay on PPC platform Reply with quote

If you're attempting to use this overlay on the PPC platform, then you'll need to put a *lot* of entries into /etc/portage/package.keywords.
For your convenience, here's the entire list:
Code:

dev-perl/Array-Compare x86
dev-perl/Catalyst x86
dev-perl/Catalyst-Engine-Apache x86
dev-perl/Catalyst-Model-DBIC x86
dev-perl/Catalyst-Model-DBIC-Plain x86
dev-perl/Catalyst-Plugin-Authentication x86
dev-perl/Catalyst-Plugin-Authentication-Store-DBIC x86
dev-perl/Catalyst-Plugin-DefaultEnd x86
dev-perl/Catalyst-Plugin-Email x86
dev-perl/Catalyst-Plugin-FillInForm x86
dev-perl/Catalyst-Plugin-FormValidator x86
dev-perl/Catalyst-Plugin-FormValidator-Simple x86
dev-perl/Catalyst-Plugin-I18N x86
dev-perl/Catalyst-Plugin-Pluggable x86
dev-perl/Catalyst-Plugin-Prototype x86
dev-perl/Catalyst-Plugin-Session x86
dev-perl/Catalyst-Plugin-Session-State-Cookie x86
dev-perl/Catalyst-Plugin-Session-State-URI x86
dev-perl/Catalyst-Plugin-Session-Store-File x86
dev-perl/Catalyst-Plugin-Singleton x86
dev-perl/Catalyst-Plugin-StackTrace x86
dev-perl/Catalyst-Plugin-SubRequest x86
dev-perl/Catalyst-Plugin-Unicode x86
dev-perl/Catalyst-Plugin-XMLRPC x86
dev-perl/Catalyst-View-TT x86
dev-perl/Class-Accessor-Chained x86
dev-perl/Class-C3 x86
dev-perl/DBIx-Class x86
dev-perl/DBIx-Class-Loader x86
dev-perl/Data-FormValidator x86
dev-perl/Data-Page x86
dev-perl/Email-Address x86
dev-perl/Email-Date x86
dev-perl/Email-MIME x86
dev-perl/Email-MIME-ContentType x86
dev-perl/Email-MIME-Creator x86
dev-perl/Email-MIME-Encodings x86
dev-perl/Email-MIME-Modifier x86
dev-perl/Email-MessageID x86
dev-perl/Email-Send x86
dev-perl/Email-Simple x86
dev-perl/Email-Simple-Creator x86
dev-perl/Email-Valid-Loose x86
dev-perl/FCGI-ProcManager x86
dev-perl/File-Copy-Recursive x86
dev-perl/File-Modified x86
dev-perl/FormValidator-Simple x86
dev-perl/HTML-Prototype x86
dev-perl/HTTP-Body x86
dev-perl/HTTP-Request-AsCGI x86
dev-perl/List-MoreUtils x86
dev-perl/Module-Find x86
dev-perl/Module-Install x86
dev-perl/Module-Pluggable x86
dev-perl/Module-Pluggable-Fast x86
dev-perl/Module-ScanDeps x86
dev-perl/Object-Signature x86
dev-perl/PAR x86
dev-perl/Path-Class x86
dev-perl/Return-Value x86
dev-perl/SQL-Abstract-Limit x86
dev-perl/Set-Object x86
dev-perl/Sub-Name x86
dev-perl/Template-Timer x86
dev-perl/Test-Deep x86
dev-perl/Test-MockObject x86
dev-perl/Test-NoWarnings x86
dev-perl/Test-Tester x86
dev-perl/Test-WWW-Mechanize-Catalyst x86
dev-perl/Test-Warn x86
dev-perl/Text-SimpleTable x86
dev-perl/Tree-DAG_Node x86
dev-perl/Tree-Simple-VisitorFactory x86
dev-perl/UNIVERSAL-can x86
dev-perl/UNIVERSAL-isa x86
dev-perl/UNIVERSAL-require x86
dev-perl/URI-Find x86
dev-perl/catalystframework x86
dev-perl/catalystframework-most x86
dev-perl/Tree-Simple ~ppc
dev-perl/Test-Base ~ppc
dev-perl/SQL-Abstract x86
dev-perl/locale-maketext-lexicon ~ppc
dev-perl/Locale-Maketext-Simple ~ppc
dev-perl/Test-WWW-Mechanize ~ppc
dev-perl/HTTP-Server-Simple ~ppc
dev-perl/Carp-Assert-More ~ppc
dev-perl/Carp-Assert ~ppc
dev-perl/Test-LongString ~ppc
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Feb 02, 2006 10:45 am    Post subject: Reply with quote

Hello!

Version 5.63-r1 is out. Here's the changelog:

Code:

- Added all Gentoo keywords to any package, so installation is now
possible on other plastforms besides x86 and amd64 (but I'm testing
these two only, as I only own PC with these)

Updated ebuilds:
----------------
Module-Install: 0.55 [ 0.54 ]
File-Copy-Recursive: 0.18 [ 0.16 ]
Catalyst-View-TT: 0.22 [ 0.21 ]
Email-Send: 2.04 [ 2.00 ]
Catalyst-Plugin-Session-State-URI: 0.02 [ 0.01 ]
DBIx-Class-Loader: 0.16 [ 0.12 ]


So this should build on any platform (including the PPC wintrmute requested), therefore making the /etc/package.keywords under ppc similar to the amd64 one.

Michele.
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Tue Feb 07, 2006 4:07 pm    Post subject: ebuilds for DBIx::Class 0.05002 and Class::Data::Accessor Reply with quote

erato Class-Data-Accessor # cat Class-Data-Accessor-0.02.ebuild
Code:

# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header$

inherit perl-module

DESCRIPTION="Class::Data::Accessor"
HOMEPAGE="http://search.cpan.org/dist/${PN}/"
SRC_URI="mirror://cpan/authors/id/C/CL/CLACO/${P}.tar.gz"
LICENSE="|| ( Artistic GPL-2 )"

SLOT="0"
KEYWORDS="x86 ppc amd64"
RESTRICT="nomirror"

DEPEND="dev-perl/module-build"


erato DBIx-Class # cat DBIx-Class-0.05002.ebuild
Code:

# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header$

inherit perl-module

DESCRIPTION="Extensible and flexible object <-> relational mapper."
HOMEPAGE="http://search.cpan.org/dist/${PN}/"
SRC_URI="mirror://cpan/authors/id/D/DK/DKAMHOLZ/${P}.tar.gz"
LICENSE="|| ( Artistic GPL-2 )"

SLOT="0"
KEYWORDS="x86 amd64"
RESTRICT="nomirror"

IUSE="sqlite"
DEPEND="dev-perl/module-build
        >=dev-perl/Data-Page-2.00
        dev-perl/DBI
        >=dev-perl/Class-Data-Accessor-0.02
        dev-perl/UNIVERSAL-require
        perl-core/Scalar-List-Utils
        >=dev-perl/SQL-Abstract-1.20
        >=dev-perl/SQL-Abstract-Limit-0.10.1
        sqlite? ( >=dev-perl/DBD-SQLite-1.08 )
        >=dev-perl/Class-C3-0.07
        dev-perl/Tie-IxHash
        dev-perl/Module-Find
        perl-core/Storable
        dev-perl/Class-Trigger
        dev-perl/DBIx-ContextualFetch"
Back to top
View user's profile Send private message
dwc
n00b
n00b


Joined: 09 Jun 2003
Posts: 24

PostPosted: Wed Feb 08, 2006 7:16 am    Post subject: Available in Subversion Reply with quote

Hi,

I'm the Daniel that Michele mentioned in the original post. :)

My ebuilds are available in Subversion. Currently I have all of Task::Catalyst, including Catalyst 5.64 (released earlier today).

Code:

mkdir -p /usr/local/overlays
cd /usr/local/overlays
svn checkout http://svn.westermann-clark.com/overlays/perl-catalyst/trunk/ perl-catalyst


Then add /usr/local/overlays/perl-catalyst to PORTDIR_OVERLAY in your make.conf, and run:

Code:
emerge -av Task-Catalyst


Currently the ebuilds are keyworded x86 only, but I can easily rekeyword them tomorrow morning. :)
Back to top
View user's profile Send private message
wintrmute
n00b
n00b


Joined: 24 Jan 2006
Posts: 10

PostPosted: Wed Feb 08, 2006 3:45 pm    Post subject: Re: Available in Subversion Reply with quote

dwc wrote:
Currently the ebuilds are keyworded x86 only, but I can easily rekeyword them tomorrow morning. :)


Don't forgest PPC and AMD64! Thanks :)

(As I have a PPC laptop and AMD64 machine, I hit the lack-of-keywords thing all the time :( )
Back to top
View user's profile Send private message
dwc
n00b
n00b


Joined: 09 Jun 2003
Posts: 24

PostPosted: Wed Feb 08, 2006 11:17 pm    Post subject: Re: Available in Subversion Reply with quote

wintrmute wrote:
Don't forgest PPC and AMD64! Thanks :)

(As I have a PPC laptop and AMD64 machine, I hit the lack-of-keywords thing all the time :( )


amd64 and ppc keywords added, thanks to ekeyword. :)

I'm being pretty liberal with the keywords at this point - if you run into any problems, let me know.

If users on other arches find the ebuilds stable, let me know and I'll add the appropriate keywords. Thanks!
Back to top
View user's profile Send private message
thomash
n00b
n00b


Joined: 25 Oct 2003
Posts: 14

PostPosted: Sun Feb 12, 2006 9:53 pm    Post subject: Reply with quote

This ebuild looks nice. I've had alot of trouble getting Catalyst apps to run with apache2 and mod_perl.

Could anyone post complete httpd.conf and 75-mod_perl.conf files (or links to them)?
Something that will make Catalyst examples working out of the box would be nice.

Thanks.
Thomas
Back to top
View user's profile Send private message
dlucian
n00b
n00b


Joined: 13 Feb 2006
Posts: 1

PostPosted: Mon Feb 13, 2006 7:35 am    Post subject: Reply with quote

Hi. I have 2 catalyst-apps on mod_perl2. Here are the interesting bits from /etc/apache2/modules.d/:

in apache2-mod_perl-startup.pl:
Code:

use ModPerl::Util (); #for CORE::GLOBAL::exit

use Apache2::Connection  ();
use Apache2::RequestIO ();
use Apache2::RequestRec ();
use Apache2::RequestUtil ();
use Apache2::Response    ();

use Apache2::ServerRec ();
use Apache2::ServerUtil ();
use Apache2::Connection ();
use Apache2::Log ();

#use APR::Table ();

use ModPerl::Registry ();

use Apache2::Const -compile => ':common';
#use APR::Const -compile => ':common';

1;


in 75_mod_perl.conf:
Code:

<IfDefine PERL>
  <IfModule !mod_perl.c>
    LoadModule perl_module    modules/mod_perl.so
  </IfModule>
</IfDefine>

<IfModule mod_perl.c>
    PerlSwitches -w
#   PerlTrace all
    PerlRequire "/etc/apache2/modules.d/apache2-mod_perl-startup.pl"

    ### Apache-DBI
    PerlModule Apache2::Status
    PerlModule Apache::DBI
    PerlModule DBI

    PerlSetVar StatusOptionsAll On
    PerlSetVar StatusTerse On
    #PerlSetVar StatusTerseSize On
    #PerlSetVar StatusTerseSizeMainSummary On
    #PerlModule B::TerseSize

    <Location /perl-status>
        SetHandler perl-script
        PerlResponseHandler Apache2::Status
        PerlSetVar StatusOptionsAll On
        PerlSetVar StatusDeparseOptions "-p -sC"
        <IfModule mod_access.c>
            Order deny,allow
            Deny from all
            Allow from 127.0.0.1 192.168.0.1
        </IfModule>
    </Location>

</ifModule>


in 997_catalystapps.conf
Code:

PerlSwitches -I/home/lucid/projects/dssr/lib -I/home/lucid/projects/plpr/lib

PerlLoadModule DSSR
<Location /dssr>
     SetHandler perl-script
     PerlResponseHandler DSSR
</Location>
Alias /dssr/static /home/lucid/projects/dssr/root/static
<Location /dssr/static>
    SetHandler default-handler
</Location>

PerlLoadModule  PLPR
<Location /plpr>
     SetHandler perl-script
     PerlResponseHandler PLPR
</Location>
Alias /plpr/static /home/lucid/projects/plpr/root/static
<Location /plpr/static>
    SetHandler default-handler
</Location>


dlucian
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Tue Feb 14, 2006 4:33 pm    Post subject: Reply with quote

Hello folks!

Version 5.64 of the ebuilds is up, and now catalystframework matches the latest Task::Catalyst.

For who wants to contribute: I managed to setup a (protected) SVN server, if somebody wants to help me with this ebuilds just send a personal message to me to get an user/password pair.

Here's the changelog:

Code:

- Authentication modules moved from catalystframework-most to
catalystframework.
- FormValidator e FillInForm plugins were removed from Task:Catalyst,
so I moved them to catalystframewor-most since it seems many people
are still using them.
- catalystframework-most now pulls in also Catalyst::Plugin::CDBI
and all the depending modules, as many people still use Class::DBI
instead of DBIx::Class.

Updated ebuilds:
----------------
Module-Install: 0.56 [ 0.55 ]
Module-Pluggable: 2.97 [ 2.96 ]
Catalyst: 5.64 [ 5.63 ]
HTML-Prototype: 1.43 [ 1.41 ]
Class-C3: 0.10 [ 0.09 ]
DBIx-Class: 0.05005 [ 0.04001 ]
DBIx-Class-Loader: 0.18 [ 0.16 ]
Data-FormValidator: 4.13 [ 4.12 ]
UNIVERSAL-can: 1.11 [ 1.03 ]

_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun Feb 19, 2006 5:49 pm    Post subject: Reply with quote

Hello!

First of all, the anonymous SVN server is now available, just read at the top of the first message of this thread for more information.

Then, version 5.64-r1 of the ebuilds package is out. CHANGES:

Code:

Updated ebuilds:
----------------
DBIx-Class: 0.05006 [ 0.05005 ]
Module-ScanDeps: 0.55 [ 0.54 ]
Catalyst-Engine-Apache: 1.07 [ 1.06 ]
PAR: 0.91 [ 0.90 ]
DBIx-Class-Loader: 0.20 [ 0.19 ]
Data-FormValidator: 4.14 [ 4.13 ]


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 1 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum