Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOW-TO]Cómo usar Portage correctamente(actualizado: 29-5-8)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3733

PostPosted: Wed May 11, 2005 1:01 pm    Post subject: Reply with quote

Quote:
Una nota rapida. Si deseo emerger un paquete unico sin instlar ninguna de sus dependencias, ¿Como se hace?


emerge -O paquete ;)
( una o mayúscula, no un cero)

saluetes
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ArsDangor
Guru
Guru


Joined: 20 May 2003
Posts: 477

PostPosted: Wed May 11, 2005 7:05 pm    Post subject: Reply with quote

Code:
emerge -O paquete.

man emerge wrote:
--nodeps (-O)
Merges specified packages without merging any dependencies. Note that the build may fail if the dependencies aren't satisfied.

_________________
Cómo usar Portage correctamente
Back to top
View user's profile Send private message
Xmen
n00b
n00b


Joined: 09 Dec 2005
Posts: 35

PostPosted: Sat Dec 10, 2005 3:41 am    Post subject: instalacion de paquetes Reply with quote

hola a todos

yo soy nuevo con el gentoo, pues lo utilice hace algún tiempo pero lo cogí ya instalado y configurado y funcionaba a la perfección, como me gustó tanto y vi mi trabajo muy eficiente con él desidí entalarlo para mi trabajo profesional. en esta ocacion y como es la primera tengo problemas para instalar el openoffice-2 en estos momentos tengo el binario. En mi caso yo me actualizo de un repositorio donde estan todos los distfiles que necesito, cuando instalé el sistema lo hice con un portage viejo pero ayer lo actulizé descomprimiendo el nuevo, pero me descarga el openoffice-1.1.4 y no es 2 que es el que yo deseo.

espero alguien me ayude. y no les moleste que yo pregunte, pues soy nuevo en el tema y necesito mucha ayuda por parte de otros usuarios de gentoo.

gracias de antemano...
Back to top
View user's profile Send private message
Xmen
n00b
n00b


Joined: 09 Dec 2005
Posts: 35

PostPosted: Sat Dec 10, 2005 5:15 am    Post subject: Reply with quote

hola soy yo otra ves, tengo problemas con el screensaver pues estoy como root y no puedo bloquear la pantalla y cuando voy a las preferencias me lanza un mensaje que dice lo siguiente

The XScreenSaver daemon doesn't seem to be running on display ":0.0". Launch it now?

le doy ok y no me muestra el siguiente error:


The xscreensaver daemon did not start up properly.

alguien que tenga una idea que la comparta conmigo

gracias
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Sat Dec 10, 2005 2:56 pm    Post subject: Reply with quote

En el primer mensaje de este post, en la sección Mantener paquetes tienes la solución, el paquete tiene el siguiente estado:
http://packages.gentoo.org/ebuilds/?openoffice-bin-2.0.0
Back to top
View user's profile Send private message
Antares-1
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2005
Posts: 105

PostPosted: Mon Dec 12, 2005 2:23 pm    Post subject: Reply with quote

Hola gente, les comento una necesidad que me surgio hace poquito con el tema del Emerge.

Resulta que yo instale KDE y todos sus derivados usando el CD de Paquetes con la opción emerge -K kde-meta (O sea, instalar todo).

Como me doy maña con el Emerge y los paquetes a compilar, resulta que quiero desinstalar KDE para dejar solamente Xfce4. Pero cuando le hago Emerge -C no me deja desinstalar nada, o al menos hace que lo desinstala pero nada, siguen ahi. Ademas, estoy gastanto con el KDE y 80.000.000 de programas que no uso un monton de espacio en disco.

Alguno sabe exactamente que comando se utiliza para Desemerger paquetes que fueron extraidos del Package CD.

Mañana les pongo logs, saludos.
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2953
Location: Valencia, Spain

PostPosted: Mon Dec 12, 2005 3:05 pm    Post subject: Reply with quote

Nekki-Basara wrote:
Resulta que yo instale KDE y todos sus derivados usando el CD de Paquetes con la opción emerge -K kde-meta (O sea, instalar todo).... resulta que quiero desinstalar KDE para dejar solamente Xfce4. Pero cuando le hago Emerge -C no me deja desinstalar nada, o al menos hace que lo desinstala pero nada,

Alguno sabe exactamente que comando se utiliza para Desemerger paquetes que fueron extraidos del Package CD.
Por lo que recuerdo, los paquetes meta sirven para instalar todo de una, pero a la hora de desinstalar hay que hacerlo uno a uno.

Hay varias maneras de desinstalar de golpe los distintos paquetes de KDE que instalaste, por ejemplo
Code:
# unalias ls
# cd /usr/portage/kde-base/
# ls | awk '{ print "kde-base/"$1""}' | xargs emerge -C


Si no te funciona, indicanos la salida del comando para saber que falla.

Saludozzzzzz
Back to top
View user's profile Send private message
Xmen
n00b
n00b


Joined: 09 Dec 2005
Posts: 35

PostPosted: Mon Dec 12, 2005 4:20 pm    Post subject: Reply with quote

hola a todos

tengo problema al instalar el gimp pues cuando le hago emerge gimp luego de descargarlo me indica el siguiente mensaje

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/gimp-2.2.8-r1/work/gimp-2.2.8/config.log

!!! ERROR: media-gfx/gimp-2.2.8-r1 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

y no tengo idea de lo que me quiere decir. alguna idea de lo que debo hacer???

gracias psm1984 por lo anterior, respecto al oppenoffice-2
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2582
Location: Oviedo, Spain

PostPosted: Mon Dec 12, 2005 6:36 pm    Post subject: Reply with quote

Xmen wrote:
hola a todos

tengo problema al instalar el gimp pues cuando le hago emerge gimp luego de descargarlo me indica el siguiente mensaje

!!! Please attach the config.log to your bug report:

!!! /var/tmp/portage/gimp-2.2.8-r1/work/gimp-2.2.8/config.log

!!! ERROR: media-gfx/gimp-2.2.8-r1 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed

!!! If you need support, post the topmost build error, NOT this status message.

y no tengo idea de lo que me quiere decir. alguna idea de lo que debo hacer???

gracias psm1984 por lo anterior, respecto al oppenoffice-2


Quizás deberías abrir un nuevo hilo para tratar este problema en concreto, pero bueno ;)
Como te dice el mensaje sería interesante que nos pusieses las líneas que están encima de:
Code:
!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/gimp-2.2.8-r1/work/gimp-2.2.8/config.log

!!! ERROR: media-gfx/gimp-2.2.8-r1 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.



Saludos
________________________________________

Xmen wrote:
hola soy yo otra ves, tengo problemas con el screensaver pues estoy como root y no puedo bloquear la pantalla y cuando voy a las preferencias me lanza un mensaje que dice lo siguiente

The XScreenSaver daemon doesn't seem to be running on display ":0.0". Launch it now?

le doy ok y no me muestra el siguiente error:


The xscreensaver daemon did not start up properly.

alguien que tenga una idea que la comparta conmigo

gracias


Si mal no recuerdo xscreensaver no se puede usar como root, ya que consideran arriesgado dejar una sesión de root abierta. Por tanto deberías usar otro screensaver (como xlock, por ejemplo) en su lugar. Si como usuario normal no tienes problemas para usar xscreensaver no tienes, a mi parecer, de qué preocuparte.

Saludos
Back to top
View user's profile Send private message
Xmen
n00b
n00b


Joined: 09 Dec 2005
Posts: 35

PostPosted: Mon Dec 12, 2005 10:08 pm    Post subject: problemas para instalar GIMP Reply with quote

repecto a esto me da el error a partir de la siguiente linea:

checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/gimp-2.2.9/work/gimp-2.2.9/config.log

!!! ERROR: media-gfx/gimp-2.2.9 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

dime si esto te dice algo y gracias pacho2 por la respuesta anterior
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2582
Location: Oviedo, Spain

PostPosted: Tue Dec 13, 2005 6:53 pm    Post subject: Re: problemas para instalar GIMP Reply with quote

Xmen wrote:
repecto a esto me da el error a partir de la siguiente linea:

checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/gimp-2.2.9/work/gimp-2.2.9/config.log

!!! ERROR: media-gfx/gimp-2.2.9 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

dime si esto te dice algo y gracias pacho2 por la respuesta anterior


Es raro, lo normal es que las dependencias esten resueltas :?

¿tienes instalado libxml-perl? (y por supuesto libxml2 también, aunque este está definido como dependencia en el ebuild con lo que lo deberías tener)

Saludos
Back to top
View user's profile Send private message
Antares-1
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2005
Posts: 105

PostPosted: Tue Dec 13, 2005 10:43 pm    Post subject: Reply with quote

Bueno, gracias por aclararme las dudas, lo voy a intentar a ver que sale cuando tenga bien configurado el X y el XFCE4.

Mientras tanto, les tengo otras duditas con respecto al manejo de portage:

[b]1)[/b] Al hacer emerge -p paquete me tira maso menos las dependencias que yo necesito bajar (Como no tengo internet en casa las bajo de un mirror oficial y esas cosas) pero en algunos casos al hacer emerge paquete me empieza a pedir mas dependencias o librerias que no salen al hacer la opción -p.

Existe un parametro para saber TODAS las dependencias que voy a necesitar???

[b]2)[/b] Quiero compilar el Aterm, pero me pide el AfterStep-2.1.1.tar.bz2... pero en TODOS los mirrors que consulte solamente esta la versión 2.1.2... como puedo configurar PORTAGE para que me utilize esta versión mas nueva sin hacer el emerge --sync?

[b]3)[/b] divx4linux que me pide el mplayer no lo encuentro por ningun lado...
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2582
Location: Oviedo, Spain

PostPosted: Wed Dec 14, 2005 6:55 pm    Post subject: Reply with quote

Nekki-Basara wrote:
Bueno, gracias por aclararme las dudas, lo voy a intentar a ver que sale cuando tenga bien configurado el X y el XFCE4.

Mientras tanto, les tengo otras duditas con respecto al manejo de portage:

1) Al hacer emerge -p paquete me tira maso menos las dependencias que yo necesito bajar (Como no tengo internet en casa las bajo de un mirror oficial y esas cosas) pero en algunos casos al hacer emerge paquete me empieza a pedir mas dependencias o librerias que no salen al hacer la opción -p.

Existe un parametro para saber TODAS las dependencias que voy a necesitar???

2) Quiero compilar el Aterm, pero me pide el AfterStep-2.1.1.tar.bz2... pero en TODOS los mirrors que consulte solamente esta la versión 2.1.2... como puedo configurar PORTAGE para que me utilize esta versión mas nueva sin hacer el emerge --sync?

3) divx4linux que me pide el mplayer no lo encuentro por ningun lado...


Me parece que tendrías que hacer un emerge --sync, como veo que no parezca que puedas (como es mi caso), puedes probar a hacer lo siguiente (YO NO LO HE PROBADO):
Code:

wget http://ftp.heanet.ie/pub/gentoo/snapshots/portage-latest.tar.bz2
cd /usr/portage
tar jxvf portage-latest.tar.bz2
emerge --metada


REPITO: No lo he probado

Espera un día o así por si acaso alguien tiene que corregir algo.

Saludos
Back to top
View user's profile Send private message
Antares-1
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2005
Posts: 105

PostPosted: Wed Dec 14, 2005 7:18 pm    Post subject: Reply with quote

Todavia me falta el tema de TODAS las depencias que me tira, a ver si asi puedo compilar por fin el mplayer con mis USES...
Back to top
View user's profile Send private message
aj2r
l33t
l33t


Joined: 11 Sep 2005
Posts: 705
Location: Granada/Andalucí­a/España

PostPosted: Sun Jan 22, 2006 12:38 pm    Post subject: Reply with quote

Cuando se hace un emerge de varios programas a la vez (cientos en ocasiones) es tedioso por no decir casi imposible tener en cuenta los avisos que algunos de éstos muestran, pongo como ejemplo a perl que da el consejo de hacer perl-cleaner.
¿Existe una solución para esto? Y si no existe, ¿hay intención de tener en cuenta esta situación en versiones futuras de portage?
_________________
Fundación I+D del Software Libre
BluLabs
_____________________________________________________
Portátil HP Pavilion zd8185ea: Pentium4HT 3.2Ghz, ATI x600 256MB
gnome-2.30
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2953
Location: Valencia, Spain

PostPosted: Sun Jan 22, 2006 4:16 pm    Post subject: Reply with quote

aj2r wrote:
Cuando se hace un emerge de varios programas a la vez (cientos en ocasiones) es tedioso por no decir casi imposible tener en cuenta los avisos que algunos de éstos muestran, pongo como ejemplo a perl que da el consejo de hacer perl-cleaner.
¿Existe una solución para esto? Y si no existe, ¿hay intención de tener en cuenta esta situación en versiones futuras de portage?

Tienes un parche para portage llamado "enotice" ( http://www.fmp.com/enotice/ ) que sirve para guardar estos mensajes para leerlos mas tarde, aunque nuevamente, en la version 2.1 de portage creo que va a venir de serie.

Saludozzzzzzz
Back to top
View user's profile Send private message
navegante
l33t
l33t


Joined: 21 Jul 2004
Posts: 702

PostPosted: Mon Jan 23, 2006 2:12 am    Post subject: Reply with quote

Como bien menciona Stolz existe un pequeño script que realiza esto, si desas saber como usarlo pasate por aqui, o en español, por cierto que para que no se te pasen estas noticias (tambien avisaron de otras que generaron muchos post como el script al actualizar gcc, el python-updater, etc...) te sugiero suscribirte al GWN, saludos.
_________________
"El hombre es libre desde que nace, aún para decidir no ser libre"
KDE registered user: #2655 | Linux registered user: #404918
Back to top
View user's profile Send private message
maximan
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2005
Posts: 110
Location: Rio Cuarto-Argentina

PostPosted: Wed Feb 08, 2006 12:08 am    Post subject: Reply with quote

Tengo un problema bah no se como hacer.

recien le hice a mi gentoo un
Code:
emerge --sync

y luego

Code:
emerge -uDav --newuse world


Se tardo mucho (no se cuanto porque lo deje en la noche)

despues de 1 dia le volvi a dar

Code:
emerge -uDav --newuse world


para ver que me daba y me dice que va a bajar todo de nuevo, mi pregunta es no deberia bajar lo nuevo y no todo de nuevo???
Que hago mal?
Back to top
View user's profile Send private message
Eleazar Anzola
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1253
Location: Caracas / Venezuela

PostPosted: Wed Feb 08, 2006 1:43 pm    Post subject: Reply with quote

Recuerda que cuando le dices newuse tiene que tocar todos los paquetes que son afectados por las uses nuevas y por ende las dependencias de muchos de estos.
_________________
Salu2
Eleazar Anzola
Linux User : # 216232
__________________________________________
Por un foro ordenado y un buscador más útil:
[TEMA] Descripción problema (estado)
Back to top
View user's profile Send private message
Eleazar Anzola
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1253
Location: Caracas / Venezuela

PostPosted: Wed Feb 08, 2006 6:35 pm    Post subject: Reply with quote

Ummmm, es que no se como empezar........

Estoy intentando montar el xorg-x11-7.0-r1 pero me dice que algunas dependencias estan enmascaradas y las voy haciendo una por una y esta a su vez trae otras y otras y otras que se hace interminable.

¿Como le digo que emerja todo sinimportar que este masked?

Ya lo intente haciendo el ACCEP_KEYWORDS="~x86" pero aun asi sigue pidiendo más y más ymás y más y más. tanto que ya parece estar contagiada de mi esposa e hijas :P (Si leen esto creo que dejare de postear por mucho tiempo je je je je je je )
_________________
Salu2
Eleazar Anzola
Linux User : # 216232
__________________________________________
Por un foro ordenado y un buscador más útil:
[TEMA] Descripción problema (estado)
Back to top
View user's profile Send private message
aj2r
l33t
l33t


Joined: 11 Sep 2005
Posts: 705
Location: Granada/Andalucí­a/España

PostPosted: Wed Feb 08, 2006 8:01 pm    Post subject: Reply with quote

/etc/portage/package.unmask
Code:

>=sys-apps/man-1.6b-r2
>=dev-util/pkgconfig-0.18
app-doc/xorg-docs
app-doc/xorg-sgml-doctools
media-fonts/encodings
media-fonts/font-adobe-100dpi
media-fonts/font-adobe-75dpi
media-fonts/font-adobe-utopia-100dpi
media-fonts/font-adobe-utopia-75dpi
media-fonts/font-adobe-utopia-type1
media-fonts/font-alias
media-fonts/font-arabic-misc
media-fonts/font-bh-100dpi
media-fonts/font-bh-75dpi
media-fonts/font-bh-lucidatypewriter-100dpi
media-fonts/font-bh-lucidatypewriter-75dpi
media-fonts/font-bh-ttf
media-fonts/font-bh-type1
media-fonts/font-bitstream-100dpi
media-fonts/font-bitstream-75dpi
media-fonts/font-bitstream-speedo
media-fonts/font-bitstream-type1
media-fonts/font-cronyx-cyrillic
media-fonts/font-cursor-misc
media-fonts/font-daewoo-misc
media-fonts/font-dec-misc
media-fonts/font-ibm-type1
media-fonts/font-isas-misc
media-fonts/font-jis-misc
media-fonts/font-micro-misc
media-fonts/font-misc-cyrillic
media-fonts/font-misc-ethiopic
media-fonts/font-misc-meltho
media-fonts/font-misc-misc
media-fonts/font-mutt-misc
media-fonts/font-schumacher-misc
media-fonts/font-screen-cyrillic
media-fonts/font-sony-misc
media-fonts/font-sun-misc
media-fonts/font-util
media-fonts/font-winitzki-cyrillic
media-fonts/font-xfree86-type1
media-libs/mesa
x11-apps/appres
x11-apps/bdftopcf
x11-apps/beforelight
x11-apps/bitmap
x11-apps/editres
x11-apps/fonttosfnt
x11-apps/fslsfonts
x11-apps/fstobdf
x11-apps/iceauth
x11-apps/ico
x11-apps/lbxproxy
x11-apps/listres
x11-apps/luit
x11-apps/mesa-progs
x11-apps/mkcfm
x11-apps/mkfontdir
x11-apps/mkfontscale
x11-apps/oclock
x11-apps/proxymngr
x11-apps/rgb
x11-apps/rstart
x11-apps/scripts
x11-apps/sessreg
x11-apps/setxkbmap
x11-apps/showfont
x11-apps/smproxy
x11-wm/twm
x11-apps/viewres
x11-apps/x11perf
x11-apps/xauth
x11-apps/xbiff
x11-apps/xcalc
x11-apps/xclipboard
x11-apps/xclock
x11-apps/xcmsdb
x11-apps/xconsole
x11-apps/xcursorgen
x11-apps/xdbedizzy
x11-apps/xditview
x11-apps/xdm
x11-apps/xdpyinfo
x11-apps/xdriinfo
x11-apps/xedit
x11-apps/xev
x11-apps/xeyes
x11-apps/xf86dga
x11-apps/xfd
x11-apps/xfindproxy
x11-apps/xfontsel
x11-apps/xfs
x11-apps/xfsinfo
x11-apps/xfwp
x11-apps/xgamma
x11-apps/xgc
x11-apps/xhost
x11-apps/xinit
x11-apps/xkbcomp
x11-apps/xkbevd
x11-apps/xkbprint
x11-apps/xkbutils
x11-apps/xkill
x11-apps/xload
x11-apps/xlogo
x11-apps/xlsatoms
x11-apps/xlsclients
x11-apps/xlsfonts
x11-apps/xmag
x11-apps/xman
x11-apps/xmessage
x11-apps/xmh
x11-apps/xmodmap
x11-apps/xmore
x11-apps/xphelloworld
x11-apps/xplsprinters
x11-apps/xpr
x11-apps/xprehashprinterlist
x11-apps/xprop
x11-apps/xrandr
x11-apps/xrdb
x11-apps/xrefresh
x11-apps/xrx
x11-apps/xset
x11-apps/xsetmode
x11-apps/xsetpointer
x11-apps/xsetroot
x11-apps/xsm
x11-apps/xstdcmap
x11-apps/xtrap
x11-apps/xvidtune
x11-apps/xvinfo
x11-apps/xwd
x11-apps/xwininfo
x11-apps/xwud
>=x11-base/kdrive-6
x11-base/xorg-server
=x11-base/xorg-x11-7.0
x11-drivers/xf86-input-acecad
x11-drivers/xf86-input-aiptek
x11-drivers/xf86-input-calcomp
x11-drivers/xf86-input-citron
x11-drivers/xf86-input-digitaledge
x11-drivers/xf86-input-dmc
x11-drivers/xf86-input-dynapro
x11-drivers/xf86-input-elo2300
x11-drivers/xf86-input-elographics
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-fpit
x11-drivers/xf86-input-hyperpen
x11-drivers/xf86-input-jamstudio
x11-drivers/xf86-input-joystick
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-magellan
x11-drivers/xf86-input-magictouch
x11-drivers/xf86-input-microtouch
x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-mutouch
x11-drivers/xf86-input-palmax
x11-drivers/xf86-input-penmount
x11-drivers/xf86-input-spaceorb
x11-drivers/xf86-input-summa
x11-drivers/xf86-input-tek4957
x11-drivers/xf86-input-ur98
x11-drivers/xf86-input-void
x11-drivers/xf86-video-apm
x11-drivers/xf86-video-ark
x11-drivers/xf86-video-ati
x11-drivers/xf86-video-chips
x11-drivers/xf86-video-cirrus
x11-drivers/xf86-video-cyrix
x11-drivers/xf86-video-dummy
x11-drivers/xf86-video-fbdev
x11-drivers/xf86-video-glint
x11-drivers/xf86-video-i128
x11-drivers/xf86-video-i740
x11-drivers/xf86-video-i810
x11-drivers/xf86-video-imstt
x11-drivers/xf86-video-mga
x11-drivers/xf86-video-neomagic
x11-drivers/xf86-video-newport
x11-drivers/xf86-video-nsc
x11-drivers/xf86-video-nv
x11-drivers/xf86-video-rendition
x11-drivers/xf86-video-s3
x11-drivers/xf86-video-s3virge
x11-drivers/xf86-video-savage
x11-drivers/xf86-video-siliconmotion
x11-drivers/xf86-video-sis
x11-drivers/xf86-video-sisusb
x11-drivers/xf86-video-sunbw2
x11-drivers/xf86-video-suncg14
x11-drivers/xf86-video-suncg3
x11-drivers/xf86-video-suncg6
x11-drivers/xf86-video-sunffb
x11-drivers/xf86-video-sunleo
x11-drivers/xf86-video-suntcx
x11-drivers/xf86-video-tdfx
x11-drivers/xf86-video-tga
x11-drivers/xf86-video-trident
x11-drivers/xf86-video-tseng
x11-drivers/xf86-video-v4l
x11-drivers/xf86-video-vesa
x11-drivers/xf86-video-vga
x11-drivers/xf86-video-via
x11-drivers/xf86-video-vmware
x11-drivers/xf86-video-voodoo
x11-libs/libdmx
x11-libs/libdrm
x11-libs/libfontenc
x11-libs/libFS
x11-libs/libICE
x11-libs/liblbxutil
x11-libs/liboldX
x11-libs/libSM
x11-libs/libX11
x11-libs/libXau
x11-libs/libXaw
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXdmcp
x11-libs/libXevie
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXfont
x11-libs/libXfontcache
x11-libs/libXft
x11-libs/libXi
x11-libs/libXinerama
x11-libs/libxkbfile
x11-libs/libxkbui
x11-libs/libXmu
x11-libs/libXp
x11-libs/libXpm
x11-libs/libXprintAppUtil
x11-libs/libXprintUtil
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXres
x11-libs/libXScrnSaver
x11-libs/libXt
x11-libs/libXTrap
x11-libs/libXtst
x11-libs/libXv
x11-libs/libXvMC
x11-libs/libXxf86dga
x11-libs/libXxf86misc
x11-libs/libXxf86vm
x11-libs/xtrans
x11-misc/gccmakedep
x11-misc/imake
x11-misc/lndir
x11-misc/makedepend
x11-misc/util-macros
x11-misc/xbitmaps
x11-misc/xkbdata
x11-misc/xorg-cf-files
x11-proto/bigreqsproto
x11-proto/compositeproto
x11-proto/damageproto
x11-proto/dmxproto
x11-proto/evieext
x11-proto/fixesproto
x11-proto/fontcacheproto
x11-proto/fontsproto
x11-proto/glproto
x11-proto/inputproto
x11-proto/kbproto
x11-proto/xineramaproto
x11-proto/printproto
x11-proto/randrproto
x11-proto/recordproto
x11-proto/renderproto
x11-proto/resourceproto
x11-proto/scrnsaverproto
x11-proto/trapproto
x11-proto/videoproto
x11-proto/xcmiscproto
x11-proto/xextproto
x11-proto/xf86bigfontproto
x11-proto/xf86dgaproto
x11-proto/xf86driproto
x11-proto/xf86miscproto
x11-proto/xf86rushproto
x11-proto/xf86vidmodeproto
x11-proto/xineramaproto
x11-proto/xproto
x11-proto/xproxymanagementprotocol
x11-themes/gentoo-xcursors
x11-themes/xcursor-themes


/etc/portage/package.keywords
Code:

#Xorg-7.0
>=sys-apps/man-1.6b-r2 ~x86
>=dev-util/pkgconfig-0.18 ~x86
app-doc/xorg-docs ~x86
app-doc/xorg-sgml-doctools ~x86
media-fonts/encodings ~x86
media-fonts/font-adobe-100dpi ~x86
media-fonts/font-adobe-75dpi ~x86
media-fonts/font-adobe-utopia-100dpi ~x86
media-fonts/font-adobe-utopia-75dpi ~x86
media-fonts/font-adobe-utopia-type1 ~x86
media-fonts/font-alias ~x86
media-fonts/font-arabic-misc ~x86
media-fonts/font-bh-100dpi ~x86
media-fonts/font-bh-75dpi ~x86
media-fonts/font-bh-lucidatypewriter-100dpi ~x86
media-fonts/font-bh-lucidatypewriter-75dpi ~x86
media-fonts/font-bh-ttf ~x86
media-fonts/font-bh-type1 ~x86
media-fonts/font-bitstream-100dpi ~x86
media-fonts/font-bitstream-75dpi ~x86
media-fonts/font-bitstream-speedo ~x86
media-fonts/font-bitstream-type1 ~x86
media-fonts/font-cronyx-cyrillic ~x86
media-fonts/font-cursor-misc ~x86
media-fonts/font-daewoo-misc ~x86
media-fonts/font-dec-misc~x86
media-fonts/font-ibm-type1 ~x86
media-fonts/font-isas-misc ~x86
media-fonts/font-jis-misc ~x86
media-fonts/font-micro-misc ~x86
media-fonts/font-misc-cyrillic ~x86
media-fonts/font-misc-ethiopic ~x86
media-fonts/font-misc-meltho ~x86
media-fonts/font-misc-misc ~x86
media-fonts/font-mutt-misc ~x86
media-fonts/font-schumacher-misc ~x86
media-fonts/font-screen-cyrillic ~x86
media-fonts/font-sony-misc ~x86
media-fonts/font-sun-misc ~x86
media-fonts/font-util ~x86
media-fonts/font-winitzki-cyrillic ~x86
media-fonts/font-xfree86-type1 ~x86
media-libs/mesa ~x86
x11-apps/appres ~x86
x11-apps/bdftopcf ~x86
x11-apps/beforelight ~x86
x11-apps/bitmap ~x86
x11-apps/editres ~x86
x11-apps/fonttosfnt ~x86
x11-apps/fslsfonts ~x86
x11-apps/fstobdf ~x86
x11-apps/iceauth ~x86
x11-apps/ico ~x86
x11-apps/lbxproxy ~x86
x11-apps/listres ~x86
x11-apps/luit ~x86
x11-apps/mesa-progs ~x86
x11-apps/mkcfm ~x86
x11-apps/mkfontdir ~x86
x11-apps/mkfontscale ~x86
x11-apps/oclock ~x86
x11-apps/proxymngr ~x86
x11-apps/rgb ~x86
x11-apps/rstart ~x86
x11-apps/scripts ~x86
x11-apps/sessreg ~x86
x11-apps/setxkbmap ~x86
x11-apps/showfont ~x86
x11-apps/smproxy ~x86
x11-wm/twm ~x86
x11-apps/viewres ~x86
x11-apps/x11perf ~x86
x11-apps/xauth ~x86
x11-apps/xbiff ~x86
x11-apps/xcalc ~x86
x11-apps/xclipboard ~x86
x11-apps/xclock ~x86
x11-apps/xcmsdb ~x86
x11-apps/xconsole ~x86
x11-apps/xcursorgen ~x86
x11-apps/xdbedizzy ~x86
x11-apps/xditview ~x86
x11-apps/xdm ~x86
x11-apps/xdpyinfo ~x86
x11-apps/xdriinfo ~x86
x11-apps/xedit ~x86
x11-apps/xev ~x86
x11-apps/xeyes ~x86
x11-apps/xf86dga ~x86
x11-apps/xfd ~x86
x11-apps/xfindproxy ~x86
x11-apps/xfontsel ~x86
x11-apps/xfs ~x86
x11-apps/xfsinfo ~x86
x11-apps/xfwp ~x86
x11-apps/xgamma ~x86
x11-apps/xgc ~x86
x11-apps/xhost ~x86
x11-apps/xinit ~x86
x11-apps/xkbcomp ~x86
x11-apps/xkbevd ~x86
x11-apps/xkbprint ~x86
x11-apps/xkbutils ~x86
x11-apps/xkill ~x86
x11-apps/xload ~x86
x11-apps/xlogo ~x86
x11-apps/xlsatoms ~x86
x11-apps/xlsclients ~x86
x11-apps/xlsfonts ~x86
x11-apps/xmag ~x86
x11-apps/xman ~x86
x11-apps/xmessage ~x86
x11-apps/xmh ~x86
x11-apps/xmodmap ~x86
x11-apps/xmore ~x86
x11-apps/xphelloworld ~x86
x11-apps/xplsprinters ~x86
x11-apps/xpr ~x86
x11-apps/xprehashprinterlist ~x86
x11-apps/xprop ~x86
x11-apps/xrandr ~x86
x11-apps/xrdb ~x86
x11-apps/xrefresh ~x86
x11-apps/xrx ~x86
x11-apps/xset ~x86
x11-apps/xsetmode ~x86
x11-apps/xsetpointer ~x86
x11-apps/xsetroot ~x86
x11-apps/xsm ~x86
x11-apps/xstdcmap ~x86
x11-apps/xtrap ~x86
x11-apps/xvidtune ~x86
x11-apps/xvinfo ~x86
x11-apps/xwd ~x86
x11-apps/xwininfo ~x86
x11-apps/xwud ~x86
>=x11-base/kdrive-6 ~x86
x11-base/xorg-server ~x86
>=x11-base/xorg-x11-7 ~x86
x11-drivers/xf86-input-acecad ~x86
x11-drivers/xf86-input-aiptek ~x86
x11-drivers/xf86-input-calcomp ~x86
x11-drivers/xf86-input-citron ~x86
x11-drivers/xf86-input-digitaledge ~x86
x11-drivers/xf86-input-dmc ~x86
x11-drivers/xf86-input-dynapro ~x86
x11-drivers/xf86-input-elo2300 ~x86
x11-drivers/xf86-input-elographics ~x86
x11-drivers/xf86-input-evdev ~x86
x11-drivers/xf86-input-fpit ~x86
x11-drivers/xf86-input-hyperpen ~x86
x11-drivers/xf86-input-jamstudio ~x86
x11-drivers/xf86-input-joystick ~x86
x11-drivers/xf86-input-keyboard ~x86
x11-drivers/xf86-input-magellan  ~x86
x11-drivers/xf86-input-magictouch ~x86
x11-drivers/xf86-input-microtouch ~x86
x11-drivers/xf86-input-mouse ~x86
x11-drivers/xf86-input-mutouch ~x86
x11-drivers/xf86-input-palmax ~x86
x11-drivers/xf86-input-penmount ~x86
x11-drivers/xf86-input-spaceorb ~x86
x11-drivers/xf86-input-summa ~x86
x11-drivers/xf86-input-tek4957 ~x86
x11-drivers/xf86-input-ur98 ~x86
x11-drivers/xf86-input-void ~x86
x11-drivers/xf86-video-apm ~x86
x11-drivers/xf86-video-ark ~x86
x11-drivers/xf86-video-ati ~x86
x11-drivers/xf86-video-chips ~x86
x11-drivers/xf86-video-cirrus ~x86
x11-drivers/xf86-video-cyrix ~x86
x11-drivers/xf86-video-dummy ~x86
x11-drivers/xf86-video-fbdev ~x86
x11-drivers/xf86-video-glint ~x86
x11-drivers/xf86-video-i128 ~x86
x11-drivers/xf86-video-i740 ~x86
x11-drivers/xf86-video-i810 ~x86
x11-drivers/xf86-video-imstt ~x86
x11-drivers/xf86-video-mga ~x86
x11-drivers/xf86-video-neomagic ~x86
x11-drivers/xf86-video-newport ~x86
x11-drivers/xf86-video-nsc ~x86
x11-drivers/xf86-video-nv ~x86
x11-drivers/xf86-video-rendition ~x86
x11-drivers/xf86-video-s3 ~x86
x11-drivers/xf86-video-s3virge ~x86
x11-drivers/xf86-video-savage ~x86
x11-drivers/xf86-video-siliconmotion ~x86
x11-drivers/xf86-video-sis ~x86
x11-drivers/xf86-video-sisusb ~x86
x11-drivers/xf86-video-sunbw2 ~x86
x11-drivers/xf86-video-suncg14 ~x86
x11-drivers/xf86-video-suncg3 ~x86
x11-drivers/xf86-video-suncg6 ~x86
x11-drivers/xf86-video-sunffb ~x86
x11-drivers/xf86-video-sunleo ~x86
x11-drivers/xf86-video-suntcx ~x86
x11-drivers/xf86-video-tdfx ~x86
x11-drivers/xf86-video-tga ~x86
x11-drivers/xf86-video-trident ~x86
x11-drivers/xf86-video-tseng ~x86
x11-drivers/xf86-video-v4l ~x86
x11-drivers/xf86-video-vesa ~x86
x11-drivers/xf86-video-vga ~x86
x11-drivers/xf86-video-via ~x86
x11-drivers/xf86-video-vmware ~x86
x11-drivers/xf86-video-voodoo ~x86
x11-libs/libdmx ~x86
x11-libs/libdrm ~x86
x11-libs/libfontenc ~x86
x11-libs/libFS ~x86
x11-libs/libICE ~x86
x11-libs/liblbxutil ~x86
x11-libs/liboldX ~x86
x11-libs/libSM ~x86
x11-libs/libX11 ~x86
x11-libs/libXau ~x86
x11-libs/libXaw ~x86
x11-libs/libXcomposite ~x86
x11-libs/libXcursor ~x86
x11-libs/libXdamage ~x86
x11-libs/libXdmcp ~x86
x11-libs/libXevie ~x86
x11-libs/libXext ~x86
x11-libs/libXfixes ~x86
x11-libs/libXfont ~x86
x11-libs/libXfontcache ~x86
x11-libs/libXft ~x86
x11-libs/libXi ~x86
x11-libs/libXinerama ~x86
x11-libs/libxkbfile ~x86
x11-libs/libxkbui ~x86
x11-libs/libXmu ~x86
x11-libs/libXp ~x86
x11-libs/libXpm ~x86
x11-libs/libXprintAppUtil ~x86
x11-libs/libXprintUtil ~x86
x11-libs/libXrandr ~x86
x11-libs/libXrender ~x86
x11-libs/libXres ~x86
x11-libs/libXScrnSaver ~x86
x11-libs/libXt ~x86
x11-libs/libXTrap ~x86
x11-libs/libXtst ~x86
x11-libs/libXv ~x86
x11-libs/libXvMC ~x86
x11-libs/libXxf86dga ~x86
x11-libs/libXxf86misc ~x86
x11-libs/libXxf86vm ~x86
x11-libs/xtrans ~x86
x11-misc/gccmakedep ~x86
x11-misc/imake ~x86
x11-misc/lndir ~x86
x11-misc/makedepend ~x86
x11-misc/util-macros ~x86
x11-misc/xbitmaps ~x86
x11-misc/xkbdata ~x86
x11-misc/xorg-cf-files ~x86
x11-proto/bigreqsproto ~x86
x11-proto/compositeproto ~x86
x11-proto/damageproto ~x86
x11-proto/dmxproto ~x86
x11-proto/evieext ~x86
x11-proto/fixesproto ~x86
x11-proto/fontcacheproto ~x86
x11-proto/fontsproto ~x86
x11-proto/glproto ~x86
x11-proto/inputproto ~x86
x11-proto/kbproto ~x86
x11-proto/xineramaproto ~x86
x11-proto/printproto ~x86
x11-proto/randrproto ~x86
x11-proto/recordproto ~x86
x11-proto/renderproto ~x86
x11-proto/resourceproto ~x86
x11-proto/scrnsaverproto ~x86
x11-proto/trapproto ~x86
x11-proto/videoproto ~x86
x11-proto/xcmiscproto ~x86
x11-proto/xextproto ~x86
x11-proto/xf86bigfontproto ~x86
x11-proto/xf86dgaproto ~x86
x11-proto/xf86driproto ~x86
x11-proto/xf86miscproto ~x86
x11-proto/xf86rushproto ~x86
x11-proto/xf86vidmodeproto ~x86
x11-proto/xineramaproto ~x86
x11-proto/xproto ~x86
x11-proto/xproxymanagementprotocol ~x86
x11-themes/gentoo-xcursors ~x86
x11-themes/xcursor-themes ~x86


Y si no, pues ACCEPT_KEYWORDS="~x86" :wink:, pero no sólo tendrás inestables de Xorg sino muchos otros más
_________________
Fundación I+D del Software Libre
BluLabs
_____________________________________________________
Portátil HP Pavilion zd8185ea: Pentium4HT 3.2Ghz, ATI x600 256MB
gnome-2.30
Back to top
View user's profile Send private message
Eleazar Anzola
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1253
Location: Caracas / Venezuela

PostPosted: Fri Feb 10, 2006 3:32 pm    Post subject: Reply with quote

je je Gracias por responder y encuanto a lo de ACCEPT_KEYWORDS="~x86" hace bastantes años que esta echo je je je je :P
_________________
Salu2
Eleazar Anzola
Linux User : # 216232
__________________________________________
Por un foro ordenado y un buscador más útil:
[TEMA] Descripción problema (estado)
Back to top
View user's profile Send private message
ArsDangor
Guru
Guru


Joined: 20 May 2003
Posts: 477

PostPosted: Wed Mar 22, 2006 2:51 am    Post subject: Reply with quote

aj2r wrote:
Cuando se hace un emerge de varios programas a la vez (cientos en ocasiones) es tedioso por no decir casi imposible tener en cuenta los avisos que algunos de éstos muestran, pongo como ejemplo a perl que da el consejo de hacer perl-cleaner.
¿Existe una solución para esto? Y si no existe, ¿hay intención de tener en cuenta esta situación en versiones futuras de portage?
Si usas la versión inestable de Portage (2.1 pre6-r7 en el momento de escribir esto), tienes la facilidad ELOG. Acabo de añadir una sección sobre ELOG al how-to. Aún está en construcción, así que acepto sugerencias. :)
_________________
Cómo usar Portage correctamente
Back to top
View user's profile Send private message
GerManson
Tux's lil' helper
Tux's lil' helper


Joined: 17 Mar 2005
Posts: 86
Location: Sonora, Mexico.

PostPosted: Sat Apr 08, 2006 4:40 pm    Post subject: Reply with quote

uuu gracias por la info.
_________________
GerManson - Gentoo Linux i686 Dual Intel(R) Pentium(R) 4 CPU 2.80GHz Processor
http://www.ebrios.com.mx

Do The Evolution!! -> ∂f/∂y = ∫e^(x^2)+y^2 dx + ∫x^2+y^2 dy
Back to top
View user's profile Send private message
aj2r
l33t
l33t


Joined: 11 Sep 2005
Posts: 705
Location: Granada/Andalucí­a/España

PostPosted: Wed Apr 19, 2006 2:23 pm    Post subject: Reply with quote

Sería interesante comentar en la guía opciones como: PORTAGE_RSYNC_EXTRA_OPTS, CLEAN_DELAY, FEATURES="parallel-fetch", PORTAGE_NICENESS, ...
_________________
Fundación I+D del Software Libre
BluLabs
_____________________________________________________
Portátil HP Pavilion zd8185ea: Pentium4HT 3.2Ghz, ATI x600 256MB
gnome-2.30
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum