Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
world update?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
FINITE
Guru
Guru


Joined: 10 May 2002
Posts: 449

PostPosted: Wed Jun 26, 2002 10:24 pm    Post subject: world update? Reply with quote

Is anyone having problems with emerge --update world lately. I know alot of people were and I am about to do an update myslef. Just want to be prepared for any possible problems as a result. There are alot of kde things whe I applied the --pretend flag. I am assuming that this will update me to kde3.01. What if anything needs to be done for kde after the update. Before I read that there was a symlink that needed to be redirected or something. Thanks for any info.

PS: Ill be doing this remotely, is that a bad idea?
Back to top
View user's profile Send private message
JefP@@
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 179
Location: Belgium

PostPosted: Wed Jun 26, 2002 10:49 pm    Post subject: Reply with quote

Maybe you should filter out the big ones (like kde) and emerge them seperately ... or maybe do everything seperate;y :P

Most of the time, that's the safest thing to do ;)
Back to top
View user's profile Send private message
FINITE
Guru
Guru


Joined: 10 May 2002
Posts: 449

PostPosted: Wed Jun 26, 2002 10:57 pm    Post subject: Reply with quote

Well im feeling kinda crazy you see and want to do something dangerous :D But ya your right I should do everything seperately.
Back to top
View user's profile Send private message
phantasm
n00b
n00b


Joined: 21 Jun 2002
Posts: 71
Location: Cincinnati

PostPosted: Wed Jun 26, 2002 11:31 pm    Post subject: Reply with quote

And more then likely your portage is going to be broken after words. You should just to an emerge kde and that should get you up to the newist level. You don't want to take the chance of breaking portage. It is fairly easy to fix, but its not worth it.
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Wed Jun 26, 2002 11:43 pm    Post subject: Reply with quote

Yup -- general consensus seems to be stick w/ Portage 2.0.4 for now. People have reported problems with both 2.0.5 and 2.0.6.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
FINITE
Guru
Guru


Joined: 10 May 2002
Posts: 449

PostPosted: Thu Jun 27, 2002 2:53 am    Post subject: Reply with quote

What kind of problems? How do I know what version of portage I have? I ran an emerge rsync today so that would have updated me right? Or does that just sync me with the currect portage tree? Anyways I unmerged frozen-bubble and re-emerged the updated version and that must of had deps for all but two of the updates that emerge update would wanted to do cause now when I run emerge update world with the pretend flag it only comes up with 2 updates. Those are autoconf and automake. Before there was a whole bunch of kde stuff for 3.01, before updating frozen-bubble that is. Hmmm............
Back to top
View user's profile Send private message
phantasm
n00b
n00b


Joined: 21 Jun 2002
Posts: 71
Location: Cincinnati

PostPosted: Thu Jun 27, 2002 10:45 am    Post subject: Reply with quote

Well the fact that you can still run pretend is pretty good, that pretty much means you are not runinng a broken portage tree. Emerge rsync just pulls in the most recent stuff.

See here http://forums.gentoo.org/viewtopic.php?t=6002
and here
http://forums.gentoo.org/viewtopic.php?t=6075&highlight=
for examples on what a broken portage would do.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum