Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unsafe unmerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
zerogeny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2002
Posts: 85

PostPosted: Tue Apr 23, 2002 1:46 pm    Post subject: unsafe unmerge Reply with quote

unmerging old versions still isnt safe enough

it looks like i killed portage because i got 'rid' of and old db version...

:(
_________________
Searched the web for zerogeny.
Results 1 - 1 of 1. Search took 0.05 seconds
Back to top
View user's profile Send private message
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Wed Apr 24, 2002 10:05 am    Post subject: Re: unsafe unmerge Reply with quote

zerogeny wrote:
unmerging old versions still isnt safe enough

it looks like i killed portage because i got 'rid' of and old db version...

:(


Berkeley db libs are not backwards compatible. If you unmerge an 'old' version you will break things. I think this is the only software in portage that behaves like this. Perhaps something should be written into portage to 'catch' software that isn't backwards compatible.
Back to top
View user's profile Send private message
cedric
n00b
n00b


Joined: 10 Apr 2002
Posts: 27
Location: Belgium

PostPosted: Wed Apr 24, 2002 10:38 am    Post subject: Reply with quote

Using "emerge clean" instead of "emerge unmerge" avoids this kind of problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum