Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVRAID boot problem...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DocSpliff
n00b
n00b


Joined: 10 Dec 2005
Posts: 1

PostPosted: Sat Dec 10, 2005 5:02 am    Post subject: NVRAID boot problem... Reply with quote

I am currently trying to install Gentoo on my AMD64 NFORCE 4 NVRAID System.
Although I am still a bloody newbie, I got quite far using the HOWTOs from the Gentoo Forums, the german Gentoo-WIKI and Gerte's BIOS RAID Pages.
But during the final reboot, right after I selected the "Gentoo Linux" entry in Grub, I get the following error:

>> Mounting filesystems...
>> Preparing environment for dmraid...
>> Creating /dev/mapper/control character device with major:10 minor:63
>> Calling dmraid...
no block devices found
>> dmraid was run successfully
>> Determining root device...
>> Block device /dev/mapper/nvidia_dhfjcdfc4 is not a valid root device...
>> The rootdevice is unspecified or not detected
>> Specify real_root=<root_blockdevice> on the kernel cmdline
Please specify a device to boot, or "shell" for a shell

What's going wrong here?

my grub.conf looks like this:

title Gentoo Linux
root (hd0,0)
kernel /kernel-2.6.14-gentoo-r2 root=/dev/ram0 init=/linuxrc real_root=/dev/mapper/nvidia_dhfjcdfc4
initrd (hd0,0)/initrd

the partition layout of my RAID:

Disk /dev/mapper/nvidia_dhfjcdfc: 74.0 GB, 74039130112 bytes
255 heads, 63 sectors/track, 9001 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/mapper/nvidia_dhfjcdfc1 * 1 17 136521 83 Linux
/dev/mapper/nvidia_dhfjcdfc2 18 4577 36628200 87 NTFS volume set
/dev/mapper/nvidia_dhfjcdfc3 4578 4702 1004062+ 82 Linux swap / Solaris
/dev/mapper/nvidia_dhfjcdfc4 4703 9001 34531717+ 83 Linux

Has anyone got any ideas?
Thanks in advance, Doc Spliff
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1884

PostPosted: Mon Dec 12, 2005 12:12 pm    Post subject: Reply with quote

HAve you inserted all drivers neede into the initrd you load there?

Have you made sure that the driver modules are loaded in the proper way (sata drivers before usb drivers, ...)

IMHO it is best to build all needed drivers (every driver needed to access the hardware for the core system, like Harddiscs, CD, Floppy, ... and your mounted filesystems) into the kernel and drop the initrd. Then let udev load the drivers for additional plugged in hardware and sound, firewire, ... This way you dont get confused which driver gets loaded first.
Back to top
View user's profile Send private message
mightymephisto
n00b
n00b


Joined: 19 Dec 2005
Posts: 9

PostPosted: Mon Dec 19, 2005 5:30 pm    Post subject: Reply with quote

You need to start dmraid in your grub.conf file. I have just setup my NVRAID and it works fine...

Set grub.conf as

title Gentoo Linux
root (hd0,0)
kernel /kernel-2.6.14-gentoo-r2 root=/dev/ram0 init=/linuxrc real_root=/dev/mapper/nvidia_dhfjcdfc4 dmraid
initrd (hd0,0)/initrd

I also found that I got the message "cannot insert into memory"

so added mem=4096M to inform the kernel as to how much memory I have

So mine reads

title Gentoo Linux
root (hd0,0)
kernel /kernel-2.6.14-gentoo-r4 mem=4096M root=/dev/ram0 init=/linuxrc real_root=/dev/mapper/nvidia_djaaghda3 dmraid ide=nodma
initrd (hd0,0)/initrd
Back to top
View user's profile Send private message
m5computer
n00b
n00b


Joined: 27 May 2005
Posts: 1

PostPosted: Tue Dec 27, 2005 1:29 am    Post subject: Reply with quote

I also had the exact same problem - everything going well following the instructions in that HOWTO page...until -

>> Block device /dev/mapper/nvidia_baedjfbj4 is not a valid root device...
>> The root block device is unspecified or not detected

I did have "dmraid" (actually was "dodmraid") in the grub.conf /kernel line, but that didn't help. From the initrd shell, I saw that the mapper directory only contained the control file. Figured out that I was missing an NVIDIA SATA driver, which I added from 2 menuconfig options:

Device Drivers -> SCSI device support -> SCSI low-level drivers -> Serial ATA (SATA) support
Device Drivers -> SCSI device support -> SCSI low-level drivers -> Serial ATA (SATA) support -> NVIDIA SATA support

After rebuild/reboot, initrd found /dev/mapper/nvidia_baedjfbj4 and started up NP.
Back to top
View user's profile Send private message
MegaVolt
n00b
n00b


Joined: 24 Aug 2005
Posts: 27

PostPosted: Tue May 02, 2006 10:52 am    Post subject: Reply with quote

i got dmraid working fine with any kernel including 2.6.15
now i did try to update to 2.6.16 and i got the same error as described above

i didnt change much in the kernen config, i did not chance my initrd and i didnt change anything in my grub config
all i did was install the new kernel and change symlinks (e.g. let vmlinuz point to the new kernel)

any ideas?

update:
i updated my initrd, using one created by genkernel
i didnt use the "dodmraid" option in my grub.conf since it was not necesarry with my old initrd
now, using 2.6.15 kernel with 2.6.15 genkernel-created initrd (genkernel --dmraid initrd, kernel itself not built using genkernel) everything works fine
but when i try to update to 2.6.16 (change symlinks and create a new initrd with genkernel for the 2.6.16 kernel) nothing changed
long story short: everything as before, but i did try genkernel initrd images and it did not help ;)
building the whole 2.6.16 kernel with genkernel (genkernel --dmraid all) didnt work either

did the device names change? or i there any issue with the device mapper?
Back to top
View user's profile Send private message
kaktuspalme
n00b
n00b


Joined: 23 Apr 2006
Posts: 27

PostPosted: Wed May 10, 2006 3:50 pm    Post subject: Reply with quote

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186842

That's not a bug of gentoo, all systems using dmraid have problems with kernel 2.6.16
Back to top
View user's profile Send private message
Nodgr
n00b
n00b


Joined: 05 Feb 2006
Posts: 14
Location: Salonica - Greece

PostPosted: Sun May 14, 2006 10:14 am    Post subject: Reply with quote

If anybody knows when there'll be out a patch,please let us know.
Back to top
View user's profile Send private message
Nodgr
n00b
n00b


Joined: 05 Feb 2006
Posts: 14
Location: Salonica - Greece

PostPosted: Tue May 16, 2006 1:44 am    Post subject: Reply with quote

Nothing yet ?
Back to top
View user's profile Send private message
Nodgr
n00b
n00b


Joined: 05 Feb 2006
Posts: 14
Location: Salonica - Greece

PostPosted: Tue May 23, 2006 8:49 pm    Post subject: Reply with quote

When there will be a new ebuild of dmraid ? Anybody knows ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum