Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Jag blir tokig! Knäppa symboler istället för åäö i console.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
sdaffis
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 99

PostPosted: Mon Dec 12, 2005 6:05 pm    Post subject: Jag blir tokig! Knäppa symboler istället för åäö i con Reply with quote

Jag har slitit mitt hår i förtvivlan och följt alla guider jag letat rätt på men får det ändå inte att fungera! Istället för filnamnet åäö ser jag en massa skumma tecken när jag kör en vanlig "ls". Under X eller i console spelar ingen roll, det blir likadant. Så nu hoppas jag att ni sitter inne med bra kunskap kring detta problem :)

Ur min /etc/conf.d/consolefont saxar jag följande:
Code:

CONSOLEFONT="default8x16"
CONSOLETRANSLATION="8859-1_to_uni"


/etc/conf.d/keymaps:
Code:

KEYMAP="sv-latin1"


Och slutligen ur /etc/rc.conf:
Code:

UNICODE="yes"


Filsystemet jag använder är reiserfs 3.6, och jag har provat flera olika consolefonts, "default8x16" är bara den senaste jag provat.

Tacksam för hjälp!
Jonas
_________________
Believe the lie
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Tue Dec 13, 2005 7:01 pm    Post subject: Reply with quote

Dessa inställningar har jag :

/etc/conf.d/consolefont:
Code:
CONSOLEFONT="lat0-16"

Ingen translation

/etc/conf.d/keymaps:
Code:
 KEYMAP="sv-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS="backspace keypad euro"


/etc/env.d/02locale:
Code:
LC_ALL=sv_SE
LC_TELEPHONE=sv_SE
LANGUAGE=sv_SE
LANG=sv_SE
LC_CTYPE=sv_SE
LC_NUMERIC=sv_SE
LC_TIME=sv_SE
LC_MONETARY=sv_SE
LC_ADDRESS=sv_SE
LC_COLLATE=sv_SE
LC_NAME=sv_SE
LC_PAPER=sv_SE
SYSFONT=lat0-16
LC_MEASUREMENT=sv_SE
LC_IDENTIFICATION=sv_SE


Om det är skräptecken under pågående session, kan det vara alla dina försök att köra /etc/init.d/keymaps restart. Detta fick jag, och fick köra en /etc/init.d/consolefont restart. Det är ju trots allt - boot services som startas om.

SYSFONT=lat0-16 : ta inte detta som en absolut nödvändighet. Något jag såg någon annan ha, och petade in för hopp om bättring för egen del. Mitt fel var att jag hade LC_ALL="sv_SE.UTF-8" vilket satte en del krokben för mig när jag tröckte åäö.

Se även till att LC_ALL är riktig, alternativt ta bort denna(?)
Back to top
View user's profile Send private message
sdaffis
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 99

PostPosted: Thu Dec 15, 2005 2:55 pm    Post subject: Reply with quote

Tack för ditt svar!
Tyvärr så hjälpte det inte, utan det är fortfarande knasigt. Något jag dessutom upptäckt är att när jag skriver åäö i terminalen så fördröjs outputen till jag trycker på nästa tangent och då visas den bokstav jag tryckte på tidigare. Jag hoppas att nån känner igen symptomen!
_________________
Believe the lie
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Thu Dec 15, 2005 5:30 pm    Post subject: Reply with quote

Det du beskriver är precis vad jag hade. Behövde trycka 'ööåä' för att få öåä, exempelvis. Vad jag prövade var:
Code:

root@host # /etc/init.d/consolefont restart
root@host # export LC_ALL="sv_SE"
root@host # åäö funkar för mig nu

sedan funkade mitt åäö hur bra som helst. Säkert att du försökte dig på detta också?
Notering: LC_ALL="sv_SE.UTF-8" funkar utmärkt under gnome, men inte i console för mig.
Frågor:
1) Har du skräptecken efter ny omstart av datorn och första inloggningen, eller var det så att dessa uppkom efter repeterade försök att starta om keymaps och consolefont ?

2) Har du även USE="userlocales" och hur ser din /etc/locales.build i såfall ut?

I värsta fall är du 'torsk' och behöver ev kompillera om din glibc, vilket jag finner svårt att tro iofs.

Edit: Tokigt det kan bli...bytte ut gcc till glibc och passade på att ta bort en dubbelpost.
Back to top
View user's profile Send private message
sdaffis
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 99

PostPosted: Fri Dec 16, 2005 8:21 pm    Post subject: Reply with quote

Tack för hjälpen, men jag måste tyvärr säga "hittills". I console funkar det klockrent, men när jag hoppar in i X (senaste stabila xorg) och kde 3.4.3 så blir åäö bara en massa sörja och inmatningen av åäö är fördröjd. Vad har jag lyckats med nu egentligen?! :)
_________________
Believe the lie
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Fri Dec 16, 2005 8:27 pm    Post subject: Reply with quote

Vad jag vet av kde (misgnomer här ) så behöver du kompilerat i18n paket för kde på rätt sätt....vad det heter? Hehehe....

*tar en kik i portage* ...vad jag kan se behöver du kde-i18n. Har du detta emerge:at?

Någon mer bevandrad kde:ist som kan guidea?
_________________
update world set ignorance=off where religion=on
Back to top
View user's profile Send private message
sdaffis
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 99

PostPosted: Mon Dec 19, 2005 7:53 am    Post subject: Reply with quote

Hej!

Nu har jag emergat kde-i18n med linguas="sv" och har mycket riktigt kde på svenska. Dock så är problemet med teckeninmatning i X-terminalen kvar. Jag har helt och hållet kört slut på saker att prova, så jag hoppas att någon kan bidra med nåt litet :)
_________________
Believe the lie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum