Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dups
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Mon Jun 24, 2002 11:04 pm    Post subject: Dups Reply with quote

I've installed Gentoo, everything's running fine, and I've updated a few packages. Now qpkg --dups -v shows:
Code:
dev-libs/openssl-0.9.6d
dev-libs/openssl-0.9.6c-r1
sys-apps/baselayout-1.7.9-r1
sys-apps/baselayout-1.7.8-r1
sys-apps/shadow-4.0.2-r4
sys-apps/shadow-4.0.2-r5
sys-apps/util-linux-2.11o-r2
sys-apps/util-linux-2.11o-r3
sys-libs/db-1.85-r1
sys-libs/db-3.2.3h-r4


"emerge -p clean world" says that I have no outdated packages, though, which means that some of those "dups" are explicitly required by other packages. Now, I know that that's not hurting anything, and that the dups probably aren't even taking up much disk space. It looks to me like at least the "db-1.85-r1" and "db-3.2.3h-r4" probably have a reason to both be installed (the version numbers are different enough, after all).

Just for the sake of being anal, though, what're the chances that I'll hose my system by trying to clean some of the old packages? I can't imagine, for instance that both "shadow-4.0.2-r5" AND "shadow-4.0.2-r4" are both really required. They are the same version, after all, and just different ebuilds. Likewise for util-linux. Even the openssl and baselayout don't look different enough, version-wise, that it should break anything.

So, do you think I can get away with cleaning out some of those old packages? If I try it and it breaks stuff, will I be able to fix the system by "emerge shadow-4.0.2-r4" or whatever? Should I just forget about it, and leave things as they are? I am not hurting for disk space or anything, it just seems a little silly to have some of those "dups" installed.
Back to top
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Mon Jun 24, 2002 11:13 pm    Post subject: Reply with quote

You should be able to emerge the more obvious duplicates with no problem. If you do have problems, you can either a) remerge the same program or b) emerge --onlydeps <some program that depends on that program> which will then install just the dependencies.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Mon Jun 24, 2002 11:15 pm    Post subject: Reply with quote

You should do:
Code:
emerge unmerge =sys-apps/shadow-4.0.2-r4


This is covered in Portage User Guide
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
Guest






PostPosted: Tue Jun 25, 2002 12:08 am    Post subject: Reply with quote

Thanks for the replies, guys. I got rid of everything but the sys-libs/db dups, using the -P (prune) option to emerge. Everything seems to be working just fine.
Back to top
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum