Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't emerge system (it's in the guide on the net)
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
robinmdh
n00b
n00b


Joined: 01 Oct 2005
Posts: 6

PostPosted: Sat Oct 01, 2005 12:17 am    Post subject: can't emerge system (it's in the guide on the net) Reply with quote

i'm having trouble emerging anything with portage under mac osx (10.4.2)
first off a whole bunch of packages hve been masked (becouse they'r already in OS X),
but they'r not in portage so when i try to emerge system it's a big nono(it want's to emerge masked packages), i thought of inserting a stub into portage(emerge -i) to make it think it's aready installed the software but that hits a snag too (sed: lstat: No such file or directory)

over here it just says to set the profile right and then run emerge system...

hope some1 can help

Robin
Back to top
View user's profile Send private message
robinmdh
n00b
n00b


Joined: 01 Oct 2005
Posts: 6

PostPosted: Thu Oct 06, 2005 9:53 am    Post subject: Reply with quote

Code:
rommie root # emerge -a system

These are the packages that I would merge, in order:

Calculating system dependencies |
!!! All ebuilds that could satisfy ">=sys-devel/autoconf-2.59-r6" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/autoconf-2.59-r6 (masked by: package.mask)
- sys-devel/autoconf-2.59-r7 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "sys-devel/automake-1.5" [ebuild])


!!! Problem with ebuild sys-apps/coreutils-5.3.0-r1
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.
how do I get this right?
Back to top
View user's profile Send private message
spankmygentoo
n00b
n00b


Joined: 20 Jun 2005
Posts: 39
Location: Utah

PostPosted: Sun Oct 09, 2005 4:50 am    Post subject: Reply with quote

I get this when I try to "emerge system."

>>> Completed installing into /var/tmp/portage/portage-2.0.51.22-r3/image/

* checking 141 files for package collisions
existing file /usr/lib/portage/pym/cvstree.pyo is not owned by this package
existing file /usr/lib/portage/pym/emergehelp.pyo is not owned by this package
existing file /usr/lib/portage/pym/getbinpkg.pyo is not owned by this package
existing file /usr/lib/portage/pym/output.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_checksum.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_const.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_data.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_cpickle.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_flat.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_template.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_dep.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_exception.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_exec.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_file.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_gpg.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_localization.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_locks.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_util.pyo is not owned by this package
existing file /usr/lib/portage/pym/xpak.pyo is not owned by this package
* spend 0.182201862335 seconds checking for file collisions
* This package is blocked because it wants to overwrite
* files belonging to other packages (see messages above).
* If you have no clue what this is all about report it
* as a bug for this package on http://bugs.gentoo.org

package sys-apps/portage-2.0.51.22-r3 NOT merged

No package files given... Grabbing a set.
joseph-barneys-ibook-g4:/etc/make.profile root#

-------------------------

Is there something I am missing here? I followed the directions and it's not working. I don't have X11 installed yet. Would that make a difference? Thanks!
_________________
--Time moves forward, whether or not you do.
Back to top
View user's profile Send private message
Strukt
n00b
n00b


Joined: 11 Oct 2002
Posts: 56

PostPosted: Sun Oct 16, 2005 2:29 am    Post subject: Reply with quote

Hi,

i got the same error message as spankmygentoo:

Code:

bjrnar-kibsgaards-ibook-g4:~ strukt$ emerge system
Calculating system dependencies ...done!
>>> emerge (1 of 4) sys-apps/portage-2.0.51.22-r3 to /
>>> md5 files   ;-) ChangeLog
>>> md5 files   ;-) metadata.xml
>>> md5 files   ;-) portage-2.0.51.22-r3.ebuild
>>> md5 files   ;-) portage-2.0.53_rc5.ebuild
>>> md5 files   ;-) portage-2.1.0_alpha20050718.ebuild
>>> md5 files   ;-) files/05portage.envd
>>> md5 files   ;-) files/2.0.51.22-fixes.patch
>>> md5 files   ;-) files/digest-portage-2.0.51.22-r3
>>> md5 files   ;-) files/digest-portage-2.0.53_rc5
>>> md5 files   ;-) files/digest-portage-2.1.0_alpha20050718
>>> md5 files   ;-) files/README.RESCUE
>>> md5 src_uri ;-) portage-2.0.51.22.tar.bz2
>>> Unpacking source...
>>> Unpacking portage-2.0.51.22.tar.bz2 to /var/tmp/portage/portage-2.0.51.22-r3/work
patching file ChangeLog
patching file bin/dispatch-conf
patching file bin/ebuild.sh
patching file bin/emake
patching file bin/emerge
patching file bin/repoman
patching file pym/portage.py
>>> Source unpacked.
Listing /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/cvstree.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/dcdialog.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/dispatch_conf.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/emergehelp.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/getbinpkg.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/output.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_checksum.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_const.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_contents.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_data.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_db_anydbm.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_db_cpickle.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_db_flat.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_db_template.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_db_test.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_dep.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_exception.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_exec.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_file.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_gpg.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_localization.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_locks.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/portage_util.py ...
Compiling /var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/pym/xpak.py ...
ppc-macos
>>> Test phase [not enabled]: sys-apps/portage-2.0.51.22-r3

>>> Install portage-2.0.51.22-r3 into /var/tmp/portage/portage-2.0.51.22-r3/image/ category sys-apps
ppc-macos
strip: can't process non-object and non-archive file: /private/var/tmp/portage/portage-2.0.51.22-r3/work/portage-2.0.51.22/bin/tbz2tool
man:
prepallstrip:
strip:
strip:
>>> Completed installing into /var/tmp/portage/portage-2.0.51.22-r3/image/

* checking 141 files for package collisions
existing file /usr/lib/portage/pym/cvstree.pyo is not owned by this package
existing file /usr/lib/portage/pym/emergehelp.pyo is not owned by this package
existing file /usr/lib/portage/pym/getbinpkg.pyo is not owned by this package
existing file /usr/lib/portage/pym/output.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_checksum.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_const.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_data.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_cpickle.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_flat.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_template.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_dep.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_exception.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_exec.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_file.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_gpg.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_localization.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_locks.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_util.pyo is not owned by this package
existing file /usr/lib/portage/pym/xpak.pyo is not owned by this package
* spend 0.307098150253 seconds checking for file collisions
* This package is blocked because it wants to overwrite
* files belonging to other packages (see messages above).
* If you have no clue what this is all about report it
* as a bug for this package on http://bugs.gentoo.org

package sys-apps/portage-2.0.51.22-r3 NOT merged

No package files given... Grabbing a set.
bjrnar-kibsgaards-ibook-g4:~ strukt$


I have FINK installed, could that generate this error ?
Back to top
View user's profile Send private message
robinp
n00b
n00b


Joined: 26 Feb 2005
Posts: 8

PostPosted: Wed Oct 19, 2005 8:22 am    Post subject: Reply with quote

From memory this is a problem when first installing portage because the portage update doesn't recognise the version of portage that was installed throught the MacOS X gentoo installer package.

To correct this - temporarily turn collision protection off to let it overwrite the older version of portage.

From then on - it should be ok.

Hope this helps
Back to top
View user's profile Send private message
Cenrim
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 142
Location: Germany

PostPosted: Thu Oct 20, 2005 5:57 pm    Post subject: Reply with quote

for turning the collision protection off for one run of emerge you gotta do:
Code:
# FEATURES="-collision-protect" emerge {portage,foo,whatever}


that's how I got bash-3.00 on my Darwin 8.01

EDIT: fink stays outside of the normal system by installing everything in /sw, so portage should ignore it
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Wed Nov 16, 2005 9:38 pm    Post subject: problem emerging system on "masked packages" Reply with quote

Trying to emerge system I got this message on a powerbook 5,8 -10.4.3


Code:
Emanuele$ sudo emerge system
Calculating system dependencies /
!!! All ebuilds that could satisfy "net-misc/iputils" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-misc/iputils-021109-r3 (masked by: missing keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.



!!! Problem resolving dependencies for net-misc/iputils
!!! Depgraph creation failed.


..any idea???
Back to top
View user's profile Send private message
Lindsey
n00b
n00b


Joined: 24 Sep 2004
Posts: 20

PostPosted: Wed Nov 23, 2005 8:26 am    Post subject: Reply with quote

Cenrim, I had exactly the same problem as spankmygentoo and Strukt, and that fixed it. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum