Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Setting up an HP Visualize C360
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Thu Oct 06, 2005 6:20 pm    Post subject: Setting up an HP Visualize C360 Reply with quote

Hi,
I finally set up Gentoo on my C360. Upon boot, it seems to hang on * Starting local ... [ ok ]". If anyone has any immediate ideas on how to fix this, I'd be much appreciated.

Also, I have installed a Matrox Millenium, after hearing that I would be able to run X off it. I've found no documentation on doing so. When I compile in the Matrox drivers into the kernel I get a kernel panic upon boot.

Obviously, all this has been done over the serial console :p

Any help will be appreciated.
Back to top
View user's profile Send private message
tfp
n00b
n00b


Joined: 18 Jun 2005
Posts: 7

PostPosted: Wed Nov 09, 2005 10:13 pm    Post subject: Reply with quote

Any luck with this? I'm pretty much in the same boat you are I have C3000, I could try dropping a PCI 5200 in there but I haven't had the time to research or even install the card.
Back to top
View user's profile Send private message
HPRichard
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 94
Location: KA, Germany

PostPosted: Thu Nov 10, 2005 8:57 pm    Post subject: Reply with quote

the "X on non-HP graphics cards issue" is somewhat documented here. If you get a kernel panic on bootup with the Framebuffer driver built statically in the kernel, try to build and load it as a module.

Code:
Starting local ...               [ ok ]

is the last message during startup. If you do not recieve a login prompt, check whether your /etc/inittab has a getty entry for the serial port you are connected to, like these
Code:

s0:12345:respawn:/sbin/agetty 9600 ttyS0 vt100
s1:12345:respawn:/sbin/agetty 9600 ttyS1 vt100

which I stole from my 735
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Sun Nov 20, 2005 6:30 pm    Post subject: Reply with quote

I uncommented those two lines and it worked perfectly, thanks.

I'm going to see about getting this Matrox working also :). I'll keep you guys informed.
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Wed Nov 23, 2005 12:25 am    Post subject: Reply with quote

I compiled the matroxfb module successfully, but when I modprobe it, the system locks up. How can I catch the dmesg output? Or, better yet, how can I fix the problem all together?
Back to top
View user's profile Send private message
HPRichard
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 94
Location: KA, Germany

PostPosted: Wed Nov 23, 2005 12:44 pm    Post subject: Reply with quote

If you are running a 64bit kernel on your machine, matroxfb is very unlikely to run correctly, as described here. I don't know if you can run a 32bit kernel on that machine, but it should work that way.
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Wed Nov 23, 2005 4:32 pm    Post subject: Reply with quote

Nope, not using a 64-bit kernel.

Code:
Processor type (PA8000 and up)  --->
[ ] 64-bit kernel
[ ] Symmetric multi-processing support


What else could it be?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum